summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHilko Bengen <bengen@hilluzination.de>2011-06-01 00:43:09 +0200
committerRichard W.M. Jones <rjones@redhat.com>2011-06-01 10:10:45 +0100
commitddbfd96c3d21d05170a0af7de427c3dcbd72f014 (patch)
tree7bb0ca2504194b369ac9b3c9e615b92e23b56cd0 /configure.ac
parent8dcb6d97b279ad752732d2880b7ef7a65887e401 (diff)
downloadfebootstrap-ddbfd96c3d21d05170a0af7de427c3dcbd72f014.tar.gz
febootstrap-ddbfd96c3d21d05170a0af7de427c3dcbd72f014.tar.xz
febootstrap-ddbfd96c3d21d05170a0af7de427c3dcbd72f014.zip
febootstrap: Look for insmod.static, mke2fs in /sbin
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index da03c9f..7606bca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -68,7 +68,8 @@ dnl For ArchLinux handler.
AC_CHECK_PROG(PACMAN,[pacman],[pacman],[no])
dnl Required programs, libraries.
-AC_PATH_PROG([INSMODSTATIC],[insmod.static],[no])
+AC_PATH_PROG([INSMODSTATIC],[insmod.static],[no],
+ [$PATH$PATH_SEPARATOR/sbin$PATH_SEPARATOR])
if test "x$INSMODSTATIC" = "xno" ; then
AC_MSG_FAILURE([insmod.static program not found
@@ -82,9 +83,10 @@ fi
AC_DEFINE_UNQUOTED([INSMODSTATIC],["$INSMODSTATIC"],
[Full path to the insmod.static program.])
-AC_PATH_PROG([MKE2FS],[mke2fs],[no])
+AC_PATH_PROG([MKE2FS],[mke2fs],[no],
+ [$PATH$PATH_SEPARATOR/sbin$PATH_SEPARATOR])
if test "x$MKE2FS" = "xno" ; then
- AC_MSG_FAILURE([mke2fs program not found (is /sbin in your current path?)])
+ AC_MSG_FAILURE([mke2fs program not found])
fi
AC_DEFINE_UNQUOTED([MKE2FS],["$MKE2FS"],
[Full path to the mke2fs program.])