summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-05-13 13:29:20 +0100
committerRichard Jones <rjones@redhat.com>2010-05-14 11:41:28 +0100
commit95dd28aadbfc1f058dae26beea949cf3cbc22b26 (patch)
treea22f2dbcd2a450c339a0aaf371e2c8f437500d98 /configure.ac
parent3c9a5248737321d174aefcb9cb8251e1ab44c3fa (diff)
downloadfebootstrap-95dd28aadbfc1f058dae26beea949cf3cbc22b26.tar.gz
febootstrap-95dd28aadbfc1f058dae26beea949cf3cbc22b26.tar.xz
febootstrap-95dd28aadbfc1f058dae26beea949cf3cbc22b26.zip
Pull in febootstrap-supermin-helper (C version) from libguestfs.2.7
This commit also pulls in the automake C dependencies and gnulib. febootstrap-supermin-helper is modified so that it has the --kmods option (to read the whitelist, from the old shell script), and so that it can read supermin appliances composed of multiple parts from out of a directory. Also: Updates to documentation.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 20 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index f564048..05597b1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
dnl febootstrap configure.ac
-dnl (C) Copyright 2009 Red Hat Inc.
+dnl (C) Copyright 2009-2010 Red Hat Inc.
dnl
dnl This program is free software; you can redistribute it and/or modify
dnl it under the terms of the GNU General Public License as published by
@@ -17,9 +17,26 @@ dnl Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
dnl
dnl Written by Richard W.M. Jones <rjones@redhat.com>
-AC_INIT(febootstrap,2.6)
+AC_INIT(febootstrap,2.7)
AM_INIT_AUTOMAKE
+dnl Check for basic C environment.
+AC_PROG_CC_STDC
+gl_EARLY
+
+AC_PROG_INSTALL
+AC_PROG_CPP
+
+AC_C_PROTOTYPES
+test "x$U" != "x" && AC_MSG_ERROR([Compiler not ANSI compliant])
+
+AM_PROG_CC_C_O
+
+dnl Check support for 64 bit file offsets.
+AC_SYS_LARGEFILE
+
+gl_INIT
+
AC_CHECK_PROG(PERLDOC,[perldoc],[perldoc],[no])
if test "x$PERLDOC" = "xno" ; then
AC_MSG_WARN([perldoc not found - install perl to make man pages])
@@ -42,5 +59,5 @@ if test "x$YUM" = "xno" ; then
fi
AC_CONFIG_HEADERS([config.h])
-AC_CONFIG_FILES([Makefile examples/Makefile])
+AC_CONFIG_FILES([lib/Makefile Makefile examples/Makefile])
AC_OUTPUT