summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-08-20 19:23:03 +0100
committerRichard Jones <rjones@redhat.com>2010-08-24 13:17:41 +0100
commit89e336ee166be538e376d288fb2b3fbbffd66d4c (patch)
treecd6ddae9a5ef7a0e572db824e2755972991dc074 /configure.ac
parent53bf430e26f4a53837bd38b58a427079caab3d4b (diff)
downloadfebootstrap-89e336ee166be538e376d288fb2b3fbbffd66d4c.tar.gz
febootstrap-89e336ee166be538e376d288fb2b3fbbffd66d4c.tar.xz
febootstrap-89e336ee166be538e376d288fb2b3fbbffd66d4c.zip
Implement ext2 output module.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1a94700..9b9f39c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,6 +58,29 @@ if test "x$YUM" = "xno" ; then
AC_MSG_FAILURE([yum program not found])
fi
+AC_PATH_PROG([MKE2FS],[mke2fs],[no])
+if test "x$MKE2FS" = "xno" ; then
+ AC_MSG_FAILURE([mke2fs program not found (is /sbin in your current path?)])
+fi
+AC_DEFINE_UNQUOTED([MKE2FS],["$MKE2FS"],
+ [Full path to the mke2fs program.])
+
+old_LIBS="$LIBS"
+AC_CHECK_LIB([com_err],[error_message],[],[
+ AC_MSG_FAILURE([com_err library not found (part of e2fsprogs)])
+])
+LIBS="$old_LIBS"
+
+old_LIBS="$LIBS"
+AC_CHECK_LIB([ext2fs],[ext2fs_file_open2],[],[
+ AC_MSG_FAILURE([libext2fs library not found (part of e2fsprogs)])
+])
+LIBS="$old_LIBS"
+
+AC_CHECK_HEADER([ext2fs/ext2fs.h],[],[
+ AC_MSG_FAILURE([Header <ext2fs/ext2fs.h> not found (part of e2fsprogs)])
+])
+
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_FILES([Makefile lib/Makefile helper/Makefile examples/Makefile])
AC_OUTPUT