summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2010-12-06 12:22:58 +0000
committerRichard W.M. Jones <rjones@redhat.com>2010-12-06 12:22:58 +0000
commit72e9f7c254ff235ab25dc42952e7069099ad35da (patch)
treee1d2cd7996569705b3c21c655be1e48080615fa0 /configure.ac
parent60baadc1b201d35b30f23220a44994964936820d (diff)
downloadfebootstrap-72e9f7c254ff235ab25dc42952e7069099ad35da.tar.gz
febootstrap-72e9f7c254ff235ab25dc42952e7069099ad35da.tar.xz
febootstrap-72e9f7c254ff235ab25dc42952e7069099ad35da.zip
configure: Check for insmod.static and fail if not present.
This is not packaged on Debian/Ubuntu, but we require it. Fail with a useful error message if it is not available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d1b334d..21dd340 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,7 +64,21 @@ dnl For Debian handler.
AC_CHECK_PROG(APTITUDE,[aptitude],[aptitude],[no])
AC_CHECK_PROG(DPKG,[dpkg],[dpkg],[no])
-dnl Required e2fsprogs, libs.
+dnl Required programs, libraries.
+AC_PATH_PROG([INSMODSTATIC],[insmod.static],[no])
+if test "x$INSMODSTATIC" = "xno" ; then
+ AC_MSG_FAILURE([insmod.static program not found
+
+Is /sbin in your current path?
+
+Note that Debian/Ubuntu do not package this file from module-init-tools.
+Sorry, please fix your distribution. In the meantime you can copy
+/sbin/insmod.static from a Fedora machine.
+])
+fi
+AC_DEFINE_UNQUOTED([INSMODSTATIC],["$INSMODSTATIC"],
+ [Full path to the insmod.static program.])
+
AC_PATH_PROG([MKE2FS],[mke2fs],[no])
if test "x$MKE2FS" = "xno" ; then
AC_MSG_FAILURE([mke2fs program not found (is /sbin in your current path?)])