summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2010-12-03 13:17:00 +0000
committerRichard W.M. Jones <rjones@redhat.com>2010-12-05 09:33:25 +0000
commit66a9d53e48f14d7fe1d9f4b801a1c5582d83efa6 (patch)
tree555e29f52452cd88a6deb086b86bb55ab85f5fff /configure.ac
parent304ee3695e41904d8b2184922732f47aa6ccc0d4 (diff)
downloadfebootstrap-66a9d53e48f14d7fe1d9f4b801a1c5582d83efa6.tar.gz
febootstrap-66a9d53e48f14d7fe1d9f4b801a1c5582d83efa6.tar.xz
febootstrap-66a9d53e48f14d7fe1d9f4b801a1c5582d83efa6.zip
Rewrite febootstrap as a general supermin appliance building tool.3.0
This complete rewrite of the building tools turns febootstrap into a general purpose, cross-distro, supermin appliance only build tool. There is now only one program 'febootstrap' which is used to build a supermin appliance from a list of packages. Normal appliances are not supported. The tools are incompatible with febootstrap 2.x (use the febootstrap-2.x branch from git to get the old package).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 22 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 509db2c..d1b334d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,7 +17,7 @@ dnl Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
dnl
dnl Written by Richard W.M. Jones <rjones@redhat.com>
-AC_INIT(febootstrap,2.11)
+AC_INIT(febootstrap,3.0)
AM_INIT_AUTOMAKE
dnl Check for basic C environment.
@@ -37,27 +37,34 @@ AC_SYS_LARGEFILE
gl_INIT
+# OCaml and ocamlfind are required to compile.
+AC_PROG_OCAML
+if test "$OCAMLC" = "no"; then
+ AC_MSG_ERROR([You must install the OCaml compiler])
+fi
+AM_CONDITIONAL([HAVE_OCAMLOPT],[test "$OCAMLBEST" = "opt"])
+AC_PROG_FINDLIB
+if test "$OCAMLFIND" = "no"; then
+ AC_MSG_ERROR([You must install OCaml findlib (the ocamlfind command)])
+fi
+
+dnl Optional programs.
AC_CHECK_PROG(PERLDOC,[perldoc],[perldoc],[no])
if test "x$PERLDOC" = "xno" ; then
AC_MSG_WARN([perldoc not found - install perl to make man pages])
fi
AM_CONDITIONAL(HAVE_PERLDOC,[test "$perldoc" != "no"])
-AC_CHECK_PROG(FAKEROOT,[fakeroot],[fakeroot],[no])
-if test "x$FAKEROOT" = "xno" ; then
- AC_MSG_FAILURE([fakeroot program not found])
-fi
-
-AC_CHECK_PROG(FAKECHROOT,[fakechroot],[fakechroot],[no])
-if test "x$FAKECHROOT" = "xno" ; then
- AC_MSG_FAILURE([fakechroot program not found])
-fi
-
+dnl For yum-rpm handler.
AC_CHECK_PROG(YUM,[yum],[yum],[no])
-if test "x$YUM" = "xno" ; then
- AC_MSG_FAILURE([yum program not found])
-fi
+AC_CHECK_PROG(RPM,[rpm],[rpm],[no])
+AC_CHECK_PROG(YUMDOWNLOADER,[yumdownloader],[yumdownloader],[no])
+
+dnl For Debian handler.
+AC_CHECK_PROG(APTITUDE,[aptitude],[aptitude],[no])
+AC_CHECK_PROG(DPKG,[dpkg],[dpkg],[no])
+dnl Required e2fsprogs, libs.
AC_PATH_PROG([MKE2FS],[mke2fs],[no])
if test "x$MKE2FS" = "xno" ; then
AC_MSG_FAILURE([mke2fs program not found (is /sbin in your current path?)])
@@ -82,5 +89,5 @@ AC_CHECK_HEADER([ext2fs/ext2fs.h],[],[
])
AC_CONFIG_HEADERS([config.h])
-AC_CONFIG_FILES([Makefile lib/Makefile helper/Makefile examples/Makefile])
+AC_CONFIG_FILES([config.ml Makefile lib/Makefile helper/Makefile])
AC_OUTPUT