summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrjones <rjones>2009-03-19 15:01:50 +0000
committerrjones <rjones>2009-03-19 15:01:50 +0000
commit1ef78043a28df140e5302a4e00635e3d0792dbeb (patch)
tree6ec98bed60287b1654d50564e1d5703c47a75432 /configure.ac
downloadfebootstrap-1ef78043a28df140e5302a4e00635e3d0792dbeb.tar.gz
febootstrap-1ef78043a28df140e5302a4e00635e3d0792dbeb.tar.xz
febootstrap-1ef78043a28df140e5302a4e00635e3d0792dbeb.zip
Basic build environment and man page.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac49
1 files changed, 49 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..169617c
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,49 @@
+dnl febootstrap configure.ac
+dnl (C) Copyright 2009 Red Hat Inc.
+dnl
+dnl This program is free software; you can redistribute it and/or modify
+dnl it under the terms of the GNU General Public License as published by
+dnl the Free Software Foundation; either version 2 of the License, or
+dnl (at your option) any later version.
+dnl
+dnl This program is distributed in the hope that it will be useful,
+dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+dnl GNU General Public License for more details.
+dnl
+dnl You should have received a copy of the GNU General Public License
+dnl along with this program; if not, write to the Free Software
+dnl Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+dnl
+dnl Written by Richard W.M. Jones <rjones@redhat.com>
+
+AC_INIT(febootstrap,1.0)
+AM_INIT_AUTOMAKE
+
+AC_PROG_CC
+AM_PROG_CC_C_O
+
+AC_CHECK_PROG(PERLDOC,[perldoc],[perldoc],[no])
+if test "x$PERLDOC" = "xno" ; then
+ AC_MSG_WARN([perldoc not found - install perl to make man pages])
+fi
+AM_CONDITIONAL(PERLDOC,[test "$perldoc" != "no"])
+
+AC_CHECK_PROG(FAKEROOT,[fakeroot],[fakeroot],[no])
+if test "x$FAKEROOT" = "xno" ; then
+ AC_MSG_FAILURE([fakeroot program not found])
+fi
+
+AC_CHECK_PROG(FAKECHROOT,[fakechroot],[fakechroot],[no])
+if test "x$FAKECHROOT" = "xno" ; then
+ AC_MSG_FAILURE([fakechroot program not found])
+fi
+
+AC_CHECK_PROG(YUM,[yum],[yum],[no])
+if test "x$YUM" = "xno" ; then
+ AC_MSG_FAILURE([yum program not found])
+fi
+
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT