summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorrjones <rjones>2009-03-19 18:11:54 +0000
committerrjones <rjones>2009-03-19 18:11:54 +0000
commitc408cc553f0b420e82f3ed4f62722bd40148520e (patch)
tree48f8628df39c6bca5d59c8de74554c80df91f089 /Makefile.am
parent4cf4be3e7699a98ddd4233fafa1a74c5f52fe1e2 (diff)
downloadfebootstrap-c408cc553f0b420e82f3ed4f62722bd40148520e.tar.gz
febootstrap-c408cc553f0b420e82f3ed4f62722bd40148520e.tar.xz
febootstrap-c408cc553f0b420e82f3ed4f62722bd40148520e.zip
More updates.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am35
1 files changed, 32 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 38a4e1d..61c8172 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,7 +17,7 @@
#
# Written by Richard W.M. Jones <rjones@redhat.com>
-bin_SCRIPTS = febootstrap
+bin_SCRIPTS = febootstrap febootstrap-to-initramfs
febootstrap: febootstrap.sh
rm -f $@
@@ -25,7 +25,13 @@ febootstrap: febootstrap.sh
chmod 0555 $@-t
mv $@-t $@
-man_MANS = febootstrap.8
+febootstrap-to-initramfs: febootstrap-to-initramfs.sh
+ rm -f $@
+ cp $< $@-t
+ chmod 0555 $@-t
+ mv $@-t $@
+
+man_MANS = febootstrap.8 febootstrap-to-initramfs.8 febootstrap-fix-root.8
if HAVE_PERLDOC
febootstrap.8: febootstrap.pod
@@ -37,6 +43,29 @@ febootstrap.8: febootstrap.pod
febootstrap.txt: febootstrap.pod
pod2text $< > $@
+
+febootstrap-to-initramfs.8: febootstrap-to-initramfs.pod
+ pod2man \
+ --section 8 \
+ -c "Virtualization Support" \
+ --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
+ $< > $@
+
+febootstrap-to-initramfs.txt: febootstrap-to-initramfs.pod
+ pod2text $< > $@
+
+febootstrap-fix-root.8: febootstrap-fix-root.pod
+ pod2man \
+ --section 8 \
+ -c "Virtualization Support" \
+ --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
+ $< > $@
+
+febootstrap-fix-root.txt: febootstrap-fix-root.pod
+ pod2text $< > $@
endif
-EXTRA_DIST = febootstrap.8 febootstrap.txt
+EXTRA_DIST = \
+ febootstrap.8 febootstrap.txt \
+ febootstrap-to-initramfs.8 febootstrap-to-initramfs.txt \
+ febootstrap-fix-root.8 febootstrap-fix-root.txt