summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorrjones <rjones>2009-03-19 15:09:19 +0000
committerrjones <rjones>2009-03-19 15:09:19 +0000
commit9e86010ce13b72921b4887b235d209adc6d263b7 (patch)
treeec810eff70c277f2b134b4a9f52f4c7f9045eee7 /Makefile.am
parent1ef78043a28df140e5302a4e00635e3d0792dbeb (diff)
downloadfebootstrap-9e86010ce13b72921b4887b235d209adc6d263b7.tar.gz
febootstrap-9e86010ce13b72921b4887b235d209adc6d263b7.tar.xz
febootstrap-9e86010ce13b72921b4887b235d209adc6d263b7.zip
Build manual page.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 81c874a..24328b3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,3 +16,27 @@
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
#
# Written by Richard W.M. Jones <rjones@redhat.com>
+
+bin_SCRIPTS = febootstrap
+
+febootstrap: febootstrap.sh
+ rm -f $@
+ cp $< $@-t
+ chmod 0755 $@-t
+ mv $@-t $@
+
+man_MANS = febootstrap.8
+
+if HAVE_PERLDOC
+febootstrap.8: febootstrap.pod
+ pod2man \
+ --section 8 \
+ -c "Virtualization Support" \
+ --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
+ $< > $@
+
+febootstrap.txt: febootstrap.pod
+ pod2text $< > $@
+endif
+
+EXTRA_DIST = febootstrap.8 febootstrap.txt