summaryrefslogtreecommitdiffstats
path: root/tests/storage/Makefile.am
diff options
context:
space:
mode:
authorPeng Wu <alexepico@gmail.com>2013-10-14 14:05:27 +0800
committerPeng Wu <alexepico@gmail.com>2013-10-14 14:05:27 +0800
commit09a9b8859ffb137104943525416ea7fd6bd580c5 (patch)
treed3873627255bfb7098773d4da9ab3d9510a51097 /tests/storage/Makefile.am
parent25c03d42ad0ffdbf7128e5f4fefa083fa85d4c1d (diff)
downloadlibzhuyin-09a9b8859ffb137104943525416ea7fd6bd580c5.tar.gz
libzhuyin-09a9b8859ffb137104943525416ea7fd6bd580c5.tar.xz
libzhuyin-09a9b8859ffb137104943525416ea7fd6bd580c5.zip
clean up Makefile.am
Diffstat (limited to 'tests/storage/Makefile.am')
-rw-r--r--tests/storage/Makefile.am42
1 files changed, 13 insertions, 29 deletions
diff --git a/tests/storage/Makefile.am b/tests/storage/Makefile.am
index d8a63df..10483e4 100644
--- a/tests/storage/Makefile.am
+++ b/tests/storage/Makefile.am
@@ -22,50 +22,34 @@ INCLUDES = -I$(top_srcdir)/src \
-I$(top_srcdir)/tests \
@GLIB2_CFLAGS@
-TESTS = test_phrase_index_logger \
- test_ngram \
- test_flexible_ngram
+LDADD = ../../src/libzhuyin_internal.la @GLIB2_LIBS@
-noinst_PROGRAMS = test_phrase_index \
- test_phrase_index_logger \
- test_phrase_table \
- test_ngram \
- test_flexible_ngram \
- test_parser2 \
- test_chewing_table \
- test_table_info
+TESTS = test_phrase_index_logger \
+ test_ngram \
+ test_flexible_ngram
+noinst_PROGRAMS = test_phrase_index \
+ test_phrase_index_logger \
+ test_phrase_table \
+ test_ngram \
+ test_flexible_ngram \
+ test_parser2 \
+ test_chewing_table \
+ test_table_info
-test_phrase_index_SOURCES = test_phrase_index.cpp
-test_phrase_index_LDADD = ../../src/libzhuyin_internal.la @GLIB2_LIBS@
+test_phrase_index_SOURCES = test_phrase_index.cpp
test_phrase_index_logger_SOURCES = test_phrase_index_logger.cpp
-test_phrase_index_logger_LDADD = ../../src/libzhuyin_internal.la \
- @GLIB2_LIBS@
-
test_phrase_table_SOURCES = test_phrase_table.cpp
-test_phrase_table_LDADD = ../../src/libzhuyin_internal.la @GLIB2_LIBS@
-
test_ngram_SOURCES = test_ngram.cpp
-test_ngram_LDADD = ../../src/libzhuyin_internal.la @GLIB2_LIBS@
-
test_flexible_ngram_SOURCES = test_flexible_ngram.cpp
-test_flexible_ngram_LDADD = ../../src/libzhuyin_internal.la \
- @GLIB2_LIBS@
-
test_parser2_SOURCES = test_parser2.cpp
-test_parser2_LDADD = ../../src/libzhuyin_internal.la @GLIB2_LIBS@
-
test_chewing_table_SOURCES = test_chewing_table.cpp
-test_chewing_table_LDADD = ../../src/libzhuyin_internal.la @GLIB2_LIBS@
-
test_table_info_SOURCES = test_table_info.cpp
-
-test_table_info_LDADD = ../../src/libzhuyin_internal.la @GLIB2_LIBS@