summaryrefslogtreecommitdiffstats
path: root/tests/storage/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/storage/Makefile.am')
-rw-r--r--tests/storage/Makefile.am42
1 files changed, 13 insertions, 29 deletions
diff --git a/tests/storage/Makefile.am b/tests/storage/Makefile.am
index b7ed8b6..7675d11 100644
--- a/tests/storage/Makefile.am
+++ b/tests/storage/Makefile.am
@@ -22,50 +22,34 @@ INCLUDES = -I$(top_srcdir)/src \
-I$(top_srcdir)/tests \
@GLIB2_CFLAGS@
-TESTS = test_phrase_index_logger \
- test_ngram \
- test_flexible_ngram
+LDADD = ../../src/libpinyin_internal.la @GLIB2_LIBS@
-noinst_PROGRAMS = test_phrase_index \
- test_phrase_index_logger \
- test_phrase_table \
- test_ngram \
- test_flexible_ngram \
- test_parser2 \
- test_chewing_table \
- test_table_info
+TESTS = test_phrase_index_logger \
+ test_ngram \
+ test_flexible_ngram
+noinst_PROGRAMS = test_phrase_index \
+ test_phrase_index_logger \
+ test_phrase_table \
+ test_ngram \
+ test_flexible_ngram \
+ test_parser2 \
+ test_chewing_table \
+ test_table_info
-test_phrase_index_SOURCES = test_phrase_index.cpp
-test_phrase_index_LDADD = ../../src/libpinyin_internal.la @GLIB2_LIBS@
+test_phrase_index_SOURCES = test_phrase_index.cpp
test_phrase_index_logger_SOURCES = test_phrase_index_logger.cpp
-test_phrase_index_logger_LDADD = ../../src/libpinyin_internal.la \
- @GLIB2_LIBS@
-
test_phrase_table_SOURCES = test_phrase_table.cpp
-test_phrase_table_LDADD = ../../src/libpinyin_internal.la @GLIB2_LIBS@
-
test_ngram_SOURCES = test_ngram.cpp
-test_ngram_LDADD = ../../src/libpinyin_internal.la @GLIB2_LIBS@
-
test_flexible_ngram_SOURCES = test_flexible_ngram.cpp
-test_flexible_ngram_LDADD = ../../src/libpinyin_internal.la \
- @GLIB2_LIBS@
-
test_parser2_SOURCES = test_parser2.cpp
-test_parser2_LDADD = ../../src/libpinyin_internal.la @GLIB2_LIBS@
-
test_chewing_table_SOURCES = test_chewing_table.cpp
-test_chewing_table_LDADD = ../../src/libpinyin_internal.la @GLIB2_LIBS@
-
test_table_info_SOURCES = test_table_info.cpp
-
-test_table_info_LDADD = ../../src/libpinyin_internal.la @GLIB2_LIBS@