summaryrefslogtreecommitdiffstats
path: root/tests/storage/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/storage/CMakeLists.txt')
-rw-r--r--tests/storage/CMakeLists.txt59
1 files changed, 59 insertions, 0 deletions
diff --git a/tests/storage/CMakeLists.txt b/tests/storage/CMakeLists.txt
new file mode 100644
index 0000000..4c96046
--- /dev/null
+++ b/tests/storage/CMakeLists.txt
@@ -0,0 +1,59 @@
+add_executable(
+ test_parser
+ test_parser.cpp
+)
+
+target_link_libraries(
+ test_parser
+ libpinyin
+)
+
+add_executable(
+ test_pinyin_index
+ test_pinyin_index.cpp
+)
+
+target_link_libraries(
+ test_pinyin_index
+ libpinyin
+)
+
+add_executable(
+ test_phrase_index
+ test_phrase_index.cpp
+)
+
+target_link_libraries(
+ test_phrase_index
+ libpinyin
+)
+
+add_executable(
+ test_phrase_table
+ test_phrase_table.cpp
+)
+
+target_link_libraries(
+ test_phrase_table
+ libpinyin
+)
+
+add_executable(
+ test_ngram
+ test_ngram.cpp
+)
+
+target_link_libraries(
+ test_ngram
+ libpinyin
+)
+
+add_executable(
+ test_flexible_ngram
+ test_flexible_ngram.cpp
+)
+
+target_link_libraries(
+ test_flexible_ngram
+ libpinyin
+) \ No newline at end of file