summaryrefslogtreecommitdiffstats
path: root/tests/lookup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lookup/Makefile.am')
-rw-r--r--tests/lookup/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/tests/lookup/Makefile.am b/tests/lookup/Makefile.am
index 10c5301..027298b 100644
--- a/tests/lookup/Makefile.am
+++ b/tests/lookup/Makefile.am
@@ -14,14 +14,19 @@
## You should have received a copy of the GNU General Public License
## along with this program. If not, see <http://www.gnu.org/licenses/>.
-INCLUDES = -I$(top_srcdir)/src \
+AM_CPPFLAGS = -I$(top_srcdir)/src \
-I$(top_srcdir)/src/include \
-I$(top_srcdir)/src/storage \
-I$(top_srcdir)/src/lookup \
-I$(top_srcdir)/tests \
@GLIB2_CFLAGS@
-LDADD = ../../src/libpinyin_internal.la @GLIB2_LIBS@
+LDADD = \
+ ../../src/libpinyin_internal.a \
+ ../../src/storage/libstorage.a \
+ ../../src/lookup/liblookup.a \
+ @GLIB2_LIBS@ \
+ $(NULL)
noinst_PROGRAMS = test_pinyin_lookup \
test_phrase_lookup