summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 2 insertions, 6 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8208214..93df7d6 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -30,6 +30,8 @@ INCLUDES = -I$(top_srcdir)/src \
-I$(top_srcdir)/src/lookup \
@GLIB2_CFLAGS@
+LDADD = ../src/libpinyin.la @GLIB2_LIBS@
+
noinst_HEADERS = timer.h \
tests_helper.h
@@ -39,12 +41,6 @@ noinst_PROGRAMS = test_pinyin \
test_pinyin_SOURCES = test_pinyin.cpp
-test_pinyin_LDADD = ../src/libpinyin.la @GLIB2_LIBS@
-
test_phrase_SOURCES = test_phrase.cpp
-test_phrase_LDADD = ../src/libpinyin.la @GLIB2_LIBS@
-
test_chewing_SOURCES = test_chewing.cpp
-
-test_chewing_LDADD = ../src/libpinyin.la @GLIB2_LIBS@