summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f36e5f9..264d8c3 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -23,3 +23,15 @@ MAINTAINERCLEANFILES = Makefile.in
CLEANFILES = *.bak
ACLOCAL = aclocal -I $(ac_aux_dir)
+
+INCLUDES = -I$(top_srcdir)/src \
+ -I$(top_srcdir)/src/include \
+ -I$(top_srcdir)/src/storage \
+ -I$(top_srcdir)/src/lookup \
+ @GLIB2_CPPFLAGS@
+
+noinst_PROGRAMS = test_pinyin
+
+test_pinyin_SOURCES = test_pinyin.cpp
+
+test_pinyin_LDADD = ../src/libpinyin.la @GLIB2_LDFLAGS@ \ No newline at end of file