summaryrefslogtreecommitdiffstats
path: root/src/storage/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/storage/Makefile.am')
-rw-r--r--src/storage/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/storage/Makefile.am b/src/storage/Makefile.am
index 8c10cdf..f508b82 100644
--- a/src/storage/Makefile.am
+++ b/src/storage/Makefile.am
@@ -19,7 +19,9 @@ INCLUDES = -I$(top_srcdir)/src/include \
-I$(top_srcdir)/src/storage \
@GLIB2_CPPFLAGS@
-noinst_HEADERS = pinyin_large_table.h \
+libpinyinincludedir = $(includedir)/libpinyin-@LIBPINYIN_BINARY_VERSION@
+
+libpinyininclude_HEADERS= pinyin_large_table.h \
pinyin_base.h \
pinyin_phrase.h \
phrase_index.h \
@@ -31,6 +33,8 @@ noinst_HEADERS = pinyin_large_table.h \
noinst_LTLIBRARIES = libstorage.la
+libstorage_la_CXXFLAGS = "-fPIC"
+
libstorage_la_LDFLAGS = -static
libstorage_la_SOURCES = pinyin_base.cpp \