summaryrefslogtreecommitdiffstats
path: root/src/segment/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/segment/Makefile.am')
-rw-r--r--src/segment/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/segment/Makefile.am b/src/segment/Makefile.am
new file mode 100644
index 0000000..0e58ddf
--- /dev/null
+++ b/src/segment/Makefile.am
@@ -0,0 +1,28 @@
+## Makefile.am -- Process this file with automake to produce Makefile.in
+## Copyright (C) 2007 Peng Wu
+##
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 2, or (at your option)
+## any later version.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+MAINTAINERCLEANFILES = Makefile.in
+
+INCLUDES = -I$(top_srcdir)/src/include \
+ -I$(top_srcdir)/src/storage \
+ @GLIB2_CPPFLAGS@
+
+noinst_PROGRAMS = mmseg
+
+mmseg_SOURCES = mmseg.cpp
+
+mmseg_LDADD = @GLIB2_LDFLAGS@