summaryrefslogtreecommitdiffstats
path: root/src/lookup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/lookup/Makefile.am')
-rw-r--r--src/lookup/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/lookup/Makefile.am b/src/lookup/Makefile.am
new file mode 100644
index 0000000..2b7d21f
--- /dev/null
+++ b/src/lookup/Makefile.am
@@ -0,0 +1,30 @@
+## Makefile.am -- Process this file with automake to produce Makefile.in
+## Copyright (C) 2007 Peng Wu
+##
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 2, or (at your option)
+## any later version.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+MAINTAINERCLEANFILES = Makefile.in
+
+INCLUDES = -I$(top_srcdir)/src/include \
+ -I$(top_srcdir)/src/storage \
+ @GLIB2_CPPFLAGS@
+
+noinst_HEADERS = lookup.h winner_tree.h
+
+noinst_PROGRAMS =
+
+noinst_LTLIBRARIES = liblookup.la
+
+liblookup_la_SOURCES = pinyin_lookup.cpp winner_tree.cpp