summaryrefslogtreecommitdiffstats
path: root/src/lookup/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/lookup/CMakeLists.txt')
-rw-r--r--src/lookup/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/lookup/CMakeLists.txt b/src/lookup/CMakeLists.txt
new file mode 100644
index 0000000..99edbb6
--- /dev/null
+++ b/src/lookup/CMakeLists.txt
@@ -0,0 +1,27 @@
+set(
+ LIBLOOKUP_HEADERS
+ lookup.h
+ pinyin_lookup.h
+ phrase_lookup.h
+ winner_tree.h
+)
+
+set(
+ LIBLOOKUP_SOURCES
+ pinyin_lookup.cpp
+ winner_tree.cpp
+ phrase_lookup.cpp
+)
+
+add_library(
+ liblookup
+ STATIC
+ ${LIBLOOKUP_SOURCES}
+)
+
+install(
+ FILES
+ ${LIBLOOKUP_HEADERS}
+ DESTINATION
+ ${DIR_INCLUDE_LIBPINYIN}
+)