summaryrefslogtreecommitdiffstats
path: root/utils/training/Makefile.am
diff options
context:
space:
mode:
authorPeng Wu <alexepico@gmail.com>2010-10-27 11:12:41 +0800
committerPeng Wu <alexepico@gmail.com>2010-10-27 11:12:41 +0800
commite9e32f965272d5465b81d1ea62df3a7e3f97f134 (patch)
treeb10d03cc6999dbbe7873486a242cd2c68f7fd0b1 /utils/training/Makefile.am
parentcb42269587055a80907efd863c367d659a022a06 (diff)
downloadlibpinyin-e9e32f965272d5465b81d1ea62df3a7e3f97f134.tar.gz
libpinyin-e9e32f965272d5465b81d1ea62df3a7e3f97f134.tar.xz
libpinyin-e9e32f965272d5465b81d1ea62df3a7e3f97f134.zip
move segment and training tools to utils
Diffstat (limited to 'utils/training/Makefile.am')
-rw-r--r--utils/training/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/utils/training/Makefile.am b/utils/training/Makefile.am
new file mode 100644
index 0000000..520e4e1
--- /dev/null
+++ b/utils/training/Makefile.am
@@ -0,0 +1,36 @@
+## Makefile.am -- Process this file with automake to produce Makefile.in
+## Copyright (C) 2007 Peng Wu
+##
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 2, or (at your option)
+## any later version.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+MAINTAINERCLEANFILES = Makefile.in
+
+INCLUDES = -I$(top_srcdir)/src/include \
+ -I$(top_srcdir)/src/storage \
+ @GLIB2_CPPFLAGS@
+
+noinst_PROGRAMS = gen_ngram gen_unigram estimate_interpolation
+
+gen_ngram_SOURCES = gen_ngram.cpp
+
+gen_ngram_LDADD = ../storage/libstorage.la @GLIB2_LDFLAGS@
+
+gen_unigram_SOURCES = gen_unigram.cpp
+
+gen_unigram_LDADD = ../storage/libstorage.la @GLIB2_LDFLAGS@
+
+estimate_interpolation_SOURCES = estimate_interpolation.cpp
+
+estimate_interpolation_LDADD = ../storage/libstorage.la @GLIB2_LDFLAGS@