summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPeng Wu <alexepico@gmail.com>2015-04-13 14:02:15 +0800
committerPeng Wu <alexepico@gmail.com>2015-04-13 14:02:15 +0800
commitebbe25e0cae57e530a11ae12b965a330ff9496f4 (patch)
treece664d2e78289646460698536a1b69814801254c /configure.ac
parenta1d27fd07ae0dd1001dc6a0a2efd2d6890bcc1ed (diff)
downloadlibpinyin-ebbe25e0cae57e530a11ae12b965a330ff9496f4.tar.gz
libpinyin-ebbe25e0cae57e530a11ae12b965a330ff9496f4.tar.xz
libpinyin-ebbe25e0cae57e530a11ae12b965a330ff9496f4.zip
update autoconf
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8994d7f..41877dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -91,6 +91,8 @@ if test x"$DBM" = x"BerkeleyDB"; then
AC_CHECK_HEADER([db.h], [], AC_MSG_ERROR([Cannot find Berkeley DB library version 4]))
AC_SEARCH_LIBS([db_create], [db], [], AC_MSG_ERROR([Cannot find Berkeley DB library version 4]))
+
+ AC_DEFINE([HAVE_BERKELEY_DB], [], [Have Berkeley DB.])
fi
AM_CONDITIONAL([BERKELEYDB], [test x"$DBM" = x"BerkeleyDB"])
@@ -100,6 +102,8 @@ if test x"$DBM" = x"KyotoCabinet"; then
PKG_CHECK_MODULES(KYOTOCABINET, [
kyotocabinet
], [])
+
+ AC_DEFINE([HAVE_KYOTO_CABINET], [], [Have Kyoto Cabinet.])
fi
AM_CONDITIONAL([KYOTOCABINET], [test x"$DBM" = x"KyotoCabinet"])