summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPeng Wu <alexepico@gmail.com>2014-03-25 10:45:39 +0800
committerPeng Wu <alexepico@gmail.com>2014-03-25 10:45:39 +0800
commita79de7e24f79f97259836cb7cbba5de5d6fce8ea (patch)
tree2486fc4e55f1119776f355fdcbc299482250349e /configure.ac
parent24e045b9a7291aa9f845dd7dbf7629e5622e7887 (diff)
downloadibus-libzhuyin-a79de7e24f79f97259836cb7cbba5de5d6fce8ea.tar.gz
ibus-libzhuyin-a79de7e24f79f97259836cb7cbba5de5d6fce8ea.tar.xz
ibus-libzhuyin-a79de7e24f79f97259836cb7cbba5de5d6fce8ea.zip
require opencc
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 11409a5..f839dac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -57,6 +57,7 @@ PKG_CHECK_MODULES(IBUS, [
ibus-1.0 >= 1.4.0
])
+# check libzhuyin
PKG_CHECK_MODULES(LIBZHUYIN, [
libzhuyin >= 0.9.93
], [enable_libzhuyin=yes])
@@ -65,6 +66,9 @@ LIBZHUYIN_DATADIR=`$PKG_CONFIG --variable=pkgdatadir libzhuyin`
AC_SUBST(LIBZHUYIN_DATADIR)
+# check opencc
+PKG_CHECK_MODULES(OPENCC, [opencc], [enable_opencc=yes])
+
# check if ibus_config_get_values, which is available in ibus-1.3.99+ (git master)
save_CFLAGS="$CFLAGS"
save_LIBS="$LIBS"
@@ -118,5 +122,6 @@ Build options:
Version $VERSION
Install prefix $prefix
Use boost $enable_boost
+ Use opencc $enable_opencc
Use libzhuyin $enable_libzhuyin
])