summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPeng Huang <shawn.p.huang@gmail.com>2010-09-27 14:09:07 +0800
committerPeng Huang <shawn.p.huang@gmail.com>2010-09-27 14:09:07 +0800
commita0b31c7a250cfa7af1b52056a1d1ada81b22a455 (patch)
tree8da3ce94a625c249e3e4b1ab81afcee7f4900236 /configure.ac
parent27c2f7ea0ef69094db2dfc009bb661276fc90227 (diff)
downloadibus-libpinyin-a0b31c7a250cfa7af1b52056a1d1ada81b22a455.tar.gz
ibus-libpinyin-a0b31c7a250cfa7af1b52056a1d1ada81b22a455.tar.xz
ibus-libpinyin-a0b31c7a250cfa7af1b52056a1d1ada81b22a455.zip
Add option --disable-boost to support build without boost
When build without boost, ibus-pinyin will use smart pointer from c++0x and use the signal templates embedded instead of boost::signals2. BUG=chromium-os:5055 TEST=manual Review URL: http://codereview.appspot.com/2205044
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 16 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 3140953..ccb0ef4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -88,24 +88,6 @@ AC_CHECK_FUNCS([uuid_create], [], [
AM_CONDITIONAL(HAVE_LIBUUID, test x"$HAVE_LIBUUID" = x"yes")
-# check boost
-BOOST_REQUIRE([1.39])
-BOOST_FIND_HEADER([boost/signals2.hpp])
-# BOOST_FIND_HEADER([boost/signals2.hpp], [
-# HAVE_BOOST_SIGNALS2=no
-# BOOST_SIGNALS([s])
-# ], [
-# AC_DEFINE(HAVE_BOOST_SIGNALS2_HPP, 1, [Define if found boost.signals2])
-# HAVE_BOOST_SGINALS2=yes
-# ])
-#
-# AM_CONDITIONAL(HAVE_BOOST_SIGNALS2, test x"$HAVE_BOOST_SIGNALS2" = x"yes")
-#
-# check sigc
-# PKG_CHECK_MODULES(SIGC, [
-# sigc++-2.0
-# ])
-
# check env
AC_PATH_PROG(ENV, env)
AC_SUBST(ENV)
@@ -113,6 +95,21 @@ AC_SUBST(ENV)
# check python
AM_PATH_PYTHON([2.5])
+# --disble-boost
+AC_ARG_ENABLE(boost,
+ AC_HELP_STRING([--disable-boost],
+ [Do not use boost and use stdc++0x to replace boost.]),
+ [enable_boost=$enableval],
+ [enable_boost=yes]
+)
+if test x"$enable_boost" = x"yes"; then
+ # check boost
+ BOOST_REQUIRE([1.39])
+ BOOST_FIND_HEADER([boost/bind.hpp])
+ BOOST_FIND_HEADER([boost/signals2.hpp])
+fi
+AM_CONDITIONAL(HAVE_BOOST, test x"$enable_boost" = x"yes")
+
# --enable-opencc
AC_ARG_ENABLE(opencc,
AC_HELP_STRING([--enable-opencc],
@@ -203,6 +200,7 @@ AC_MSG_RESULT([
Build options:
Version $VERSION
Install prefix $prefix
+ Use boost $enable_boost
Use opencc $enable_opencc
Build database android $enable_db_android
Build database open-phrase $enable_db_open_phrase