summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPeng Wu <alexepico@gmail.com>2012-07-23 13:18:55 +0800
committerPeng Wu <alexepico@gmail.com>2012-07-23 13:18:55 +0800
commit513c1bef69ad0813f31bf9b8cf0287bb266035ef (patch)
tree63f01dc377d38dbee1157f00f09040e569751039 /configure.ac
parente4ddf0f70d56628e7a1cbfba521a0120c6447c4c (diff)
downloadibus-libpinyin-513c1bef69ad0813f31bf9b8cf0287bb266035ef.tar.gz
ibus-libpinyin-513c1bef69ad0813f31bf9b8cf0287bb266035ef.tar.xz
ibus-libpinyin-513c1bef69ad0813f31bf9b8cf0287bb266035ef.zip
update autoconf for stroke editor
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 65a5687..81e7396 100644
--- a/configure.ac
+++ b/configure.ac
@@ -193,6 +193,16 @@ AC_ARG_ENABLE(english-input-mode,
AM_CONDITIONAL(IBUS_BUILD_ENGLISH_INPUT_MODE, [test x"$enable_english_input_mode" = x"yes"])
+# --disable-stroke-input-mode
+AC_ARG_ENABLE(stroke-input-mode,
+ AS_HELP_STRING([--disable-stroke-input-mode],
+ [do not build stroke input mode]),
+ [enable_stroke_input_mode=$enableval],
+ [enable_stroke_input_mode=yes]
+)
+
+AM_CONDITIONAL(IBUS_BUILD_STROKE_INPUT_MODE, [test x"$enable_stroke_input_mode" = x"yes"])
+
# OUTPUT files
AC_CONFIG_FILES([ po/Makefile.in
Makefile
@@ -218,6 +228,7 @@ Build options:
Use opencc $enable_opencc
Use libpinyin $enable_libpinyin
Build lua extension $enable_lua_extension
+ Build stroke input mode $enable_stroke_input_mode
Build english input mode $enable_english_input_mode
])