summaryrefslogtreecommitdiffstats
path: root/postgresql.spec
diff options
context:
space:
mode:
authorTom Lane <tgl@fedoraproject.org>2010-02-22 18:16:56 +0000
committerTom Lane <tgl@fedoraproject.org>2010-02-22 18:16:56 +0000
commit9cc5f2029d4bcbe0297d7f106892bdf5602c24ca (patch)
treea82705ffd425d06c9cf428721449359b9c2367d0 /postgresql.spec
parentb7fa69b9cb348b3b6c56f24e96fc256abaf7e0c1 (diff)
downloadpostgresql-setup-9cc5f2029d4bcbe0297d7f106892bdf5602c24ca.tar.gz
postgresql-setup-9cc5f2029d4bcbe0297d7f106892bdf5602c24ca.tar.xz
postgresql-setup-9cc5f2029d4bcbe0297d7f106892bdf5602c24ca.zip
Fix initscript LSB compliance issuespostgresql-8_4_2-8_fc14
Diffstat (limited to 'postgresql.spec')
-rwxr-xr-xpostgresql.spec25
1 files changed, 16 insertions, 9 deletions
diff --git a/postgresql.spec b/postgresql.spec
index 68b4a77..53a10d8 100755
--- a/postgresql.spec
+++ b/postgresql.spec
@@ -53,7 +53,7 @@ Summary: PostgreSQL client programs
Name: postgresql
%global majorversion 8.4
Version: 8.4.2
-Release: 7%{?dist}
+Release: 8%{?dist}
# The PostgreSQL license is very similar to other MIT licenses, but the OSI
# recognizes it as an independent license, so we do as well.
License: PostgreSQL
@@ -170,10 +170,13 @@ PostgreSQL server.
%package server
Summary: The programs needed to create and run a PostgreSQL server
Group: Applications/Databases
-Requires: postgresql = %{version}-%{release}
+Requires: %{name} = %{version}-%{release}
Requires(pre): /usr/sbin/useradd
-Requires(post): /sbin/chkconfig
-Requires(preun): /sbin/chkconfig
+Requires(post): chkconfig
+Requires(preun): chkconfig
+# This is for /sbin/service
+Requires(preun): initscripts
+Requires(postun): initscripts
%description server
The postgresql-server package includes the programs needed to create
@@ -492,18 +495,18 @@ cat psql-%{majorversion}.lang >>main.lst
%postun libs -p /sbin/ldconfig
%pre server
-groupadd -g 26 -o -r postgres >/dev/null 2>&1 || :
-useradd -M -N -g postgres -o -r -d /var/lib/pgsql -s /bin/bash \
+/usr/sbin/groupadd -g 26 -o -r postgres >/dev/null 2>&1 || :
+/usr/sbin/useradd -M -N -g postgres -o -r -d /var/lib/pgsql -s /bin/bash \
-c "PostgreSQL Server" -u 26 postgres >/dev/null 2>&1 || :
%post server
-chkconfig --add postgresql
+/sbin/chkconfig --add postgresql
/sbin/ldconfig
%preun server
if [ $1 = 0 ] ; then
- /sbin/service postgresql condstop >/dev/null 2>&1
- chkconfig --del postgresql
+ /sbin/service postgresql stop >/dev/null 2>&1
+ /sbin/chkconfig --del postgresql
fi
%postun server
@@ -711,6 +714,10 @@ rm -rf $RPM_BUILD_ROOT
%endif
%changelog
+* Mon Feb 22 2010 Tom Lane <tgl@redhat.com> 8.4.2-8
+- Bring init script into some modicum of compliance with Fedora/LSB standards
+Resolves: #201043
+
* Thu Feb 18 2010 Tom "spot" Callaway <tcallawa@redhat.com> 8.4.2-7
- adjust license tag to reflect OSI decision