summaryrefslogtreecommitdiffstats
path: root/ui/gtk/Makefile.am
diff options
context:
space:
mode:
authorHuang Peng <shawn.p.huang@gmail.com>2009-02-05 10:39:56 +0800
committerHuang Peng <shawn.p.huang@gmail.com>2009-02-05 10:39:56 +0800
commitaedad1ea0a7fef604aa27f4b58433fd8f2ece29e (patch)
treeffcb531d8474bde18b90341bcd4eb639edd74525 /ui/gtk/Makefile.am
parent41ad46305a88637dd99f00a2d2a3f455505d357b (diff)
downloadibus-aedad1ea0a7fef604aa27f4b58433fd8f2ece29e.tar.gz
ibus-aedad1ea0a7fef604aa27f4b58433fd8f2ece29e.tar.xz
ibus-aedad1ea0a7fef604aa27f4b58433fd8f2ece29e.zip
re-implement ibus in c language.
Diffstat (limited to 'ui/gtk/Makefile.am')
-rw-r--r--ui/gtk/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/ui/gtk/Makefile.am b/ui/gtk/Makefile.am
index 18f773e..e80cf96 100644
--- a/ui/gtk/Makefile.am
+++ b/ui/gtk/Makefile.am
@@ -31,10 +31,16 @@ ui_gtk_PYTHON = \
propitem.py \
toolitem.py \
$(NULL)
-
ui_gtkdir = $(pkgdatadir)/ui/gtk
-bin_SCRIPTS = ibus-ui-gtk
+libexec_SCRIPTS = \
+ ibus-ui-gtk \
+ $(NULL)
+
+component_DATA = \
+ gtkpanel.xml \
+ $(NULL)
+componentdir = $(pkgdatadir)/component
CLEANFILES = \
*.pyc \
@@ -42,9 +48,11 @@ CLEANFILES = \
EXTRA_DIST = \
ibus-ui-gtk.in \
+ gtkpanel.xml.in \
$(NULL)
test:
$(ENV) DBUS_DEBUG=true \
+ IBUS_PREFIX=@prefix@ \
PYTHONPATH=$(top_srcdir) \
$(PYTHON) $(srcdir)/main.py