summaryrefslogtreecommitdiffstats
path: root/client/qt4/Makefile.am
diff options
context:
space:
mode:
authorHuang Peng <shawn.p.huang@gmail.com>2008-08-16 12:51:47 +0800
committerHuang Peng <shawn.p.huang@gmail.com>2008-08-16 12:51:47 +0800
commit931f116d5fee25f22a48cf50b13323f3bd89180b (patch)
tree3bea5f8278717fd9552b008ffa21b01ef698da2f /client/qt4/Makefile.am
parent6a820938ed75a8c87ba223e248cba0d552bcb8b1 (diff)
downloadibus-931f116d5fee25f22a48cf50b13323f3bd89180b.tar.gz
ibus-931f116d5fee25f22a48cf50b13323f3bd89180b.tar.xz
ibus-931f116d5fee25f22a48cf50b13323f3bd89180b.zip
WIP.
Diffstat (limited to 'client/qt4/Makefile.am')
-rw-r--r--client/qt4/Makefile.am55
1 files changed, 55 insertions, 0 deletions
diff --git a/client/qt4/Makefile.am b/client/qt4/Makefile.am
new file mode 100644
index 0000000..012a6b0
--- /dev/null
+++ b/client/qt4/Makefile.am
@@ -0,0 +1,55 @@
+# vim:set noet ts=4:
+#
+# ibus - The Input Bus
+#
+# Copyright (c) 2007-2008 Huang Peng <shawn.p.huang@gmail.com>
+#
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2 of the License, or (at your option) any later version.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, write to the
+# Free Software Foundation, Inc., 59 Temple Place, Suite 330,
+# Boston, MA 02111-1307 USA
+
+EXTRA_DIST = \
+ ibus-client.cpp \
+ ibus-client.h \
+ ibus-input-context.cpp \
+ ibus-input-context.h \
+ ibus.pro \
+ im-ibus-qt.cpp \
+ $(NULL)
+
+if IBUS_BUILD_QT4
+Makefile.qmake: ibus.pro
+ $(QMAKE) -makefile -o Makefile.qmake $(srcdir)/ibus.pro
+
+all-local: Makefile.qmake
+ $(MAKE) -f Makefile.qmake $(AM_MAKEFLAGS) all
+
+check-local: Makefile.qmake
+
+clean-local: Makefile.qmake
+ $(MAKE) -f Makefile.qmake $(AM_MAKEFLAGS) clean
+
+distclean-local: Makefile.qmake
+ $(MAKE) -f Makefile.qmake $(AM_MAKEFLAGS) distclean
+
+install-exec-local: Makefile.qmake
+ $(MAKE) -f Makefile.qmake $(AM_MAKEFLAGS) INSTALL_ROOT=$(DESTDIR) install
+
+uninstall-local: Makefile.qmake
+ $(MAKE) -f Makefile.qmake $(AM_MAKEFLAGS) INSTALL_ROOT=$(DESTDIR) uninstall
+
+test: all
+ QT_IM_MODULE=ibus kwrite
+endif
+