summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 07821bd..0a0e885 100644
--- a/configure.in
+++ b/configure.in
@@ -41,6 +41,11 @@ if test -z $irssi_path; then
AC_MSG_ERROR([Path to Irssi distribution not specified. See --with-irssi option.])
fi
+# fix relative paths (from modules/icb)
+old=`pwd`
+irssi_path=`eval cd $irssi_path; pwd`
+cd $old
+
IRSSI_DIST=$irssi_path
AC_SUBST([IRSSI_DIST])
IRSSI_PYTHON_INCLUDES="-I${IRSSI_DIST} -I${IRSSI_DIST}/src -I${IRSSI_DIST}/src/fe-common/core \