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Preface

Accessing Sun Documentation Online
The docs.sun.comSM Web site enables you to access Sun technical documentation
online. You can browse the docs.sun.com archive or search for a specific book title or
subject. The URL is http://docs.sun.com.

Typographic Conventions
The following table describes the typographic changes used in this book.

TABLE P–1 Typographic Conventions

Typeface or Symbol Meaning Example

AaBbCc123 The names of commands, files, and
directories; on-screen computer output

Edit your .login file.

Use ls -a to list all files.

machine_name% you have
mail.

AaBbCc123 What you type, contrasted with
on-screen computer output

machine_name% su

Password:

AaBbCc123 Command-line placeholder: replace with
a real name or value

To delete a file, type rm
filename.
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TABLE P–1 Typographic Conventions (Continued)
Typeface or Symbol Meaning Example

AaBbCc123 Book titles, new words, or terms, or
words to be emphasized.

Read Chapter 6 in User’s Guide.

These are called class options.

You must be root to do this.

Shell Prompts in Command Examples
The following table shows the default system prompt and superuser prompt for the C
shell, Bourne shell, and Korn shell.

TABLE P–2 Shell Prompts

Shell Prompt

C shell prompt machine_name%

C shell superuser prompt machine_name#

Bourne shell and Korn shell prompt $

Bourne shell and Korn shell superuser prompt #
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PART I A Tour of the GNOME Desktop

This section introduces the core GNOME components. This section also provides
information that helps you to start working with the desktop. The desktop is very
configurable, therefore this section covers the main functional possibilities of the
desktop features. If you want to find out how to implement the various configuration
possibilities that are mentioned in this section, see Customizing Your GNOME Desktop.
The chapters in this section are as follows:

� Basic Skills

Read this chapter to find out about mouse usage, shortcut keys, basic window
skills, and basic dialog skills.

� Overview of the Desktop

Read this chapter for an introduction to the major components and functions of the
desktop. If you do not read anything else in this manual, read this chapter.

� Desktop Sessions

Read this chapter for information about how to start, manage, and end desktop
sessions.

� Working With Panels

Read this chapter to find out more about using panels. Panels are a key component
of the desktop. This chapter tells you how to use the different parts of your panels,
and how to invoke the available functions of the desktop using panels.

� Working With Menus

Read this chapter to find out more about using menus.
� Working With Windows

Read this chapter to find out more about using windows. This chapter describes
basic windows functions such as moving and resizing. This chapter also describes
the controls that you use with windows.

� Nautilus File Manager

15



Read this chapter to find out more about the Nautilus file manager. This chapter
describes how to use Nautilus to work with your file system. This chapter also
describes how to customize Nautilus.

� Using the Desktop Background

Read this chapter to find out more about using the desktop background. This
chapter describes how to use the desktop background to start applications, and
open your files and folders. The chapter also describes how to use Trash from the
desktop, how to use the Desktop Background menu, and how to customize the
desktop background.
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CHAPTER 1

Basic Skills

This chapter introduces you to the basic skills that you need to work with your
desktop.

� “1.1 Mouse Skills” on page 17
� “1.2 Keyboard Skills” on page 21
� “1.3 Using Windows and Dialogs” on page 25

1.1 Mouse Skills
Even if you are very familiar with mouse devices, you should still familiarize yourself
with the button conventions and action terminology used in this manual. This section
also describes the mouse pointers.

1.1.1 Mouse Button Conventions
All the instructions in this manual are for the following types of mouse devices:

� Devices that are configured for right-hand users.

� Three button devices. If you have a two-button mouse device, then you press the
two buttons simultaneously to simulate the effect of a middle mouse button.

The mouse button conventions used in this manual are as follows:

17



Mouse Button Definition

Left mouse button The button on the left side of a mouse device configured
for normal right-hand use.

Middle mouse button The middle button of a mouse device configured for
normal right-hand use.

Right mouse button The button on the right side of a mouse device configured
for normal right-hand use.

To reverse the handedness of your mouse device, choose Applications → Desktop
Preferences → Mouse, then select the options that you require. If you do reverse the
handedness of your mouse device, then you must reverse the mouse button
conventions used in this manual.

1.1.2 Mouse Actions
The following table describes the actions that you can perform with the mouse:

Mouse Button Definition

Left mouse button Use to perform the following actions:
� Select text.
� Choose items.
� Drag items.

Middle mouse button Use to perform the following actions:
� Paste text.
� Move items.

Right mouse button Opens a menu for the selected object, if a menu applies.

For example, if you want to copy text then perform the following steps:

1. Select the text with the left mouse button.
2. Move the mouse pointer to the location where you want to copy the text.
3. Click on the middle mouse button.

You can also right-click on the desktop background to open the Desktop Background
menu.
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1.1.3 Mouse Action Terminology
The conventions used in this manual to describe actions that you take with the mouse
are as follows:

Action Definition

Click Press and release the left mouse button, without moving
the mouse.

Click-and-hold Press and do not release the left mouse button.

Left-click Same as click. Left-click clarifies the action when there
might be confusion with right-click.

Middle-click Press and release the middle mouse button, without
moving the mouse.

Right-click Press and release the right mouse button, without moving
the mouse.

Double-click Press and release the left mouse button twice in rapid
succession without moving the mouse.

Drag Click-and-hold a mouse button, then move an object. For
example, you can drag a window or an icon. The left and
middle mouse buttons can perform drag actions.

Drag-and-drop Click-and-hold a mouse button, then move an object. For
example, you can drag-and-drop a window or an icon.
Release the mouse button to place the object in a new
location.

Grab Point to an item that you can move, and click-and-hold on
the mouse button. For example, you can grab the titlebar of
a window, then drag the window to a new location.

1.1.4 Mouse Pointers
As you use the mouse, the appearance of the mouse pointer can change. The
appearance of the pointer can provide feedback about a particular operation, location,
or state. The following table lists and describes some of the mouse pointers.
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Pointer Associated Action Description

Point to an item, choose a menu
item

Normal pointer. The pointer that
appears during normal use of the
mouse.

Drag-and-drop Move pointer. Indicates that when
you drop the object, the object is
moved from the old location to the
new location.

Drag-and-drop Copy pointer. Indicates that when
you drop the object, a copy of the
object is created where you drop
the object.

Drag-and-drop Link pointer. Indicates that when
you drop the object, a link to the
object is created where you drop
the object.

Drag-and-drop Ask pointer. Indicates that when
you drop the object, a menu opens.
You can choose to move or copy
the object, or to create a link to the
object.

Drag-and-drop Not available pointer. Indicates that
you cannot drop the object at the
current location.

Move panel object Move panel object pointer.
Indicates that you have selected a
panel object to move.

Resize window horizontally Horizontal resize pointer. Indicates
that you have selected a vertical
window border to resize the
window horizontally.

Resize window vertically Vertical resize pointer. Indicates
that you have selected a horizontal
window border to resize the
window vertically.

Resize window horizontally and
vertically

Corner resize pointer. Indicates that
you have selected a corner of a
window border to resize the
window horizontally and vertically.
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Pointer Associated Action Description

Resize window pane or resize table
column

Window pane or table column
resize pointer. Indicates that you
have selected a column in a table to
resize.

1.2 Keyboard Skills
For almost every task that you can perform with the mouse, you can use the keyboard
to perform the same task. Shortcut keys are keys that provide you with a quick way to
perform a task.

You can use shortcut keys to perform desktop tasks and to work with interface items
such as panels and windows. You can also use shortcut keys in applications. To
customize your shortcut keys, choose Applications → Desktop Preferences →
Keyboard Shortcuts.

You can also modify your desktop preferences to use keyboard accessibility features.

The following sections describe the shortcut keys that you can use.

1.2.1 Desktop Shortcut Keys
Desktop shortcut keys enable you to use the keyboard to perform desktop tasks. The
following table lists some desktop shortcut keys:

Default Shortcut Keys Function

Alt + F1 Opens the GNOME Menu.

Alt + F2 Displays the Run Program dialog.

Print Screen Takes a screenshot.

Alt + Print Screen Takes a screenshot of the window that has focus.

Ctrl + Alt + right arrow Switches to the workspace to the right of the current
workspace.

Ctrl + Alt + left arrow Switches to the workspace to the left of the current
workspace.
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Default Shortcut Keys Function

Ctrl + Alt + up arrow Switches to the workspace above the current workspace.

Ctrl + Alt + down arrow Switches to the workspace below the current workspace.

Ctrl + Alt + d Minimizes all windows, and gives focus to the desktop
background.

F1 Starts the online help browser, and displays appropriate
online help.

1.2.2 Window Shortcut Keys
Window shortcut keys enable you to use the keyboard to perform window tasks. The
following table lists some window shortcut keys:

Default Shortcut Keys Function

Alt + Tab Switches between windows. Release the keys to select a
window.

Alt + Esc Switches between windows in reverse order. Release the
keys to select a window.

F10 Opens the first menu on the left side of the menubar.

Alt + spacebar Opens the Window Menu.

Arrow keys Moves the focus between items in a menu.

Return Chooses a menu item.

Esc Closes an open menu.

Ctrl + Alt + right arrow Switches to the workspace to the right of the current
workspace.

Ctrl + Alt + left arrow Switches to the workspace to the left of the current
workspace.

Ctrl + Alt + up arrow Switches to the workspace above the current workspace.

Ctrl + Alt + down arrow Switches to the workspace below the current workspace.

Ctrl + Alt + d Minimizes all windows, and gives focus to the desktop
background.
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1.2.3 Panel Shortcut Keys
Panel shortcut keys enable you to use the keyboard to perform panel tasks. The
following table lists panel shortcut keys:

Default Shortcut Keys Function

Ctrl + Alt + Tab Switches the focus between the panels and the desktop
background.

Ctrl + F10 Opens the popup menu for the selected panel.

Tab Switches the focus between objects on a panel.

Return Chooses the selected panel object or menu item.

Shift + F10 Opens the popup menu for the selected panel object.

Arrow keys Moves the focus between items in a menu. Moves the focus
between interface items in an applet also.

Esc Closes an open menu.

F10 Opens the Applications menu on the Menu Panel, if the Menu
Panel is selected.

1.2.4 Application Shortcut Keys
Application shortcut keys enable you to perform application tasks. You can use
shortcut keys to perform application tasks more quickly than if you use a mouse. The
following table lists some application shortcut keys:

Shortcut Keys Command

Ctrl + N New

Ctrl + X Cut

Ctrl + C Copy

Ctrl + V Paste

Ctrl + Z Undo

Ctrl + S Save

Ctrl + Q Quit
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1.2.5 Access Keys
A menubar is a bar at the top of a window that contains the menus for the application.
An access key is an underlined letter in a menubar, menu, or dialog that you can use to
perform an action. On a menubar, the access key for each menu is underlined.

To open a menu, press Alt, then press the access key. In the menu, the access key for
each menu item is underlined. To choose a menu item, press the access key for the
menu item. The following table shows example access keys from the Text Editor
application:

Access Keys Function

Alt + F Opens the File menu.

N Chooses the New item on the File menu.

You can also use access keys to access elements in a dialog. In a dialog, one letter in
most dialog elements is underlined. To access a particular dialog element, press Alt,
then press the access key. The following table shows an example access key from the
Preferences dialog in the Text Editor application:

Access Key Function

Alt + U Gives focus to the Use default theme font
check box.

You can use also other keys to navigate within a window or dialog.

Key Function

Tab Moves the focus from element to element in a window or
dialog.

Arrow keys Use the arrow keys to perform the following actions:
� In a menubar, move the focus from one menu to the

next menu. In an open menu, move the focus from one
menu item to the next menu item.

� Move the focus from one option to the next option to
make your selection, for example, within a group of
radio buttons in a dialog.

� Change the value that a spin box displays.
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1.3 Using Windows and Dialogs
This section provides information on how to use windows and dialogs.

1.3.1 To Resize Panes in Windows
Some windows contain more than one pane. A pane is a subdivision of a window. For
example, the Nautilus window contains a side pane and a view pane. A window that
contains panes has a resize handle on the edge between the panes. To resize the pane,
grab the resize handle, then drag the edge to the size you require.

1.3.2 Using Tables
Some windows contain information that is organized in a table. This section describes
how to work with tables.

To change the width of a column, drag one of the vertical edges of the column.

In some tables, you can sort the information by a particular column. To sort
information in a table, click on the heading on top of the column by which you want
to sort the information. An up arrow is displayed in the column heading by which the
table is sorted. The following figure shows the up arrow.

To reverse the sort order, click on the column heading again. The up arrow changes to
a down arrow. The down arrow indicates that the information in the column is sorted
in reverse order.

In some tables, you can select multiple items. The following table describes how to
select items in tables.

Task Action

Select an item Click on the item.

Select a group of contiguous
items

Press-and-hold Shift. Click on the first item in the group,
then click on the last item in the group.
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Task Action

Select multiple items Press-and-hold Ctrl. Click on the items that you want to
select.
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CHAPTER 2

Overview of the Desktop

This chapter introduces you to the features and main components of the GNOME
desktop. Before you start to use the desktop read this chapter to familiarize yourself
with the various features, and how the main components work. The desktop is very
configurable, so this chapter describes the typical default configuration, covering the
following topics.

� “2.1 Introducing Desktop Components” on page 27
� “2.2 Panels” on page 30
� “2.3 Menus” on page 33
� “2.4 Windows in the Desktop” on page 34
� “2.5 Workspaces” on page 36
� “2.6 Nautilus File Manager” on page 37
� “2.7 Desktop Background” on page 39
� “2.8 Start Here Location” on page 40
� “2.9 Desktop Preferences” on page 41
� “2.10 Applications” on page 42
� “2.11 To Find Out More” on page 43

2.1 Introducing Desktop Components
When you start a desktop session for the first time, you should see a default startup
screen, with panels, windows, and various icons. Figure 2–1 shows a typical desktop.
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FIGURE 2–1 A Typical Desktop

The major components of the desktop are as follows:

� Panels

Panels are areas on your desktop from which you can access all of your system
applications and menus. Panels are very configurable. A particularly important
panel in Figure 2–1 is the Menu Panel. The Menu Panel stretches the full width of
the top edge of the desktop. The Menu Panel includes two special menus, as
follows:

� Applications menu: Contains all applications and configuration tools. This
menu also includes the file manager and the help browser.

� Actions menu: Contains various commands that perform desktop functions, for
example Search for Files and Log Out.
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Click on the icon at the extreme right of the Menu Panel to display a list of all open
windows.

� Menus

You can access all desktop functions through menus. The Menu Panel contains
menus, so you can use a combination of menus and panels to perform your tasks.
You can use the Applications menu and the Actions menu to access almost all of
the standard applications, commands, and configuration options.

You can also access the items in the Applications and Actions menus from the
GNOME Menu. The items in the Actions menu are at the top level of the GNOME
Menu.

� Windows

You can display many windows at the same time. You can run different
applications in each window. The window manager provides frames and buttons
for windows. The window manager enables you to perform standard actions such
as move, close, and resize windows.

� Workspaces

You can subdivide your desktop into separate workspaces. A workspace is a discrete
area on the desktop in which you can work. You can specify the number of
workspaces on your desktop. You can switch to a different workspace, but you can
only display one workspace at a time.

� Nautilus file manager

The Nautilus file manager provides an integrated access point to your files and
applications. You can display the contents of your files within a Nautilus window,
or open the files in the appropriate application from Nautilus. You can use the
Nautilus file manager to manage your files and folders.

� Desktop background

The desktop background lies behind all of the other components on the desktop.
The desktop background is an active component of the user interface. You can
place objects on the desktop background to quickly access your files and
directories, or to start applications that you use often. You can also right-click on
the background to open a menu.

� Start Here location

The Start Here location provides an access point to some of the key features of the
GNOME desktop. You can access your GNOME applications and configuration
tools from the Start Here location. You can also access programs that enable you to
configure your system as a server, and to choose other system settings.

� Desktop preferences

The GNOME desktop contains dedicated preference tools. Each tool controls a
particular part of the behavior of the desktop. To start a preference tool, choose
Applications → Desktop Preferences. Choose the item that you want to configure
from the submenus.
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The most powerful features of the desktop are the high degree of configurability and
the multiple ways that you can perform tasks.

The desktop provides interoperability of the desktop components. Usually, you can
perform the same action in several different ways. For example, you can start
applications from panels, from menus, or from the desktop background.

Your system administrator can make configuration changes to suit your needs, so that
the desktop might not be exactly the same as described in this chapter. Nevertheless,
this chapter provides a useful quick guide to how to work with the desktop.

2.2 Panels
You can add or delete panels at any time. When you start a session for the first time,
the desktop usually contains at least two panels, as follows:

� Menu Panel
� Edge panel at the bottom of the desktop

You can perform the following actions with panels:

� Create panels.
� Delete panels.
� Hide panels.
� Add objects to panels.
� Manipulate panel objects.

2.2.1 To Create Panels
To create a panel follow these steps:

1. Right-click on a vacant space on any panel, then choose New Panel.

2. Choose the type of panel that you want to create from the submenu. The panel is
added to the desktop.

You can create as many panels as you want. However, you can only create one Menu
Panel. You can create different types of panel to fit your own requirements. You can
customize the behavior and appearance of your panels. For example, you can change
the background of your panels.

2.2.2 To Delete Panels
To delete a panel, right-click on the panel then choose Delete This Panel.
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2.2.3 To Hide Panels
Except for the Menu Panel, panels can have hide buttons at each end of the panel. You
click on the hide buttons to hide or show the panel.

2.2.4 To Add Objects to Panels
A panel can hold several types of objects. The panel in Figure 2–2 contains each type
of panel object.

FIGURE 2–2 A Panel With Various Panel Objects

You can add any of the following objects to all types of panels:

� Applets

Applets are small, interactive applications that reside within a panel, for example
CD Player in Figure 2–2. Each applet has a simple user interface that you can
operate with the mouse or keyboard. The following applets appear in your panels
by default:

� Window List: Displays a button for each window that is open. You can click on
a window list button to minimize and restore windows. By default, Window
List appears in the edge panel at the bottom of the desktop.

� Workspace Switcher: Displays a visual representation of your workspaces. You
can use Workspace Switcher to switch between workspaces. By default,
Workspace Switcher appears in the edge panel at the bottom of the desktop.

To add an applet to a panel, right-click on a vacant space on the panel, then choose
Add to Panel. Choose the applet that you require from one of the following
submenus:

� Accessories
� Amusements
� Internet
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� Multimedia
� Utility

� Launchers

A launcher starts a particular application, executes a command, or opens a file. The
calculator icon in Figure 2–2 is a launcher for the Calculator application. A launcher
can reside in a panel or in a menu. Click on the launcher to perform the action that
is associated with the launcher.

You can create your own launchers for applications. For example, you can create a
launcher for a word processor application that you use frequently, and place the
launcher in a panel for convenient access. To add a new launcher to a panel,
right-click on a vacant space on the panel, then choose Add to Panel → Launcher.

Alternatively, to add a launcher from a menu, right-click on a vacant space on the
panel, then choose Add to Panel → Launcher from menu. Choose the launcher to
add from the submenus.

� Menus

You can access all desktop functions through menus. The default panels contain
menus, so you can use a combination of menus and panels to perform your tasks.
To open a menu from a panel, click on the icon that represents the menu. To open a
menu from the Menu Panel, click on the text that represents the menu.

Menus that you add to your panels are represented by an icon with an arrow. The
arrow indicates that the icon represents a menu. The icon in Figure 2–2 is the icon
that is displayed when you add the Desktop Preferences menu to a panel.

You can also add the GNOME Menu to any of your panels. To add the GNOME
Menu to a panel, right-click on a vacant space on the panel, then choose Add to
Panel → GNOME Menu.

� Drawers

Drawers are sliding extensions to a panel that you can open or close from a drawer
icon, as shown in Figure 2–2. Drawers can help you to organize your work when
you run a lot of applications simultaneously. You can place all the same functional
elements in a drawer that you can put in any other type of panel.

To add a drawer to a panel, right-click on a vacant space on the panel, then choose
Add to Panel → Drawer.

To open a drawer click on the drawer. To close a drawer click on the drawer again.
� Lock button and Log Out button

The Lock button enables you to lock your screen. The lock icon in Figure 2–2 is the
Lock button. The Lock button enables you to end your session.

To add the buttons to a panel, right-click on a vacant space on the panel, then
choose Add to Panel. You can then choose the button you require.
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2.2.5 To Manipulate Panel Objects
You can manipulate panel objects in the following ways:

� Move objects within a panel, or to another panel.

You can move any object to another location in the panel. You can also move an
object from one panel to another panel. Use the middle mouse button to drag the
panel object to the new location.

� Copy menu items to a panel.

Drag the item from the menu to the panel. Alternatively, if the menu item is a
launcher right-click on the menu item, then choose Add this launcher to panel.

2.3 Menus
You can access all desktop functions through menus. Your default panels contain
menus, so you can use a combination of menus and panels to perform your tasks. The
Menu Panel contains Applications and Actions menus. You can also add the GNOME
Menu to your panels.

You can use the Applications menu and the Actions menu to access almost all of the
standard applications, commands, and configuration options. You can also access the
items in the Applications and Actions menus from the GNOME Menu.

To add a GNOME Menu to a panel, right-click on the panel then choose Add to Panel
→ GNOME Menu. The GNOME Menu is represented by a stylized footprint, as
follows:

Click on the GNOME Menu button on a panel to open the GNOME Menu.

You can add as many additional menus as you want to any of your panels. To open a
menu that you add to a panel, click on the menu icon on the panel. You can perform
other actions on your menus, such as copy menu items to panels.
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2.4 Windows in the Desktop
You can display many windows at the same time on your desktop. Each window has a
frame. The window frame contains active control elements that you can use to work
with the window.

2.4.1 Types of Windows
The desktop features the following types of window:

� Application windows

When you run an application, a frame usually borders the window. The top edge
of the application window contains a titlebar. The titlebar contains buttons that you
can use to work with the window. The buttons in an application window frame
enable you to perform actions such as open the Window Menu, or close the
window. The Window Menu provides commands that you can perform on the
window.

� Dialog windows

Dialog windows are associated with interactive processes. A dialog window
consists of the window frame, and a single interactive pane that provides
information and controls for the user. This manual refers to the interactive part of a
dialog window as a dialog. The frame of a dialog window contains buttons that
enable you to open the Window Menu, or to close the dialog window.

2.4.2 To Manipulate Windows
You use the frame of an application window or dialog window to perform various
actions with the window. Most of the control elements are located on the top edge of
the window frame. Figure 2–3 shows the top edge of a frame for a typical application
window.
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FIGURE 2–3 Top Edge of Frame for a Typical Application Window

The active control elements of the window frame are as follows:

Control Element Description

Window Menu button Click on the Window Menu button to open the
Window Menu.

Titlebar You can use the titlebar to move and shade the
window.

Minimize button Click on the Minimize button to minimize the
window.

Maximize button You can use the Maximize button to maximize and
restore the window.

To maximize a window click on the Maximize button.
To restore the window click on the Maximize button
again.

Close Window button Click on the Close Window button to close the
window.

Border Right-click on the border to open the Window Menu.

To change the size of windows grab the border of the window, but not the titlebar.
Drag the border until the window is the size that you require.

2.4.3 To Give Focus to a Window
A window that has focus can receive input from the mouse and the keyboard. Only
one window can have focus at a time. The window that has focus has a different
appearance than other windows.

You can use the following elements to give focus to a window:
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Element Action

Mouse Click on the window, if the window is visible.

Shortcut keys Use shortcut keys to switch between the windows that are
open. To give focus to a window, release the keys. The default
shortcut keys to switch between windows are Alt + Tab.

Window List Click on the button that represents the window in Window
List.

Workspace Switcher Click on the window that you want to give focus to in the
Workspace Switcher display.

2.5 Workspaces
You can display many windows at the same time on your desktop. Your windows are
displayed in subdivisions of your desktop that are called workspaces. A workspace is
a discrete area on the desktop in which you can work.

Every workspace on the desktop contains the same desktop background, the same
panels, and the same menus. However, you can run different applications, and open
different windows in each workspace. You can display only one workspace at a time
on your desktop but you can have windows open in other workspaces.

Workspaces enable you to organize the desktop when you run many applications at
the same time. When your current workspace becomes crowded with windows, you
can move your work to another workspace. You can also switch to another workspace
then start more applications.

Workspaces are displayed in the Workspace Switcher applet. In Figure 2–4, Workspace
Switcher contains four workspaces. The first three workspaces contain open windows.
The last workspace does not contain currently active windows.

FIGURE 2–4 Workspaces Displayed in Workspace Switcher

2.5.1 To Switch Between Workspaces
You can switch between workspaces in the following ways:

� In Workspace Switcher, click on the workspace where you want to work.
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� Press Ctrl + Alt + right arrow to switch to the workspace on the right of the current
workspace.

� Press Ctrl + Alt + left arrow to switch to the workspace on the left of the current
workspace.

2.5.2 To Add Workspaces
To add workspaces to your desktop, right-click on the Workspace Switcher applet,
then choose Preferences. The Workspace Switcher Preferences dialog is displayed. Use
the Number of workspaces spin box to specify the number of workspaces that you
require.

2.6 Nautilus File Manager
The Nautilus file manager provides an integrated access point to your files,
applications, and FTP sites. To open a Nautilus window, choose Applications → Home
Folder. The following figure shows a Nautilus window that displays the contents of a
folder.
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A Nautilus window contains the following panes:

� Side pane

Enables you to navigate through your files. This pane also displays information
about the current file or folder. The side pane is on the left side of the window.

� View pane

Displays the contents of files and folders. The view pane is on the right side of the
window.

Nautilus enables you to do the following:

� View files and folders

You can view your files and folders as icons or as a list. You can view the contents
of some types of file within a Nautilus window. Alternatively, you can open the
files in the appropriate application from Nautilus.
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� Manage your files and folders

You can use Nautilus to create, move, copy, rename, and remove files and folders.
� Run scripts

You can run scripts from Nautilus, and you can select files and folders on which to
run your scripts.

� Customize your files and folders

You can add emblems to your files and folders to indicate particular states. For
example, you can add an Important emblem to a file to indicate that the file is
important. You can also customize folders in the following ways:

� Add a note to a folder.
� Specify a custom background pattern for a folder.
� Specify a zoom setting for a folder.

Nautilus also creates the desktop background.

2.6.1 To Open Files From the Nautilus File
Manager
To navigate to the folder where the file that you want to open resides, double-click on
the folder icons in the view pane. When the file that you want to open is displayed,
double-click on the file icon to open the file.

2.6.2 To Move Files Between Folders
You can move files between folders by opening two or more Nautilus windows. Open
a different folder in each window, then drag the files from one window to the other.

2.7 Desktop Background
The desktop background is an active component of the desktop. You can use the
desktop background to perform the following actions:

� Start your applications, and open your files and folders.

You can add desktop background objects for convenient access to the files, folders, and
applications that you use frequently. For example, you add a launcher for an
application that you use often.

� Open the Desktop Background menu.
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Right-click on the desktop background to open the Desktop Background menu.
You can use the Desktop Background menu to perform actions on the desktop
background.

The Nautilus file manager manages the desktop background.

2.7.1 To Open Desktop Background Objects
To open an object from the desktop background, double-click on the object. You can
set your preferences in a Nautilus window so that you click once on an object to
execute the default action.

2.7.2 To Add Objects to the Desktop Background
You can add desktop background objects for convenient access to files, folders, and
applications that you use frequently. You can add objects to your desktop background
in the following ways:

� Use the Desktop Background menu to add a launcher to the desktop background.
� Drag an object from a file manager window to the desktop background. For

example, you can create a symbolic link to a file that you use often, then drag the
link to your desktop background. The icon for the link is moved to the desktop
background. To open the file, double-click on the icon. You can also drag files and
folders to the desktop background.

� Drag an application launcher from a menu to the desktop background. For
example, you can open a menu that contains a launcher for an application that you
use often, then drag the launcher to your desktop background.

2.8 Start Here Location

The Start Here location enables you to access the following functions:

� Applications
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Double-click on Applications to access your key GNOME applications. You can
also access the Applications menu through the GNOME Menu and the Menu
Panel.

� Desktop Preferences

Double-click on Desktop Preferences to customize your desktop.

� Programs that enable you to configure your system as a server, and to choose other
system settings.

You can access the Start Here location in the following ways:

� From a Nautilus window

Choose Go → Start Here. The contents of the Start Here location are displayed in
the window.

� From the desktop background

Double-click on the Start Here object on the desktop background. The contents of
the Start Here location are displayed in a Nautilus window.

2.9 Desktop Preferences
You can use desktop preference tools to configure almost every feature of the desktop.
Each tool controls a particular part of the behavior of the desktop. For example, you
can use a preference tool to select a theme for your desktop. A theme is a group of
coordinated settings that specify the visual appearance of a part of your interface.

For convenience, the tools are grouped under the following headings:

� Basic
� Accessibility
� Advanced

You can open your desktop preference tools in either of the following ways:

� Choose Applications → Desktop Preferences. Choose the item that you require
from the submenus.

� Double-click on the Start Here object on the desktop background. A Nautilus
window opens at the Start Here location. Double-click on the Desktop Preferences
object in the Nautilus window to display the desktop preference tools. Double-click
on the item that you require.
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2.10 Applications
The applications that are provided with the GNOME desktop share several
characteristics. For example, the applications have a consistent look-and-feel. The
applications share characteristics because the applications use the same programming
libraries. An application that uses the standard GNOME programming libraries is
called a GNOME-compliant application. For example, Nautilus and the gedit text editor
are GNOME-compliant applications.

GNOME provides libraries in addition to the libraries provided by your operating
system. The libraries enable GNOME to run your existing applications as well as
GNOME-compliant applications. For example, if your operating system is
UNIX-based, you can run your current X11 applications and Motif applications from
the GNOME desktop.

Some of the features of GNOME-compliant applications are as follows:

� Consistent look-and-feel

GNOME-compliant applications have a consistent look-and-feel.
GNOME-compliant applications use the look-and-feel settings that you specify in
the desktop preference tools. You can use the following tools to change the
look-and-feel of your GNOME-compliant applications:

� Applications → Desktop Preferences → Menus & Toolbars
� Applications → Desktop Preferences → Theme

� Menubars, toolbars, and statusbars

Most GNOME-compliant applications have a menubar, a toolbar, and a statusbar.
The menubar always contains a File menu and a Help menu. The File menu always
contains an Quit menu item, and the Help menu always contains an About menu
item.

A toolbar is a bar that appears under the menubar. A toolbar contains buttons for
the most commonly-used commands. A statusbar is a bar at the bottom of a
window that provides information about the current state of what you are viewing
in the window. GNOME-compliant applications might also contains other bars. For
example, Nautilus contains a location bar.

Some of the bars in GNOME-compliant applications are detachable. That is, the bar
has a handle that you can grab then drag the bar to another location. You can drag
the bar to snap to another side of the window, or to another part of the desktop.
For example, you can detach the menubar, toolbar, and location bar in the Nautilus
file manager.

� Default shortcut keys

GNOME-compliant applications use the same shortcut keys to perform the same
actions. For example, to quit a GNOME-compliant application, press Ctrl + Q. To
undo an action in a GNOME-compliant application, press Ctrl + Z.
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� Drag-and-drop

GNOME-compliant applications use the same protocol to implement
drag-and-drop operations. Therefore, GNOME-compliant applications provide
consistent feedback when you drag-and-drop items.

The use of the same protocol also enables GNOME-compliant applications to
interoperate in a sophisticated manner. For example, GNOME-compliant
applications recognize the format of the items that you drag. When you drag a
HTML file from a Nautilus window to a web browser, the file is displayed in
HTML format in the browser. However, when you drag the HTML file to a text
editor, the file is displayed in plain text format in the text editor.

2.11 To Find Out More
The desktop provides help if you want to find out more about the following areas:

� Desktop topics
� Applets
� Applications

2.11.1 To Find Out More About Desktop Topics
You can find out more about particular desktop topics in the integrated Yelp help
system. To start the Yelp help system, choose Applications → Help.

2.11.2 To Find Out More About Applets
To find out more about a specific applet, right-click on the applet, then choose Help.

2.11.3 To Find Out More About Applications
To find out more about a specific application, start the application, then choose Help
→ Contents. Alternatively, start the application then press F1.
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CHAPTER 3

Desktop Sessions

This chapter provides the information you need to start, manage, and end a desktop
session.

� “3.1 Starting a Desktop Session” on page 45
� “3.2 Locking Your Screen” on page 46
� “3.3 Managing the Session” on page 50
� “3.4 Ending a Session” on page 51

3.1 Starting a Desktop Session
A desktop session occurs between the time that you log in to the desktop and the time
that you log out. The login screen, displayed by the Login Manager, is your gateway
to the desktop. The login screen provides fields for you to enter your username and
password. The Options menu on the login screen lists your login options, for example
you can select the language of your session.

You start a session when you log in. The session manager starts after the Login
Manager authenticates your username and password. The session manager enables
you to manage the session. For example, you can save the state of your most recent
session and return to that session the next time that you log in. The session manager
saves and restores the following:

� The appearance and behavior settings, for example fonts, colors, and mouse
settings.

� The applications that you were running, for example file manager and text editor
windows. You cannot save and restore applications that the session manager does
not manage. For example, if you start the vi editor from the command line in a
terminal window, session manager cannot restore your editing session.
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3.1.1 To Log in to a Desktop Session
To log in to a session, perform the following actions.

1. Choose Options → Session. Choose the GNOME desktop from the list of available
desktop environments.

2. Enter your login name in the field on the Login Manager dialog, then click OK.

3. Enter your password in the field on the Login Manager dialog, then click OK.

When you log in successfully, the session manager starts a session. If this is the first
time you log in, then the session manager starts a new session. If you have logged in
before, then the session manager restores your previous session.

3.1.2 To Start a Session in a Different Language
To start a session in a different language, perform the following actions.

1. On the login dialog, choose Options → Session. Choose the GNOME desktop from
the list of available desktop environments.

2. On the login dialog, choose Options → Language.

3. Choose the language group that includes the language that you want.

4. Choose a language.

5. Log in.

Your system administrator sets the default language for your system. The Options
menu on the Login Manager dialog enables you to access other languages. When you
choose a language in the Options menu, your system sets the LANG variable for your
session. The system restores the default language at the end of the session.

3.2 Locking Your Screen
This section provides information on how to lock your screen, and how to configure
your screensaver.

3.2.1 To Lock Your Screen
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To lock the screen, perform one of the following actions:

� Choose Actions → Lock Screen.

� If the Lock button is present on a panel, click on the Lock button.

To add the Lock button to a panel, right-click on the panel. Choose Add to Panel →
Lock button.

When you lock your screen, the screensaver starts. To unlock the screen, move your
mouse to display the locked screen dialog. Enter your username and password in the
locked screen dialog, then press Return.

Note – To lock your screen correctly, you must have a screensaver enabled.

3.2.2 To Configure Your Screensaver
A screensaver is an application that you can use to replace the image on your screen
when the screen is not in use. You can use screensavers in the following ways:

� Activate after a specified period of idle time.
� Activate when you lock your screen.
� Manage power used by your monitor when your system is idle.

To configure your screensaver application, perform the following steps:

1. Right-click on the Lock button, then choose Properties from the popup menu. An
XScreenSaver dialog is displayed.

If the Lock button is not present on a panel, you can add the button to a panel. To
add the Lock button to a panel, right-click on the panel. Choose Add to Panel →
Lock button.

2. To configure your screensaver application, use the elements in the Display Modes
tab. The following table describes the dialog elements on the Display Modes
tabbed section:
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Setting Function

Mode Use the drop-down list box to specify the behavior of
the screensaver application. Select from the following
options:
� Disable Screen Saver: Select this option if you do

not want to use the screensaver application.
� Blank Screen Only: Select this option if you want

your screen to become blank when your screen
locks.

� Only One Screen Saver: Select this option if you
want to display a single screensaver display from
the display list box when your screen locks.

� Random Screen Saver: Select this option if you
want to display a random selection of screensaver
displays from the screensaver display list box
when your screen locks.

Display list box Select the screensaver display that you require from
the list box.

Blank After Specify how long to wait after the last use of the
mouse or keyboard, to activate the screensaver.

Cycle After Specify how long to show a particular screensaver
display before the next display.

Lock Screen After Select this option if you want the screen to lock after
the screensaver is activated. Use the spin box to
specify the delay between the activation of the
screensaver and when the screen locks.

Preview Click on this button to preview the screensaver
display that is selected in the screensaver display list
box. To stop the preview, press any key or click a
mouse button.

Settings Click on this button to display the options for the
screensaver display that is selected in the screensaver
display list box.

3. To configure advanced options, click on the Advanced tab. The following table
describes the dialog elements on the Advanced tabbed section:

Setting Function

Grab Desktop Images Some screensavers can take a screenshot of your
desktop, then manipulate the screenshot to create
your screensaver display. Select this option to enable
screensavers to take a screenshot of your desktop.
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Setting Function

Grab Video Frames Some screensavers can capture a frame of video, then
manipulate the captured image to create your
screensaver display. If your system has a video
capture card, select this option to enable screensavers
to capture a frame of video.

Choose Random Image Select this option to enable screensavers to use
images from a directory that you select. Type the
path for the directory in the field. Alternatively, click
Browse to display a dialog from which you can select
a directory.

Verbose Dialognostics Select this option if you want to display screensaver
diagnostic information.

Display Subprocess Errors Select this option if you want to display errors
related to screensaver subprocesses on screen.

Display Splash Screen at Startup Select this option to if you want Xscreensaver to
display a splash dialog when Xscreensaver starts.

Power Management Enabled Select this option to enable power management of
your monitor. Power management can reduce energy
consumption by your monitor when you are not
using the monitor.

Standby After Specify how long to wait to put the monitor in
standby mode. When the monitor is in standby
mode, the screen is black.

Suspend After Specify how long to wait to put the monitor in
power-saving mode.

Off After Specify how long to wait to switch off monitor.

Install Colormap Select this option to install a private colormap when
the screensaver is active. Use of a private colormap
might improve the quality of the color in particular
screensaver displays.

Fade to Black When Blanking Select this option if you want your display to fade to
black when the screensaver activates.

Fade from Black When Unblanking Select this option if you want your display to fade
from black to the screen contents when the
screensaver stops.

Fade Duration Specify how long to take to fade to black when the
screensaver activates.

4. Click on the Close Window window frame button to close the XScreenSaver dialog.
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3.3 Managing the Session
To configure the session management of the desktop, choose Applications → Desktop
Preferences → Advanced → Sessions. The Sessions preference tool recognizes the
following types of application:

� Applications that are session-managed. When you save the settings for your
session, the session manager saves all of the session-managed applications. If you
log out, then log in again, the session manager automatically starts the
session-managed applications.

� Applications that are not session-managed. When you save the settings for your
session, the session manager does not save any applications that are not
session-managed. If you log out, then log in again, the session manager does not
start non-session-managed applications. You must start the application manually.
Alternatively, you can use the Sessions preference tool to specify
non-session-managed applications that you want to automatically start.

3.3.1 Defining Session Behavior When You Log In
and Log Out
To set how a session behaves when you log in and log out, choose Applications →
Desktop Preferences → Advanced → Sessions. Make the changes you require in the
Session Options tabbed section. For example, you can select to display a splash screen
when you log in.

3.3.2 To Use Startup Applications
You can configure your sessions to start with applications that are not
session-managed. To configure non-session-managed startup applications, choose
Applications → Desktop Preferences → Advanced → Sessions. Use the Startup
Programs tabbed section to add, edit, and delete applications. If you save your settings
and log out, the next time that you log in, the startup applications start automatically.

3.3.3 To Browse Applications in the Current Session
To browse the applications in the current session, choose Applications → Desktop
Preferences → Advanced → Sessions. The Current Session tabbed section lists the
following:

� All GNOME applications that are currently running, that can connect to the session
manager, and that can save the state of the application.
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� All desktop preference tools that can connect to the session manager, and that can
save the state of the tool.

You can use the Current Session tabbed section to perform a limited number of actions
on the session properties of an application or preference tool. For example, you can
edit the startup order, and restart style of any GNOME application or desktop
preference tool that is in the list.

3.3.4 To Save Session Settings
To save your session settings, perform the following steps:

1. Configure your session to automatically save settings when you end the session. To
configure your session, choose Applications → Desktop Preferences → Advanced
→ Sessions. The Sessions preference tool starts. Select the Automatically save
changes to session option on the Session Options tabbed section.

2. End your session.

If you do not select the Automatically save changes to session option, when you log
out, a dialog asks if you want to save your current settings. To save your settings,
select the option, then continue to log out.

3.4 Ending a Session

To end your session, close all your currently active processes, then perform one of the
following actions:

� Click on the Log Out button.
� Choose Actions → Log Out.
� Open the GNOME Menu, then choose Log Out.

Before you end a session, you might want to save your current settings so that you can
restore the session later. During the logout process, a dialog asks if you want to save
your current settings. In the Sessions preference tool, you can select an option to
automatically save your current settings.
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CHAPTER 4

Working With Panels

The information in this chapter describes how to use panels.

� “4.1 Introducing Panels” on page 53
� “4.2 Managing Your Panels” on page 55
� “4.3 Panel Objects” on page 61
� “4.5 Launchers” on page 65
� “4.6 Menus” on page 69
� “4.4 Applets” on page 63
� “4.7 Drawers” on page 70
� “4.8 Log Out Button” on page 73
� “4.9 Lock Button” on page 73

4.1 Introducing Panels
A panel is an area on your desktop from which you can run applications and applets,
and perform other tasks. When you start a session for the first time, the desktop
contains the following panels:

� Menu Panel
� Edge panel at the bottom of the desktop

The following sections describe these panels.

4.1.1 Menu Panel
The Menu Panel stretches the full length of the top edge of your screen. The Menu
Panel includes textual rather than graphical menus. Figure 4–1 shows the Menu Panel.
Your system administrator might have set your default Menu Panel according to your
local requirements, so you might see a slightly different Menu Panel.
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FIGURE 4–1 Typical Menu Panel

The typical Menu Panel contains the following objects:

Object Description

Applications menu The Applications menu contains the standard GNOME
applications.

Actions menu The Actions menu provides commands that enable you to
perform desktop tasks.

Home folder launcher Click on this launcher to open your home folder in a Nautilus
file manager window.

Terminal launcher Click on this launcher to start the Terminal application. Terminal
provides access to a UNIX command line.

Volume Control applet Volume Control enables you to control the volume of the speaker
on your system.

Clock applet Clock shows the current time. Click on the time readout to
display a menu of clock commands.

Window list icon The window list is a list of all your open windows. To give focus
to a window, click on the icon at the extreme right of the Menu
Panel, then choose the window.

Unlike other types of panel, you can only have one Menu Panel at a time on your
desktop.

4.1.2 Bottom Edge Panel
On startup, an edge panel stretches the full length of the bottom edge of the desktop.
Figure 4–2 shows a typical bottom edge panel. Your system administrator might have
set your default bottom edge panel according to your local requirements, so you might
see a slightly different bottom edge panel.
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FIGURE 4–2 Typical Bottom Edge Panel

The bottom edge panel contains the following applets:

� Window List: Displays a button for each window that is open. Window List
enables you to minimize and restore windows.

� Workspace Switcher: Enables you to navigate between your workspaces.

You can change the behavior and appearance of your bottom edge panel to suit your
requirements. You can also add or remove objects from your bottom edge panel. You
can create multiple panels, and choose different properties, objects, and backgrounds
for each panel. You can also hide panels.

4.2 Managing Your Panels
The following sections describe how to manage your panels.

4.2.1 To Add a New Panel
You can add different types of panels to your desktop. Table 4–1 lists the types of
panel that you can add, and their characteristics.

TABLE 4–1 Types of Panel

Panel Type Snap Behavior Size

Corner Panel Snaps to one of the edges of the
screen, but can only snap to the
center or the corner of the edge.

Stretches as much as required to
display the objects on the panel.

Edge Panel Snaps to one of the edges of the
screen. The startup panel at the
bottom of the desktop is an
example of an edge panel.

Stretches the full length of the
edge that the panel snaps to.

Floating Panel Does not snap to anything. You
can place a floating panel
anywhere on your desktop.

Stretches as much as required to
display the objects on the panel.
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TABLE 4–1 Types of Panel (Continued)
Panel Type Snap Behavior Size

Sliding Panel Snaps to one of the edges of the
screen, can snap to any point on
the edge.

Stretches as much as required to
display the objects on the panel.

Menu Panel Snaps to the top edge of the
screen. You cannot move the
Menu Panel.

Stretches the full length of the top
edge of the screen. You can only
have one Menu Panel on your
desktop.

To add a panel perform the following steps:

1. Right-click on a vacant space on any panel, then choose New Panel.

2. Choose the type of panel that you want to add. The new panel is added to the
desktop. The new panel contains no objects, except for a Menu Panel.

You can customize the new panel to suit your preferences.

4.2.2 To Interact With a Panel
To interact with a panel, you must left-click, middle-click, or right-click on a vacant
space on the panel. You can also middle-click or right-click on one of the hide buttons
to select the panel, if the panel has no vacant space. If the hide buttons are not visible
on a panel, modify the properties of the panel so that the hide buttons are visible.

You use the mouse buttons to interact with a panel in the following ways:

Middle-click Enables you to grab a panel, then drag the panel to a new
location.

Right-click Opens the panel popup menu.

4.2.3 To Move a Panel
You can move panels to different locations on your desktop. To move a panel,
middle-click and hold on any vacant space on the panel, then drag the panel to the
new location.

When you drag a floating panel, the panel follows the mouse pointer. The panel does
not snap to any part of the desktop. When you drag a corner panel, an edge panel, or
a sliding panel, the panel snaps to the edge of the screen.
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Note – You cannot move the Menu Panel.

4.2.4 To Hide a Panel
You can hide or show panels, except for the Menu Panel. To hide a panel, use a hide
button. If the hide buttons are not visible on a panel, modify the panel properties so
that the hide buttons are visible.

Hide buttons are at either end of a panel. The hide buttons contain an optional arrow
icon. The following illustration shows hide buttons.

To hide a panel, click on one of the hide buttons. The panel reduces in the direction of
the arrow on the hide button. The hide button at the other end of the panel remains
visible.

To show a hidden panel again, click on the visible hide button. The panel expands in
the direction of the arrow on the hide button. Both hide buttons are now visible.

You can set a panel to autohide. When you set autohide, the panel hides automatically
when the mouse is not pointing to the panel. The panel reappears when you point to
the part of the screen where the panel resides. To set your panel to autohide, modify
the properties of the panel.

Note – On a corner panel, the behavior of the hide buttons is slightly different. If the
panel is in one of the corners of the screen, you can use the hide buttons as follows:

� To hide the panel, click the hide button that is closest to the edge of the screen, as
normal.

� To move the panel to the opposite corner of the screen, click the hide button that is
farthest from the edge of the screen.

4.2.5 To Modify Panel Properties
To modify preferences for all panels, choose Applications → Desktop Preferences →
Advanced → Panel, then make the changes that you require. For example, you can
specify various settings related to the appearance and behavior of panel objects.
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You can also modify properties for each individual panel. You can change the features
for each panel, such as the type of the panel, the hide behavior, and the visual
appearance.

Note – You cannot modify properties for the Menu Panel.

To modify the properties of a panel perform the following steps:

1. Right-click on a vacant space on the panel, then choose Properties to display the
Panel Properties dialog. The following figure shows the Panel Properties dialog for
the edge panel at the bottom of your desktop.

The Panel Properties dialog contains the following tabbed sections:

� Panel_type Panel
� Background

2. To modify panel size, position, and hiding properties, click on the Panel_type Panel
tab. The following table describes the dialog elements on the Panel_type Panel
tabbed section:

Dialog Element Description

Position Select the position of the panel on your desktop. Click on the
required position for the panel.
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Dialog Element Description

Size Select the size of the panel.

Orient horizontally Floating panel only. Select this option to display the panel
horizontally.

Orient vertically Floating panel only. Select this option to display the panel
vertically.

Horizontal offset Floating panel only. Use the spin box to specify the distance of
the panel from the left edge of the desktop.

Vertical offset Floating panel only. Use the spin box to specify the distance of
the panel from the top edge of the desktop.

Screen edge offset Sliding panel only. Use this spin box to specify the distance
between your panel and the edge of the desktop, in pixels.

Autohide Select this option to enable autohide.

Show hide buttons Select this option to display hide buttons on your panel.

Arrows on hide button Select this option to display arrows on the hide buttons, if the
hide button is enabled.

3. To modify the panel background, click on the Background tab. The Background
tabbed section contains the following elements:

Dialog Element Description

Background Type Choose the type of background for the panel. The choices are as
follows:
� Default: The default background type. The standard

background depends on the settings in Applications →
Desktop Preferences → Theme.

� Color: Enables you to choose a color for the panel
background.

� Image: Enables you to choose an image for the panel
background.

Background Color If Background Type is Color, click on the Color to use button to
display the color selector dialog. Choose the color that you
require from the color selector dialog.
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Dialog Element Description

Image If Background Type is Image, choose the image to use on the
background of the panel. Specify the following settings for the
image background:

Do not scale image to fit Select this option to tile the
background image to fit the panel
background.

Scale image Select this option to scale the
background image to fit the panel
background. The width-to-height
ratio of the image is retained.

Stretch image Select this option to stretch the
background image to fit the panel
background. The width-to-height
ratio of the image is not retained.

Rotate image for vertical
panels

Select this option to rotate the
background image on a vertical
panel.

You can also drag a color or image on to a panel to set the color or image as the
background of the panel. For more information, see “4.2.5.1 To Drag a Color or
Image to the Background of a Panel” on page 60.

4. Click Close to close the Panel Properties dialog.

4.2.5.1 To Drag a Color or Image to the Background of a
Panel
You can drag a color or image on to a panel to set the color or image as the
background of the panel. You can drag a color or image from many applications. For
example, you can drag a color from the Nautilus file manager to a panel to set the
color as the background of the panel. You can also drag a color from any color selector
dialog.

You can drag an image to a panel to set the image as the background of the panel. You
can also drag pattern images from the Nautilus file manager application to set the
background of the panel.

4.2.6 To Delete a Panel
To delete a panel from the desktop, right-click on the panel that you want to delete,
then choose Delete This Panel.
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Note – You must always have at least one panel on your desktop. If you have only one
panel on your desktop, you cannot delete that panel.

4.3 Panel Objects
This section describes the objects that you can add to your panels, and use from your
panels.

4.3.1 Interacting With Panel Objects
You use the mouse buttons to interact with a panel object in the following ways:

Left-click Launches the panel object.

Middle-click Enables you to grab an object, then drag the object to a new
location.

Right-click Opens the panel object popup menu.

You interact with applet panel objects in a different way. For more information, see
“4.4.2 To Select an Applet” on page 64.

4.3.2 To Add an Object to a Panel
You can add an object to a panel in several ways, as follows:

� From the panel popup menu

Right-click on a vacant space on a panel to open the panel popup menu. The panel
popup menu contains an Add to Panel submenu. The Add to Panel submenu
enables you to add the following objects to your panels:

� Accessory applets
� Amusement applets
� Internet applets
� Multimedia applets
� Utility applets
� Launchers
� GNOME Menu
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� Drawers
� Log Out button
� Lock button

� From any menu

When you right-click on a launcher in any menu, a popup menu for the launcher
opens. You can use this popup menu to add the launcher to a panel.

You can also drag menus, launchers, and applets from menus to panels.
� From the file manager

Each launcher and applet corresponds to a .desktop file. You can drag the
.desktop file on to your panels to add the launcher or applet to the panel.

Each menu corresponds to a directory. You can drag the directory on to your panels
to add the directory to the panel as a menu object.

4.3.3 To Modify the Properties of an Object
Some panel objects have a set of associated properties. The properties are different for
each type of object. The properties specify details such as the following:

� The command that starts a launcher application.
� The location of the source files for a menu.
� The icon that represents the object.

To modify the properties of an object perform the following steps:

1. Right-click on the object to open the panel object popup menu, as shown in Figure
4–3.

FIGURE 4–3 Panel Object Popup Menu

2. Choose Properties. Use the Properties dialog to modify the properties as required.
The properties in the Properties dialog depend on which object you select in step 1.

3. Click OK to apply the changes, then close the Properties dialog.

4.3.4 To Move a Panel Object
You can move panel objects within a panel, and from one panel to another panel. You
can also move objects between panels and drawers.
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To move a panel object, middle-click and hold on the object and drag the object to a
new location. When you release the middle mouse button, the object anchors at the
new location.

Alternatively, you can use the panel object popup menu to move an object, as follows:

1. Right-click on the object, then choose Move.

2. Point to the new location for the object, then click any mouse button to anchor the
object to the new location. This location can be on any panel that is currently on
your desktop.

Movement of a panel object affects the position of other objects on the panel. To
control how objects move on a panel, you can specify a movement mode. To specify
the movement mode, press one of the following keys as you move the panel object:

Key Movement Mode Description

No key Switched movement The object swaps places with other panel objects.
Switched movement is the default movement
mode.

Alt key Free movement The object jumps over other panel objects into the
next vacant space on the panel.

Shift key Push movement The object pushes other panel objects further
along the panel.

4.3.5 To Remove a Panel Object
To remove an object from a panel right-click on the object to open the panel object
popup menu, then choose Remove From Panel.

4.4 Applets
An applet is a small application whose user interface resides within a panel. You use
the applet panel object to interact with the applet. For example, the following figure
shows the following applets, from left to right:

� Window List: Displays the windows currently open on your system.

� CD Player: Enables you to control the compact disc player on your system.

� Volume Control: Enables you to control the volume of the speaker on your system.
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4.4.1 To Add an Applet to a Panel
You can add an applet to a panel from the panel popup menu. Right-click on any
vacant space on the panel to open the panel popup menu. Choose Add to Panel, then
choose the applet that you want to add from one of the following submenus:

� Accessories
� Amusements
� Internet
� Multimedia
� Utility

Alternatively, drag the applet from the submenu on to the panel.

4.4.2 To Select an Applet
To modify the properties of an applet, you must first right-click on the applet to
display the panel object popup menu. To move an applet, you must middle-click on
the applet.

Some restrictions apply on where you can click on an applet in order to display the
panel object popup menu, or to move the applet, as follows:

� Some applets have popup menus of applet-specific commands that open when you
right-click on particular parts of the applet. For example, the Window List applet
has a vertical handle on the left side, and buttons that represent your windows on
the right side. To open the panel object popup menu for the Window List applet,
you must right-click on the handle. If you right-click on a button on the right side,
a popup menu for the button opens.

� Some applets have areas that you cannot use to select the applet. For example, the
Command Line applet has a field in which you enter commands. You cannot
middle-click or right-click on this field to select the applet. Instead, middle-click or
right-click on another part of the applet.

4.4.3 To Modify Preferences for an Applet
To modify the preferences for an applet perform the following steps:
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1. Right-click on the applet, then choose Preferences. Use the Preferences dialog to
modify the preferences as required. The preferences for applets vary depending on
the applet.

2. Click Close to close the Preferences dialog.

4.5 Launchers
When you click on a launcher, you initiate one of the following actions:

� Start a particular application.

� Execute a command.

� Open a folder in a file manager window.

� Open a browser at a particular Uniform Resource Locator (URL). A URL is the
address of a particular location on the Web.

You can find launchers in the following places on the desktop:

� Panels: On panels, launchers are represented by icons.

� Menus: On menus, launchers are represented by menu items. The menu items
usually have an icon beside the menu item.

� Desktop background: On the desktop background, launchers are represented by
icons.

You can modify the properties of a launcher. For example, the properties of a launcher
include the name of the launcher, the icon that represents the launcher, and how the
launcher runs.

4.5.1 To Add a Launcher to a Panel
You can add a launcher to a panel in one of the following ways:

� From the panel popup menu

To create a new launcher, right-click on any vacant space on the panel, then choose
Add to Panel → Launcher. A Create Launcher dialog is displayed. For more
information on how to complete this dialog, see “4.5.1.1 To Create a Launcher With
the Create Launcher Dialog” on page 66.

Alternatively, to add an existing launcher to the panel, choose Add to Panel →
Launcher from menu from the panel popup men. Choose the launcher that you
want to add from the menu.

� From any menu
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To add a launcher to a panel from any menu, perform one of the following steps:

� Open the menu that contains the launcher from the panel where you want the
launcher to reside. Right-click on the title of the launcher. Choose Add this
launcher to panel.

� Open a menu that contains the launcher. Drag the launcher on to the panel.

� From the file manager

To add a launcher to a panel from the file manager, find the .desktop file for the
launcher in your file system. To add the launcher drag the .desktop file to the
panel.

4.5.1.1 To Create a Launcher With the Create Launcher
Dialog
To create a launcher with the Create Launcher dialog perform the following steps:

1. Right-click on any part of a panel to open the panel popup menu. Choose Add to
Panel → Launcher to display the Create Launcher dialog. The dialog displays the
Basic tabbed section.

2. Enter the properties of the launcher in the dialog. The following table describes the
dialog elements on the Basic tabbed section:
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Dialog Element Description

Name Use this text box to specify the name of the launcher. You can use
the Advanced tab to add translations of the name. This name is
the name that appears when you add the launcher to a menu or to
the desktop background.

Generic name Use this text box to specify the class of application to which the
launcher belongs. For example, you might type Text Editor in
this text box for a gedit launcher. You can use the Advanced tab to
add translations of the generic name.

Comment Use this text box to specify a short description of the launcher.
The comment is displayed as a tooltip when you point to the
launcher icon on the panel. You can use the Advanced tabbed
section to add translations of the comment.

Command Use this field to specify a command to execute when you click on
the launcher.

Type Use this drop-down combination box to specify the type of
launcher. Select from the following:
� Application: Select this option to create a launcher that starts

an application.
� Link: Select this option to create a launcher that links to a file,

folder, or FTP site.

Icon Choose an icon to represent the launcher. To choose an icon, click
on the No Icon button. An icon selector dialog is displayed.
Choose an icon from the dialog. Alternatively, to choose an icon
from another directory, click Browse. When you choose an icon,
click OK.

Run in Terminal Select this option to run the application or command in a terminal
window. Choose this option for an application or command that
does not create a window in which to run.

3. To set advanced properties for the launcher, click on the Advanced tab. The
Launcher Properties dialog displays the Advanced tabbed section.
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4. Enter the advanced properties of the launcher in the dialog. The following table
describes the dialog elements on the top part of the Advanced tabbed section:

Dialog Element Description

Try this before using Enter a command here to check before starting the launcher.
If the command is executable and is in your path, the
launcher appears on the panel.

Documentation This field is not currently in use.

5. You can also add a translation of the Name, Generic name, and Comment fields
from the Basic tabbed section. To add a translation, enter the details of the
translation in the Name/Comment translations table as follows:

Field Description

First field Enter the two-letter code for the language for which you want to add a
translation.

Second field Enter the translation of the Name of the launcher.

Third field Enter the translation of the Generic name of the launcher.

Fourth field Enter the translation for the Comment for the launcher.

Then click on the Add/Set button.

To edit a translation, select the translation. The translated text appears in the lower
part of this dialog. Edit the fields as required, then click on the Add/Set button.
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To remove a translation, select the translation, then click on the Remove button.

6. To create the launcher and close the Launcher Properties dialog, click OK.

4.5.2 To Modify the Properties of a Launcher
To modify the properties of a launcher perform the following steps:

1. Right-click on the launcher to open the panel object popup menu.

2. Choose Properties. Use the Launcher Properties dialog to modify the properties as
required. For more information on the Launcher Properties dialog, see “4.5.1.1 To
Create a Launcher With the Create Launcher Dialog” on page 66.

3. Click Close to close the Launcher Properties dialog.

4.6 Menus
You can add the following types of menu to your panels:

� System menus: System menus contain the standard applications and tools that you
can use on your desktop. The Applications menu and Actions menu are system
menus. To add a system menu to a panel, right-click on a launcher in the menu,
then choose Entire menu → Add this as menu to panel.

� GNOME Menu: You can access almost all of the standard applications, commands,
and configuration options from the GNOME Menu. To add a GNOME Menu to a
panel, right-click on any vacant space on the panel, then choose Add to Panel →
GNOME Menu. You can add as many GNOME Menu objects to your panels as you
want. By default, the GNOME Menu is represented on panels by a stylized
footprint icon, as follows:

Menus that you add to your panels are represented by an icon with an arrow. The
arrow indicates that the icon represents a menu or drawer. Figure 4–4 shows how
menus typically appear on panels.
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FIGURE 4–4 Typical Menu Objects on a Panel

4.7 Drawers
A drawer is an extension of a panel. You can open and close a drawer in the same way
that you can show and hide a panel. A drawer can contain all panel objects, including
launchers, menus, applets, other panel objects, and other drawers. When you open a
drawer, you can use the objects in the same way that you use objects on a panel.

The following figure shows an open drawer that contains two panel objects.

The arrow on the drawer icon indicates that the icon represents a drawer or menu.

You can add, move, and remove objects from drawers in the same way that you add,
move, and remove objects from panels.

4.7.1 To Open and Close a Drawer
To open a drawer, click on the drawer object in a panel. You can close a drawer in the
following ways:

� Click on the drawer.
� Click on the drawer hide button.
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4.7.2 To Add a Drawer to a Panel
You can add a drawer to a panel in the following ways:

� From the panel popup menu

Right-click on any vacant space on the panel, then choose Add to Panel → Drawer.

� From any menu

You can add a menu as a drawer object to a panel.

To add a menu as a drawer to a panel, open the menu from the panel. Right-click
on any launcher in the menu, then choose Entire menu → Add this as drawer to
panel.

4.7.3 To Add an Object to a Drawer
You add an object to a drawer in the same way that you add objects to panels. For
more information, see “4.3.2 To Add an Object to a Panel” on page 61.

4.7.4 To Modify Drawer Properties
To modify preferences for all panels and drawers, choose Applications → Desktop
Preferences → Advanced → Panel, then make the changes that you require. For
example, you can select various options related to the appearance and behavior of
objects on panels and drawers. You can also select options that relate to drawers only.
For example, you can select an option to close your drawers when you click on a
launcher in the drawer.

You can also modify other properties for each individual drawer. You can change
features for each drawer, such as the visual appearance of the drawer and whether the
drawer has hide buttons.

To modify properties for a drawer perform the following steps:

1. Right-click on the drawer, then choose Properties to display the Panel Properties
dialog. The dialog displays the Drawer tabbed section.
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2. Select the properties for the drawer in the dialog. The following table describes the
elements on the Drawer tabbed section:

Dialog Element Description

Size Select the size of the drawer.

Tooltip/Name Use this text box to specify a name for the drawer. The name
appears as a tooltip when you point at the drawer on the panel.

Icon Choose an icon to represent the drawer. Click on the Icon
button to display an icon selector dialog. Choose an icon from
the dialog. Alternatively, click Browse to choose an icon from
another directory. When you choose an icon, click OK.

Enable hide button Select this option to display a hide button when the drawer
opens.

Enable hide button arrow Select this option to display an arrow on the hide button if the
hide button is enabled.

3. You can use the Background tabbed section to set the background for the drawer.
For information on how to complete the Background tabbed section, see the step
on this topic in “4.2.5 To Modify Panel Properties” on page 57. You can also drag a
color or image on to a drawer to set the color or image as the background of the
drawer. For more information, see “4.2.5.1 To Drag a Color or Image to the
Background of a Panel” on page 60.

4. Click Close to close the Panel Properties dialog.
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4.8 Log Out Button

The Log Out button begins the process to log out of a GNOME session.

To add a Log Out button to a panel, right-click on any vacant space on the panel.
Choose Add to Panel →Log Out Button. To log out of your session or shut down your
system, click on the Log Out button.

4.9 Lock Button

The Lock button locks your screen and activates your screensaver. To access your
session again, you must enter your password. To lock your screen correctly, you must
have a screensaver enabled.

To add a Lock button to a panel, right-click on any vacant space on the panel. Choose
Add to Panel →Lock Button.

Right-click on the Lock button to open a menu of screensaver-related commands.
Table 4–2 describes the commands that are available from the menu.
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TABLE 4–2 Lock Screen Menu Items

Menu Item Function

Activate Screensaver Activates the screensaver immediately, but does not
lock the screen.

Lock Screen Locks the screen immediately. This command
performs the same function as when you click on the
Lock button.

Kill Screensaver Daemon Terminates the screensaver process. After you
terminate the screensaver process, you cannot lock
your screen.

Restart Screensaver Daemon Terminates and restarts the screensaver process. Use
this command after you change your password.
When you restart the screensaver process, use your
new password with the screensaver.

Properties Displays an XScreenSaver dialog that you can use to
configure the screensaver.
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CHAPTER 5

Working With Menus

This chapter describes how to use menus in the desktop.

� “5.1 Introduction to Menus” on page 75
� “5.2 Menu Features” on page 76
� “5.3 Applications Menu” on page 77
� “5.4 Actions Menu” on page 78
� “5.5 GNOME Menu” on page 81

5.1 Introduction to Menus
You can access all desktop functions through menus. The Menu Panel contains menus,
so you can use a combination of menus and panels to perform your tasks. You can
perform various actions on your menus, such as copy menu items to panels.

You can access the following menus from the desktop:

� Applications menu: You can access many of your applications, commands, and
configuration options from the Applications menu. You can also access the desktop
preference tools from the Applications menu.

� Actions menu: You can access various commands that enable you to perform
desktop tasks from the Actions menu. For example, you can start the Search Tool
application, or log out of the desktop.

� GNOME Menu: You can also access the items in the Applications and Actions
menus from the GNOME Menu. You can have many GNOME Menu buttons in
your panels.

You can also right-click on the desktop background to open the Desktop Background
menu. The Desktop Background menu enables you to perform desktop
background-related tasks.
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All of these menus provide you with multiple ways to perform your tasks, and enable
you to work in the way that you prefer.

5.2 Menu Features
Menus can contain the following items:

� Submenus
� Launchers or menu items

An arrow to the right of an item in a menu indicates that the item is a submenu. When
you point to the submenu, the submenu opens. You can choose items from the
submenu.

When you choose a launcher, the launcher starts an application or runs a command.
You can also right-click on a launcher to open a popup menu. The popup menu
enables you to add the item to a panel, and perform other tasks. For more information
on the popup menu, see the next section.

You can change the theme for your session to change how all your menus look. To
change the theme, choose Applications → Desktop Preferences → Theme.

5.2.1 Launcher Popup Menu
Launchers on menus have an associated popup menu that enables you to perform
tasks related to launchers. When you right-click on a launcher in a menu, the popup
menu for the launcher opens. The popup menu also contains a submenu that allows
you to perform menu-related tasks.

You can use the launcher popup menu to perform the following tasks:

� Add launchers to panels.

� Remove launchers from menus.

� Open the Run Program dialog with the launcher command in the dialog.

� Add menus to panels. You can add a menu as a menu object or as a drawer object.

� Add new items to menus.

� Change the properties of submenus and launchers.

Figure 5–1 shows the popup menu.
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FIGURE 5–1 Launcher Popup Menu

Table 5–1 describes the items on launcher popup menus.

TABLE 5–1 Items on Launcher Popup Menus

Item Description

Add this launcher to panel Adds the launcher to the panel from which you open
the menu.

Remove this item Removes the launcher from the menu.

Put into run dialog Displays the Run Program dialog with the command
from the Command field of the launcher in the
command field on the Run Program dialog.

Help on application_name Opens the online help for the application.

Properties Displays a dialog that enables you to edit the
properties of the launcher.

Entire menu → Add this as drawer to
panel

Adds the submenu as a drawer to the panel from
which you open the menu.

Entire menu → Add this as menu to
panel

Adds the submenu as a menu object to the panel
from which you open the menu.

Entire menu → Add new item to this
menu

Enables you to add an item to the submenu.

Entire menu → Properties Displays a dialog that enables you to edit the
properties of the submenu.

5.3 Applications Menu
The Applications menu contains a hierarchy of submenus, from which you can start
the standard GNOME applications and preference tools. The Applications menu
contains the Desktop Preferences menu. You can use the Desktop Preferences menu to
start the desktop preference tools. The Applications menu also includes the file
manager and the help browser.
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The Applications menu resides in the following places:

� Menu Panel
� Start Here location in Nautilus
� GNOME Menu

5.4 Actions Menu
The Actions menu contains various commands that enable you to perform desktop
tasks. Table 5–2 describes the commands in the Actions menu.

TABLE 5–2 Actions Menu Commands

Menu Item Function

Run Program Opens the Run Program dialog. Use the Run Program
dialog to run commands. For more information, see
“5.4.1 Using the Run Program Dialog” on page 78.

Search for Files Starts the Search Tool application. For more information,
see the Search Tool manual.

Screenshot Takes a screenshot of the desktop, and opens the
Screenshot dialog. Use the Screenshot dialog to save the
screenshot.

Lock Screen Locks your screen.

Log Out Logs you out of the current session.

The Actions menu resides in the following places:

� Menu Panel.
� GNOME Menu. The items in the Actions menu are at the top level of the GNOME

Menu.

5.4.1 Using the Run Program Dialog
The Run Program dialog gives you access to the command line. When you run a
command in the Run Program dialog, you cannot receive output from the command.

To run a command from the command line perform the following steps:

1. Display the Run Program dialog. You can display the Run Program dialog in any
of the following ways:
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� From the Menu Panel

Choose Actions → Run Program.
� From the GNOME Menu

Open the GNOME Menu, then choose Run Program.
� Use shortcut keys

The default shortcut keys to display the Run Program dialog is Alt + F2. You
can change the shortcut keys that display the Run Program dialog in the
Keyboard Shortcuts preference tool. To change the shortcut keys, choose
Applications → Desktop Preferences → Keyboard Shortcuts.

� From a launcher popup menu

Right-click on a launcher in a menu, then choose Put into run dialog from the
popup menu. The Run Program dialog opens with the command from the
menu in the command field. The Run Program dialog is displayed.

2. Enter the command that you want to run in the blank field. Alternatively, to choose a
command that you ran previously, click the down arrow button beside the command
field, then choose the command to run.

Alternatively, click on the Known Applications button to display a list of available
applications.

You can also use the Append File button to choose a file to append to the command
line. For example, you can enter emacs as the command, then choose a file to edit.

Select the Run in terminal option to run the application or command in a terminal
window. Choose this option for an application or command that does not create a
window in which to run.

3. Click on the Run button on the Run Program dialog.
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5.4.2 To Take a Screenshot
You can take a screenshot in any of the following ways:

� Use the Actions menu

To take a screenshot of the entire screen, choose Actions → Screenshot. A
Screenshot dialog is displayed. To save the screenshot, select the Save screenshot to
file option. Enter the path and filename for the screenshot in the drop-down
combination box. Alternatively, to save the screenshot to another directory, click
Browse. When you select a directory, click OK.

You can also save the screenshot to the desktop background. To save the screenshot
to the desktop background, select the Save screenshot to desktop option.

� Use shortcut keys

To take a screenshot, use the following shortcut keys:

Default Shortcut Keys Function

Print Screen Takes a screenshot of the entire screen, and displays the
Screenshot dialog. Use the Screenshot dialog to save the
screenshot.

Alt + Print Screen Takes a screenshot of the window that has focus, and
displays the Screenshot dialog. Use the Screenshot dialog
to save the screenshot.

You can use the Keyboard Shortcuts preference tool to modify the default shortcut
keys.

� Use a command

You can use the gnome-panel-screenshot command to take a screenshot. The
gnome-panel-screenshot command takes a screenshot of the entire screen, and
displays the Screenshot dialog. Use the Screenshot dialog to save the screenshot.

You can also use options on the gnome-panel-screenshot command as
follows:

Option Function

--window Takes a screenshot of the window that has focus, and
displays the Screenshot dialog. Use the Screenshot dialog
to save the screenshot.

--delay=seconds Takes a screenshot after the specified number of seconds,
and displays the Screenshot dialog. Use the Screenshot
dialog to save the screenshot.

--help Displays the options for the command.
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5.5 GNOME Menu

You can access almost all of the standard applications, commands, and configuration
options from the GNOME Menu.

The GNOME Menu provides the following top-level menus and special menu items:

� Applications: Contains all applications and preference tools. This menu also
includes the file manager and the help browser.

� Actions: Contains commands that enable you to perform desktop tasks, for
example the Lock Screen and Log Out commands. The items in the Actions menu
are at the top level of the GNOME Menu.

You can add GNOME Menu buttons to your panels. By default, the GNOME Menu is
represented on panels by a stylized footprint icon, as follows:

5.5.1 To Open the GNOME Menu
You can open the GNOME Menu in the following ways:

� From a panel with a GNOME Menu

Click on the GNOME Menu.

� Use shortcut keys

You can use shortcut keys to open the GNOME Menu. When you use shortcut keys
to open the GNOME Menu, the GNOME Menu appears at the mouse pointer.
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The default shortcut keys to open the GNOME Menu are Alt + F1. To change the
shortcut keys that open the GNOME Menu, choose Applications → Desktop
Preferences → Keyboard Shortcuts.

5.5.2 To Add a GNOME Menu to a Panel
You can add as many GNOME Menu buttons as you want to your panels. To add a
GNOME Menu to a panel, right-click on any vacant space on the panel. Choose Add
to Panel → GNOME Menu.

5.6 Customizing Your Menus
You can modify the contents of the following menus:

� Applications menu
� Desktop Preferences menu

You use the following desktop components to customize menus:

� Menus on panels
� Nautilus file manager

When you use panels to customize your menus, you use the launcher popup menu.
For more information, see “5.2.1 Launcher Popup Menu” on page 76.

When you use Nautilus to customize your menus, you must access the Applications
menu or the Desktop Preferences menu from within Nautilus. To access the
Applications menu or the Desktop Preferences menu, open a Nautilus window.
Choose Go → Start Here. Double-click on the Applications object or on the Desktop
Preferences object. For more information on Nautilus, see Nautilus File Manager.

5.6.1 To Add a Menu
To add a menu, perform the following steps:

1. In a Nautilus window, access the location where you want to add the menu. For
example, to add a menu to the Applications menu, choose Go → Start Here, then
double-click on the Applications object.

2. Choose File → New Folder. An untitled folder is added to the view pane. The name
of the folder is selected.

3. Type a name for the folder, then press Return.
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The next time that you log out then log in again, the menu is in the assigned location.

5.6.2 To Add a Launcher to a Menu
To add a launcher to a menu, perform the following steps:

1. Right-click on any item in the menu to which you want to add the launcher.

2. Choose Entire menu → Add new item to this menu. A Create Launcher dialog is
displayed.

3. Enter the properties of the launcher in the Create Launcher dialog. For more
information on the elements in the Create Launcher dialog, see Working With
Panels.

4. Click OK.

5.6.3 To Copy a Launcher to a Menu
To copy an existing launcher to a menu, perform the following steps:

1. In a Nautilus window, access the location from which you want to copy the
launcher. For example, to copy a launcher from the Applications menu, choose Go
→ Start Here, then double-click on the Applications object.

2. Select the launcher that you want to copy, then choose Edit → Copy File.

3. In a Nautilus window, access the location to which you want to copy the launcher.

4. Choose Edit → Paste Files. The launcher is added to the new location.

Alternatively, you can drag the launcher from one location to another.

The next time that you log out then log in again, the launcher is in the new menu
location.

5.6.4 To Edit the Properties of a Menu
To edit the properties of a menu, perform the following steps:

1. Right-click on any item in the menu that you want to edit.

2. Choose Entire menu → Properties. A Launcher Properties dialog is displayed.

3. Modify the properties of the menu in the Launcher Properties dialog. For more
information on the elements in the Launcher Properties dialog, see Working With
Panels.

4. Click OK.
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5.6.5 To Edit a Menu Item
To edit a menu item, perform the following steps:

1. Right-click on the item that you want to edit.

2. Choose Properties. A Launcher Properties dialog is displayed.

3. Modify the properties of the launcher in the Launcher Properties dialog. For more
information on the elements in the Launcher Properties dialog, see Working With
Panels.

4. Click OK.

5.6.6 To Delete an Item from a Menu
To delete an item from a menu, use the launcher popup menu. To delete an item from
a menu, perform the following steps:

1. Right-click on the item that you want to delete.
2. Choose Remove this item.
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CHAPTER 6

Working With Windows

The information in this chapter describes how to use windows in the desktop. You can
use several types of window manager with the GNOME desktop, for example,
Metacity and Sawfish. Many of the functions in Metacity are also available in Sawfish.
This chapter describes the functions that are associated with the Metacity window
manager.

� “6.1 Windows and Workspaces” on page 85
� “6.2 Types of Window” on page 86
� “6.3 Menus and Applets for Working With Windows and Workspaces” on page 90
� “6.4 Manipulating Windows” on page 94
� “6.5 Manipulating Workspaces” on page 98

6.1 Windows and Workspaces
You can display many windows at the same time on your desktop. Your windows are
displayed in subdivisions of your desktop that are called workspaces. A workspace is
a discrete area on the desktop in which you can work. Every workspace on the
desktop contains the same desktop background, the same panels, and the same
menus. However, you can run different applications, and open different windows in
each workspace. You can display only one workspace at a time on your desktop but
you can have windows open in other workspaces.

The Workspace Switcher applet displays a visual representation of your windows and
workspaces, as show in Figure 6–1.
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FIGURE 6–1 Workspace Switcher Applet

You can add workspaces at any time. To add workspaces to your desktop, right-click
on the Workspace Switcher applet, then choose Preferences. The Workspace Switcher
Preferences dialog is displayed. Use the Number of workspaces spin box to specify the
number of workspaces you require.

6.1.1 Window Manager Behavior
A window manager controls how windows appear and behave. The window manager
manages where your windows are located, which window has focus, and the theme of
the frame on the windows. The window frame contains buttons that enable you to
perform standard actions such as moving, closing, and resizing windows.

You can configure some window manager settings in the Window Focus preference
tool. This manual describes the functions that are associated with the default
configuration of the Metacity window manager. The default configuration is specified
in the Window Focus preference tool. This manual also describes the default functions
of the Crux theme.

6.2 Types of Window
The desktop features the following types of windows:

� Application windows

When you start an application, an application window opens. The window
manager applies a frame to the application window. By default, the top edge of the
application window contains a titlebar. The titlebar contains buttons that you can
use to work with the window. The buttons in an application window frame enable
you to perform actions such as open the Window Menu, or close the window. The
Window Menu provides a number of actions that you can perform on the window.

The following figure shows a typical application window.
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� Dialog windows

A dialog window is a popup window in which you enter information or
commands. The dialog appears within a window frame.

You can use the top edge of the frame to work with the window. For example, you
can use the titlebar to move the dialog. The frame also contains buttons that enable
you to do the following:

� Open the Window Menu
� Close the dialog window

Typically, you open a dialog window from an application window. When you open
a dialog window, the window is usually raised and has focus. Some dialog
windows do not allow you to use the application until you close the dialog.

The following figure shows a typical dialog window.
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6.2.1 Window Frames
A window frame is a border around a window. The window frame contains a titlebar.
The titlebar contains buttons that you can use to work with the window.

6.2.1.1 Themes
You can apply several themes to your window frames. The theme determines how the
frame looks. To choose a theme for all your window frames, choose Applications →
Desktop Preferences → Theme.

The default theme is Crux. This manual describes the functions that are associated
with the Crux theme.

6.2.1.2 Control Elements
You can use the window frame to perform various actions with the window. In
particular, the titlebar contains various buttons. The following figure shows the
titlebar of an application window:

Dialog windows also contain some of the window frame control elements. Table 6–1
describes the active control elements on window frames, from left to right.
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TABLE 6–1 Window Frame Control Elements

Control Element Description

Window Menu button Click on the button to open the Window Menu.

Titlebar You can use the titlebar to perform the following
actions:
� To give focus to the window click on the titlebar.
� To move the window grab the titlebar and drag the

window to the new location.
� To shade the window, double-click on the titlebar.

To unshade the window, double-click on the
titlebar again.

Minimize button Click on the Minimize button to minimize the
window.

Maximize button Click on the Maximize button to maximize the
window.

Close Window button Click on the Close Window button to close the
window.

Border The border around the window. Use the border to
perform the following actions:
� To resize the window grab the border and drag the

border to the new size.
� To open the Window Menu, right-click on the

border.

Window contents The area inside the window frame. Use the window
contents to perform the following actions:
� To move a window, press-and-hold Alt, click in the

window contents, then drag the window to the
new location.

� To resize a window, press-and-hold Alt, then
middle-click near the corner you want to resize. To
resize the window, drag from the corner on which
you middle-clicked.

� To open the Window Menu, press-and-hold Alt,
then right-click in the window contents.
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6.3 Menus and Applets for Working With
Windows and Workspaces
This section describes the menus and applets that you can use to work with windows
and workspaces.

6.3.1 Window Menu

The Window Menu is a menu of commands that you can use to perform actions on
your windows. To open the Window Menu perform one of the following actions:

� Click on the Window Menu button on the window that you want to work with.

� Press Alt + spacebar.

� Press-and-hold Alt, then right-click on any part of the window that you want to
work with.

Table 6–2 describes the commands and submenus in the Window Menu.

TABLE 6–2 Window Menu Commands and Submenus

Menu Item Function

Minimize Minimizes the window.

Maximize or Unmaximize Maximizes the window. If the window is already maximized,
choose Unmaximize to restore the window to its previous size.

Shade or Unshade Shades the window. If the window is already shaded, choose
Unshade to restore the window to its previous size.

Move Enables you to use the arrow keys to move the window.
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TABLE 6–2 Window Menu Commands and Submenus (Continued)
Menu Item Function

Resize Enables you to use the arrow keys to resize the window.

Close Closes the window.

Put on All Workspaces or
Only on This Workspace

Puts the window on all of your workspaces. If the window is
already on all of your workspaces, choose Only on This
Workspace to put the window on the current workspace only.

Move to workspace_name or
Only on workspace_name

Moves the window to the workspace that you choose. If the
window is on all of your workspaces, choose Only on
workspace_name to put the window on the workspace that you
want.

6.3.2 Window List Applet
Window List displays a button for each application window that is open. You can use
the Window List to perform the following tasks:

� To minimize a window

Click on the button that represents the window.

� To restore a minimized window

Click on the button that represents the window.

� To give focus to a window

Click on the button that represents the window.

When you open an application window, Window List displays a button that
represents the window. The window list buttons show which application windows are
open. You can view which windows are open even if some windows are minimized,
or other windows overlap a window. Window List can display buttons for the
windows in your current workspace, or in all workspaces. To select this option, you
must change the preferences of Window List.

You can also right-click on a window list button to open the Window Menu for the
window that the button represents. When you open the Window Menu from Window
List, the Window Menu does not contain the workspace commands. For more
information on the Window Menu commands, see “6.3.1 Window Menu” on page 90.

Figure 6–2 shows Window List when the following windows are open:

� gedit
� Dictionary
� GHex
� GNOME Terminal

Chapter 6 • Working With Windows 91



FIGURE 6–2 Window List Applet

The buttons in the applet show the status of your windows. Table 6–3 explains the
information that the window list buttons provide about the window. The examples in
Table 6–3 refer to Figure 6–2.

TABLE 6–3 Window Status Information on Window List Buttons

State Indicates Example

Button is pressed in. The window has focus. gedit

Square brackets around
window title.

The window is minimized. [Dictionary]

Button is not pressed in, no
square brackets around title.

The window is displayed, and
is not minimized.

ghex

Numeral on button, in
parentheses.

The button represents a group
of buttons.

Gnome-terminal (3)

6.3.2.1 Grouping Buttons
Window List can group the buttons that represent windows in the same class under
one window list button. The Gnome-terminal button in Figure 6–2 is an example of a
button that represents a group of buttons. The following figure shows an example of
Window List with a button group open:

To open a list of the windows in a group, click on the window list button that
represents the group. You can click on the items in the list to give focus to windows,
minimize windows, and restore windows.

To open the Window Menu for a window in a button group, right-click on the window
list button that represents the group. A list of the windows in the group is displayed.
To open the Window Menu for a window in the group, click on the item in the list.
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When you open the Window Menu from the Window List, the Window Menu does
not contain the workspace commands. For more information on the Window Menu
commands, see “6.3.1 Window Menu” on page 90.

6.3.3 Workspace Switcher Applet
Workspace Switcher displays a visual representation of your workspaces, as shown in
Figure 6–3. Figure 6–3 shows the applet when the GNOME session contains four
workspaces. Your workspaces appear as buttons on the applet. The background of the
button in the applet that represents the current workspace is highlighted. The current
workspace in Figure 6–3 is the workspace at the left of the applet. To switch to another
workspace, click on the workspace in the applet.

FIGURE 6–3 Workspace Switcher Applet

Workspace Switcher also displays the application windows and dialogs that are open
in your workspaces.

The applet displays the workspaces in order from left to right across the rows of the
applet. In Figure 6–3, the applet is set up to display the workspaces in one row. You
can specify the number of rows in which your workspaces are displayed in Workspace
Switcher. You can also change the default behavior of the applet to display the names
of your workspaces in the applet.

6.3.4 Using the Menu Panel to Work With Windows
From the Menu Panel, you can view a list of all windows that are currently open. You
can also choose a window to give focus to. To view the window list, click on the icon
at the extreme right of the Menu Panel. The following figure shows an example of the
window list that is displayed from the Menu Panel:
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When the focus changes, the icon that you click on to display the window list changes.
The icon represents the window that currently has focus. To give focus to a window,
choose that window from the window list.

The window list lists the windows in all workspaces. The windows in all workspaces
other than the current workspace, are listed under a separator line.

You cannot move the icon at the extreme right of the Menu Panel.

6.4 Manipulating Windows
This section describes how to manipulate windows.

6.4.1 To Give Focus to a Window
A window that has focus can receive input from the mouse and the keyboard. Only
one window can have focus at a time. The window that has focus has a different
appearance than other windows.

You can use the following elements to give focus to a window:

Element Action

Mouse Click on the window, if the window is visible.

Shortcut keys Use shortcut keys to switch between the windows that are
open. To give focus to a window, release the keys. The default
shortcut keys to switch between windows are Alt + Tab.
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Element Action

Window List Click on the button that represents the window in Window
List.

Workspace Switcher Click on the window that you want to give focus to in the
Workspace Switcher display. If you click on a window in
another workspace, Workspace Switcher switches to the new
workspace, and gives focus to the window.

Menu Panel Click on the icon at the extreme right of the Menu Panel. A list
of your open windows is displayed. Choose the window from
the list.

6.4.2 To Minimize a Window
To minimize a window perform one of the following actions:

� Click on the Minimize button on the window frame.
� Open the Window Menu, then choose Minimize.
� If the window has focus, click on the button that represents the window in

Window List. If the window does not have focus, click twice on the button that
represents the window.

� Right-click on the button that represents the window in Window List, then choose
Minimize from the popup menu.

6.4.3 To Maximize a Window
When you maximize a window, the window expands as much as possible. To
maximize a window perform one of the following actions:

� To maximize the window, click on the Maximize button on the window frame.
Alternatively, open the Window Menu, then choose Maximize.

� Right-click on the button that represents the window in Window List, then choose
Maximize from the Window Menu.

6.4.4 To Restore a Window
To restore a maximized window perform one of the following actions:

� Click on the Maximize button on the window frame.
� Open the Window Menu. Choose Unmaximize.
� Right-click on the button that represents the window in Window List to open the

Window Menu. Choose Unmaximize.
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To restore a minimized window, click on the button that represents the window in
Window List.

6.4.5 To Close a Window
To close a window perform one of the following actions:

� Click on the Close Window button on the window frame.
� Open the Window Menu. Choose Close.
� Right-click on the button that represents the window in Window List, then choose

Close from the Window Menu.

If you have unsaved data in the window, you are prompted to save your data.

6.4.6 To Resize a Window
To resize a window perform one of the following actions:

� Point to a corner of the window. The mouse pointer changes to indicate that you
can resize the window. Grab the corner and drag the window to the new size.

� Right-click on the button that represents the window in Window List. Choose
Resize from the Window Menu. Use the arrow keys to resize the window.

� Press-and-hold Alt, then middle-click near the corner that you want to resize. The
mouse pointer changes to indicate that you can resize from the corner. To resize the
window, drag from the corner on which you middle-clicked.

� To resize a window horizontally point to one of the vertical edges of the window.
The mouse pointer changes to indicate that you can resize the window. Grab the
edge and drag the window to the new size.

� To resize a window vertically point to the bottom edge of the window. The mouse
pointer changes to indicate that you can resize the window. Grab the edge and
drag the window to the new size.

Note – You cannot resize some dialog windows. Also, some application windows have
a minimum size below which you cannot reduce the window.

6.4.7 To Move a Window
To move a window perform one of the following actions:

� Grab the titlebar of the window and drag the window to the new location.
� Press-and-hold Alt, then drag the window to the new location.
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� Open the Window Menu, then choose Move. Use the arrow keys to move the
window to the new location.

� Right-click on the button that represents the window in Window List, then choose
Move from the Window Menu. Use the arrow keys to move the window to the new
location.

6.4.8 To Shade a Window
You can shade and unshade windows, as follows:

Shade Reduce the window so that only the titlebar is visible.

Unshade Switch a window from a shaded state so that the full window is
displayed.

To shade a window perform one of the following actions:

� Double-click on the titlebar of the window. To unshade the window, double-click
on the titlebar again.

� Open the Window Menu. Choose Shade. To unshade the window, choose Unshade.

� Right-click on the button that represents the window in Window List, then choose
Shade from the Window Menu. To unshade the window, choose Unshade.

6.4.9 To Put a Window on All Workspaces
To put a window in all workspaces, open the Window Menu. Choose Put on All
Workspaces. To set the window to appear only in the current workspace, choose Only
on This Workspace.

6.4.10 To Move a Window to Another Workspace
You can move a window to another workspace in either of the following ways:

� Use Workspace Switcher

In the Workspace Switcher display, drag the window to the workspace you require.

� Use the Window Menu

Open the Window Menu. To move the window to the next workspace choose
Move to workspace_name.
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6.5 Manipulating Workspaces
This section describes how to manipulate workspaces.

6.5.1 To Switch Between Workspaces
You can switch between workspaces in any of the following ways:

� Use Workspace Switcher

Click on the workspace that you want to switch to in Workspace Switcher.
� Use shortcut keys

The default shortcut keys to switch between the workspaces are as follows:

Default Shortcut Keys Function

Ctrl + Alt + right arrow Selects the workspace to the right.

Ctrl + Alt + left arrow Selects the workspace to the left.

6.5.2 To Add Workspaces
To add workspaces to your desktop, right-click on Workspace Switcher, then choose
Preferences. The Workspace Switcher Preferences dialog is displayed. Use the Number
of workspaces spin box to specify the number of workspaces you require. Workspace
Switcher adds new workspaces at the end of the workspace list.

6.5.3 To Name Workspaces
The default names of your workspaces are Workspace 1, Workspace 2, Workspace
3, and so on. To assign names to your workspaces, right-click on Workspace Switcher,
then choose Preferences. The Workspace Switcher Preferences dialog is displayed. Use
the Workspaces list box to specify the names of your workspaces. Select a workspace,
then type the new name for the workspace.

6.5.4 To Delete Workspaces
When you delete a workspace the windows in the workspace are moved to another
workspace, and the empty workspace is deleted.
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To delete workspaces from your desktop, right-click on Workspace Switcher, then
choose Preferences. The Workspace Switcher Preferences dialog is displayed. Use the
Number of workspaces spin box to specify the number of workspaces you require.
Workspace Switcher deletes workspaces from the end of the workspace list.
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CHAPTER 7

Nautilus File Manager

This chapter describes how to use the Nautilus file manager.

� “7.1 Introduction to Nautilus File Manager” on page 101
� “7.2 Nautilus Windows” on page 102
� “7.3 Navigating Your Computer” on page 108
� “7.4 Managing Your Files and Folders” on page 117
� “7.5 Running Scripts From Nautilus” on page 124
� “7.6 Modifying the Appearance of Files and Folders” on page 124
� “7.7 Assigning Actions to Files” on page 131
� “7.8 Customizing Nautilus” on page 133

7.1 Introduction to Nautilus File
Manager
The Nautilus file manager provides an integrated access point to your files and
applications. Nautilus enables you to do the following:

� Display your files and folders.
� Manage your files and folders.
� Run scripts.
� Customize your files and folders.

Nautilus also manages the desktop background. The desktop background lies behind
all of the other components on your visible desktop. The desktop background is an
active component of the user interface.

Nautilus windows enable you to display and manage your files and folders. You can
open a Nautilus window in any of the following ways:

� Double-click on the Home object on the desktop background.
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� Choose Applications → Home Folder.

� Right-click on the desktop background to open the Desktop Background menu.
Choose New Window.

The Nautilus window displays the contents of your home location in the view pane.

7.2 Nautilus Windows
Nautilus windows enable you to display and manage your files and folders. Figure
7–1 shows a Nautilus window that displays the contents of a folder.
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FIGURE 7–1 Contents of a Folder in a Nautilus Window

Table 7–1 describes the components of Nautilus windows.

TABLE 7–1 Nautilus Window Components

Component Description

Menubar Contains menus that you use to perform tasks in Nautilus.

Toolbar Contains buttons that you use to perform tasks in Nautilus.
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TABLE 7–1 Nautilus Window Components (Continued)
Component Description

Location bar Contains the following elements:
� Location field or Go To field: Enables you to specify a file,

folder, or URL that you want to display.
� Zoom buttons: Enable you to change the size of items in the

view pane.
� View as drop-down list box: Enables you to choose how to

display items in your view pane.

Side pane Performs the following functions:
� Enables you to navigate through your files.
� Displays information about the current file or folder.

Tabs Click on a tab to open a tabbed pane. The side pane contains the
following tabbed panes:
� History
� Notes
� Tree

View pane Displays the contents of the following:
� Particular types of files
� Folders
� FTP sites

Resize handle Grab this handle, then drag to resize the side pane and the view
pane.

Statusbar Displays status information.

You can also open a popup menu from Nautilus windows. To open this popup menu
right-click in a Nautilus window. The items in this menu depend on where you
right-click. For example, when you right-click on a file or folder, you can choose items
related to the file or folder. When you right-click on the background of a view pane,
you can choose items related to the display of items in the view pane.

7.2.1 View Pane
The view pane can display the contents of the following:

� Particular types of files
� Folders
� FTP sites

Nautilus contains viewer components that enable you to display particular types of file
in the view pane. For example, you can use an image viewer to display Portable
Network Graphics (PNG) files in the view pane. The following figure shows a PNG
file displayed in the view pane.
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Displaying a file in the view pane provides the following benefits:

� Uses less system resources than when you launch an application.
� Takes less time than when you launch an application.

However, you cannot edit a file in the view pane.

Nautilus also includes views that enable you to display the contents of your folders in
different ways. For example, you can display the contents of a folder in the following
types of view:

� Icon view: Displays the items in the folder as icons.
� List view: Displays the items in the folder as a list.

Use the View menu to choose how to display a folder. For more information on views,
see “7.6.4 Using Views to Display Your Files and Folders” on page 126.

7.2.2 Side Pane
The side pane can contain the following elements:

� An icon that represents the current file or current folder. The side pane also
contains information about the current file or current folder.

� Tabbed panes that enable you to navigate through your files.
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� If a file is displayed in the view pane, buttons appear in the side pane. The buttons
enable you to perform actions on a file, other than the default action.

7.2.3 Tabbed Panes
The side pane can contain the following tabbed panes:

� History

Contains a history list of files, folders, and FTP sites that you have recently visited.

� Notes

Enables you to add notes to your folders.

� Tree

Displays a hierarchical representation of your file system. You can use the Tree
tabbed pane to navigate through your files.

Table 7–2 describes how to work with tabbed panes.

TABLE 7–2 Tabbed Pane Tasks

Task Action

Open a tabbed pane. Click on the tab.

Close a tabbed pane. Click on the tab.

Remove a tab from the side
pane.

Right-click in the side pane, then choose the tab that you
want to remove from the menu.

Add a tab to the side pane. Right-click in the side pane, then choose the tab that you
want to add from the menu.

7.2.4 Icons and Emblems
In icon view, Nautilus displays your files and folders as icons. You can add emblems
to your file icons and folder icons. An emblem is a small icon that you can add to an
item to visually mark the item. For example, to mark a file as important, you can add
an Important emblem to the file icon to create the following visual effect:
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For more information on how to add an emblem to an icon, see “7.6.1 To Add an
Emblem to a File or Folder” on page 124.

The following table describes the structure of the file icon:

Component Description

Emblem. This emblem is the Important emblem.

Icon that represents the file. This icon contains a preview of
the contents of the file.

Icon caption. You can modify what items of information are
displayed in the icon caption.

Nautilus includes default emblems for the following types of item:

� Symbolic links

� Items for which you have the following permissions:

� Read permission only
� No read permission and no write permission

The default emblems change depending on your theme. The following table shows the
default emblems for the Default theme.
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Default Emblem Description

Symbolic link

Read permission only

No read permission and no write permission

7.3 Navigating Your Computer
Each Nautilus window displays the contents of a single file, folder, or FTP site. This
section describes the following:

� How to display items in Nautilus windows.
� How to open files from Nautilus windows.
� How to navigate the files and folders in your file system.
� How to navigate to FTP sites.

7.3.1 To Display Your Home Location

To display your home location, perform one of the following actions:

� Double-click on the Home object on the desktop background.
� On a Nautilus window, choose Go → Home.
� On a Nautilus window, click on the Home toolbar button.
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The Nautilus window displays the contents of your home location. To reload the
display, click on the Reload button.

7.3.2 To Display a Folder
You can display the contents of a folder in any of the following ways:

� Double-click on the folder in the view pane.

� In the Location field, type the path of the folder that you want to display, then
press Return. The Location field includes an autocomplete feature. As you type a
path, Nautilus reads your file system. When you type enough characters to
uniquely identify a directory, Nautilus completes the name of the directory in the
Location field.

� Use the Tree tabbed pane. For more information, see “7.3.3 Using the Tree Tabbed
Pane” on page 109.

� Use the Back toolbar button and the Forward toolbar button to browse through
your navigation history.

To change to the folder that is one level above the current folder, choose Go → Up.
Alternatively, click on the Up toolbar button.

To reload the display, click on the Reload button.

If you cannot find the folder that you want to display, you can use Search Tool. To start
Search Tool, choose Actions → Search for Files.

7.3.3 Using the Tree Tabbed Pane
The Tree tabbed pane displays a hierarchical representation of your file system. The
Tree tabbed pane provides a convenient way to navigate your file system. By default,
the Tree tabbed pane is not displayed in your side pane. To add the Tree tabbed pane
to the side pane, right-click in the side pane, then choose Tree from the popup menu.

The following figure shows the Tree tabbed pane.
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In the Tree tabbed pane, folders are represented as follows:

Folder State Graphic Representation

Closed folder Right arrow

Open folder Down arrow

Table 7–3 describes the tasks that you can perform with the Tree tabbed pane, and how
to perform the tasks.

TABLE 7–3 Tree Tabbed Pane Tasks

Task Action

Open the Tree tabbed pane. Click on the Tree tab.

Close the Tree tabbed pane. Click on the Tree tab.

Open a folder in the Tree tabbed pane. Click on the arrow next to the folder in the
Tree tabbed pane.
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TABLE 7–3 Tree Tabbed Pane Tasks (Continued)
Task Action

Close a folder in the Tree tabbed pane. Click on the arrow next to the folder in the
Tree tabbed pane.

Display the contents of a folder in the view
pane.

Select the folder in the Tree tabbed pane.

Display the contents of a file in the view pane. Select the file in the Tree tabbed pane.

You can set your preferences so that the Tree tabbed pane does not display files. For
more information, see “7.8.1.7 To Set Side Pane Preferences” on page 141.

7.3.4 Opening Files
When you open a file, Nautilus performs the default action for that file type. The
default action can be one of the following:

� Use a viewer component to display the file in the view pane.
� Launch an application that opens the file.

Nautilus checks the contents of a file to determine the type of a file. If the first lines do
not determine the type of the file, then Nautilus checks the file extension.

If you cannot find the file that you want to open, you can use Search Tool. To start
Search Tool, choose Actions → Search for Files.

7.3.4.1 Viewing Files in the View Pane
Nautilus contains viewer components that enable you to display particular types of
file in the view pane. For example, you can display the following types of files in the
view pane:

� Plain text files
� Portable Network Graphics (PNG) files
� Joint Photographic Experts Group (JPEG) files

To reload the contents of the view pane, choose View → Reload. To stop loading an
item in the view pane, choose View → Stop.

When you display a file in the view pane, the viewer component might add menu
items to the Nautilus menus. The menu items relate to the file type that is displayed.
For example, when you display a PNG file, the View menu contains Interpolation,
Dither, and other submenus.

Also, when you display some types of file in the view pane, you can use the Nautilus
zoom buttons to change the size of the item.
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7.3.4.2 To Execute the Default Action
To execute the default action for a file, double-click on the file. For example, if the
default action for plain text documents is to display the file in a text viewer. In this
case, you can double-click on the file to display the file in a text viewer.

You can set your Nautilus preferences so that you click once on a file to execute the
default action. For more information, see “7.8.1.5 To Set Icon and List Views
Preferences” on page 138.

7.3.4.3 To Execute Non-Default Actions Using the Open
With Submenu
To execute actions other than the default action for a file, perform the following steps:

1. In the view pane, select the file that you want to perform an action on. Choose File
→ Open With. The Open With submenu opens. The items in this submenu
correspond to the contents of the following parts of the File Types and Programs
preference tool:

� Default action drop-down list box in the Edit file type dialog
� Viewer Component drop-down list box in the Edit file type dialog

2. Choose an action from the Open With submenu.

7.3.4.4 To Execute Other Actions When Displaying a File
When you display a file in the view pane, the side pane might contain buttons. Figure
7–2 shows the side pane when a text file is displayed in the view pane.
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FIGURE 7–2 Side Pane When a File is Displayed in the View Pane

The buttons represent any actions that are defined in the File Types and Programs
preference tool. The actions are defined in the Default action drop-down list box in the
Edit file type dialog in the File Types and Programs preference tool. Click on a button
to execute an action. For example, if an action defined for plain text documents is to
open the file in gedit. If this action is defined, an Open with gedit button is displayed
in the side pane. To open the file in the gedit application, click on the Open with gedit
button.

Note – A button that represents the action does not appear in the side pane if the
actions are excluded in either of the following dialogs:

� Open with Other Application
� Open with Other Viewer

7.3.5 Using the Start Here Location

The Start Here location enables you to access the following functions:
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� Applications

Double-click on Applications to access your key GNOME applications. You can
also access the Applications menu through the GNOME Menu and the Menu
Panel.

� Desktop Preferences

Double-click on Desktop Preferences to customize your desktop. You can also
access the desktop preferences through the Applications menu.

� Programs that enable you to configure your system as a server, and to choose other
system settings.

You can access the Start Here location in the following ways:

� From a Nautilus window

Choose Go → Start Here. The contents of the Start Here location are displayed in
the window.

� From the desktop background

Double-click on the Start Here object on the desktop background. The contents of
the Start Here location are displayed in a Nautilus window.

7.3.6 To Access FTP Sites
You can use Nautilus to access FTP sites. To access an FTP site, enter the URL for the
site in the field on the location bar, then press Return. The contents of the site are
displayed in the view pane. To copy a file from the FTP site, drag the file to the new
location.

To access an FTP site that requires a username and password, you can enter the URL
in the following form:

ftp://username:password@hostname.domain

To reload the FTP site in the view pane, choose View → Reload. To stop loading the
FTP site, choose View → Stop.

7.3.7 Using Your Navigation History
Nautilus maintains a history list of files, folders, and FTP sites. You can use the history
list to navigate to files, folders, and FTP sites that you have recently visited. The
following sections describe how to navigate your history list.

To clear your history list choose Go → Clear History.
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7.3.7.1 To Navigate Your History List Using the Go Menu
To display a list of previously-viewed items, choose the Go menu. Your history list is
displayed in the lower part of the Go menu. To open an item in your history list,
choose the item from the Go menu.

7.3.7.2 To Navigate Your History List Using the Toolbar
To use the toolbar to navigate your history list, perform one of the following actions:

� To open the previous file, folder, or URL in your history list, click on the Back
toolbar button.

� To open the next file, folder, or URL in your history list, click on the Forward
toolbar button.

� To display a list of previously-viewed items, click on the down arrow to the right
of the Back toolbar button. To open an item from this list, click on the item.

� To display a list of items that you viewed after you viewed the current item, click
on the down arrow to the right of the Forward toolbar button. To open an item
from this list, click on the item.

7.3.7.3 To Navigate Your History List Using the History
Tabbed Pane
To display the History tabbed pane, click on the History tab in the side pane. The
History tabbed pane displays a list of your previously-viewed items.
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To display an item from your history list in the view pane, click on the item in the
History tabbed pane.

7.3.8 To Bookmark Your Favorite Locations
To access an item in your bookmarks, choose the item from the Bookmarks menu. You
can add your favorite locations to your Bookmarks menu. You can add bookmarks to
files and folders in your file system, or to FTP sites.

7.3.8.1 To Add a Bookmark
To add a bookmark, display the item that you want to bookmark in the view pane.
Choose Bookmarks → Add Bookmark.

7.3.8.2 To Edit a Bookmark
To edit your bookmarks perform the following steps:

1. Choose Bookmarks → Edit Bookmarks. An Edit Bookmarks dialog is displayed.

2. To edit a bookmark, select the bookmark on the left side of the Edit Bookmarks
dialog. Edit the details for the bookmark on the right side of the Edit Bookmarks
dialog, as follows:
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Dialog Element Description

Name Use this text box to specify the name that identifies the bookmark
in the Bookmarks menu.

Location Use this field to specify the location of the bookmark.

3. To delete a bookmark, select the bookmark on the left side of the dialog. Click
Delete.

7.4 Managing Your Files and Folders
This section describes how to work with your files and folders.

7.4.1 Drag-and-Drop in Nautilus
You can use drag-and-drop to perform several tasks in Nautilus. When you
drag-and-drop, the mouse pointer provides feedback about the task that you perform.
Table 7–4 describes the tasks that you can perform with drag-and-drop. The table also
shows the mouse pointers that appear when you drag-and-drop.

TABLE 7–4 Drag-and-Drop in Nautilus

Task Action Mouse Pointer

Move an item Drag the item to the new location.

Copy an item Grab the item, then press-and-hold Ctrl. Drag the item
to the new location.

Link to an item Grab the item, then press-and-hold Ctrl + Shift. Drag
the item to the location where you want the link to
reside.
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TABLE 7–4 Drag-and-Drop in Nautilus (Continued)
Task Action Mouse Pointer

Ask what to do
with the item you
drag

Grab the item, then press-and-hold Alt. Drag the item
to the location where you want the item to reside.
Release the mouse button. A popup menu appears.
Choose one of the following items from the popup
menu:
� Move here

Moves the item to the location.
� Copy here

Copies the item to the location.
� Link here

Creates a symbolic link to the item at the location.
� Set as Background

If the item is an image, sets the image to be the
background wallpaper. You can use this command
to set the desktop background and the view pane
background.

� Cancel
Cancels the drag-and-drop operation.

7.4.2 To Select Files and Folders
You can select files and folders in several ways in Nautilus. Table 7–5 describes how to
select items in Nautilus windows and on the Nautilus desktop background.

TABLE 7–5 Selecting Items in Nautilus

Task Action

Select an item Click on the item.

Select a group of contiguous
items

In icon view, drag around the files that you want to select.

In list view, press-and-hold Shift. Click on the first item in
the group, then click on the last item in the group.

Select multiple items Press-and-hold Ctrl. Click on the items that you want to
select.

Alternatively, press-and-hold Ctrl, then drag around the
files that you want to select.

Select all items in a folder Choose Edit → Select All Files.

To perform the default action on an item, double-click on the item. You can set your
Nautilus preferences so that you work with Nautilus as follows:

� Click once on a file to execute the default action.
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� Point to an item to select the item.

For more information, see “7.8.1.5 To Set Icon and List Views Preferences”
on page 138.

7.4.3 To Move a File or Folder
The following sections describe the ways you can move a file or folder.

7.4.3.1 Drag to the New Location in a View Pane
To drag a file or folder to a new location in a view pane, perform the following steps:

1. Open a Nautilus window. Choose File → New Window to open a second Nautilus
window.

2. In one window, select the folder from which you want to move the file or folder. In
the other window, select the folder to which you want to move the file or folder.

3. Drag the file or folder that you want to move to the new location in the other
window.

To move the file or folder to a folder that is one level below the current location, do
not open a new window. Instead, drag the file or folder to the new location in the
same window.

7.4.3.2 Cut and Paste to the New Location
You can cut a file or folder and paste the file or folder into another folder, as follows:

1. Select the file or folder that you want to move, then choose Edit → Cut File.

2. Open the folder to which you want to move the file or folder, then choose Edit →
Paste Files.

7.4.3.3 Drag to the New Location in the Tree Tabbed Pane
You can drag a file or folder from the view pane to a location on the Tree tabbed pane.
Alternatively, you can drag a file or folder within the Tree tabbed pane to another
location in the Tree tabbed pane.

7.4.4 To Copy a File or Folder
The following sections describe the ways you can copy a file or folder.
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7.4.4.1 Drag to the New Location in a View Pane
To copy a file or folder perform the following steps:

1. Open a Nautilus window. Choose File → New Window to open a second Nautilus
window.

2. In one window, select the folder from which you want to copy the file or folder. In
the other window, select the folder to which you want to copy the file or folder.

3. Grab the file or folder, then press-and-hold Ctrl. Drag the file or folder to the new
location in the other window.

To copy the file or folder to a folder that is one level below the current location, do not
open a new window. Instead, grab the file or folder, then press-and-hold Ctrl. Drag the
file or folder to the new location in the same window.

7.4.4.2 Copy and Paste to the New Location
You can copy a file or folder and paste the file or folder into another folder, as follows:

1. Select the file or folder that you want to copy, then choose Edit → Copy File.

2. Open the folder to which you want to copy the file or folder, then choose Edit →
Paste Files.

7.4.5 To Duplicate a File or Folder
To create a copy of a file or folder in the current folder perform the following steps:

1. Select the file or folder that you want to duplicate in the view pane.

2. Choose Edit → Duplicate. Alternatively, right-click on the file or folder in the view
pane, then choose Duplicate.

A copy of the file or folder appears in the current folder.

7.4.6 To Create a Folder
To create a folder perform the following steps:

1. Select the folder where you want to create the new folder.

2. Choose File → New Folder. Alternatively, right-click on the background of the view
pane, then choose New Folder.

An untitled folder is added to the view pane. The name of the folder is selected.

3. Type a name for the folder, then press Return.
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7.4.7 To Rename a File or Folder
To rename a file or folder perform the following steps:

1. Select the file or folder that you want to rename in the view pane.

2. Choose Edit → Rename. Alternatively, right-click on the file or folder in the view
pane, then choose Rename.

The name of the file or folder is selected.

3. Type a new name for the file or folder, then press Return.

7.4.8 To Move a File or Folder to Trash
To move a file or folder to Trash perform the following steps:

1. Select the file or folder that you want to move to Trash in the view pane.

2. Choose Edit → Move to Trash. Alternatively, right-click on the file or folder in the
view pane, then choose Move to Trash.

Alternatively, you can drag the file or folder from the view pane to the Trash object on
the desktop background.

7.4.9 To Delete a File or Folder
When you delete a file or folder, the file or folder is not moved to Trash, but is deleted
from your file system immediately. The Delete menu item is only available if you
select the Include a Delete command that bypasses Trash option in the Preferences
dialog.

To delete a file or folder perform the following steps:

1. Select the file or folder that you want to delete in the view pane.

2. Choose Edit → Delete. Alternatively, right-click on the file or folder in the view
pane, then choose Delete.

7.4.10 To Create a Symbolic Link to a File or Folder
A symbolic link is a special type of file that points to another file or folder. When you
perform an action on a symbolic link, the action is performed on the file or folder to
which the symbolic link points. However, when you delete a symbolic link, you delete
the link file, not the file to which the symbolic link points.

To create a symbolic link to a file or folder, select the file or folder to which you want
to create a link. Choose Edit → Make Link. A link to the file or folder is added to the
current folder.
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Alternatively, grab the item to which you want to create a link, then press-and-hold
Ctrl + Shift. Drag the item to the location where you want to place the link.

By default, Nautilus adds an emblem to symbolic links.

7.4.11 To Change Permissions
To change the permissions on a file or folder perform the following steps:

1. Select the file or folder that you want to change.

2. Choose File → Properties. A properties dialog is displayed.

3. Click on the Permissions tab. In the Permissions tabbed section, use the drop-down
list boxes and check boxes to change the permissions for the file or folder.

4. Click Close to close the properties dialog.

7.4.12 Using Trash

You can move the following items to Trash:

� Files
� Folders
� Desktop background objects

When you move an item to Trash, the item is stored in your /.Trash directory. If you
need to retrieve a file from Trash, you can display Trash and move the file out of Trash.

When you empty Trash, you delete the contents of Trash permanently.

7.4.12.1 To Display Trash
You can display the contents of Trash in the following ways:

� From a Nautilus window

Choose Go → Trash. The contents of Trash are displayed in the window.
� From the desktop background
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Double-click on the Trash object on the desktop background.

7.4.12.2 To Empty Trash
You can empty the contents of Trash in the following ways:

� From a Nautilus window

Choose File → Empty Trash.

� From the desktop background

Right-click on the Trash object, then choose Empty Trash.

7.4.13 Adding Notes to Folders

You can use the Notes tab to add a note to a folder. To add a note to a folder perform
the following steps:

1. Display the folder in the view pane.

2. Click on the Notes tab to open the Notes tabbed pane. The Notes tabbed pane
opens.

3. Type the note in the Notes tabbed pane.
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7.5 Running Scripts From Nautilus
Nautilus includes a special folder where you can store your scripts. When you add an
executable file to this folder, the file is added to the Scripts submenu. To run a script
choose File → Scripts, then choose the script that you want to run from the submenu.

To run a script on a particular file, select the file in the view pane. Choose File →
Scripts, then choose the script that you want to run on the file from the submenu. You
can also select multiple files to run your scripts on.

To view the contents of your scripts folder, choose File → Scripts → Open Scripts
Folder.

7.6 Modifying the Appearance of Files
and Folders
Nautilus enables you to modify the appearance of your files and folders in several
ways, as described in the following sections.

7.6.1 To Add an Emblem to a File or Folder
To add an emblem to an item perform the following steps:

1. Select the item to which you want to add an emblem.

2. Right-click on the item, then choose Properties. A properties dialog is displayed.

3. Click on the Emblems tab to display the Emblems tabbed section.

124 GNOME 2.0 on Solaris User Guide • August 27, 2002 (Beta)



4. Select the emblem to add to the item.

5. Click Close to close the properties dialog.

7.6.2 To Modify the Icon for a File or Folder
To change the icon that represents an individual file or folder, perform the following
steps:

1. Select the file or folder that you want to change.

2. Choose File → Properties. A properties dialog is displayed.

3. On the Basic tabbed section, click on the Select Custom Icon button. A Select an
icon dialog is displayed.

4. Use the Select an icon dialog to choose the icon to represent the file or folder.

5. Click Close to close the properties dialog.

To change the icon that represents a file type, use the File Types and Programs
preference tool. To open the File Types and Programs preference tool, choose
Applications → Desktop Preferences → Advanced → File Types and Programs.

To restore an icon from a custom icon to the default icon specified in the File Types
and Programs preference tool, right-click on the icon then choose Remove Custom
Icon. Alternatively, click on the Remove Custom Icon button on the Properties dialog.
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7.6.3 To Change the Size of Items in a View
You can change the size of items in a view. You can change the size if the view
displays a file or a folder. You can change the size of items in a view in the following
ways:

� To enlarge the size of items in a view, choose View → Zoom In.
� To reduce the size of items in a view, choose View → Zoom Out.
� To return items in a view to the normal size, choose View → Normal Size.

You can also use the zoom buttons on the location bar to change the size of items in a
view. Table 7–6 describes how to use the zoom buttons.

TABLE 7–6 Zoom Buttons

Button Button Name Description

Zoom Out button Click on this button to reduce the size of
items in a view.

Normal Size button Click on this button to return items in a
view to normal size.

Zoom In button Click on this button to enlarge the size of
items in a view.

Nautilus remembers the size of items in a particular folder. The next time that you
display the folder, the items are displayed in the size that you selected. In other words,
when you change the size of items in a folder, you customize the folder to display the
items at that size. To return the size of the items to the default size specified in your
preferences, choose View → Reset View to Defaults.

7.6.4 Using Views to Display Your Files and
Folders
Nautilus provides several ways to display the contents of your files. Nautilus includes
viewer components that enable you to display particular types of file in the view pane.
For example, you can use a web page viewer to display HTML files in the view pane.
You can use a text viewer to view plain text files in the view pane.
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You can also use Nautilus to open a file in an appropriate application. For more
information, see “7.3.4 Opening Files” on page 111.

Nautilus includes views that enable you to display the contents of your folders in
different ways. For example, you can display the contents of a folder in the following
types of view:

� Icon view

Displays the items in the folder as icons. Figure 7–1 shows a folder displayed in
icon view.

� List view

Displays the items in the folder as a list. Figure 7–3 shows a folder displayed in list
view.

FIGURE 7–3 Nautilus Window in List View

Use the View menu to choose how to display a file or folder. You can also use the View
as drop-down list box to choose how to display a file or folder. When you display a
folder, you can specify how you want to arrange or sort items in the folder. You can
modify the size of the items in the view pane. The following sections describe how to
work with icon view, list view, and views of files.
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7.6.4.1 To Choose a View in Which to Display a File or
Folder
Choose the type of view in which to display the contents of a file or folder from the
View menu.

Alternatively, to choose a view, choose View → View as. Select the view that you want
to use from the Open with Other Viewer dialog, then click on the Choose button.

You can also choose the type of view from the View as drop-down list box. The View
as drop-down list box is located at the right side of the location bar.

You can display different folders in different views. Nautilus remembers the view that
you choose for a particular folder. The next time that you display the folder, Nautilus
displays the folder in that view. To return the view for the folder to the default view
specified in your preferences, choose View → Reset View to Defaults.

7.6.4.2 To Arrange Your Files in Icon View
When you display the contents of a folder in icon view, you can specify how to
arrange the items in the folder. To specify how to arrange items in icon view, choose
View → Arrange Items. The Arrange Items submenu contains the following sections:

� The top section contains an option that enables you to arrange your files manually.

� The middle section contains options that enable you to sort your files
automatically.

� The bottom section contains options that enable you to modify how your files are
arranged.

Choose the appropriate options from the submenu, as described in the following table:

Option Description

Manually Select this option to arrange the items manually. To arrange the
items manually, drag the items to the location you require within
the view pane.

By Name Select this option to sort the items alphabetically by name. The
order of the items is not case sensitive. If Nautilus is set to display
hidden files, the hidden files are shown last.

By Size Select this option to sort the items by size, with the largest item
first. When you sort items by size, the folders are sorted by the
number of items in the folder. The folders are not sorted by the
total size of the items in the folder.
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Option Description

By Type Select this option to sort the items alphabetically by object type.
The items are sorted alphabetically by the description of their
Multipurpose Internet Mail Extension (MIME) type in the File Types
and Programs preference tool.

By Modification Date Select this option to sort the items by the date the items were last
modified. The most recently modified item is first.

By Emblems Select this option to sort the items by any emblems that are added
to the items. The items are sorted alphabetically by emblem name.
Items that do not have emblems are last.

Compact Layout Select this option to arrange the items so that the items are closer
to each other.

Reversed Order Select this option to reverse the order of the option by which you
sort the items. For example, if you sort the items by name, select
the Reversed Order option to sort the items in reverse alphabetical
order.

Nautilus remembers how you arrange the items in a particular folder. The next time
that you display the folder, the items are arranged in the way that you selected. In
other words, when you specify how to arrange the items in a folder, you customize the
folder to display the items in that way. To return the arrangement settings of the folder
to the default arrangement settings specified in your preferences, choose View →
Reset View to Defaults.

7.6.4.3 To Stretch an Icon in Icon View
In icon view, you can change the size of the icon that represents an item that is
displayed. To change the size of an item in icon view, perform the following steps:

1. Right-click on the item that you want to resize, then choose Stretch Icon. A
rectangle appears around the item, with a handle at each corner.

2. Grab one of the handles, then drag the icon to the size that you want.

To return the icon to the original size, right-click on the icon, then choose Restore
Icon’s Original Size.

You can also stretch icons on the desktop background.

7.6.4.4 To Modify the Behavior of a View
You can modify the behavior of a view in the following ways:

� Specify that the view is the default view for a particular file or folder.
� Specify that the view is the default view for a file type or all folders.
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� Specify that the view is an item in the View as submenu for a particular file or
folder.

� Specify that the view is an item in the View as submenu for all of a particular file
type or for all folders.

� Specify that the view is not an item in the View as submenu for a particular file or
folder.

To modify the behavior of a view perform the following steps:

1. Choose View → View as. A Open with Other Viewer dialog is displayed.

2. Select the view that you want to modify from the table in the dialog.

3. Click on the Modify button. A Modify dialog is displayed. The following table
describes the options on the Modify dialog:

Option Description

Include in the menu for
item_name items

Select this option to include the view in the View as
submenu for this type of item.

Use as default for item_name
items

Select this option to use the view as the default for this
type of item.

Include in the menu for
item_name only

Select this option to include the view in the View as
submenu for this item only.

Use as default for item_name
only

Select this option to use the view as the default for this
item only.

130 GNOME 2.0 on Solaris User Guide • August 27, 2002 (Beta)



Option Description

Don’t include in the menu for
item_name items

Select this option to exclude the view from the View as
submenu for this type of item.

4. Click OK, then click Cancel to close the Open with Other Viewer dialog.

Note – You can also modify the actions that are associated with a file type in the File
Types and Programs preference tool. To open the File Types and Programs preference
tool, click on the Go There button.

7.7 Assigning Actions to Files
When you open a file, Nautilus performs the default action for that file type. The File
Types and Programs preference tool contains a table of file types, their associated file
extensions, and their default actions. This table specifies what happens when you
double-click on a file in Nautilus.

You can also use Nautilus to modify the actions that are associated with a particular
file or file type.

You can use the File Types and Programs preference tool to perform the following
tasks:

� Specify the default action for a file type. You can also change the default action for
a file type in Nautilus.

� Associate a file type with one or more applications. The default action might
specify to open the file in an application that is associated with the file type.

� Associate a file type with one or more viewers. The default action might specify to
open the file in a viewer that is associated with the file type.

� Associate a file extension with a MIME type. The MIME type specifies the format
of the file so that Internet browsers and email applications can read the file.

7.7.1 To Modify Actions
You can modify the actions associated with a file or file type. You can do the following:

� Specify that the action is the default action for a particular file.
� Specify that the action is the default action for a particular file type.
� Specify that the action is an item in the Open With submenu for a particular file.
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� Specify that the action is an item in the Open With submenu for a particular file
type.

� Specify that the action is not an item in the Open With submenu for a particular file
type.

To modify the actions associated with a file or file type, perform the following steps:

1. In the view pane, select the file for which you want to modify an action. If you
want to modify an action associated with a file type, select a file of that type.

2. Choose File → Open With. Perform either of the following steps:

� Choose Other Application. An Open with Other Application dialog is
displayed.

� Choose Other Viewer. A Open with Other Viewer dialog is displayed.

3. From the table in the dialog, select the application or viewer for which you want to
modify the behavior.

4. Click on the Modify button. A Modify dialog is displayed. The following table
describes the options on the Modify dialog:

Option Description

Include in the menu for filetype
items

Select this option to include the application or viewer in
the Open With submenu for this file type.

Use as default for filetype items Select this option to use the application or viewer as the
default action for this file type.

Include in the menu for filename
only

Select this option to include the application or viewer in
the Open With submenu for this file, and not for other
files of this type.

Use as default for filename only Select this option to use the application or viewer as the
default action for this file, and not for other files of this
type.

Don’t include in the menu for
filetype items

Select this option to exclude the application or viewer
from the Open With submenu for this file type.

5. Click OK, then click Cancel to close the dialog.

Note – You can also modify the actions that are associated with a file type in the File
Types and Programs preference tool. To open the File Types and Programs preference
tool, click on the Go There button.
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7.8 Customizing Nautilus
You can customize Nautilus to suit your requirements and preferences. This section
describes how to customize Nautilus.

7.8.1 Setting Your Preferences
Use the Preferences dialog to set preferences for the Nautilus windows and desktop
background. To display the Preferences dialog, choose Edit → Preferences.

You can set preferences in the following categories:

� The default settings for views.
� The appearance of the Nautilus windows and desktop background.
� The behavior and visible components of new Nautilus windows.
� The behavior of the desktop background and Trash.
� The behavior of items in icon views and list views.
� The information that is displayed in icon captions.
� Items that are displayed in the side pane.
� Performance options to improve the performance of Nautilus.

7.8.1.1 To Set View Preferences
You can specify a default view, and default settings for icon views and list views. To
specify your default view settings for Nautilus windows, choose Edit → Preferences.
Choose Views from the Preferences dialog.
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Table 7–7 lists the view settings that you can modify. The Preferences dialog contains
an Icon View Defaults group box and a List View Defaults group box. The group
boxes contain mostly the same dialog elements. Each dialog element is described once
in Table 7–7.

TABLE 7–7 View Preferences

Dialog Element Description

View new folders using Select the default view for folders. When you open a folder,
the folder is displayed in the view that you select.

Arrange Items Select the characteristic by which you want to sort the items
in folders that are displayed in this view.

Default zoom level Select the default zoom level for folders that are displayed
in this view. The zoom level specifies the size of items in a
view.

Sort in reverse Select this option if you want to reverse the order by which
items are sorted in this view. If you select this option, the
order of the characteristic you select in Arrange Items is
reversed. For example, if you select By Name from the
Arrange Items drop-down list box. You can select the Sort in
reversed order option to sort the items in reverse
alphabetical order.
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TABLE 7–7 View Preferences (Continued)
Dialog Element Description

Use compact layout Icon view only. Select this option to arrange the items so
that the items in the folder are closer to each other.

7.8.1.2 To Select a Nautilus Theme
Nautilus includes themes that you can use to change the look-and-feel of the Nautilus
windows and the desktop background. To set your preferences for the font and theme
of the Nautilus windows and desktop background, choose Edit → Preferences. Choose
Appearance from the Preferences dialog.

Table 7–8 lists the font and theme settings that you can modify.

TABLE 7–8 Appearance Preferences

Dialog Element Description

Nautilus Themes To change your Nautilus theme, choose a theme from the
list.

Add Theme To add a new Nautilus theme, click on the Add New Theme
button. A dialog is displayed. Use the dialog to find the new
theme.
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7.8.1.3 To Set Preferences for New Windows
To set your preferences for new Nautilus windows, choose Edit → Preferences. Choose
Windows from the Preferences dialog.

Table 7–9 lists the window settings that you can modify.

TABLE 7–9 New Window Preferences

Option Description

Open each file or folder in a
separate window

Select this option to open a new window when you open a
file or folder.

Display side pane Select this option to display a side pane in new windows.

Display toolbar Select this option to display a toolbar in new windows.

Display location bar Select this option to display a location bar in new windows.

Display statusbar Select this option to display a statusbar in new windows.

7.8.1.4 To Set Desktop Background and Trash Preferences
To set your preferences for the Nautilus desktop background and Trash, choose Edit →
Preferences. Choose Desktop & Trash from the Preferences dialog.
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Table 7–10 lists the desktop background and Trash settings that you can modify.

TABLE 7–10 Windows and Desktop Background Preferences

Option Description

Use Nautilus to draw the
desktop

Select this option to use Nautilus to manage your desktop
background. If you do not use Nautilus to manage your
desktop background, you cannot do the following:
� Use the Desktop Background menu.
� Use Nautilus to change the pattern or color of the

desktop background.
� Use the Nautilus Home launcher and Trash launcher.

The Home launcher and Trash launcher are not
displayed on the desktop background.

Use your home folder as the
desktop

Select this option to use your home directory as the desktop
background directory, instead of the default directory. If you
select this option, the contents of your home directory are
displayed as desktop background objects.

Ask before emptying the Trash
or deleting files

Select this option to display a confirmation message before
Trash is emptied, or files are deleted.
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TABLE 7–10 Windows and Desktop Background Preferences (Continued)
Option Description

Include a Delete command that
bypasses Trash

Select this option to add a Delete menu item to the
following menus:
� The Edit menu.
� The popup menu that is displayed when you right-click

on a file, folder, or desktop background object.

When you select an item then choose the Delete menu item,
the item is deleted from your file system immediately.

7.8.1.5 To Set Icon and List Views Preferences
To set your preferences for items in icon views and list views, choose Edit →
Preferences. Choose Icon & List Views from the Preferences dialog.

Table 7–11 lists the settings that you can modify for items in icon views and list views.

TABLE 7–11 Icon and List Views Preferences

Option Description

Activate items with a single click Select this option to perform the default action for an item
when you click on the item. When this option is selected,
and you point to an item, the title of the item is underlined.
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TABLE 7–11 Icon and List Views Preferences (Continued)
Option Description

Activate items with a double
click

Select this option to perform the default action for an item
when you double-click on the item.

Execute files when they are
clicked

Select this option to run an executable file when you choose
the executable file. An executable file is a text file that can
execute, that is, a shell script.

Display files when they are
clicked

Select this option to display the contents of an executable
file when you choose the executable file.

Ask each time Select this option to display a dialog when you choose an
executable file. The dialog asks whether you want to execute
the file or display the file.

Hidden files Select this option to display hidden files in the view pane.
The first character in a hidden file name is a period (.).

Backup files Select this option to display backup files in the view pane.
The last character in a backup file name is a tilde (~).

Special flags in Properties dialog Select this option to show the following special flags in the
Permissions tab on a properties dialog:
� Set User ID
� Set Group ID
� Sticky

Folders before files Select this option to list folders before files when you sort a
folder.

7.8.1.6 To Set Icon Captions Preferences
An icon caption displays the name of a file or folder in an icon view. The icon caption
also includes three additional items of information on the file or folder. The additional
information is displayed after the file name. Normally only one item of information is
visible, but when you zoom in on an icon, more of the information is displayed. You
can modify what additional information is displayed in icon captions.

To set your preferences for icon captions, choose Edit → Preferences. Choose Icon
Captions from the Preferences dialog.
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Select the items of information that you want to display in the icon caption from the
three drop-down list boxes. Select the first item from the first drop-down list box,
select the second item from the second drop-down list box, and so on. The following
table describes the items of information that you can select:

Information Description

Size Choose this option to display the size of the item.

Type Choose this option to display the description of the MIME
type of the item from the File Types and Programs
preference tool.

Date modified Choose this option to display the last modification date of
the item.

Date changed Choose this option to display the last modification date of
the inode of the item. An inode is a data structure that
contains information about individual files in UNIX file
systems. Each file has one inode. An inode contains the
node, type, owner, and location of a file.

Date accessed Choose this option to display the date that the item was last
accessed.

Owner Choose this option to display the owner of the item.
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Information Description

Group Choose this option to display the group to which the owner
of the item belongs.

Permissions Choose this option to display the permissions of the item as
three sets of three characters, for example -rwxrw-r--.

Octal permissions Choose this option to display the permissions of the item in
octal notation, for example 764.

MIME type Choose this option to display the MIME type of the item.

None Choose this option to display no information for the item.

7.8.1.7 To Set Side Pane Preferences
To set your preferences for the side pane, choose Edit → Preferences. Choose Side
Panes from the Preferences dialog.

Table 7–12 lists the side pane settings that you can modify.

TABLE 7–12 Side Pane Preferences

Option Description

History Select this option to display the History tab in the side pane.
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TABLE 7–12 Side Pane Preferences (Continued)
Option Description

Notes Select this option to display the Notes tab in the side pane.

Tree Select this option to display the Tree tab in the side pane.

Show folders only Select this option to display only folders in the Tree tabbed
pane.

7.8.1.8 To Set Performance Preferences
Some Nautilus features can affect the speed with which Nautilus responds to your
requests. You can modify the behavior of some of these features to improve the speed
of Nautilus. For each performance preference, you can select one of the options
described in the following table:

Option Description

Always Performs the action for both local files, and files on other file
systems.

Local File Only Performs the action for local files only.

Never Never performs the action.

To set your speed tradeoff preferences, choose Edit → Preferences. Choose
Performance from the Preferences dialog.
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Table 7–13 lists the speed tradeoff settings that you can modify.

TABLE 7–13 Speed Tradeoff Preferences

Dialog Element Description

Show Text in Icons Select an option to specify when to preview the content of
text files in the icon that represents the file.

Show Number of Items in
Folders

Select an option to specify when to show the number of
items in folders.

Show Thumbnails for Image
Files

Select an option to specify when to show thumbnails of
image files. Nautilus stores the thumbnail files for each
folder in a .thumbnails directory that is one level below
the folder.

Do not make thumbnails for files larger than: Specify the
maximum file size for files for which Nautilus creates a
thumbnail.

Preview Sound Files Select an option to specify when to preview sound files.

7.8.2 Changing Backgrounds
Nautilus includes backgrounds that you can use to change the look-and-feel of the
following screen components:

� Nautilus desktop background
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� Side pane
� View pane
� Panels, except for the Menu Panel

To change the background of a screen component perform the following steps:

1. Choose Edit → Backgrounds and Emblems. The Backgrounds and Emblems dialog
is displayed.

2. To display a list of patterns that you can use on the background, click on the
Patterns button. To display a list of the colors that you can use on the background,
click on the Colors button.

3. To change the background to a pattern, drag the pattern to the screen component.
To change the background to a color, drag the color to the screen component.

4. Click Close to close the dialog.

Alternatively, you can right-click on the background of the side pane and the view
pane, then choose Change Background. The Backgrounds and Emblems dialog is
displayed. To reset the pane background to the default background, right-click on the
background of the pane, then choose Use Default Background.

When you change the background of the side pane or the view pane of a particular
folder, Nautilus remembers the background that you chose. The next time that you
display the folder, the background that you selected is displayed. In other words,
when you change the background of a folder, you customize the folder to display the
background.

7.8.2.1 To Add a Pattern
To add a pattern to the patterns that you can use on your screen components, choose
Edit → Backgrounds and Emblems. Click on the Patterns button, then click on the Add
New Pattern button. A dialog is displayed. Use the dialog to find the new pattern.
Click OK to add the new pattern to the Backgrounds and Emblems dialog.

7.8.2.2 To Add a Color
To add a color to the colors that you can use on your screen components, choose Edit
→ Backgrounds and Emblems. Click on the Colors button, then click on the Add New
Color button. A color selector dialog is displayed. Use the color wheel or the sliders to
choose the color. Click OK to add the new color to the Backgrounds and Emblems
dialog.

7.8.3 To Show and Hide Window Components
You can show and hide Nautilus window components as follows:
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� To hide the side pane, choose View → Side Pane. To display the side pane again,
choose View → Side Pane again.

� To hide the toolbar, choose View → Toolbar. To display the toolbar again, choose
View → Toolbar again.

� To hide the location bar, choose View → Location Bar. To display the location bar
again, choose View → Location Bar again.

� To hide the statusbar, choose View → Statusbar. To display the statusbar again,
choose View → Statusbar again.

� To remove a tab from the side pane, right-click in the side pane. Choose the tab that
you want to remove from the popup menu. To add the tab to the side pane again,
choose the tab from the popup menu again.

7.9 Using Removable Media
Nautilus supports the following removable media:

� Floppy diskette
� CD-ROM
� Iomega Zip disk
� Iomega Jaz disk
� Digital Video Disc (DVD)

When Nautilus detects a new media, an object for the media is added to the desktop
background. You can display the contents of the media in a Nautilus window. You can
drag-and-drop files and folders between removable media.

You can protect media, and format media. You can also create slices on Zip and Jaz
media. A slice is a partition of a disk. An object for each slice appears on the desktop
background.

Note – Removable media works on Solaris 9 only.

7.9.1 To Display Media Contents
You can display media contents in any of the following ways:

� Double-click on the object that represents the media on the desktop background.
� Right-click on the object that represents the media on the desktop background,

then choose Open.
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A Nautilus window displays the contents of the media. To reload the display, click on
the Reload button.

7.9.2 To Display Media Properties
To display the properties of removable media, right-click on the object that represents
the media on the desktop background, then choose Media Properties. A Media
Properties dialog is displayed.

To view general information on the media, select the Information option. The
following table describes the information dialog elements on the Media Properties
dialog:

Dialog Element Description

Alias Displays the name of the media.

Product Id Displays the media type.

Write Protect Indicates whether the media is write-protected.

Password Protect Indicates whether the media is password-protected.

File System Displays the file system in which the media is formatted.

Mount Point Displays the file system location where the device is
attached.

Total Capacity Displays the total amount of storage space on the media.
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To view the amount of used storage space and available storage space on the media,
select the Floating Capacities option. The storage space details are displayed on the
Media Properties dialog.

7.9.3 To Format Media
To format media is to prepare the media for use with a particular file system. When
you format media, you overwrite any existing information on the media. You can
format the following media:

� Floppy diskette
� Zip disk
� Jaz disk

To format media, perform the following steps:

1. Right-click on the object that represents the media on the desktop background,
then choose Format. A Media Format dialog is displayed.

2. Select your format options in the Media Format dialog. The following table
describes the elements on the dialog:

Dialog Element Description

Quick Format Select this option to format without certification, or with
limited certification of certain tracks on the media.
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Dialog Element Description

Long Format Select this option to perform a complete format. For some
devices this might include certification of whole media by
the drive.

File System Type Select the type of file system in which you want to format
the media. Select from the following options:
� PCFS (DOS): Select this option if you want to use the

media on an MS-DOS operating system.
� UFS (UNIX): Select this option if you want to use the

media on a UNIX operating system.
� UDFS (UNIX): Select this option if you want to format

the media in Universal Disk File System (UDFS).
� NEC (DOS): Select this option if you want to format

the media in the NEC file system.

Volume Label Type a name for the media in the text box.

Slice Editor Click on this button if you want to slice a Zip disk or Jaz
disk. This button is only available if you select UFS in the
File System Type drop-down list box. For more
information, see the next section.

3. Click Apply to format the media.

7.9.4 To Create Slices
You can only modify or delete slices as part of the format process. You can slice the
following media:

� Zip disk
� Jaz disk

You cannot create more than seven slices on a media. In the slice creation process, an
additional backup slice is created. The additional slice always takes the numeric
identifier 2. Slice 2 exists for system purposes only. Slice 0 must always use the UFS
file system.

To slice a Zip disk or Jaz disk manually perform the following steps:

1. Right-click on the object that represents the media on the desktop background,
then choose Format.

2. Select your format options in the Media Format dialog. You can only create slices
on media if you select UFS in the File System Type drop-down list box. For more
information on format options, see the previous section.

3. Click on the Slice Editor button. The Slice Editor dialog is displayed.
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4. To create slices automatically, click on the AutoSlice button. A dialog is displayed.
Type the number of slices that you want on the media. Click OK. Slices are created
in approximately equal sizes on the media.

5. To create a slice manually, enter your slice options in the Slice Editor dialog, then
click on the New button. The following table describes the elements on the dialog:

Dialog Element Description

Slices table Displays the slices that are currently on the media.

Delete To delete a slice, select the slice in the Slices table, then
click Delete.

Size Type the size that you require for the slice.

Size units drop-down list box Select the units in which you want to display the size of
slices.

Start To edit a slice, type the numeric identifier for the slice in
this text box.

Prevent Overlaps Select this option to prevent slices overlapping each other.

Tags Select a tag for the slice. The tags in the drop-down list box
are label that describe typical uses of slices.

File System Select the file system for the slice. You can select either
UFS or UDFS file systems. Slice 0 must be in UFS file
system.
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Dialog Element Description

Flags Select the flags that you want to apply to the slice. Select
from the following options:
� Read: Select this option to make the slice readable.
� Write: Select this option to make the slice writable.
� Mountable: Select this option to enable the slice to be

mounted. To mount media is to make the file system of
the media available for access. When you mount
media, the file system of the media is attached as a
subdirectory to your file system.

6. To edit a slice, enter your slice options in the Slice Editor dialog, then click on the
Change button.

7. Click OK to close the Slice Editor dialog.

7.9.5 To Protect Media
You can protect removable media from write operations, or from read operations and
write operations. You can protect media with or without a password. You can protect
the following types of media:

� Jaz disk
� Zip disk

To view the protection of media, right-click on the object that represents the media on
the desktop background, then choose Media Properties.

Nautilus recognizes the protection on media. Nautilus displays emblems on the
desktop background objects that represent the media, to indicate the type of protection
that applies. Nautilus also recognizes if a floppy diskette is write-protected.

To protect media, perform the following steps:

1. Right-click on the object that represents the media on the desktop background,
then choose Protect. A protection dialog is displayed.
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2. Select one of the following options from the dialog:

Dialog Element Description

Disable Protection Select this option to remove protection from the media. If
the media is protected by a password, a Password dialog is
displayed. Type the password in the Password field, then
click OK.

This option is only available if the media is protected.

Write Protect Without
Password

Select this option to protect the media from write
operations, without a password.

Write Protect With Password Select this option to protect the media from write
operations, with a password.

Read-Write Protect With
Password

Select this option to protect the media from read
operations and from write operations, with a password.

3. Click OK.

If you selected the Write Protect With Password option, or the Read-Write Protect
With Password option, the Media Password Entry dialog is displayed. Type the
password for the media, then type the password again to verify the password.
Click OK to set the password.

To change the password for media, you must first disable the protection on the
media, then apply the new password protection to the media.

7.9.6 To Eject Media
To eject media, right-click on the media object on the desktop background, then choose
Eject. If the drive for the media is a motorized drive, the media is ejected from the
drive. If the drive for the media is not a motorized drive, a message is displayed when
you can manually eject the media.
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When you use the Eject command to eject media, the media is automatically
unmounted.
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CHAPTER 8

Using the Desktop Background

By default, the Nautilus file manager manages your desktop background. If you do
not use Nautilus to manage your desktop background, ignore this chapter. This
chapter describes how to use the Nautilus desktop background.

� “8.1 Introduction to the Desktop Background” on page 153
� “8.2 Starting Your Desktop Background” on page 155
� “8.3 Desktop Background Objects” on page 156
� “8.4 Using Trash on the Desktop Background” on page 161
� “8.5 Using the Desktop Background Menu” on page 162
� “8.6 Changing the Pattern or Color of the Desktop Background” on page 163

8.1 Introduction to the Desktop
Background
The desktop background lies behind all of the other components on your visible
desktop. The desktop background is an active component of the user interface. You
can perform the following tasks from your desktop background:

� Start your applications, and open your files and folders.

You can add desktop background objects for convenient access to files, folders, and
applications that you use frequently. For example, you can add an application
launcher to the desktop background. You can create a symbolic link to a file that
you use often, then add this link to your desktop background. You can also store
files and folders on the desktop background.

� Open the Desktop Background menu.

Right-click on the desktop background to open the Desktop Background menu.
You can use the Desktop Background menu to perform actions on the desktop
background.
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� Work with Trash.

You can move objects to Trash and empty your Trash.

� Customize your desktop background.

You can customize the pattern or color of the desktop background.

By default, your desktop background contains three objects. The following figure
shows the desktop background with the default objects:

FIGURE 8–1 Desktop Background with Default Objects

Table 8–1 describes the functions of the default objects on the desktop background.
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TABLE 8–1 Functions of Default Desktop Background Objects

Object Component Function

Home Opens a Nautilus window, and displays
your home location in the view pane.

Start Here Provides an access point to some of the key
features of the GNOME desktop.

Trash Opens a Nautilus window, and displays
your Trash in the view pane.

8.2 Starting Your Desktop Background
If Nautilus does not currently manage your desktop background, the default objects
do not appear on your desktop background. In this case, you might need to restart the
desktop background. If the default objects do not appear on your desktop
background, one of the following might be true:

� Your Nautilus preferences are set so that Nautilus does not manage your desktop
background. To restart the desktop background, you must set your Nautilus
preferences so that Nautilus manages the desktop background.

� You have inadvertently killed a desktop background process. To restart the desktop
background, you must set your Nautilus preferences so that Nautilus manages the
desktop background.

� You have deleted the /.nautilus directory. To restart the desktop background,
you must set up Nautilus so that Nautilus manages the desktop background.
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To set your preferences so that Nautilus manages the desktop background perform the
following steps:

1. Choose Applications → Home Folder. A Nautilus window is displayed.

2. Choose Edit → Preferences. A Preferences dialog is displayed. Choose Desktop &
Trash from the Preferences dialog.

3. Select the Use Nautilus to draw the desktop option.

4. Click Close to close the dialog.

To set up Nautilus so that Nautilus manages the desktop background perform the
following steps:

1. Choose Applications → Home Folder. A Nautilus First Time Setup dialog is
displayed.

2. The Nautilus First Time Setup dialog enables you to customize your Nautilus
environment. Follow the instructions on the Nautilus First Time Setup dialog. On
the GMC to Nautilus Transition screen, select the Use Nautilus to draw the desktop
option.

3. When you reach the Finished screen, click on the Finish button.

8.3 Desktop Background Objects
A desktop background object is an icon on your desktop background that you can use
to open your files, folders, and applications. All objects on your desktop background
reside in the desktop background directory. When you move objects to the desktop
background, the objects are moved to this directory. You can also use your home
directory as the desktop background directory.

By default, your desktop background contains three objects. You can also add objects
to your desktop background to provide convenient access to files, folders, and
applications that you use frequently. For example, you can add a launcher to your
desktop background to enable you to open a particular application that you use often.

Table 8–2 describes the types of object that you can add to your desktop background.
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TABLE 8–2 Types of Desktop Background Objects

Object Type Description

Symbolic link A symbolic link is an object that points to another file or folder.
When you choose a symbolic link from the desktop background,
the file or folder that the symbolic link points to is opened. You
can move or copy a symbolic link to the desktop background.

You can identify symbolic links by the default arrow emblem
that appears on all symbolic links.

Launcher You can add the following types of launcher to the desktop
background:
� Application: Starts a particular application.
� Link: Links to a particular file, folder, or URL.

File You can add files to your desktop background. Files on your
desktop background reside in your desktop background
directory.

Folder You can move folders to your desktop background, and you can
create folders on your desktop background. Folders on your
desktop background reside in your desktop background
directory.

You can modify desktop background objects in the following ways:

� View the properties of the object.
� Rename the object.
� Change the permissions of the object.
� Change the icon that represents the object.
� Resize the icon that represents the object.
� Add an emblem to the object.

The following sections describe how to work with objects on the desktop background.

8.3.1 To Select Objects on the Desktop Background
To select an object on the desktop background, click on the object. To select multiple
objects, press-and-hold Ctrl, then click on the objects that you want to select.

You can also select an area on the desktop background to select all objects within that
area. Click-and-hold on the desktop background, then drag over the area that contains
the objects that you want to select. When you click-and-hold then drag, a grey
rectangle appears to mark the area that you select.

To select multiple areas, press-and-hold Ctrl, then drag over the areas that you want to
select.
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8.3.2 To Open an Object from the Desktop
Background
To open an object from the desktop background, double-click on the object.
Alternatively, right-click on the object, then choose Open. When you open on an
object, the default action for the object executes. For example, if the object is a text file,
the text file opens in a Nautilus window. The default actions for file types are specified
in the File Types and Programs preference tool.

To execute an action other than the default action for an object, right-click on the
object, then choose Open With. Choose an action from the Open With submenu.

The items in the Open With submenu correspond to the contents of the following parts
of the File Types and Programs preference tool:

� Default action drop-down list box in the Edit file type dialog
� Viewer Component drop-down list box in the Edit file type dialog

You can set your preferences in a Nautilus window so that you click once on a file to
execute the default action.

8.3.3 To Add a Launcher to the Desktop
Background
A desktop background launcher can start an application or link to a particular file,
folder, or FTP site.

To add a launcher to your desktop background, perform the following steps:

1. Right-click on the desktop background, then choose New Launcher. A Create
Launcher dialog is displayed.

2. For information on how to enter the properties of the launcher in the Create
Launcher dialog, see Working With Panels.

The command that you enter for the launcher is the command that is executed
when you use the desktop background object. The following table shows some
sample commands and the actions that the commands perform.

Sample Command Action

gedit Starts the gedit application.

gedit /user123/loremipsum.txt Opens the file /user123/loremipsum.txt
in the gedit application.
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Sample Command Action

nautilus /user123/Projects Opens the folder /user123/Projects in a
Nautilus window.

8.3.4 To Add a Symbolic Link to the Desktop
Background
You can create symbolic links on your desktop background to perform the following
actions:

� Open a particular file in a particular application.
� Open a particular folder in a Nautilus window.
� Run a binary file or a script.

To create a symbolic link on the desktop background, perform the following steps:

1. Display the file or folder for which you want to create a symbolic link in a Nautilus
window.

2. Create a symbolic link to the file or folder. To create a symbolic link to a file or
folder, select the file or folder to which you want to create a link. Choose Edit →
Make Link. A link to the file or folder is added to the current folder. You can
identify symbolic links by the default arrow emblem that appears on all symbolic
links. The following figure shows a symbolic link to a file:

3. Drag the symbolic link to the desktop background. The icon for the object is moved
to the desktop background.

8.3.5 Adding a File or Folder to the Desktop
Background
The following sections describe how you can add file objects and folder objects to the
desktop background.
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8.3.5.1 To Move a File or Folder to the Desktop
Background
You can move a file or folder from a Nautilus window to the desktop background. To
move a file or folder to the desktop background, perform the following steps:

1. Open a Nautilus window.

2. In the view pane, display the file or folder that you want to move.

3. Drag the file or folder to the desktop background. The icon for the file or folder is
moved to the desktop background. The file or folder is moved to your desktop
background directory.

Alternatively, select the file or folder, then choose Edit → Cut Files. Right-click on
any desktop background object, then choose Paste Files.

8.3.5.2 To Copy a File or Folder to the Desktop
Background
You can copy a file or folder from a Nautilus window to the desktop background. To
copy a file or folder to the desktop background, perform the following steps:

1. Open a Nautilus window.

2. In the view pane, display the file or folder that you want to move.

3. Press-and-hold Ctrl, then drag the file or folder to the desktop background. An
icon for the file or folder is added to the desktop background. The file or folder is
copied to your desktop background directory.

Alternatively, select the file or folder, then choose Edit → Copy Files. Right-click on
any desktop background object, then choose Paste Files.

8.3.5.3 To Create a Folder Object on the Desktop
Background
To create a folder object, right-click on the desktop background to open the Desktop
Background menu. Choose New Folder. An untitled folder is added to the desktop
background. Type the name of the new folder, then press Return. The folder is
displayed with the new name. The new folder resides in your desktop background
directory.

8.3.6 To Remove an Object from the Desktop
Background
To remove an object from the desktop background right-click on the object, then
choose Move to Trash. Alternatively, drag the object to Trash.
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8.3.7 To Delete an Object from the Desktop
Background
When you delete an object from the desktop background, the object is not moved to
Trash, but is immediately deleted from the desktop background. The Delete menu
item is only available if you select the Include a Delete command that bypasses Trash
option in the Nautilus Preferences dialog.

To delete an object from the desktop background right-click on the object, then choose
Delete.

8.4 Using Trash on the Desktop
Background

You can move the following items to Trash:

� Files
� Folders
� Desktop background objects

When you move an item to Trash, the item is temporarily stored in your /.Trash
folder. If you need to retrieve a file from Trash, you can view Trash and move the file
out of Trash.

When you empty Trash, you delete the items in Trash permanently.

8.4.1 To Display Trash
You can display the contents of Trash in the following ways:

� From the desktop background

Double-click on the Trash object on the desktop background. The contents of Trash
are displayed in a Nautilus window.
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� From a Nautilus window

Choose Go → Trash. The contents of Trash are displayed in the window.

8.4.2 To Empty Trash
You can empty the contents of Trash in the following ways:

� From the desktop background

Right-click on the Trash object, then choose Empty Trash.

� From a Nautilus window

Choose File → Empty Trash.

8.5 Using the Desktop Background
Menu

To open the Desktop Background menu, right-click on a vacant space on the desktop
background. You can use the Desktop Background menu to perform actions on the
desktop background.

Table 8–3 describes the items in the Desktop Background menu.
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TABLE 8–3 Items on the Desktop Background Menu

Menu Item Function

New Window Opens a new Nautilus window that displays your home
location.

New Folder Creates a new folder object on your desktop background.
The folder is created in your desktop background directory.

New Terminal Starts a GNOME Terminal.

New Launcher Creates a launcher on your desktop background. For more
information, see “8.3.3 To Add a Launcher to the Desktop
Background” on page 158.

Scripts Opens a submenu of scripts that you can run.

Clean Up By Name Arranges the objects on the desktop background
alphabetically by name.

Cut Files Deletes the selected file or files from the folder or desktop
background, and places the file or files in buffer.

Copy Files Copies the selected file or files from the folder or desktop
background, and places the file or files in buffer.

Paste Files Puts the file or files in the buffer into the selected folder or
the desktop background.

Disks Enables you to mount diskettes and CD-ROMs.

Change Desktop Background Starts the Background preference tool to enable you to
change the desktop background.

Use Default Background Resets the desktop background to the last pattern that you
chose from the Backgrounds and Emblems dialog. You can
access the Backgrounds and Emblems dialog from Nautilus
windows.

8.6 Changing the Pattern or Color of the
Desktop Background
You can change the pattern or color of the desktop background to suit your
preferences. Nautilus includes background patterns and colors that you can use to
change the look-and-feel of the desktop background.

You can change the pattern or color of the desktop background in any of the following
ways:
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� Drag a pattern or color from another window or dialog to the desktop background.

If your desktop background is a color, you can create a gradient effect from a color
into the desktop background color. A gradient effect is a visual effect where one
color blends gradually into another color. To create a gradient effect on your
desktop background, drag a color to one of the edges of the screen. The color
blends from the edge to which you drag the color, to the opposite edge of the
screen.

Before you drag a color to a screen edge, check if there is an edge panel on the
screen edge. If there is an edge panel on the screen edge, you must hide the panel
before you drag the color.

� Use the Background preference tool.

� Choose a pattern or color for the background from the Backgrounds and Emblems
dialog. To change the pattern or color of the desktop background, perform the
following steps:

1. Open a Nautilus window.

2. Choose Edit → Backgrounds and Emblems. The Backgrounds and Emblems
dialog is displayed.

3. To display a list of patterns that you can use, click on the Patterns button. To
display a list of the colors that you can use, click on the Colors button.

4. To change the desktop background to a pattern, drag the pattern to the desktop
background. To change the desktop background to a color, drag the color to the
desktop background.

5. Click Close to close the dialog.
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PART II Customizing Your GNOME Desktop

You can customize many of the characteristics of your desktop. The customization of
each aspect of the desktop is controlled by a dedicated software tool that is called a
desktop preference tool. For convenience, the preference tools are grouped under the
following headings:

� Basic
� Accessibility
� Advanced

You can open your preference tools in either of the following ways:

� Choose Applications → Desktop Preferences. Choose the tool that you require from
the submenus.

� Double-click on the Start Here object on the desktop background. A Nautilus
window opens at the Start Here location. Double-click on the Preferences object in
the Nautilus window to display your preference tools. Double-click on the tool that
you require.

This section describes how to configure the desktop in the following chapters.

� Using the Basic Preference Tools

Read this chapter to find out how to customize your desktop background. This
chapter also contains information on how to configure your keyboard settings and
your mouse settings. This chapter also describes how to configure shortcut keys,
how to set your sound preferences, and how to configure your network proxy. This
chapter also contains information on how to choose a theme and fonts for your
desktop, and how to customize your application menubars and toolbars. This
chapter also describes how to customize window focus behavior.

� Using the Advanced Preference Tools

This chapter describes how to configure file types, your preferred applications, and
your panels. This chapter also contains information on how to customize your
sessions and startup programs.

� Using the Accessibility Preference Tools
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Read this chapter to find out how to use the accessibility features of the desktop.
This chapter describes how to use the keyboard accessibility features.
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CHAPTER 9

Using the Basic Preference Tools

The basic preference tools enable you to customize your desktop background. You can
use the basic preference tools to configure your keyboard settings and your mouse
settings. You can use the basic preference tools to configure shortcut keys, to set your
sound preferences, and to configure your network proxy. You can also use the basic
preference tools to choose a theme and fonts for your desktop, and to customize your
application menubars and toolbars. You can also customize window focus behavior.

This chapter describes how to use the basic preference tools to customize your
desktop.

� “9.1 Opening a Basic Preference Tool” on page 167
� “9.2 Customizing the Desktop Background” on page 168
� “9.3 Choosing Default Fonts” on page 170
� “9.4 Configuring Keyboard Settings” on page 171
� “9.5 Customizing Keyboard Shortcuts” on page 173
� “9.6 Customizing Menus and Toolbars” on page 174
� “9.7 Configuring Mouse Settings” on page 176
� “9.8 Configuring Network Proxy Settings” on page 179
� “9.9 Setting Sound Preferences” on page 180
� “9.10 Setting Themes in the Desktop” on page 182
� “9.11 Customizing Window Focus” on page 183

9.1 Opening a Basic Preference Tool
You can open one of the basic preference tools in either of the following ways:

� From the Desktop Preferences menu

Choose Applications → Desktop Preferences. Choose the preference tool that you
require from the submenu. The dialog for the tool is displayed.

� From the Start Here location
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Open a Nautilus window, then choose Go → Start Here. Alternatively, double-click
on the Start Here object on the desktop background. The Start Here location is
displayed. Double-click on the Preferences object in the Nautilus window to
display your preference tools.

Double-click on the tool that you require. The dialog for the tool is displayed.

9.2 Customizing the Desktop
Background
The desktop background is the part of the desktop where there are no interface
graphical items, such as panels and windows. The desktop background is always
beneath the other interface items.

You can customize the desktop background in the following ways:

� Select an image to display on the desktop background. The image is superimposed
on the desktop background color. The desktop background color is visible if you
select a transparent image, or if the image does not cover the entire desktop
background.
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� Select a color for the desktop background. You can select a solid color, or create a
gradient effect with two colors. A gradient effect is a visual effect where one color
blends gradually into another color.

You can also change the appearance of your desktop background from within the
Nautilus file manager.

FIGURE 9–1 Desktop Background Preference Tool

Table 9–1 lists the background settings that you can configure.

TABLE 9–1 Settings for Desktop Background

Element Function

Select picture Choose an image to display on the desktop background. To choose
an image, click on the Picture button. An image selector dialog is
displayed. Choose an image from the dialog. Alternatively, to
choose an image from another directory, click Browse. When you
choose an image, click OK.

Picture Options To specify how to display the image, select one of the following
options:
� Wallpaper: Repeats the image to cover the desktop background.
� Centered: Displays the image in the middle of the desktop

background.
� Scaled: Enlarges the image until the image meets the screen

edges, and maintains the relative dimensions of the image.
� Stretched: Enlarges the image to cover the desktop background,

and does not maintain the relative dimensions of the image.
� No Picture: Displays no image.
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TABLE 9–1 Settings for Desktop Background (Continued)
Element Function

Background Style To specify a color scheme, use the options in the Background Style
drop-down list box, and the color selector buttons.

You can specify a color scheme in one of the following ways:
� Choose Solid color from the Background Style drop-down list

box to specify a single color for the desktop background.
To choose the color that you require, click on the Color button.
The Pick a Color dialog is displayed. Choose a color, then click
OK.

� Choose Horizontal gradient from the Background Style
drop-down list box. This option creates a gradient effect from
the left screen edge to the right screen edge.
Click on the Left Color button to display the Pick a Color dialog.
Choose the color that you want to appear at the left edge.
Click on the Right Color button. Choose the color that you want
to appear at the right edge.

� Choose Vertical gradient from the Background Style drop-down
list box. This creates a gradient effect from the top screen edge
to the bottom screen edge.
Click on the Top Color button to display the Pick a Color dialog.
Choose the color that you want to appear at the top edge.
Click on the Bottom Color button. Choose the color that you
want to appear at the bottom edge.

9.3 Choosing Default Fonts
Use the Font preference tool to select the fonts to use on in your applications and on
the desktop background.

FIGURE 9–2 Font Preference Tool

Table 9–2 lists the font settings that you can configure.
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TABLE 9–2 Settings for Fonts

Option Function

Application font Click on the font selector button to select a font to use in your
applications.

Desktop font Click on the font selector button to select a font to use on your
desktop background only.

9.4 Configuring Keyboard Settings
Use the Keyboard preference tool to select the autorepeat settings for your keyboard,
and to configure the sound events that are associated with the keyboard.

You can customize the settings for the Keyboard preference tool in the following
functional areas:

� Keyboard
� Sound

9.4.1 Keyboard Settings
Use the Keyboard tabbed section to set general keyboard preferences. To start the
Keyboard accessibility preference tool, that is, AccessX, click on the Accessibility
button.

FIGURE 9–3 Keyboard Tabbed Section in Keyboard Preference Tool

Table 9–3 lists the keyboard settings that you can configure.
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TABLE 9–3 Settings for Keyboard

Option Function

Keyboard repeats when
key is held down

Select this option to enable keyboard repeat. If keyboard repeat is
enabled, when you press-and-hold a key, the action associated
with the key is performed repeatedly. For example, if you
press-and-hold a character key, the character is typed repeatedly.

Delay Select the delay from the time you press a key to the time that the
action repeats.

Speed Select the speed at which the action is repeated.

Blinks in text boxes and
fields

Select this option to enable the cursor to blink in fields and text
boxes.

Speed Use the slider to specify the speed at which the cursor blinks in
fields and text boxes.

9.4.2 Sound Settings
Use the Sound tabbed section to set your preferences for keyboard sound.

FIGURE 9–4 Sound Tabbed Section in Keyboard Preference Tool

Some applications play a bell sound to indicate a keyboard input error. Use the
options in the Sound tabbed section to configure the bell sound. Table 9–4 lists the
keyboard sound settings that you can configure.
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TABLE 9–4 Settings for Keyboard Sound

Option Function

Off Select this option to disable the keyboard bell.

Beep Select this option to enable the keyboard bell.

9.5 Customizing Keyboard Shortcuts
A keyboard shortcut is a key or combination of keys that provides an alternative to
standard ways of performing an action.

Use the Keyboard Shortcuts preference tool to display the default keyboard shortcuts.
You can customize the default keyboard shortcuts to your requirements. You can also
create hot keys. Hot keys are keyboard shortcuts that start applications.

FIGURE 9–5 Keyboard Shortcuts Preference Tool

Table 9–5 lists the keyboard shortcut settings that you can customize.
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TABLE 9–5 Default Settings for Keyboard Shortcuts

Option Function

Text editing shortcuts Select one of the following settings:
� Default: Use this setting for standard shortcut keys.
� Emacs: Use this setting for Emacs shortcut keys.

Desktop shortcuts This table lists actions and the shortcut keys that are
associated with each action.

To change the shortcut keys for an action, click on the
action to select the action. Press the keys that you want to
associate with the action.

To disable the shortcut keys for an action, double-click on
the action, then press Back Space.

Custom Shortcuts To add a hot key, perform the following steps:
1. Click Add. A Custom Binding dialog is displayed.

Enter the command to associate with the hot key in the
New Command field. Alternatively, to browse for the
command, click on the Browse button. When you have
selected the command, click OK. The command is
added to the Custom bindings section of the Desktop
shortcuts table.

2. Click in the Shortcut column of the command in the
Custom bindings section of the Desktop shortcuts table.
Press the key or key combination that you want to
associate with the command.

To edit a hot key, select the hot key in the Custom bindings
section of the Desktop shortcuts table, then click Edit. Edit
the command in the Custom Binding dialog.

To delete a hot key, select the hot key in the Custom
bindings section of the Desktop shortcuts table, then click
Remove.

9.6 Customizing Menus and Toolbars
You can use the Menus & Toolbars preference tool to customize the appearance of
menus, menubars, and toolbars for GNOME-compliant applications.
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FIGURE 9–6 Menus and Toolbars Preference Tool

Table 9–6 lists the menu and toolbar settings that you can customize for
GNOME-compliant applications.

TABLE 9–6 Settings for Customizing Applications

Option Function

Button Labels Choose one of the following options to specify what to display on
the toolbars in your GNOME-compliant applications:
� Text Below Icons: Select this option to display toolbars with text

as well as an icon on each button.
� Priority Text Beside Icons: Select this option to display toolbars

with an icon only on each button, and with text on the most
important buttons.

� Icons Only: Select this option to display toolbars with an icon
only on each button.

� Text Only: Select this option to display toolbars with text only
on each button.

Toolbars can be detached
and moved around

Select this option if you want to move toolbars from application
windows to any location on the desktop. If you select this option,
handles are displayed on the left side of the toolbars in your
applications. To move a toolbar, click-and-hold on the handle, then
drag the toolbar to the new location.

Show icons in menus Select this option to display an icon beside each item in a menu.
Some menu items do not have an icon.
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9.7 Configuring Mouse Settings
Use the Mouse preference tool to configure your mouse for right-hand use or for
left-hand use. You can also specify the speed and sensitivity of mouse movement.

You can customize the settings for the Mouse preference tool in the following
functional areas:

� Buttons
� Cursors
� Motion

9.7.1 Buttons Settings
Use the Buttons tabbed section to specify whether the mouse buttons are configured
for left-hand use. You can also specify the delay between clicks for a double-click.

FIGURE 9–7 Buttons Tabbed Section in the Mouse Preference Tool

Table 9–7 lists the mouse button settings that you can configure.
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TABLE 9–7 Settings for Mouse Buttons

Option Function

Left-handed mouse Select this option to configure your mouse for left-hand use.
When you configure your mouse for left-hand use, the functions
of the left mouse button and the right mouse button are swapped.

Delay Use the slider to specify the amount of time that can pass between
clicks when you double-click. If the interval between the first and
second clicks exceeds the time that is specified here, the action is
not interpreted as a double-click.

9.7.2 Pointer Settings
Use the Cursors tabbed section to set your mouse pointer preferences.

FIGURE 9–8 Cursors Tabbed Section in the Mouse Preference Tool

Table 9–8 lists the mouse pointer settings that you can configure:

TABLE 9–8 Settings for Mouse Pointers

Option Function

Cursor Theme Select the mouse pointer theme that you
require from the list box.
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TABLE 9–8 Settings for Mouse Pointers (Continued)
Option Function

Show position of cursor when the Control key
is pressed

Select this option to enable a mouse pointer
animation when you press and release Ctrl.
This feature can assist you to locate the mouse
pointer.

9.7.3 Motion Settings
Use the Motion tabbed section to set your preferences for mouse movement.

FIGURE 9–9 Motion Tabbed Section in the Mouse Preference Tool

Table 9–9 lists the mouse motion settings that you can configure:

TABLE 9–9 Settings for Mouse Motion

Setting Function

Acceleration Use the slider to specify the speed at which your mouse pointer
moves on your screen when you move your mouse.

Sensitivity Use the slider to specify how sensitive your mouse pointer is to
movements of your mouse.

Threshold Use the slider to specify the distance that you must move an item
before the move action is interpreted as a drag-and-drop action.
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9.8 Configuring Network Proxy Settings
The Network Proxy preference tool enables you to configure how your system
connects to networks. You can configure the desktop to connect to a proxy server, and
specify the details of the proxy server. A proxy server is a server that intercepts
requests to another server, and fulfills the request itself, if it can. You can enter the
Domain Name Service (DNS) name or the Internet Protocol (IP) address of the proxy
server. A DNS name is a unique alphabetic identifier for a computer on a network. An
IP address is a unique numeric identifier for a computer on a network.

FIGURE 9–10 Network Proxy Preference Tool

Table 9–10 lists the network proxy settings that you can configure.

TABLE 9–10 Network Proxy Settings

Option Function

Use HTTP Proxy Select this option to use a proxy server for the HTTP service.

Location Enter the DNS name, or the IP address of the proxy server
to use when you request a HTTP service.

Port Enter the port number of the HTTP service on the proxy
server.

Proxy requires username and
password

Select this option if the proxy server requires a username
and password.

Username Enter your username for the proxy server.

Password Enter your password for the proxy server.
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9.9 Setting Sound Preferences
The Sound preference tool enables you to control when the GNOME sound server
starts. You can also specify which sounds to play when particular events occur.

You can customize the settings for the Sound preference tool in the following
functional areas:

� General
� Sound Events

9.9.1 General Settings
Use the General tabbed section of the Sound preference tool to specify when to launch
the GNOME sound server. You can also enable sound event functions.

FIGURE 9–11 General Tabbed Section in the Sound Preference Tool

Table 9–11 lists the general sound settings that you can configure.

TABLE 9–11 Settings for Sound

Option Function

Enable sound server
startup

Select this option to start the GNOME sound server when you
start a GNOME session. When the sound server is active, the
desktop can play sounds.
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TABLE 9–11 Settings for Sound (Continued)
Option Function

Sounds for events Select this option to play sounds when particular events occur in
your desktop. You can select this option only if the Enable sound
server startup option is selected.

9.9.2 Sound Event Settings
Use the Sound Events tabbed section of the Sound preference tool to associate
particular sounds with particular events.

Note – You must select the Enable sound server startup option, and the Sounds for
events option before you can access the Sound Events tabbed section.

FIGURE 9–12 Sound Events Tabbed Section in the Sound Preference Tool

Table 9–12 lists the sound events settings that you can configure.
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TABLE 9–12 Settings for Sound Events

Option Function

Sounds table Use the Sounds table to associate particular sounds with
particular events.

The Event column displays a hierarchical list of events that can
occur. To expand a category of events, click on the right arrow
beside a category of events.

The File to play column lists the sound file that plays when the
event occurs.

Play Click on this button to play the sound file that is associated with
the selected event.

Sound file drop-down
combination box, Browse

To associate a sound with an event, select the event in the Sounds
table. Enter the name of the sound file that you want to associate
with the selected event in the drop-down combination box.
Alternatively, click Browse to display a Select sound file dialog.
Use the dialog to specify the sound file that you want to associate
with the selected event.

Note – You can only associate sound files in .wav format with
events.

9.10 Setting Themes in the Desktop
Use the Theme preference tool to select a theme for your desktop.

Your desktop theme specifies the visual appearance of your panels, applets, and
windows. The desktop theme also specifies the appearance of GNOME-compliant
application interface items. For example, the theme affects the appearance of buttons,
scrollbars, check boxes, and so on.

The desktop theme is not the only theme that determines the appearance of your
desktop. For example, Nautilus includes themes that you can use to change the
look-and-feel of the Nautilus windows and the desktop background.

You can choose from the list of available themes, or you can install new themes.
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FIGURE 9–13 Theme Preference Tool

Table 9–13 lists the theme settings that you can configure.

TABLE 9–13 Settings for Themes

Option Function

Installed Themes Select the theme that you require from the list box.

Install new theme You can add a theme to the list of available themes. The
new theme must be an archive file that is tarred and
zipped. That is, the new theme must be a .tar.gz file.

To add a theme to the list of available themes, click on
the Install new theme button. A dialog is displayed.
Enter the name of the theme archive file in the
drop-down combination box. Alternatively, to browse
for the file, click on the Browse button. When you have
selected the file, click OK.

You can find many GTK themes on the Internet.

Go to theme folder Click on this button to open a file manager window on
the default theme folder.

9.11 Customizing Window Focus
Use the Window Focus preference tool to customize window focus behavior for your
desktop.
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FIGURE 9–14 Window Focus Preference Tool

Table 9–14 lists the window focus settings that you can customize.

TABLE 9–14 Settings for Window Focus

Option Function

Click to give focus Select this option to give focus to a window when you click on the
window. The window retains focus until you click on another
window.

Point to give focus Select this option to give focus to a window when you point to the
window. The window retains focus until you point to another
window.

Raise window on focus Select this option if you want your windows to be raised when the
windows receive focus.
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CHAPTER 10

Using the Advanced Preference Tools

The Advanced preference tools enable you to customize the behavior and appearance
of your applications, panels, and other user interface items. You can use the Advanced
preference tools to configure file types, your default applications, and your panels.
You can also use the Advanced tools to customize your sessions and startup programs.
This chapter describes how to use the Advanced tools to customize your desktop.

� “10.1 Opening an Advanced Preference Tool” on page 185
� “10.2 Configuring a CD Database” on page 186
� “10.3 Configuring File Types and Programs” on page 188
� “10.4 Customizing Your Panels” on page 191
� “10.5 Choosing Your Preferred Applications” on page 192
� “10.6 Configuring Sessions” on page 195

10.1 Opening an Advanced Preference
Tool
You can open an Advanced preference tool in either of the following ways:

� From the Desktop Preferences menu

Choose Applications → Desktop Preferences → Advanced. Choose the tool that
you require from the submenu. The dialog for the tool is displayed.

� From the Start Here location

Open a Nautilus window, then choose Go → Start Here. Alternatively, double-click
on the Start Here object on the desktop background. The Start Here location is
displayed. Double-click on the Preferences object in the Nautilus window, then
double-click on the Advanced folder. The Advanced preference tools are displayed.
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Double-click on the tool that you require. The dialog for the tool is displayed.

10.2 Configuring a CD Database
The CD Database preference tool enables you to configure a CD database that your
system can query. A CD database contains information about CDs, such as the name of
the artist, the title, and the track list. When an application plays a CD, the application
can query the CD database about the CD, then display the information.
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FIGURE 10–1 CD Database Preference Tool

Table 10–1 describes the elements on the CD Database preference tool.

TABLE 10–1 Settings for CD Database

Element Description

Send no info Select this option if you do not want to send any information to the
CD database server.

Send real info Select this option to send your name and hostname information to
the CD database server.

Send other info Select this option to send another name and hostname to the CD
database server. Enter the name in the Name field. Enter the
hostname in the Hostname field.

FreeDB round robin
server

FreeDB is a CD database. The FreeDB round robin server is a
load-sharing configuration of FreeDB servers. Select this option to
access the FreeDB CD database from this server.

Other FreeDB server Select this option to access the FreeDB CD database from another
server. Select the server that you require from the server table.

Update server list Click on this button to update the list of available FreeDB servers in
the server table.
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TABLE 10–1 Settings for CD Database (Continued)
Element Description

Other server Select this option to use another CD database. Enter the name of the
server on which the database resides in the Hostname field. Enter
the port number on which you can access the database in the Port
field.

10.3 Configuring File Types and
Programs
Use the File Types and Programs preference tool to specify how files of various types
are created, displayed, and edited. For example, you can specify that if a file is a plain
text file, the file is launched in a text editor.

Nautilus and other GNOME applications check the contents of a file to determine the
type of a file. If the first lines do not determine the type of the file, then the application
checks the file extension.

FIGURE 10–2 File Types and Programs Preference Tool

Table 10–2 describes the elements on the File Types and Programs preference tool.
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TABLE 10–2 Elements on File Types and Programs Preference Tool

Element Description

Table To view the contents of a category of file types, click on the right
arrow next to the category name. The category expands, and
displays a description of each file type, and the file extension that is
associated with the file type.

To select a file type that you want to work with, click on the file
type.

Add file type Click on this button to add a file type. For more information, see
“10.3.1 To Add a File Type” on page 189.

Add service Click on this button to add a service. For more information, see
“10.3.2 To Add a Service” on page 190.

Edit To edit a file type, a service, or a file type category, select the item
that you want to edit, then click Edit.

Delete To delete a file type or a service, select the item that you want to
delete, then click Delete.

10.3.1 To Add a File Type
To add a file type, perform the following steps:

1. Choose Applications → Desktop Preferences → Advanced → File Types and
Programs to start the File Types and Programs preference tool.

2. Click on the Add file type button. The Add file type dialog is displayed.

3. Enter the properties of the file type in the dialog. The following table describes the
dialog elements on the Add file type dialog:

Option Function

No Icon Choose an icon to represent the file type. To choose an
icon, click on the No Icon button. An icon selector
dialog is displayed. Choose an icon from the dialog.
Alternatively, to choose an icon from another directory,
click Browse. When you choose an icon, click OK.

Description Type a description of the file type.

MIME Type Enter the MIME type for this type of file.
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Option Function

Category Enter the category to which you want the file type to
belong in the File Types and Programs preference tool.
Click on the Choose to choose a category from the
Choose a file category dialog.

Filename Extensions Enter the filename extensions to associate with the file
type. Enter a filename extension in the field on the left
side, then click on the Add button. To delete a filename
extension, select the filename extension in the field on
the right side, then click on the Remove button.

Viewer Component Information to be supplied in a future release.

Default action Information to be supplied in a future release.

Program to Run If you do not select the Use category defaults option,
specify a program to associate with the file type. Enter
the command to start the program in this field.
Alternatively, to choose a command that you entered
previously, click the down arrow button, then choose
the command to run.

You can also use the Browse button to choose a
command to run.

Run in Terminal Select this option to run the program in a terminal
window. Choose this option for a program that does not
create a window in which to run.

4. Click OK.

10.3.2 To Add a Service
To add a service, perform the following steps:

1. Choose Applications → Desktop Preferences → Advanced → File Types and
Programs to start the File Types and Programs preference tool.

2. Click on the Add service button. The Add service dialog is displayed.

3. Enter the properties of the service in the dialog. The following table describes the
dialog elements on the Add service dialog:

Option Function

Description Type a description of the service.

Protocol Enter the protocol for the service.
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Option Function

Program to run Information to be supplied in a future release.

Program Specify the program to associate with the file type.
Enter the command to start the program in this
field. Alternatively, to choose a command that you
entered previously, click the down arrow button,
then choose the command to run.

You can also use the Browse button to choose a
command to run.

Run in Terminal Select this option to run the program in a terminal
window. Choose this option for a program that does
not create a window in which to run.

4. Click OK.

10.4 Customizing Your Panels
The Panel preference tool enables you to configure the behavior of panels. Any
changes that you make with the Panel preference tool affect all of your panels.

FIGURE 10–3 Panel Preference Tool

TABLE 10–3 Settings for Panels

Setting Function

Close drawer when launcher is clicked Select this option if you want a drawer on a
panel to close when you choose a launcher in
the drawer.

Animation Select this option if you want your panels to
show and to hide in an animated style.
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TABLE 10–3 Settings for Panels (Continued)
Setting Function

Animation speed Select the speed of the panel animation from
the drop-down list box.

10.5 Choosing Your Preferred
Applications
Use the Preferred Applications preference tool to specify the applications that you
want the desktop to use when the desktop starts an application for you. For example,
you can specify Xterm as your preferred terminal application. When you open the
Desktop Background menu then choose New Terminal, Xterm starts.

You can customize the settings for the Preferred Applications preference tool in the
following functional areas.

� Web Browser
� Text Editor
� Terminal

10.5.1 Web Browser Settings
Use the Web Browser tabbed section to configure your preferred web browser. The
preferred web browser opens when you click on a URL. For example, the preferred
web browser opens when you select a URL in an application, or when you select a
URL launcher on the desktop background.

FIGURE 10–4 Web Browser Tabbed Section in the Preferred Applications Preference Tool

Table 10–4 lists the preferred web browser settings that you can configure.

192 GNOME 2.0 on Solaris User Guide • August 27, 2002 (Beta)



TABLE 10–4 Settings for Preferred Web Browser

Option Function

Select a Web Browser Select this option if you want to use a standard web browser. Use
the drop-down combination box to select your preferred web
browser.

Custom Web Browser Select this option if you want to use a custom web browser.

Command Enter the command to execute to start the custom web browser. To
enable the browser to display a URL that you click on, include
“%s” after the command.

Start in Terminal Select this option to run the command in a terminal window. Select
this option for a browser that does not create a window in which to
run.

10.5.2 Text Editor Settings
Use the Text Editor tabbed section to configure your preferred text editor.

FIGURE 10–5 Text Editor Tabbed Section in the Preferred Applications Preference Tool

Table 10–5 lists the preferred text editor settings that you can configure.

TABLE 10–5 Settings for Preferred Text Editor

Option Function

Select an Editor Select this option if you want to use a standard text editor. Use the
drop-down combination box to specify your preferred text editor.
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TABLE 10–5 Settings for Preferred Text Editor (Continued)
Option Function

Custom Editor Select this option if you want to use a custom text editor. A Custom
Editor Properties dialog is displayed.
� Name: Type the name of the custom text editor.
� Command: Enter the command to execute to start the custom

text editor.
� This application can open multiple files: Select this option if the

default text editor can open multiple files.
� This application needs to be run in a shell: Select this option to

run the command in a terminal window. Select this option for
an editor that does not create a window in which to run.

Properties Click on this button to display the Custom Editor Properties dialog.
Use the dialog to modify the properties of the custom text editor.

Use this editor to open
text files in the file
manager

Select this option if you want the file manager to start the custom
text editor to display text files.

10.5.3 Terminal Settings
Use the Terminal tabbed section to configure your preferred terminal.

FIGURE 10–6 Terminal Tabbed Section in the Preferred Applications Preference Tool

Table 10–6 lists the preferred terminal settings that you can configure.

TABLE 10–6 Settings for Preferred Terminal

Option Function

Select a Terminal Select this option if you want to use a standard terminal. Use the
drop-down combination box to specify your preferred terminal.
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TABLE 10–6 Settings for Preferred Terminal (Continued)
Option Function

Custom Terminal Select this option if you want to use a custom terminal.

Command Enter the command to execute to start the custom terminal.

Exec Flag Enter the exec option to use with the command.

10.6 Configuring Sessions
The Sessions preference tool enables you to manage your sessions. You can set session
preferences, and specify which applications to start when you start a session. You can
configure sessions to save the state of applications on your desktop, and to restore the
state when you start another session. You can also use this preference tool to manage
multiple GNOME sessions.

You can customize the settings for sessions and startup applications in the following
functional areas:

� Session Options
� Current Session
� Startup Programs

10.6.1 Setting Session Options
Use the Session Options tabbed section to manage multiple sessions, and to set
preferences for the current session.
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FIGURE 10–7 Session Options Tabbed Section in the Sessions Preference Tool

Table 10–7 lists the session options settings that you can configure.

TABLE 10–7 Settings for Session Options

Option Function

Show splash screen on
login

Select this option to display a splash screen when you start a
session.

Prompt on logout Select this option to display a confirmation dialog when you end a
session.

Automatically save
changes to session

Select this option if you want the session manager to save the
current state of your session. The session manager saves the
session-managed applications that are open, and the settings
associated with the session-managed applications. The next time
that you start a session, the applications start automatically, with
the saved settings.

If you do not select this option, when you end you session the
Logout Confirmation dialog displays a Save current setup option.

Sessions Use this area of the dialog to manage multiple sessions on the
desktop, as follows:
� To create a new session, click on the Add button. The Add a

new session dialog is displayed. Use this dialog to specify a
name for your session.

� To change the name of a session, select the session in the Choose
Current Session table. Click on the Edit button. The Edit session
name dialog is displayed. Type a new name for your session.

� To delete a session, select the session in the Choose Current
Session table. Click on the Delete button.
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10.6.2 Setting Session Properties
Use the Current Session tabbed section to specify startup order values, and to choose
restart styles for the session-managed applications in your current session.

FIGURE 10–8 Current Session Tabbed Section in the Sessions Preference Tool

Table 10–8 lists the session properties that you can configure.

TABLE 10–8 Session Properties

Option Function

Order The Order setting specifies the order in which the session manager
starts session-managed startup applications. The session manager
starts applications with lower order values first. The default value is
50.

To specify the startup order of an application, select the application
in the table. Use the Order spin box to specify the startup order
value.
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TABLE 10–8 Session Properties (Continued)
Option Function

Style The Style setting determines the restart style of an application. To
select a restart style for an application, select the application in the
table, then choose one of the following styles:
� Normal

Starts automatically when you start a GNOME session. Use the
kill command to terminate applications with this restart style
during a session.

� Restart
Restarts automatically whenever you close or terminate the
application. Choose this style for an application if the
application must run continuously during your session. To
terminate an application with this restart style, select the
application in the table, then click on the Remove button.

� Trash
Does not start when you start a GNOME session.

� Settings
Starts automatically when you start a session. Applications with
this style usually have a low startup order, and store your
configuration settings for GNOME and session-managed
applications.

Remove Click on the Remove button to delete the selected application from
the list. The application is removed from the session manager, and
closed. Application that you delete are not started the next time that
you start a session.

Apply Click on the Apply button to apply changes to the startup order and
the restart style.

10.6.3 Configuring Startup Applications
Use the Startup Programs tabbed section of the Sessions preference tool to specify
non-session-managed startup applications. Startup applications are applications that
start automatically when you start a session. You specify the commands that run the
non-session-managed applications in the Startup Programs tabbed section. The
commands execute automatically when you log in.

You can also start session-managed applications automatically. For more information,
“10.6.1 Setting Session Options” on page 195.
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FIGURE 10–9 Startup Programs Tabbed Section in the Sessions Preference Tool

Table 10–9 lists the startup applications settings that you can configure.

TABLE 10–9 Settings for Startup Programs

Option Function

Additional startup
programs

Use this table to manage non-session-managed startup applications
as follows:
� To add a startup application, click on the Add button. The Add

Startup Program dialog is displayed. Enter the command to
start the application in the Startup Command field.
Alternatively, you can use the Browse button to choose a
command to run. You can also use the Browse button to choose
a file to append to the command line. For example, you can
enter emacs on the command line, then choose a file to edit.
If you specify more than one startup application, use the
Priority spin box to specify the startup order of the each
application. The startup order is the order in which you want
the startup applications to start.

� To edit a startup application, select the startup application, then
click on the Edit button. The Edit Startup Program dialog is
displayed. Use the dialog to modify the command and the
startup order for the startup application.

� To delete a startup application, select the startup application,
then click on the Delete button.
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CHAPTER 11

Using the Accessibility Preference
Tools

This chapter describes how to use the Accessibility preference tools to customize your
desktop.

� “11.1 Opening an Accessibility Tool” on page 201
� “11.2 Configuring Keyboard Accessibility Options” on page 202

11.1 Opening an Accessibility Tool
You can open an Accessibility preference tool in the following ways:

� From the Desktop Preferences menu

Choose Applications → Desktop Preferences → Accessibility. Choose the preference
tool that you require from the submenu. The dialog for the tool is displayed.

� From the Start Here location

Open a Nautilus window, then choose Go → Start Here. Alternatively, double-click
on the Start Here object on the desktop background. The Start Here location is
displayed. Double-click on the Preferences object in the Nautilus window, then
double-click on the Accessibility folder.
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11.2 Configuring Keyboard Accessibility
Options
Use the Keyboard accessibility preference tool to set the keyboard accessibility
preferences. The Keyboard accessibility preference tool is also known as AccessX.
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FIGURE 11–1 Keyboard Accessibility Preference Tool

Table 11–1 lists the keyboard accessibility settings that you can modify.

TABLE 11–1 Keyboard Accessibility Settings

Option Function

Enable keyboard
accessibility

Select this option to enable keyboard accessibility features. When you
select this option, the other options in the preference tool become
available.

Beep when
enabling/disabling
keyboard accessibility
features

Select this option for an audible indication when a feature such as
sticky keys or slow keys is activated, or deactivated.

Disable if unused for Select this option to enable you to deactivate the keyboard
accessibility preferences. Specify the period of time that must pass
before timeout occurs.
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TABLE 11–1 Keyboard Accessibility Settings (Continued)
Option Function

Enable Mouse Keys Select this option to make the numeric keypad emulate mouse
actions. You can specify the following mouse key settings:
� Maximum pointer speed: Use this setting to specify the maximum

speed that the pointer moves across the screen.
� Time to accelerate to maximum speed: Use this setting to specify

the duration of the acceleration time of the pointer.
� Start moving this long after keypress: Use this setting to specify

the period of time that must pass after a keypress before the
pointer moves.

Enable Slow Keys Select this option to control the period of time that you must
press-and-hold a key before acceptance. You can specify the following
slow keys settings:
� Only accept keypress after: Use this setting to specify the period

of time that you must press-and-hold a key before acceptance.
� Beep when key is pressed: Select this option for an audible

indication of a keypress.
� Beep when key is accepted: Select this option for an audible

indication of key acceptance.
� Beep when key is rejected: Select this option for an audible

indication of key rejection.

Enable Bounce Keys Select this option to accept a key input and to control the key repeat
characteristics of the keyboard. You can specify the following bounce
keys settings:
� Ignore keypresses within: Use this setting to specify the interval to

wait after the first keypress before the automatic repeat of a
pressed key.

� Beep when key is rejected: Select this option for an audible
indication of key rejection.

Enable Sticky Keys Select this option to perform multiple simultaneous keypress
operations by pressing the keys in sequence. You can specify the
following sticky keys settings:
� Beep when modifier is pressed: Select this option for an audible

indication when you press a modifier key.
� Turn off Sticky Keys when two keys pressed simultaneously:

Select this option to specify that when you press two keys
simultaneously, you can no longer press keys in sequence to
perform multiple simultaneous keypresses.

Toggle and Repeat
Keys

Select this option for an audible indication of a toggle keypress. You
hear one beep when a toggle key is turned on. You hear two beeps
when a toggle key is turned off.
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TABLE 11–1 Keyboard Accessibility Settings (Continued)
Option Function

Testing Area The test area is an interactive interface so you can see how the
keyboard settings affect the display as you type. Type text in the test
area to test the effect of your settings.

Import CDE AccessX
file

Click on this button to import a CDE AccessX configuration file.
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Glossary

applet An applet is a small, interactive application that resides within a panel,
for example the CD Player. Each applet has a simple user interface that
you can operate with the mouse or keyboard.

desktop background
object

An icon on your desktop background that you can use to open your
files, folders, and applications. You can use desktop background
objects to provide convenient access to files, folders, and applications
that you use frequently.

DNS name A unique alphabetic identifier for a computer on a network.

drawer A drawer is a sliding extension to a panel that you can open or close
from a drawer icon.

format To format media is to prepare the media for use with a particular file
system. When you format media, you overwrite any existing
information on the media.

GNOME-compliant
application

An application that uses the standard GNOME programming libraries
is called a GNOME-compliant application. For example, Nautilus and
gedit are GNOME-compliant applications.

hot key Hot keys are keyboard shortcuts that start applications.

inode A data structure that contains information about individual files in
UNIX file systems. Each file has one inode. An inode contains the
node, type, owner, and location of a file.

IP address A unique numeric identifier for a computer on a network.

keyboard shortcut A keyboard shortcut is a key or combination of keys that provides an
alternative to standard ways of performing an action.

launcher A launcher starts a particular application, executes a command, or
opens a file. A launcher can reside in a panel or in a menu.

menubar A menubar is a bar at the top of an application window that contains
the menus for the application.
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mount To mount is to make a file system available for access. When you
mount a file system, the file system is attached as a subdirectory to
your file system.

pane A pane is a subdivision of a window. For example, the Nautilus
window contains a side pane and a view pane.

preference tool A dedicated software tool that controls a particular part of the
behavior of the desktop.

shortcut keys Shortcut keys are keystrokes that provide a quick way to perform an
action.

slice A partition of a disk. You can create slices on your Zip and Jaz media.
An object for each slice appears on the desktop background.

stacking order The stacking order is the order in which windows are stacked on top
of each other on your screen.

statusbar A statusbar is a bar at the bottom of a window that provides
information about the current state of what you are viewing in the
window.

toolbar A toolbar is a bar that contains buttons for the most commonly-used
commands in an application. Typically, a toolbar appears under a
menubar.

Uniform Resource
Locator

A Uniform Resource Locator (URL) is the address of a particular
location on the Web.

view A Nautilus component that enables you to display a folder in a
particular way. For example, Nautilus contains an icon view which
enables you to display the contents of a folder as icons. Nautilus also
contains a list view which enables you to display the contents of a
folder as a list.

viewer component A Nautilus component that enables you to display a particular type of
file in the view pane. A viewer component might add menu items that
are relevant to the file type to the Nautilus menus. A viewer
component might also enable you to use the Nautilus zoom buttons to
change the size of the item in the view pane.

workspace A workspace is a discrete area on the desktop in which you can work.
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Index

A
access keys, 24
accessibility

bounce keys, 204
configuring keyboard, 202
mouse keys, 204
slow keys, 204
sticky keys, 204
toggle keys, 204

AccessX
See preference tools, Keyboard Accessibility

applets
adding to panel, 64
getting help, 43
introduction, 63
modifying preferences, 64
overview, 31
selecting, 64
Window List, 91
Workspace Switcher, 93

applications
help, 43
overview, 42

B
backgrounds

adding colors, 144
adding patterns, 144
changing desktop background, 163
changing screen component, 143
customizing desktop background, 168

basic skills
keyboard skills, 21
mouse skills, 17
using windows and dialogs, 25

bottom edge panel
default contents, 55
introduction, 54

C
closing windows, 96

D
default applications

See preferred applications
desktop background

adding a file or folder to, 159
adding launchers, 158
adding symbolic links, 159
changing pattern or color, 163
copying a file or folder to, 160
creating a folder on, 160
customizing, 168
deleting an object from, 161
desktop background objects, 156
introduction, 153
moving a file or folder to, 160
opening objects, 158
overview, 39
preferences, 136
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desktop background (Continued)
removing an object from, 160
selecting objects, 157
starting, 155
using Desktop Background menu, 162
using Trash, 161

Desktop Background menu
description, 162
illustration, 162

desktop background objects
deleting, 161
files and folders, 159
launchers, 158
opening, 158
removing, 160
selecting, 157
symbolic links, 159

desktop components, introducing, 27
desktop preference tools

See preference tools
drawers

adding objects to, 71
adding to panel, 71
closing, 70
modifying properties, 71
opening, 70

E
emblems

See file manager
events, associating sounds with, 180

F
file manager

assigning actions to files, 131
bookmarks, 116
changing backgrounds, 143
changing permissions, 122
copying files and folders, 119
creating folders, 120
creating symbolic link, 121
customizing, 133
deleting files or folders, 121
displaying folders, 109

file manager (Continued)
drag-and-drop, 117
duplicating files and folders, 120
emblems

adding, 124
introduction, 106

executing default actions for files, 112
executing non-default actions for files, 112
executing other actions for files, 112
FTP sites

See FTP sites
Home location

See Home location
icon view

arranging files in, 128
illustration, 102
preferences, 138

icons
caption preferences, 139
introduction, 106
modifying, 125
stretching, 129

introduction, 101
list view

illustration, 127
preferences, 138

managing files and folders, 117
modifying actions, 131
modifying appearance of files and

folders, 124
moving files and folders, 119
navigating, 108
navigating history list, 114
opening files, 111
overview, 37
preferences

desktop background, 136
icon and list views, 138
icon captions, 139
introduction, 133
new windows, 136
performance, 142
side pane, 141
theme, 135
Trash, 136
views, 133

renaming folders, 121
running scripts, 124

210 GNOME 2.0 on Solaris User Guide • August 27, 2002 (Beta)



file manager (Continued)
selecting files and folders, 118
side pane

introduction, 105
preferences, 141

Start Here location
See Start Here location

tabbed panes
History, 115
introduction, 106
Notes, 123
Tree, 109

Trash
See Trash

view pane
See view pane

viewing files in view pane, 111
views

choosing, 128
introduction, 126
modifying behavior, 129
preferences, 138

window components, showing and
hiding, 144

windows, 102
zooming in and out, 126

file types
adding, 189
configuring, 188
editing, 189

focus, giving to a window, 94
fonts

applications, 170
desktop background, 170

FTP sites, accessing, 114

G
GNOME Menu

adding to panel, 82
introduction, 81
opening, 81

Gtk+ themes
See themes

H
help

applets, 43
applications, 43
desktop topics, 43
how to find, 43
starting help system, 43

Home location, displaying, 108
hot keys, configuring, 173

K
keyboard

basic skills, 21
configuring accessibility options, 202
configuring general preferences, 171
configuring sound preferences, 172

keyboard shortcuts, configuring, 173

L
language, starting session in different, 46
launcher popup menu

description, 76
illustration, 76

launchers
adding to panel, 65, 77
modifying properties, 69

Lock button, 47, 73
locking screen, 47, 73
Log Out button, 73
logging in, 46
logging out, 51

M
maximizing windows, 95
Menu Panel

default contents, 54
introduction, 53
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Menu Panel (Continued)
window list icon, 54, 93

menus
Actions menu, 78
adding, 82
adding launchers to, 83
adding to panel, 69, 77
Applications menu, 77
copying launchers to, 83
customizing, 82
deleting menu items, 84
Desktop Background menu, 162
editing menu items, 84
editing properties, 83
features, 76
GNOME Menu

See GNOME Menu
in applications, customizing

appearance, 174
introduction, 75
launcher popup menu, 76
overview, 33
Window Menu, 90

Metacity window manager
See window manager

minimizing, windows, 95
mouse

action terminology, 19
actions, 18
basic skills, 17
button conventions, 17
configuring, 176
pointers, 19

moving windows, 96

N
Nautilus desktop background

See desktop background
Nautilus file manager

See file manager
network proxy, setting preferences, 179
notes, adding to folders, 123

P
panel object popup menu, illustration, 62
panel objects

adding, 61
applets

See applets
drawers

See drawers
interacting with, 61
launchers

See launchers
Lock button, 73
Log Out button, 73
menus, 69
modifying properties, 62
moving, 62
removing, 63

panels
adding new, 55
bottom edge panel

See bottom edge panel
changing background, 60
customizing behavior and appearance, 191
deleting, 60
hiding, 57
interacting with, 56
introduction, 53
managing, 55
Menu Panel

See Menu Panel
modifying properties, 57
moving, 56
overview, 30
panel objects

See panel objects
panes, resizing, 25
partitions

See slices
pointers

See mouse pointers
preference tools

Background, 168
CD Database, 186
File Types and Programs, 188
Font, 170
Keyboard, 171
Keyboard Accessibility, 202
Keyboard Shortcuts, 173
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preference tools (Continued)
Menus & Toolbars, 174
Mouse, 176
Network Proxy, 179
overview, 41
Panel, 191
Preferred Applications, 192
Sessions, 50, 195
Sound, 180
Theme, 182
Window Focus, 183

preferences, file manager
See file manager preferences

preferred applications
terminal, 194
text editor, 193
web browser, 192

proxy, setting preferences, 179

R
removable media

creating slices, 148
displaying contents, 145
displaying properties, 146
ejecting, 151
formatting, 147
introduction, 145
protecting, 150

resizing windows, 96
restoring, windows, 95
Run Program dialog, using, 78

S
screensaver, configuring, 47
screenshots, taking, 80
scripts, running from file manager, 124
services

adding, 190
editing, 189

sessions
browsing applications, 50
configuring screensaver, 47
different language, starting in, 46
ending, 51

sessions (Continued)
locking screen, 47
logging in, 46
logging out, 51
login behavior, 50
logout behavior, 50
managing, 50
preferences, 195
saving settings, 51
setting options, 195
setting properties, 197
starting, 45
using startup applications, 50

shading windows, 97
shortcut keys

application, 23
configuring, 173
desktop, 21
panel, 23
window, 22

side pane
See file manager

slices, removable media, 148
sound

associating events with sounds, 180
configuring keyboard preferences, 172
setting preferences, 180

sound server, 180
Start Here location

overview, 40
using, 113

startup applications
customizing, 195
non-session-managed, 50, 198
session-managed, 50, 196, 197

startup programs
See startup applications

T
tabbed panes

See file manager
tables, using, 25
terminal, preferred application, 194
text editor, preferred application, 193
themes, setting desktop themes, 182
toolbars, customizing appearance, 174
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Trash
displaying, 122, 161
emptying, 123, 162
introduction, 122
moving files or folders to, 121
preferences, 136
using on desktop background, 161

Tree tabbed pane, using, 109

V
view pane

introduction, 104
viewing files in, 111

viewer components, 104, 111, 126

W
web browser, preferred application, 192
Window List applet

grouping buttons, 92
introduction, 91
window status information, 92

window lists
Menu Panel, 93
Window List applet, 91

window manager, customizing, 183
windows

applets and menus for working with, 90
closing, 96
frame control elements, 88
frames, 88
giving focus to, 94
introduction, 85
manipulating, 94
maximizing, 95
minimizing, 95
moving, 96
moving to another workspace, 97
overview, 34
putting on all workspaces, 97
resizing, 96
resizing panes, 25
restoring, 95
shading, 97
themes, 88

windows (Continued)
types of, 86
using tables, 25
Window List applet

See Window List applet
window managers, 86
Window Menu, 90

workspaces
adding, 98
deleting, 98
introduction, 85
manipulating, 98
moving windows to, 97
naming, 98
overview, 36
specifying number of, 37
switching between, 36, 98
Workspace Switcher applet, 93

X
XScreenSaver

See screensaver
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