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PART I

A Tour of the GNOME Desktop

A desktop environment desktop environment is a windows-based environment for
users. The desktop environment is the sum of all the parts of your working
environment. This section introduces the core components in the GNOME Desktop
environment.

The GNOME Desktop is very configurable, therefore this section covers the main
functional possibilities of the GNOME Desktop features. If you want to find out how
to implement the various configuration possibilities that are mentioned in this section,
see Customizing Your GNOME Desktop.

The chapters in this section are as follows:

� Basic Skills

Read this chapter to find out about mouse usage, shortcut keys, basic window
skills, and basic dialog skills.

� Overview of the GNOME Desktop

Read this chapter for an introduction to the major components and functions of the
desktop environment. If you do not read anything else in this manual, read this
chapter.

� GNOME Desktop Sessions

Read this chapter for information about how to start, manage, and end GNOME
Desktop sessions.

� Working With Panels

Read this chapter to find out more about using panels. Panels are a key component
of the GNOME Desktop. This chapter tells you how to use the different parts of
your panels, and how to invoke the available functions of the desktop environment
using panels.

� Working With Menus

Read this chapter to find out more about using menus.
� Working With Windows
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Read this chapter to find out more about using windows. This chapter describes
basic windows functions such as moving and resizing. This chapter also describes
the controls that you use with windows.

� Nautilus File Manager

Read this chapter to find out more about the Nautilus file manager. This chapter
describes how to use the file manager to work with your file system. This chapter
also describes how to customize the file manager.

� Using Your Desktop

Read this chapter to find out more about using the desktop. The desktop is the part
of the desktop environment where there are no interface graphical items, such as
panels and windows. This chapter describes how to use the desktop to start
applications, and open your files and folders. The chapter also describes how to
use Trash from the desktop, how to use the Desktop menu, and how to customize
the desktop.
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CHAPTER 1

Basic Skills

This chapter introduces you to the basic skills that you need to work with the GNOME
Desktop.

� “Mouse Skills” on page 17
� “Keyboard Skills” on page 21
� “Using Windows” on page 25

Mouse Skills
Even if you are very familiar with mouse devices, you should still familiarize yourself
with the button conventions and action terminology used in this manual. This section
also describes the mouse pointers.

Mouse Button Conventions
All the instructions in this manual are for the following types of mouse devices:

� Devices that are configured for right-hand users.

� Three button devices. If you have a two-button mouse device, then you press the
two buttons simultaneously to simulate the effect of a middle mouse button.

The mouse button conventions used in this manual are as follows:
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Mouse Button Definition

Left mouse button The button on the left side of a mouse device configured
for normal right-hand use.

Middle mouse button The middle button of a mouse device configured for
normal right-hand use.

Right mouse button The button on the right side of a mouse device configured
for normal right-hand use.

To reverse the handedness of your mouse device, open the , then select the options
that you require. If you do reverse the handedness of your mouse device, then you
must reverse the mouse button conventions used in this manual.

Mouse Actions
The following table describes the actions that you can perform with the mouse:

Mouse Button Usage

Left mouse button Use to perform the following actions:
� Select text.
� Choose items.
� Drag items.

Middle mouse button Use to perform the following actions:
� Paste text.
� Move items.

Right mouse button Opens a menu for the selected object, if a menu applies.

For example, if you want to copy text then perform the following steps:

1. Select the text with the left mouse button.
2. Move the mouse pointer to the location where you want to copy the text.
3. Click on the middle mouse button.

You can also right-click on the desktop to open the Desktop menu.
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Mouse Action Terminology
The conventions used in this manual to describe actions that you take with the mouse
are as follows:

Action Definition

Click Press and release the left mouse button, without moving
the mouse.

Click-and-hold Press and do not release the left mouse button.

Left-click Same as click. Left-click clarifies the action when there
might be confusion with right-click.

Middle-click Press and release the middle mouse button, without
moving the mouse.

Right-click Press and release the right mouse button, without moving
the mouse.

Double-click Press and release the left mouse button twice in rapid
succession without moving the mouse.

Drag Click-and-hold a mouse button, then move an object. For
example, you can drag a window or an icon. The left and
middle mouse buttons can perform drag actions.

Drag-and-drop Click-and-hold a mouse button, then move an object. For
example, you can drag-and-drop a window or an icon.
Release the mouse button to place the object in a new
location.

Grab Point to an item that you can move, and click-and-hold on
the mouse button. For example, you can grab the titlebar of
a window, then drag the window to a new location.

Mouse Pointers
As you use the mouse, the appearance of the mouse pointer can change. The
appearance of the pointer can provide feedback about a particular operation, location,
or state. The following table lists and describes some of the mouse pointers.
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Pointer Associated Action Description

Point to an item, choose a menu
item

Normal pointer. The pointer that
appears during normal use of the
mouse.

Drag-and-drop Move pointer. Indicates that when
you drop the object, the object is
moved from the old location to the
new location.

Drag-and-drop Copy pointer. Indicates that when
you drop the object, a copy of the
object is created where you drop
the object.

Drag-and-drop Symbolic link pointer. Indicates
that when you drop the object, a
symbolic link to the object is created
where you drop the object. A
symbolic link is a special type of
file that points to another file or
folder.

Drag-and-drop Ask pointer. Indicates that when
you drop the object, a menu opens.
You can choose to move or copy
the object, or to create a symbolic
link to the object.

Drag-and-drop Not available pointer. Indicates that
you cannot drop the object at the
current location.

Move panel object Move panel object pointer.
Indicates that you have selected a
panel object to move.

Resize window horizontally Horizontal resize pointer. Indicates
that you have selected a vertical
window border to resize the
window horizontally.

Resize window vertically Vertical resize pointer. Indicates
that you have selected a horizontal
window border to resize the
window vertically.
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Pointer Associated Action Description

Resize window horizontally and
vertically

Corner resize pointer. Indicates that
you have selected a corner of a
window border to resize the
window horizontally and vertically.

Resize window pane or resize table
column

Window pane or table column
resize pointer. Indicates that you
have selected a column in a table to
resize.

Keyboard Skills
For almost every task that you can perform with the mouse, you can use the keyboard
to perform the same task. Shortcut keys are keys that provide you with a quick way to
perform a task.

You can use shortcut keys to perform desktop environment tasks and to work with
interface items such as panels and windows. You can also use shortcut keys in
applications. To customize your shortcut keys, use the Keyboard Shortcuts preference
tool.

You can also modify your desktop environment preferences to use keyboard
accessibility features.

The following sections describe the shortcut keys that you can use.

Desktop Environment Shortcut Keys
Desktop environment shortcut keys enable you to use the keyboard to perform
desktop environment tasks. The following table lists some desktop environment
shortcut keys:

Default Shortcut Keys Function

Alt + F1 Opens the Main Menu.

Alt + F2 Displays the Run Application dialog.

Print Screen Takes a screenshot.

Alt + Print Screen Takes a screenshot of the window that has focus.
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Default Shortcut Keys Function

Ctrl + Alt + right arrow Switches to the workspace to the right of the current
workspace.

Ctrl + Alt + left arrow Switches to the workspace to the left of the current
workspace.

Ctrl + Alt + up arrow Switches to the workspace above the current workspace.

Ctrl + Alt + down arrow Switches to the workspace below the current workspace.

Ctrl + Alt + d Minimizes all windows, and gives focus to the desktop.

F1 Starts the online help browser, and displays appropriate
online help.

Window Shortcut Keys
Window shortcut keys enable you to use the keyboard to perform window tasks. The
following table lists some window shortcut keys:

Default Shortcut Keys Function

Alt + Tab Switches between windows. When you use these shortcut
keys, a list of windows that you can select is displayed.
Release the keys to select a window.

Alt + Esc Switches between windows in reverse order. Release the
keys to select a window.

F10 Opens the first menu on the left side of the menubar.

Alt + spacebar Opens the Window Menu.

Arrow keys Moves the focus between items in a menu.

Return Chooses a menu item.

Esc Closes an open menu.

Ctrl + Alt + right arrow Switches to the workspace to the right of the current
workspace.

Ctrl + Alt + left arrow Switches to the workspace to the left of the current
workspace.

Ctrl + Alt + up arrow Switches to the workspace above the current workspace.

Ctrl + Alt + down arrow Switches to the workspace below the current workspace.

Ctrl + Alt + d Minimizes all windows, and gives focus to the desktop.
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Panel Shortcut Keys
Panel shortcut keys enable you to use the keyboard to perform panel tasks. The
following table lists panel shortcut keys:

Default Shortcut Keys Function

Ctrl + Alt + Tab Switches the focus between the panels and the desktop. When
you use these shortcut keys, a list of items that you can select is
displayed. Release the keys to select an item.

Ctrl + Alt + Esc Switches the focus between the panels and the desktop. Release
the keys to select an item.

Ctrl + F10 Opens the popup menu for the selected panel.

Tab Switches the focus between objects on a panel.

Return Chooses the selected panel object or menu item.

Shift + F10 Opens the popup menu for the selected panel object.

Arrow keys Moves the focus between items in a menu. Moves the focus
between interface items in an applet also.

Esc Closes an open menu.

F10 Opens the Applications menu from the Menu Bar, if the Menu
Bar is in a panel.

Application Shortcut Keys
Application shortcut keys enable you to perform application tasks. You can use
shortcut keys to perform application tasks more quickly than if you use a mouse. The
following table lists some application shortcut keys:

Shortcut Keys Command

Ctrl + N New

Ctrl + X Cut

Ctrl + C Copy

Ctrl + V Paste

Ctrl + Z Undo

Ctrl + S Save
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Shortcut Keys Command

Ctrl + Q Quit

Access Keys
A menubar is a bar at the top of a window that contains the menus for the application.
An access key is an underlined letter in a menubar, menu, or dialog that you can use to
perform an action. On a menubar, the access key for each menu is underlined.

To open a menu, press Alt, then press the access key. In the menu, the access key for
each menu item is underlined. To choose a menu item, press the access key for the
menu item. The following table shows example access keys from the Text Editor
application:

Access Keys Function

Alt + F Opens the File menu.

N Chooses the New item on the File menu.

You can also use access keys to access elements in a dialog. In a dialog, one letter in
most dialog elements is underlined. To access a particular dialog element, press Alt,
then press the access key. The following table shows an example access key from the
Preferences dialog in the Text Editor application:

Access Key Function

Alt + U Gives focus to the Use default theme font check box.

You can use also other keys to navigate within a window or dialog.

Key Function

Tab Moves the focus from element to element in a window or
dialog.
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Key Function

Arrow keys Use the arrow keys to perform the following actions:
� In a menubar, move the focus from one menu to the

next menu. In an open menu, move the focus from one
menu item to the next menu item.

� Move the focus from one option to the next option to
make your selection, for example, within a group of
radio buttons in a dialog.

� Change the value that a spin box displays.

Using Windows
This section provides information on how to use windows.

To Resize Panes
Some windows contain more than one pane. A pane is a subdivision of a window. For
example, the Nautilus file manager window contains a side pane and a view pane. A
window that contains panes has a resize handle on the edge between the panes. To
resize the pane, grab the resize handle, then drag the edge to the size you require.

Using Tables
Some windows contain information that is organized in a table. This section describes
how to work with tables.

To change the width of a column, drag one of the vertical edges of the column.

In some tables, you can sort the information by a particular column. To sort
information in a table, click on the heading on top of the column by which you want
to sort the information. An up arrow is displayed in the column heading by which the
table is sorted. The following figure shows the up arrow.

To reverse the sort order, click on the column heading again. The up arrow changes to
a down arrow. The down arrow indicates that the information in the column is sorted
in reverse order.
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In some tables, you can select multiple items. The following table describes how to
select items in tables.

Task Action

Select an item Click on the item.

Select a group of contiguous
items

Press-and-hold Shift. Click on the first item in the group,
then click on the last item in the group.

Select multiple items Press-and-hold Ctrl. Click on the items that you want to
select.
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CHAPTER 2

Overview of the GNOME Desktop

This chapter introduces you to the features and main components of the GNOME
Desktop. Before you start to use the desktop environment read this chapter to
familiarize yourself with the various features, and how the main components work.
The desktop environment is very configurable, so this chapter describes the typical
default configuration, covering the following topics.

� “Introducing Desktop Environment Components” on page 27
� “Panels” on page 30
� “Menus” on page 33
� “Windows” on page 34
� “Workspaces” on page 36
� “Nautilus File Manager” on page 37
� “Desktop and Desktop Objects” on page 39
� “Start Here Location” on page 40
� “Desktop Environment Preferences” on page 41
� “Applications” on page 42
� “To Find Out More” on page 43

Introducing Desktop Environment
Components
When you start a desktop environment session for the first time, you should see a
default startup screen, with panels, windows, and various icons. Figure 2–1 shows a
typical desktop environment.
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FIGURE 2–1 A Typical Desktop Environment

The major components of the desktop environment are as follows:

� Panels

Panels are areas in your desktop environment from which you can access all of
your system applications and menus. Panels are very configurable. A particularly
important panel in Figure 2–1 is the top edge panel. The top edge panel includes
the Menu Bar. The Menu Bar contains two special menus, as follows:

� Applications menu: Contains all applications and configuration tools. This
menu also includes the file manager and the help browser. To start the file
manager, choose Home Folder from the Applications menu.

� Actions menu: Contains various commands that perform desktop environment
functions, for example Search for Files and Log Out.
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Click on the icon at the extreme right of the top edge panel to display a list of all
open windows.

� Menus

You can access all desktop environment functions through menus. The top edge
panel contains menus, so you can use a combination of menus and panels to
perform your tasks. You can use the Applications menu and the Actions menu to
access almost all of the standard applications, commands, and configuration
options.

You can also access almost all of the standard applications, commands, and
configuration options from the Main Menu. You can access the items in the
Applications and Actions menus from the Main Menu. You can add the Main
Menu as a button to your panels.

� Windows

You can display many windows at the same time. You can run different
applications in each window. The window manager provides frames and buttons
for windows. The window manager enables you to perform standard actions such
as move, close, and resize windows.

� Workspaces

You can subdivide your desktop environment into separate workspaces. A
workspace is a discrete area in which you can work. You can specify the number of
workspaces in your desktop environment. You can switch to a different workspace,
but you can only display one workspace at a time.

� Nautilus file manager

The Nautilus file manager provides an integrated access point to your files and
applications. You can display the contents of your files within a file manager
window, or open the files in the appropriate application from the file manager. You
can use the file manager to manage your files and folders.

� Desktop

The desktop is behind all of the other components on the desktop. The desktop is
an active component of the user interface. You can place objects on the desktop to
quickly access your files and directories, or to start applications that you use often.
You can also right-click on the desktop to open a menu.

� Start Here location

The Start Here location provides an access point to some of the key features of the
desktop environment. You can access your GNOME applications and configuration
tools from the Start Here location. You can also access programs that enable you to
configure your system as a server, and to choose other system settings.

� Desktop environment preferences

The desktop environment contains dedicated preference tools. Each tool controls a
particular part of the behavior of the desktop environment. To start a preference
tool, choose Applications → Desktop Preferences. Choose the item that you want to
configure from the submenus.
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The most powerful features of the desktop environment are the high degree of
configurability and the multiple ways that you can perform tasks.

The desktop environment provides interoperability of the desktop environment
components. Usually, you can perform the same action in several different ways. For
example, you can start applications from panels, from menus, or from the desktop.

Your system administrator can make configuration changes to suit your needs, so that
the desktop environment might not be exactly the same as described in this chapter.
Nevertheless, this chapter provides a useful quick guide to how to work with the
desktop environment.

Panels
You can add or delete panels at any time. When you start a session for the first time,
the desktop environment usually contains a panel at the top edge of the screen, and a
panel at the bottom edge of the screen.

You can perform the following actions with panels:

� Create panels.
� Delete panels.
� Hide panels.
� Add objects to panels.
� Manipulate panel objects.

To Create Panels
To add a panel, right-click on a vacant space on any panel, then choose New Panel.
The new panel is added to your desktop environment. The new panel contains no
objects. You can customize the new panel to suit your preferences. You can add objects
to the panel to fit your own requirements. You can also change the background of the
panel. You can create as many panels as you want.

To Delete Panels
To delete a panel, right-click on the panel then choose Delete This Panel.

To Hide Panels
Panels can have hide buttons at each end of the panel. You click on the hide buttons to
hide or show the panel.
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To Add Objects to Panels
A panel can hold several types of objects. The panel in Figure 2–2 contains each type
of panel object.

FIGURE 2–2 A Panel With Various Panel Objects

You can add any of the following objects to all types of panels:

� Applets

Applets are small, interactive applications that reside within a panel, for example
CD Player in Figure 2–2. Each applet has a simple user interface that you can
operate with the mouse or keyboard. The following applets appear in your panels
by default:

� Menu Bar: Provides access to the Applications menu and the Actions menu. You
can use the menus to access your applications, preference tools, and other
desktop environment tasks.

� Window List: Displays a button for each window that is open. You can click on
a window list button to minimize and restore windows. By default, Window
List appears in the edge panel at the bottom of the screen.

� Workspace Switcher: Displays a visual representation of your workspaces. You
can use Workspace Switcher to switch between workspaces. By default,
Workspace Switcher appears in the edge panel at the bottom of the screen.

To add an applet to a panel, right-click on a vacant space on the panel, then choose
Add to Panel. Choose the applet that you require from one of the following
submenus:

� Accessories
� Amusements
� Internet
� Multimedia
� Utility

� Launchers
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A launcher starts a particular application, executes a command, or opens a file. The
calculator icon in Figure 2–2 is a launcher for the Calculator application. A launcher
can reside in a panel or in a menu. Click on the launcher to perform the action that
is associated with the launcher.

You can create your own launchers for applications. For example, you can create a
launcher for a word processor application that you use frequently, and place the
launcher in a panel for convenient access. To add a new launcher to a panel,
right-click on a vacant space on the panel, then choose Add to Panel → Launcher.

Alternatively, to add a launcher from a menu, right-click on a vacant space on the
panel, then choose Add to Panel → Launcher from menu. Choose the launcher to
add from the submenus.

� Buttons

You can add buttons to your panels to provide quick access to common functions.
You can add the following buttons to your panels:

� Force Quit: Use this button to terminate applications that do not respond to
your commands.

� Lock: Click on this button to lock your screen. The lock icon in Figure 2–2 is the
Lock button.

� Log Out: Click on this button to end your session
� Run: Click on this button to open the Run Application dialog, from which you

can run commands.
� Screenshot: Click on this button to take a screenshot of the screen.
� Search: Click on this button to open the Search Tool application, from which

you can search for files.
� Show Desktop: Click on this button to minimize all windows and show the

desktop.

To add the buttons to a panel, right-click on a vacant space on the panel, then
choose Add to Panel → Actions. You can then choose the button you require.

� Menus

You can access all desktop environment functions through menus. The default
panels contain menus, so you can use a combination of menus and panels to
perform your tasks. To open a menu from a panel, click on the icon that represents
the menu. To open a menu from the Menu Bar, click on the text that represents the
menu.

Menus that you add to your panels are represented by an icon with an arrow. The
arrow indicates that the icon represents a menu. The icon in Figure 2–2 is the icon
that is displayed when you add the Desktop Preferences menu to a panel.

You can add the Main Menu to any of your panels. To add the Main Menu to a
panel, right-click on a vacant space on the panel, then choose Add to Panel → Main
Menu.
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You can also add the Menu Bar to any of your panels. To add the Menu Bar to a
panel, right-click on a vacant space on the panel, then choose Add to Panel →
Menu Bar.

� Drawers

Drawers are sliding extensions to a panel that you can open or close from a drawer
icon, as shown in Figure 2–2. Drawers can help you to organize your work when
you run a lot of applications simultaneously. You can place all the same functional
elements in a drawer that you can put in any other type of panel.

To add a drawer to a panel, right-click on a vacant space on the panel, then choose
Add to Panel → Drawer.

To open a drawer click on the drawer. To close a drawer click on the drawer again.

To Manipulate Panel Objects
You can manipulate panel objects in the following ways:

� Move objects within a panel, or to another panel.

You can move any object to another location in the panel. You can also move an
object from one panel to another panel. Use the middle mouse button to drag the
panel object to the new location.

� Copy menu items to a panel.

Drag the item from the menu to the panel. Alternatively, if the menu item is a
launcher right-click on the menu item, then choose Add this launcher to panel.

Menus
You can access all desktop environment functions through menus. Your default panels
contain menus, so you can use a combination of menus and panels to perform your
tasks. The top edge panel contains the Menu Bar. The Menu Bar contains Applications
and Actions menus.

You can use the Applications menu and the Actions menu to access almost all of the
standard applications, commands, and configuration options. You can also access the
items in the Applications and Actions menus from the Main Menu.

To add a Menu Bar to a panel, right-click on the panel then choose Add to Panel →
Menu Bar.

To add a Main Menu to a panel, right-click on the panel then choose Add to Panel →
Main Menu. The Main Menu is represented by a stylized footprint, as follows:
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Click on the Main Menu button on a panel to open the Main Menu.

You can add as many additional menus as you want to any of your panels. To open a
menu that you add to a panel, click on the menu icon on the panel. You can perform
other actions on your menus, such as copy menu items to panels.

Windows
You can display many windows at the same time in your desktop environment. Each
window has a frame. The window frame contains active control elements that you can
use to work with the window.

Types of Windows
The desktop environment features the following types of window:

� Application windows

When you run an application, a frame usually borders the window. The top edge
of the application window contains a titlebar. The titlebar contains buttons that you
can use to work with the window. The buttons in an application window frame
enable you to perform actions such as open the Window Menu, or close the
window. The Window Menu provides commands that you can perform on the
window.

� Dialog windows

Dialog windows are associated with interactive processes. A dialog window
consists of the window frame, and a single interactive pane that provides
information and controls for the user. This manual refers to the interactive part of a
dialog window as a dialog. The frame of a dialog window contains buttons that
enable you to open the Window Menu, or to close the dialog window.
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To Manipulate Windows
You use the frame of an application window or dialog window to perform various
actions with the window. Most of the control elements are located on the top edge of
the window frame. Figure 2–3 shows the top edge of a frame for a typical application
window.

FIGURE 2–3 Top Edge of Frame for a Typical Application Window

The active control elements of the window frame are as follows:

Control Element Description

Window Menu button Click on the Window Menu button to open the
Window Menu.

Titlebar You can use the titlebar to move and shade the
window.

Minimize button Click on the Minimize button to minimize the
window.

Maximize button You can use the Maximize button to maximize and
restore the window.

To maximize a window click on the Maximize button.
To restore the window click on the Maximize button
again.

Close Window button Click on the Close Window button to close the
window.

Border Right-click on the border to open the Window Menu.

To change the size of windows grab the border of the window, but not the titlebar.
Drag the border until the window is the size that you require.
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To Give Focus to a Window
A window that has focus can receive input from the mouse and the keyboard. Only
one window can have focus at a time. The window that has focus has a different
appearance than other windows.

You can use the following elements to give focus to a window:

Element Action

Mouse Click on the window, if the window is visible.

Shortcut keys Use shortcut keys to switch between the windows that are
open. To give focus to a window, release the keys. The default
shortcut keys to switch between windows are Alt + Tab.

Window List Click on the button that represents the window in Window
List.

Workspace Switcher Click on the window that you want to give focus to in the
Workspace Switcher display.

Workspaces
You can display many windows at the same time in your desktop environment. Your
windows are displayed in subdivisions of your desktop environment that are called
workspaces. A workspace is a discrete area in which you can work.

Every workspace contains the same desktop, the same panels, and the same menus.
However, you can run different applications, and open different windows in each
workspace. You can display only one workspace at a time in your desktop
environment but you can have windows open in other workspaces.

Workspaces enable you to organize the desktop environment when you run many
applications at the same time. When your current workspace becomes crowded with
windows, you can move your work to another workspace. You can also switch to
another workspace then start more applications.

Workspaces are displayed in the Workspace Switcher applet. In Figure 2–4, Workspace
Switcher contains four workspaces. The first three workspaces contain open windows.
The last workspace does not contain currently active windows.
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FIGURE 2–4 Workspaces Displayed in Workspace Switcher

To Switch Between Workspaces
You can switch between workspaces in the following ways:

� In Workspace Switcher, click on the workspace where you want to work.

� Press Ctrl + Alt + right arrow to switch to the workspace on the right of the current
workspace.

� Press Ctrl + Alt + left arrow to switch to the workspace on the left of the current
workspace.

To Add Workspaces
To add workspaces to your desktop environment, right-click on the Workspace
Switcher applet, then choose Preferences. The Workspace Switcher Preferences dialog
is displayed. Use the Number of workspaces spin box to specify the number of
workspaces that you require.

Nautilus File Manager
The Nautilus file manager provides an integrated access point to your files,
applications, FTP sites, and URIs. To open a file manager window, choose Applications
→ Home Folder. The following figure shows a file manager window that displays the
contents of a folder.
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A file manager window contains the following panes:

Side pane Enables you to navigate through your files. This pane also displays
information about the current file or folder. The side pane is on the left
side of the window.

View pane Displays the contents of files and folders. The view pane is on the right
side of the window.

Nautilus enables you to do the following:

� View files and folders

You can view your files and folders as icons or as a list. You can view the contents
of some types of file within a file manager window. Alternatively, you can open the
files in the appropriate application from the file manager.

� Manage your files and folders

You can use the file manager to create, move, copy, rename, and remove files and
folders.

� Run scripts

You can run scripts from the file manager, and you can select files and folders on
which to run your scripts.

� Customize your files and folders

You can add emblems to your files and folders to indicate particular states. For
example, you can add an Important emblem to a file to indicate that the file is
important. You can also customize folders in the following ways:

� Add a note to a folder.
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� Specify a custom background pattern for a folder.
� Specify a zoom setting for a folder.

� Open special Uniform Resource Identifiers (URIs)

The GNOME Desktop contains special URIs that enable you to access particular
functions from the file manager. For example, to access the preference tools, you
can access the preferences:/// URI in the file manager.

� Write CDs

The file manager provides a special location where you can copy files and folders
that you want to write to a CD. You can write the contents of the location to a CD
easily.

The file manager also creates the desktop.

To Open Files From the File Manager
To navigate to the folder where the file that you want to open resides, double-click on
the folder icons in the view pane. When the file that you want to open is displayed,
double-click on the file icon to open the file.

To Move Files Between Folders
You can move files between folders by opening two or more file manager windows.
Open a different folder in each window, then drag the files from one window to the
other.

Desktop and Desktop Objects
The desktop is an active component of the desktop. You can use the desktop to
perform the following actions:

� Start your applications, and open your files and folders.

You can add desktop objects for convenient access to the files, folders, and
applications that you use frequently. For example, you add a launcher for an
application that you use often.

� Open the Desktop menu.

Right-click on the desktop to open the Desktop menu. You can use the Desktop
menu to perform actions on the desktop.
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The file manager manages the desktop.

To Open Desktop Objects
To open an object from the desktop, double-click on the object. You can set your
preferences in a Nautilus window so that you click once on an object to execute the
default action.

To Add Objects to the Desktop
You can add desktop objects for convenient access to files, folders, and applications
that you use frequently. You can add objects to your desktop in the following ways:

� Use the Desktop menu to add a launcher to the desktop.

� Drag an object from a file manager window to the desktop. For example, you can
create a symbolic link to a file that you use often, then drag the link to your
desktop. The icon for the link is moved to the desktop. To open the file,
double-click on the icon. You can also drag files and folders to the desktop.

� Drag an application launcher from a menu to the desktop. For example, you can
open a menu that contains a launcher for an application that you use often, then
drag the launcher to your desktop.

Start Here Location

The Start Here location enables you to access the following functions:

� Applications

Double-click on Applications to access your key GNOME applications. You can
also access the Applications menu through the Menu Bar and the Main Menu.

� Desktop Preferences
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Double-click on Desktop Preferences to customize your desktop environment.

� Programs that enable you to configure your system as a server, and to choose other
system settings.

You can access the Start Here location in the following ways:

� From a file manager window

Choose Go → Start Here. The contents of the Start Here location are displayed in
the window.

� From the desktop

Double-click on the Start Here object on the desktop. The contents of the Start
Here location are displayed in a file manager window.

Desktop Environment Preferences
You can use desktop environment preference tools to configure almost every feature of
the desktop environment. Each tool controls a particular part of the behavior of the
desktop environment. For example, you can use a preference tool to select a theme for
your desktop environment. A theme is a group of coordinated settings that specify the
visual appearance of a part of your interface.

For convenience, the tools are grouped under the following headings:

� Basic
� Accessibility
� Advanced

You can open your desktop environment preference tools in either of the following
ways:

� Choose Applications → Desktop Preferences. Choose the item that you require
from the submenus.

� Double-click on the Start Here object on the desktop. A Nautilus window opens at
the Start Here location. Double-click on the Desktop Preferences object in the
Nautilus window to display the preference tools. Double-click on the item that you
require.
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Applications
The applications that are provided with the GNOME Desktop share several
characteristics. For example, the applications have a consistent look-and-feel. The
applications share characteristics because the applications use the same programming
libraries. An application that uses the standard GNOME programming libraries is
called a GNOME-compliant application. For example, Nautilus and the gedit text editor
are GNOME-compliant applications.

GNOME provides libraries in addition to the libraries provided by your operating
system. The libraries enable GNOME to run your existing applications as well as
GNOME-compliant applications. For example, if your operating system is
UNIX-based, you can run your current X11 applications and Motif applications from
the GNOME Desktop.

Some of the features of GNOME-compliant applications are as follows:

� Consistent look-and-feel

GNOME-compliant applications have a consistent look-and-feel.
GNOME-compliant applications use the look-and-feel settings that you specify in
the preference tools. You can use the following tools to change the look-and-feel of
your GNOME-compliant applications:

� Menus & Toolbars preference tool
� Theme preference tool

� Menubars, toolbars, and statusbars

Most GNOME-compliant applications have a menubar, a toolbar, and a statusbar.
The menubar always contains a File menu and a Help menu. The File menu always
contains an Quit menu item, and the Help menu always contains an About menu
item.

A toolbar is a bar that appears under the menubar. A toolbar contains buttons for
the most commonly-used commands. A statusbar is a bar at the bottom of a
window that provides information about the current state of what you are viewing
in the window. GNOME-compliant applications might also contains other bars. For
example, Nautilus contains a location bar.

Some of the bars in GNOME-compliant applications are detachable. That is, the bar
has a handle that you can grab then drag the bar to another location. You can drag
the bar to snap to another side of the window, or to another part of the screen. For
example, you can detach the menubar, toolbar, and location bar in the file manager.

� Default shortcut keys

GNOME-compliant applications use the same shortcut keys to perform the same
actions. For example, to quit a GNOME-compliant application, press Ctrl + Q. To
undo an action in a GNOME-compliant application, press Ctrl + Z.
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� Drag-and-drop

GNOME-compliant applications use the same protocol to implement
drag-and-drop operations. Therefore, GNOME-compliant applications provide
consistent feedback when you drag-and-drop items.

The use of the same protocol also enables GNOME-compliant applications to
interoperate in a sophisticated manner. For example, GNOME-compliant
applications recognize the format of the items that you drag. When you drag a
HTML file from a Nautilus window to a web browser, the file is displayed in
HTML format in the browser. However, when you drag the HTML file to a text
editor, the file is displayed in plain text format in the text editor.

To Find Out More
The desktop environment provides help if you want to find out more about the
following areas:

� Desktop environment topics
� Applets
� Applications

To Find Out More About Desktop Environment
Topics
You can find out more about particular desktop environment topics in the integrated
Yelp help system. To start the Yelp help system, choose Applications → Help.

To Find Out More About Applets
To find out more about a specific applet, right-click on the applet, then choose Help.

To Find Out More About Applications
To find out more about a specific application, start the application, then choose Help
→ Contents. Alternatively, start the application then press F1.
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CHAPTER 3

GNOME Desktop Sessions

This chapter provides the information you need to start, manage, and end a GNOME
Desktop session.

� “Starting a Session” on page 45
� “To Lock Your Screen” on page 46
� “Managing the Session” on page 47
� “Ending a Session” on page 49

Starting a Session
A session occurs between the time that you log in to the desktop environment and the
time that you log out. The login screen is your gateway to the desktop environment.
The login screen provides fields for you to enter your username and password. The
login screen enables you to select login options, for example you can select the
language of your session.

You start a session when you log in. The session manager starts after your username
and password are authenticated. The session manager enables you to manage the
session. For example, you can save the state of your most recent session and return to
that session the next time that you log in. The session manager saves and restores the
following:

� The appearance and behavior settings, for example fonts, colors, and mouse
settings.

� The applications that you were running, for example file manager and text editor
windows. You cannot save and restore applications that the session manager does
not manage. For example, if you start the vi editor from the command line in a
terminal window, session manager cannot restore your editing session.
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To Log in to a Session
To log in to a session, perform the following steps:

1. On the login screen, click on the Session icon. Choose the GNOME Desktop from
the list of available desktop environments.

2. Enter your username in the Username field on the login screen, then press Return.

3. Enter your password in the Password field on the login screen, then press Return.

When you log in successfully, the session manager starts a session. If this is the first
time you log in, then the session manager starts a new session. If you have logged in
before, then the session manager restores your previous session, if you saved your
session settings when you logged out.

If you want to shut down or restart the system before you log in, click on the System
icon on the login screen. A dialog is displayed. Select the option that you require, then
click OK.

To Log in to a Session in a Different Language
To log in to a session in a different language, perform the following actions.

1. On the login screen, click on the Language icon. Choose the language you require
from the list of available languages.

2. Enter your username in the Username field on the login screen, then press Return.

3. Enter your password in the Password field on the login screen, then press Return.

Note – When you log in to a session in a different language, you choose the language
for the user interface. You do not specify a keyboard layout for the session. To specify
a keyboard layout, use the Keyboard Layout Switcher applet.

To Lock Your Screen

To lock the screen, perform one of the following actions:
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� Choose Actions → Lock Screen.
� If the Lock button is present on a panel, click on the Lock button.

To add the Lock button to a panel, right-click on the panel. Choose Add to Panel →
Actions → Lock.

When you lock your screen, the screensaver starts. To unlock the screen, move your
mouse to display the locked screen dialog. Enter your username and password in the
locked screen dialog, then press Return.

For information on configuring your screensaver, see Using the Basic Preference Tools.

Note – To lock your screen correctly, you must have a screensaver enabled.

Managing the Session
To configure the session management of the desktop environment, use the Sessions
preference tool. The Sessions preference tool recognizes the following types of
application:

� Applications that are session-managed. When you save the settings for your
session, the session manager saves all of the session-managed applications. If you
log out, then log in again, the session manager automatically starts the
session-managed applications.

� Applications that are not session-managed. When you save the settings for your
session, the session manager does not save any applications that are not
session-managed. If you log out, then log in again, the session manager does not
start non-session-managed applications. You must start the application manually.
Alternatively, you can use the Sessions preference tool to specify
non-session-managed applications that you want to automatically start.

Defining Session Behavior When You Log In and
Log Out
To set how a session behaves when you log in and log out, use Sessions preference
tool. Make the changes you require in the Session Options tabbed section. For
example, you can select to display a splash screen when you log in.
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To Use Startup Applications
You can configure your sessions to start with applications that are not
session-managed. To configure non-session-managed startup applications, use the
Sessions preference tool. Use the Startup Programs tabbed section to add, edit, and
delete applications. If you save your settings and log out, the next time that you log in,
the startup applications start automatically.

To Browse Applications in the Current Session
To browse the applications in the current session, use the Sessions preference tool. The
Current Session tabbed section lists the following:

� All GNOME applications that are currently running, that can connect to the session
manager, and that can save the state of the application.

� All preference tools that can connect to the session manager, and that can save the
state of the tool.

You can use the Current Session tabbed section to perform a limited number of
actions on the session properties of an application or preference tool. For example, you
can edit the startup order, and restart style of any GNOME application or preference
tool that is in the list.

To Save Session Settings
To save your session settings, perform the following steps:

1. Configure your session to automatically save settings when you end the session. To
configure your session, use the Sessions preference tool. The Sessions preference
tool starts. Select the Automatically save changes to session option on the Session
Options tabbed section.

2. End your session.

If you do not select the Automatically save changes to session option, when you log
out, a dialog asks if you want to save your current settings. To save your settings,
select the option, then continue to log out.
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Ending a Session

To end your session, close all your currently active processes, then perform one of the
following actions:

� Click on a Log Out button.
� Choose Actions → Log Out.
� Open the Main Menu, then choose Log Out.

Before you end a session, you might want to save your current settings so that you can
restore the session later. During the logout process, a dialog asks if you want to save
your current settings. In the Sessions preference tool, you can select an option to
automatically save your current settings.
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CHAPTER 4

Working With Panels

The information in this chapter describes how to use panels.

� “Introducing Panels” on page 51
� “Managing Your Panels” on page 53
� “Panel Objects” on page 56
� “Launchers” on page 60
� “Menus” on page 68
� “Applets” on page 59
� “Drawers” on page 69
� “Log Out Button” on page 66
� “Lock Button” on page 65

Introducing Panels
A panel is an area in your desktop environment from which you can run applications
and applets, and perform other tasks. When you start a session for the first time, the
desktop environment contains at least one panel. Your system administrator might
have set your default panels according to your local requirements, so you might see
slightly different default panels.

You can change the behavior and appearance of your panels to suit your requirements.
You can also add or remove objects from your panels. You can create multiple panels,
and choose different properties, objects, and backgrounds for each panel. You can also
hide panels.

Typically, the GNOME Desktop contains a panel at the top edge of the screen, and a
panel at the bottom edge of the screen. The following sections describe these panels.
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Top Edge Panel
Figure 4–1 shows the panel at the top edge of the screen. Your system administrator
might have set your default top edge panel according to your local requirements, so
you might see a slightly different top edge panel.

FIGURE 4–1 Typical Top Edge Panel

The typical top edge panel contains the following objects:

Object Description

Menu Bar applet Contains the Applications and the Actions menu. The
Applications menu contains the standard GNOME applications.
The Actions menu provides commands that enable you to
perform desktop environment tasks.

Home folder launcher Click on this launcher to open your home folder in a Nautilus
file manager window.

Terminal launcher Click on this launcher to start the Terminal application. Terminal
provides access to a UNIX command line.

Clock applet Clock shows the current time. Click on the time readout to
display a menu of clock commands.

Volume Control applet Volume Control enables you to control the volume of the speaker
on your system.

Window list icon The window list is a list of all your open windows. To give focus
to a window, click on the icon at the extreme right of the top
edge panel, then choose the window.

Bottom Edge Panel
Figure 4–2 shows a typical bottom edge panel. Your system administrator might have
set your default bottom edge panel according to your local requirements, so you might
see a slightly different bottom edge panel.

FIGURE 4–2 Typical Bottom Edge Panel

The bottom edge panel contains the following items:

� Show Desktop button: Click on this button to minimize all open windows and
show the desktop.

� Window List applet: Displays a button for each window that is open. Window List
enables you to minimize and restore windows.
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� Workspace Switcher applet: Enables you to navigate between your workspaces.

Managing Your Panels
The following sections describe how to manage your panels.

To Add a New Panel
To add a panel, right-click on a vacant space on any panel, then choose New Panel.
The new panel is added to your desktop environment. The new panel contains no
objects. You can customize the new panel to suit your preferences.

To Interact With a Panel
To interact with a panel, you must left-click, middle-click, or right-click on a vacant
space on the panel. You can also middle-click or right-click on one of the hide buttons
to select the panel, if the panel has no vacant space. If the hide buttons are not visible
on a panel, modify the properties of the panel so that the hide buttons are visible.

You use the mouse buttons to interact with a panel in the following ways:

Middle-click Enables you to grab a panel, then drag the panel to a new location.

Right-click Opens the panel popup menu.

To Move a Panel
You can move panels to different locations. To move a panel, middle-click and hold on
any vacant space on the panel, then drag the panel to the new location.

To Hide a Panel
You can hide or show panels. To hide a panel, use a hide button. If the hide buttons
are not visible on a panel, modify the panel properties so that the hide buttons are
visible.

Hide buttons are at either end of a panel. The hide buttons contain an optional arrow
icon. The following illustration shows hide buttons.
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To hide a panel, click on one of the hide buttons. The panel reduces in the direction of
the arrow on the hide button. The hide button at the other end of the panel remains
visible.

To show a hidden panel again, click on the visible hide button. The panel expands in
the direction of the arrow on the hide button. Both hide buttons are now visible.

You can set a panel to autohide. When you set autohide, the panel hides automatically
when the mouse is not pointing to the panel. The panel reappears when you point to
the part of the screen where the panel resides. To set your panel to autohide, modify
the properties of the panel.

To Modify Panel Properties
To modify preferences for all panels, use the Panel preference tool to make the
changes that you require. For example, you can specify various settings related to the
appearance and behavior of panel objects.

You can also modify properties for each individual panel. You can change the features
for each panel, such as the type of the panel, the hide behavior, and the visual
appearance.

To modify the properties of a panel perform the following steps:

1. Right-click on a vacant space on the panel, then choose Properties to display the
Panel Properties dialog. The Panel Properties dialog contains the following tabbed
sections:

� General
� Background

2. To modify panel size, position, and hiding properties, click on the General tab. The
following table describes the dialog elements on the General tabbed section:

Dialog Element Description

Name Type a name for the panel. When you use shortcut keys to
switch between your panels and the desktop, this panel name is
displayed.
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Dialog Element Description

Orientation Select the position of the panel on your screen. Click on the
required position for the panel.

Size Use the spin box to specify the size of the panel.

Expand Select this option if you want the panel to expand to the full
length of the edge of the screen where the panel is located.

Autohide Select this option to enable autohide.

Show hide buttons Select this option to display hide buttons on your panel.

Arrows on hide button Select this option to display arrows on the hide buttons, if the
hide button is enabled.

3. To modify the panel background, click on the Background tab. The Background
tabbed section contains the following elements:

Choose the type of background for the panel. The choices are as follows:

Dialog Element Description

None (use system theme) Select this option to use the default panel background. The
default panel background depends on the settings in the
Theme preference tool.

Solid color Select this option to specify a single color for the panel
background. Click on the Color button to display the color
selector dialog. Choose the color that you require from the
color selector dialog.

Use the Style slider to specify the degree of transparency or
opaqueness for the color. For example, to make the panel
transparent, move the slider towards the Transparent end.

Background image Select this option to specify an image for the panel
background. Enter the filename of the image to use in the
drop-down combination box. Alternatively, to browse for the
file, click on the Browse button. When you have selected the
file, click OK.

You can also drag a color or image on to a panel to set the color or image as the
background of the panel. For more information, see “To Drag a Color or Image to
the Background of a Panel” on page 56.

4. Click Close to close the Panel Properties dialog.
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To Drag a Color or Image to the Background of a Panel
You can drag a color or image on to a panel to set the color or image as the
background of the panel. You can drag a color or image from many applications. For
example, you can drag a color from the Nautilus file manager to a panel to set the
color as the background of the panel. You can also drag a color from any color selector
dialog.

You can drag an image to a panel to set the image as the background of the panel. You
can also drag pattern images from the file manager to set the background of the panel.

To Delete a Panel
To delete a panel from your desktop environment, right-click on the panel that you
want to delete, then choose Delete This Panel.

Note – You must always have at least one panel in your desktop environment. If you
have only one panel in your desktop environment, you cannot delete that panel.

Panel Objects
This section describes the objects that you can add to your panels, and use from your
panels.

Interacting With Panel Objects
You use the mouse buttons to interact with a panel object in the following ways:

Left-click Launches the panel object.

Middle-click Enables you to grab an object, then drag the object to a new location.

Right-click Opens the panel object popup menu.

You interact with applet panel objects in a different way. For more information, see “To
Select an Applet” on page 60.
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To Add an Object to a Panel
You can add an object to a panel in several ways, as follows:

� From the panel popup menu

Right-click on a vacant space on a panel to open the panel popup menu. The panel
popup menu contains an Add to Panel submenu. The Add to Panel submenu
enables you to add the following objects to your panels:

� Applets in the following categories: Accessory, Amusement, Internet,
Multimedia, Utility.

� Buttons for quick access to common actions: Force Quit button, Lock button,
Log Out button, Run button, Screenshot button, Search button, Show Desktop
button.

� Launchers

� Launchers from menus

� Main Menu

� Menu Bar

� Drawers

� From any menu

When you right-click on a launcher in any menu, a popup menu for the launcher
opens. You can use this popup menu to add the launcher to a panel.

You can also drag menus, launchers, and applets from menus to panels.

� From the file manager

Each launcher corresponds to a .desktop file. You can drag the .desktop file on
to your panels to add the launcher to the panel.

To Modify the Properties of an Object
Some panel objects, such as launchers and drawers, have a set of associated properties.
The properties are different for each type of object. The properties specify details such
as the following:

� The command that starts a launcher application.
� The location of the source files for a menu.
� The icon that represents the object.

To modify the properties of an object perform the following steps:

1. Right-click on the object to open the panel object popup menu, as shown in Figure
4–3.
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FIGURE 4–3 Panel Object Popup Menu

2. Choose Properties. Use the Properties dialog to modify the properties as required.
The properties in the Properties dialog depend on which object you select in step 1.

3. Click OK to apply the changes, then close the Properties dialog.

To Move a Panel Object
You can move panel objects within a panel, and from one panel to another panel. You
can also move objects between panels and drawers.

To move a panel object, middle-click and hold on the object and drag the object to a
new location. When you release the middle mouse button, the object anchors at the
new location.

Alternatively, you can use the panel object popup menu to move an object, as follows:

1. Right-click on the object, then choose Move.

2. Point to the new location for the object, then click any mouse button to anchor the
object to the new location. This location can be on any panel that is currently in
your desktop environment.

Movement of a panel object affects the position of other objects on the panel. To
control how objects move on a panel, you can specify a movement mode. To specify
the movement mode, press one of the following keys as you move the panel object:

Key Movement Mode Description

No key Switched movement The object swaps places with other panel objects.
Switched movement is the default movement
mode.

Alt key Free movement The object jumps over other panel objects into the
next vacant space on the panel.

Shift key Push movement The object pushes other panel objects further
along the panel.
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To Lock a Panel Object
You can lock panel objects so that the objects stay in the same position on the panel.
This feature is useful if you do not want some panel objects to change position when
you move other panel objects.

To lock an object to the current location of the object in the panel, right-click on the
object to open the panel object popup menu, then choose Lock. To unlock the object,
right-click on the object, then choose Unlock.

To Remove a Panel Object
To remove an object from a panel right-click on the object to open the panel object
popup menu, then choose Remove From Panel.

Applets
An applet is a small application whose user interface resides within a panel. You use
the applet panel object to interact with the applet. For example, the following figure
shows the following applets, from left to right:

� Window List: Displays the windows currently open on your system.
� CD Player: Enables you to control the compact disc player on your system.
� Volume Control: Enables you to control the volume of the speaker on your system.

To Add an Applet to a Panel
You can add an applet to a panel from the panel popup menu. Right-click on any
vacant space on the panel to open the panel popup menu. Choose Add to Panel, then
choose the applet that you want to add from one of the following submenus:

� Accessories
� Amusements
� Internet
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� Multimedia
� Utility

Alternatively, drag the applet from the submenu on to the panel.

To Select an Applet
To modify the properties of an applet, you must first right-click on the applet to
display the panel object popup menu. To move an applet, you must middle-click on
the applet.

Some restrictions apply on where you can click on an applet in order to display the
panel object popup menu, or to move the applet, as follows:

� Some applets have popup menus of applet-specific commands that open when you
right-click on particular parts of the applet. For example, the Window List applet
has a vertical handle on the left side, and buttons that represent your windows on
the right side. To open the panel object popup menu for the Window List applet,
you must right-click on the handle. If you right-click on a button on the right side,
a popup menu for the button opens.

� Some applets have areas that you cannot use to select the applet. For example, the
Command Line applet has a field in which you enter commands. You cannot
middle-click or right-click on this field to select the applet. Instead, middle-click or
right-click on another part of the applet.

To Modify Preferences for an Applet
To modify the preferences for an applet perform the following steps:

1. Right-click on the applet, then choose Preferences. Use the Preferences dialog to
modify the preferences as required. The preferences for applets vary depending on
the applet.

2. Click Close to close the Preferences dialog.

Launchers
When you click on a launcher, you initiate one of the following actions:

� Start a particular application.
� Execute a command.
� Open a folder in a file manager window.
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� Open a browser at a particular Uniform Resource Locator (URL). A URL is the
address of a particular location on the Web.

� Open special Uniform Resource Identifiers (URIs). The GNOME Desktop contains
special URIs that enable you to access particular functions from the file manager.

You can find launchers in the following places in the desktop environment:

� Panels: On panels, launchers are represented by icons.
� Menus: On menus, launchers are represented by menu items. The menu items

usually have an icon beside the menu item.

� Desktop: On the desktop, launchers are represented by icons.

You can modify the properties of a launcher. For example, the properties of a launcher
include the name of the launcher, the icon that represents the launcher, and how the
launcher runs.

To Add a Launcher to a Panel
You can add a launcher to a panel in one of the following ways:

� From the panel popup menu

To create a new launcher, right-click on any vacant space on the panel, then choose
Add to Panel → Launcher. A Create Launcher dialog is displayed. For more
information on how to complete this dialog, see “To Create a Launcher With the
Create Launcher Dialog” on page 61.

Alternatively, to add an existing launcher to the panel, choose Add to Panel →
Launcher from menu from the panel popup menu. Choose the launcher that you
want to add from the menu.

� From any menu

To add a launcher to a panel from any menu, perform one of the following steps:

� Open a menu that contains the launcher. Drag the launcher on to the panel.

� Open the menu that contains the launcher from the panel where you want the
launcher to reside. Right-click on the title of the launcher. Choose Add this
launcher to panel.

� From the file manager

To add a launcher to a panel from the file manager, find the .desktop file for the
launcher in your file system. To add the launcher drag the .desktop file to the
panel.

To Create a Launcher With the Create Launcher Dialog
To create a launcher with the Create Launcher dialog perform the following steps:
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1. Right-click on any part of a panel to open the panel popup menu. Choose Add to
Panel → Launcher to display the Create Launcher dialog. The dialog displays the
Basic tabbed section.

2. Enter the properties of the launcher in the dialog. The following table describes the
dialog elements on the Basic tabbed section:

Dialog Element Description

Name Use this text box to specify the name of the launcher. You can use
the Advanced tab to add translations of the name. This name is
the name that appears when you add the launcher to a menu or to
the desktop.

Generic name Use this text box to specify the class of application to which the
launcher belongs. For example, you might type Text Editor in
this text box for a gedit launcher. You can use the Advanced tab to
add translations of the generic name.

Comment Use this text box to specify a short description of the launcher.
The comment is displayed as a tooltip when you point to the
launcher icon on the panel. You can use the Advanced tabbed
section to add translations of the comment.

Command Use this field to specify a command to execute when you click on
the launcher. For sample commands, see the next section.

Type Use this drop-down combination box to specify the type of
launcher. Select from the following:
� Application: Select this option to create a launcher that starts

an application.
� Link: Select this option to create a launcher that links to a URI.

Icon Choose an icon to represent the launcher. To choose an icon, click
on the No Icon button. An icon selector dialog is displayed.
Choose an icon from the dialog. Alternatively, to choose an icon
from another directory, click Browse. When you choose an icon,
click OK.

Run in Terminal Select this option to run the application or command in a terminal
window. Choose this option for an application or command that
does not create a window in which to run.

3. To set advanced properties for the launcher, click on the Advanced tab. The
Launcher Properties dialog displays the Advanced tabbed section.

4. Enter the advanced properties of the launcher in the dialog. The following table
describes the dialog elements on the top part of the Advanced tabbed section:
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Dialog Element Description

Try this before using Enter a command here to check before starting the launcher.
If the command is executable and is in your path, the
launcher appears on the panel.

Documentation Enter the path to the help file for the launcher. If you enter a
path in this field, a Help on launcher-name Application menu
item is displayed on the popup menu for the launcher.

5. You can also add a translation of the Name, Generic name, and Comment fields
from the Basic tabbed section. To add a translation, enter the details of the
translation in the Name/Comment translations table as follows:

Field Description

First field Enter the two-letter code for the language for which you want to add a
translation.

Second field Enter the translation of the Name of the launcher.

Third field Enter the translation of the Generic name of the launcher.

Fourth field Enter the translation for the Comment for the launcher.

Then click on the Add/Set button.

To edit a translation, select the translation. The translated text appears in the lower
part of this dialog. Edit the fields as required, then click on the Add/Set button.

To remove a translation, select the translation, then click on the Remove button.

6. To create the launcher and close the Launcher Properties dialog, click OK.

Launcher Commands
The type of commands that you can enter in the Command field depend on the option
that you choose from the Type drop-down combination box. If you choose
Application from the Type drop-down combination box, you can enter a normal
command. The following table shows some sample commands and the actions that the
commands perform:

Sample Application Command Action

gedit Starts the gedit application.

Chapter 4 • Working With Panels 63



Sample Application Command Action

gedit /user123/loremipsum.txt Opens the file /user123/loremipsum.txt in
the gedit application.

nautilus /user123/Projects Opens the folder /user123/Projects in a file
manager window.

If you choose Link from the Type drop-down combination box, you can enter a link
command. The following table shows some sample link commands and the actions
that the commands perform:

Sample Link Command Action

http://www.gnome.org Opens the GNOME website in your default
browser.

ftp://ftp.gnome.org Opens the GNOME FTP site in your default
browser.

applications:/// Opens the Applications location in a file
manager window. Double-click on an
application to start the application.

preferences:/// Opens the Desktop Preferences location in a file
manager window. Double-click on a preference
tool to start the preference tool.

To Modify the Properties of a Launcher
To modify the properties of a launcher perform the following steps:

1. Right-click on the launcher to open the panel object popup menu.

2. Choose Properties. Use the Launcher Properties dialog to modify the properties as
required. For more information on the Launcher Properties dialog, see “To Create
a Launcher With the Create Launcher Dialog” on page 61.

3. Click Close to close the Launcher Properties dialog.

Buttons
You can add buttons to your panels to provide quick access to common actions and
functions.
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Force Quit Button

The Force Quit button enables you to select a window to terminate an application.
This button is useful if you want to terminate an application that does not respond to
your commands.

To add a Force Quit button to a panel, right-click on any vacant space on the panel.
Choose Add to Panel → Actions → Force Quit. To terminate an application, click on
the Force Quit button, then click on a window from the application that you want to
terminate. If you do not want to terminate an application after you click on the Force
Quit button, press Esc.

Lock Button

The Lock button locks your screen and activates your screensaver. To access your
session again, you must enter your password. To lock your screen correctly, you must
have a screensaver enabled.

To add a Lock button to a panel, right-click on any vacant space on the panel. Choose
Add to Panel → Actions → Lock.

Right-click on the Lock button to open a menu of screensaver-related commands.
Table 4–1 describes the commands that are available from the menu.

TABLE 4–1 Lock Screen Menu Items

Menu Item Function

Activate Screensaver Activates the screensaver immediately, but does not
lock the screen.

Lock Screen Locks the screen immediately. This command
performs the same function as when you click on the
Lock button.
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TABLE 4–1 Lock Screen Menu Items (Continued)
Menu Item Function

Kill Screensaver Daemon Terminates the screensaver process. After you
terminate the screensaver process, you cannot lock
your screen.

Restart Screensaver Daemon Terminates and restarts the screensaver process. Use
this command after you change your password.
When you restart the screensaver process, use your
new password with the screensaver.

Properties Displays the XScreenSaver preference tool.

Log Out Button

The Log Out button begins the process to log out of a GNOME session.

To add a Log Out button to a panel, right-click on any vacant space on the panel.
Choose Add to Panel → Actions → Log Out. To log out of your session or shut down
your system, click on the Log Out button.

Run Button

You can use the Run button to open the Run Application dialog.

To add a Run button to a panel, right-click on any vacant space on the panel. Choose
Add to Panel → Actions → Run. To open the Run Application dialog, click on the Run
button.

For more information on the Run Application dialog, see Working With Menus.

Screenshot Button
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You can use the Screenshot button to take a screenshot of your screen.

To add a Screenshot button to a panel, right-click on any vacant space on the panel.
Choose Add to Panel → Actions → Screenshot. To take a screenshot of your screen,
click on the Screenshot button.

For more information on how to take screenshots, see Working With Menus.

Search Button

You can use the Search button to open the Search Tool.

To add a Search button to a panel, right-click on any vacant space on the panel.
Choose Add to Panel → Actions → Search. To open the Search Tool, click on the Search
button.

For more information on the Search Tool, see the Search Tool Manual.

Show Desktop Button

You can use the Show Desktop button to minimize all open windows and show the
desktop.

To add a Show Desktop button to a panel, right-click on any vacant space on the
panel. Choose Add to Panel → Actions → Show Desktop. To minimize all windows
and show the desktop, click on the Show Desktop button.
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Notification Area Applet

The Notification Area applet displays icons from various applications to indicate
activity in the application. For example, when you use the CD Player application to
play a CD, a CD icon is displayed in the Notification Area applet. The graphic above
illustrates the CD icon in the Notification Area applet.

To add a Notification Area applet to a panel, right-click on any vacant space on the
panel. Choose Add to Panel → Utility → Notification Area.

Menus
You can add the following types of menu to your panels:

� Main Menu: You can access almost all of the standard applications, commands, and
configuration options from the Main Menu. To add a Main Menu to a panel,
right-click on any vacant space on the panel, then choose Add to Panel → Main
Menu. You can add as many Main Menu objects to your panels as you want. By
default, the Main Menu is represented on panels by a stylized footprint icon, as
follows:

� Menu Bar: You can access almost all of the standard applications, commands, and
configuration options from the menus in the Menu Bar. The Menu Bar contains the
Applications menu and the Actions menu. To add a Menu Bar to a panel,
right-click on any vacant space on the panel, then choose Add to Panel → Menu
Bar. You can add as many Menu Bar objects to your panels as you want.

� System menus: System menus contain the standard applications and tools that you
can use in your desktop environment. The Applications menu and Actions menu
are system menus. To add a system menu to a panel, right-click on a launcher in
the menu, then choose Entire menu → Add this as menu to panel.
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Menus that you add to your panels are represented by an icon with an arrow. The
arrow indicates that the icon represents a menu or drawer. Figure 4–4 shows how
menus typically appear on panels.

FIGURE 4–4 Typical Menu Objects on a Panel

Drawers
A drawer is an extension of a panel. You can open and close a drawer in the same way
that you can show and hide a panel. A drawer can contain all panel objects, including
launchers, menus, applets, other panel objects, and other drawers. When you open a
drawer, you can use the objects in the same way that you use objects on a panel.

The following figure shows an open drawer that contains two panel objects.

The arrow on the drawer icon indicates that the icon represents a drawer or menu.

You can add, move, and remove objects from drawers in the same way that you add,
move, and remove objects from panels.
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To Open and Close a Drawer
To open a drawer, click on the drawer object in a panel. You can close a drawer in the
following ways:

� Click on the drawer.
� Click on the drawer hide button.

To Add a Drawer to a Panel
You can add a drawer to a panel in the following ways:

� From the panel popup menu

Right-click on any vacant space on the panel, then choose Add to Panel → Drawer.
� From any menu

You can add a menu as a drawer object to a panel.

To add a menu as a drawer to a panel, open the menu from the panel. Right-click
on any launcher in the menu, then choose Entire menu → Add this as drawer to
panel.

To Add an Object to a Drawer
You add an object to a drawer in the same way that you add objects to panels. For
more information, see “To Add an Object to a Panel” on page 57.

To Modify Drawer Properties
To modify preferences for all panels and drawers, use the Panel preference tool. For
example, you can select various options related to the appearance and behavior of
objects on panels and drawers. You can also select options that relate to drawers only.
For example, you can select an option to close your drawers when you click on a
launcher in the drawer.

You can also modify other properties for each individual drawer. You can change
features for each drawer, such as the visual appearance of the drawer and whether the
drawer has hide buttons.

To modify properties for a drawer perform the following steps:

1. Right-click on the drawer, then choose Properties to display the Panel Properties
dialog. The dialog displays the General tabbed section.

2. Select the properties for the drawer in the dialog. The following table describes the
elements on the General tabbed section:
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Dialog Element Description

Name Type a name for the panel. When you use shortcut keys to
switch between your panels and the desktop, this panel name is
displayed.

Size Select the size of the panel.

Icon Choose an icon to represent the drawer. Click on the Icon button
to display an icon selector dialog. Choose an icon from the
dialog. Alternatively, click Browse to choose an icon from
another directory. When you choose an icon, click OK.

Show hide buttons Select this option to display hide buttons on your panel.

Arrows on hide button Select this option to display arrows on the hide buttons, if the
hide button is enabled.

3. You can use the Background tabbed section to set the background for the drawer.
For information on how to complete the Background tabbed section, see the step
on this topic in “To Modify Panel Properties” on page 54. You can also drag a color
or image on to a drawer to set the color or image as the background of the drawer.
For more information, see “To Drag a Color or Image to the Background of a
Panel” on page 56.

4. Click Close to close the Panel Properties dialog.
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CHAPTER 5

Working With Menus

This chapter describes how to use menus in the GNOME Desktop.

� “Introduction to Menus” on page 73
� “Menu Features” on page 74
� “Applications Menu” on page 76
� “Actions Menu” on page 76
� “Main Menu” on page 79
� “Menu Bar” on page 80
� “Customizing Your Menus” on page 80

Introduction to Menus
You can access all desktop environment functions through menus. The panels contains
menus, so you can use a combination of menus and panels to perform your tasks. You
can perform various actions on your menus, such as copy menu items to panels.

You can access the following menus in your desktop environment:

� Applications menu: You can access many of your applications, commands, and
configuration options from the Applications menu. You can also access the desktop
environment preference tools from the Applications menu.

� Actions menu: You can access various commands that enable you to perform
desktop environment tasks from the Actions menu. For example, you can start the
Search Tool application, or log out of the desktop environment.

� Main Menu: You can access the items in the Applications and Actions menus from
the Main Menu. You can have many Main Menu buttons in your panels.

� Menu Bar: You can also access the items in the Applications and Actions menus
from the Menu Bar. You can have many Menu Bar objects in your panels.
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You can also right-click on the desktop to open the Desktop menu. The Desktop menu
enables you to perform desktop-related tasks.

All of these menus provide you with multiple ways to perform your tasks, and enable
you to work in the way that you prefer.

Menu Features
Menus can contain the following items:

� Submenus
� Launchers or menu items

An arrow to the right of an item in a menu indicates that the item is a submenu. When
you point to the submenu, the submenu opens. You can choose items from the
submenu.

When you choose a launcher, the launcher starts an application or runs a command.
You can also right-click on a launcher to open a popup menu. The popup menu
enables you to add the item to a panel, and perform other tasks. For more information
on the popup menu, see the next section.

You can change the theme for your session to change how all your menus look. To
change the theme, use the Theme preference tool.

Menu Item Popup Menu
Items in menus have an associated popup menu that enables you to perform tasks
related to the item. When you right-click on an item in a menu, the popup menu for
the item opens. The popup menu also contains a submenu that allows you to perform
menu-related tasks.

You can use the menu item popup menu to perform the following tasks:

� Add menu items as launchers to panels.
� Remove items from menus.
� Open the Run Application dialog with the menu item command in the dialog.
� Add menus to panels. You can add a menu as a menu object or as a drawer object.
� Add new items to menus.
� Change the properties of submenus and menu items.

Figure 5–1 shows the popup menu.
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FIGURE 5–1 Menu Item Popup Menu

Table 5–1 describes menu item popup menus.

TABLE 5–1 Menu Item Popup Menus

Item Description

Add this launcher to panel Adds the launcher to the panel from which you open
the menu.

Remove this item Removes the launcher from the menu.

Put into run dialog Displays the Run Application dialog with the
command from the Command field of the launcher in
the command field on the Run Application dialog.

Help on application-name Opens the online help for the application.

Properties Displays a dialog that enables you to edit the
properties of the launcher.

Entire menu → Add this as drawer to
panel

Adds the submenu as a drawer to the panel from
which you open the menu.

Entire menu → Add this as menu to
panel

Adds the submenu as a menu object to the panel
from which you open the menu.

Entire menu → Add new item to this
menu

Enables you to add an item to the submenu.

Entire menu → Properties Displays a dialog that enables you to edit the
properties of the submenu.
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Applications Menu
The Applications menu contains a hierarchy of submenus, from which you can start
the standard GNOME applications and preference tools. The Applications menu
contains the Desktop Preferences menu. You can use the Desktop Preferences menu to
start the desktop environment preference tools. The Applications menu also includes
the file manager and the help browser.

The Applications menu resides in the following places:

� Main Menu
� Menu Bar
� Start Here location in the file manager

Actions Menu
The Actions menu contains various commands that enable you to perform desktop
environment tasks. Table 5–2 describes the commands in the Actions menu.

TABLE 5–2 Actions Menu Commands

Menu Item Function

Run Application Opens the Run Application dialog. Use the Run
Application dialog to run commands. For more
information, see “Using the Run Application Dialog”
on page 77.

Search for Files Starts the Search Tool application. For more information,
see the Search Tool manual.

Open Recent Displays a submenu of the last ten files which you saved.

Take Screenshot Takes a screenshot of the screen, and opens the Save
Screenshot dialog. Use the Save Screenshot dialog to
save the screenshot.

Lock Screen Locks your screen.

Log Out Logs you out of the current session.

The Actions menu resides in the following places:

� Main Menu. The items in the Actions menu are at the top level of the Main Menu.
� Menu Bar.
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Using the Run Application Dialog
The Run Application dialog gives you access to the command line. When you run a
command in the Run Application dialog, you cannot receive output from the
command.

To run a command from the command line perform the following steps:

1. Display the Run Application dialog. You can display the Run Application dialog
in any of the following ways:

� From any panel

Add the Run button to a panel. Right-click on the panel, then choose Add to
Panel → Actions → Run. Click on the Run button.

� From the Main Menu

Open the Main Menu, then choose Run Application.
� From the Menu Bar

Choose Actions → Run Application.
� Use shortcut keys

The default shortcut keys to display the Run Application dialog are Alt + F2.
You can change the shortcut keys that display the Run Application dialog in
the Keyboard Shortcuts preference tool.

� From a menu item popup menu

Right-click on an item in a menu, then choose Put into run dialog from the
popup menu. The Run Application dialog opens with the command from the
menu in the command field. The Run Application dialog is displayed.

2. Enter the command that you want to run in the blank field. Alternatively, to choose a
command that you ran previously, click the down arrow button beside the command
field, then choose the command to run.

Alternatively, select the Show list of known applications option to display a list of
available applications.

You can also use the Run with file button to choose a file to append to the command
line. For example, you can enter emacs as the command, then choose a file to edit.

Select the Run in terminal option to run the application or command in a terminal
window. Choose this option for an application or command that does not create a
window in which to run.

3. Click on the Run button on the Run Application dialog.

To Take a Screenshot
You can take a screenshot in any of the following ways:

� From the Menu Bar
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To take a screenshot of the entire screen, choose Actions → Take Screenshot. A Save
Screenshot dialog is displayed. To save the screenshot, select the Save screenshot
to file option. Enter the path and filename for the screenshot in the drop-down
combination box. Alternatively, to save the screenshot to another directory, click
Browse. When you select a directory, click OK.

You can also save the screenshot to the desktop. To save the screenshot to the
desktop, select the Save screenshot to desktop option.

� From any panel

Add the Screenshot button to a panel. Right-click on the panel, then choose Add to
Panel → Actions → Screenshot. Click on the Screenshot button to take a screenshot
of the entire screen. Use the Save Screenshot dialog to save the screenshot.

� Use shortcut keys

To take a screenshot, use the following shortcut keys:

Default Shortcut Keys Function

Print Screen Takes a screenshot of the entire screen, and displays the
Save Screenshot dialog. Use the Save Screenshot dialog
to save the screenshot.

Alt + Print Screen Takes a screenshot of the window to which the mouse
points, and displays the Save Screenshot dialog. Use the
Save Screenshot dialog to save the screenshot.

You can use the Keyboard Shortcuts preference tool to modify the default shortcut
keys.

� Use a command

You can use the gnome-panel-screenshot command to take a screenshot. The
gnome-panel-screenshot command takes a screenshot of the entire screen, and
displays the Save Screenshot dialog. Use the Save Screenshot dialog to save the
screenshot.

You can also use options on the gnome-panel-screenshot command as
follows:

Option Function

--window Takes a screenshot of the window that has focus, and
displays the Save Screenshot dialog. Use the Save
Screenshot dialog to save the screenshot.

--delay=seconds Takes a screenshot after the specified number of seconds,
and displays the Save Screenshot dialog. Use the Save
Screenshot dialog to save the screenshot.
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Option Function

--help Displays the options for the command.

Main Menu

The Main Menu provides access to the Applications menu and the many of the items
in the Actions menu. You can access almost all of the standard applications,
commands, and configuration options from the Main Menu.

You can add Main Menu buttons to your panels. By default, the Main Menu is
represented on panels by a stylized footprint icon, as illustrated in the graphic above.

To Open the Main Menu
You can open the Main Menu in the following ways:

� From a panel with a Main Menu

Click on the Main Menu.
� Use shortcut keys

You can use shortcut keys to open the Main Menu. When you use shortcut keys to
open the Main Menu, the Main Menu appears at the mouse pointer.

The default shortcut keys to open the Main Menu are Alt + F1. To change the
shortcut keys that open the Main Menu, use the Keyboard Shortcuts preference
tool.
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To Add a Main Menu to a Panel
You can add as many Main Menu buttons as you want to your panels. To add a Main
Menu to a panel, right-click on any vacant space on the panel. Choose Add to Panel →
Main Menu.

Menu Bar

The Menu Bar provides access to the Applications and Actions menus. You can access
almost all of the standard applications, commands, and configuration options from the
Menu Bar.

To Add a Menu Bar to a Panel
You can add as many Menu Bar applets as you want to your panels. To add a Menu
Bar to a panel, right-click on any vacant space on the panel. Choose Add to Panel →
Menu Bar.

Customizing Your Menus
You can modify the contents of the following menus:

� Applications menu
� Desktop Preferences menu

You use the following desktop environment components to customize menus:

� Menus on panels
� Nautilus file manager

When you use panels to customize your menus, you use the menu item popup menu.
For more information, see “Menu Item Popup Menu” on page 74.
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When you use the file manager to customize your menus, you must access the
Applications menu or the Desktop Preferences menu from within the file manager. To
access the Applications menu or the Desktop Preferences menu, open a file manager
window. Choose Go → Start Here. Double-click on the Applications object or on the
Desktop Preferences object. For more information on the file manager, see Nautilus
File Manager.

To Add a Menu
To add a menu, perform the following steps:

1. In a file manager window, access the location where you want to add the menu.
For example, to add a menu to the Applications menu, choose Go → Start Here,
then double-click on the Applications object.

2. Choose File → New Folder. An untitled folder is added to the view pane. The name
of the folder is selected.

3. Type a name for the folder, then press Return.

The next time that you log out then log in again, the menu is in the assigned location.

To Add a Launcher to a Menu
To add a launcher to a menu, perform the following steps:

1. Right-click on any item in the menu to which you want to add the launcher.

2. Choose Entire menu → Add new item to this menu. A Create Launcher dialog is
displayed.

3. Enter the properties of the launcher in the Create Launcher dialog. For more
information on the elements in the Create Launcher dialog, see Working With
Panels.

4. Click OK.

To Add a Launcher to an Empty Menu
To add a launcher to an empty menu, perform the following steps:

1. Open a file manager window, then choose Go → Start Here. Alternatively,
double-click on the Start Here object on the desktop. The Start Here location is
displayed.

2. In the file manager window, double-click on the object that represents the menu to
which you want to add the launcher.

3. Choose File → New Launcher. A Create Launcher dialog is displayed.
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4. Enter the properties of the launcher in the Create Launcher dialog. For more
information on the elements in the Create Launcher dialog, see Working With
Panels.

5. Click OK.

To Copy a Launcher to a Menu
To copy an existing launcher to a menu, perform the following steps:

1. In a file manager window, access the location from which you want to copy the
launcher. For example, to copy a launcher from the Applications menu, choose Go
→ Start Here, then double-click on the Applications object.

2. Select the launcher that you want to copy, then choose Edit → Copy File.

3. In a file manager window, access the location to which you want to copy the
launcher.

4. Choose Edit → Paste Files. The launcher is added to the new location.

Alternatively, you can drag the launcher from one location to another.

The next time that you log out then log in again, the launcher is in the new menu
location.

To Edit the Properties of a Menu
To edit the properties of a menu, perform the following steps:

1. Right-click on any item in the menu that you want to edit.

2. Choose Entire menu → Properties. A Launcher Properties dialog is displayed.

3. Modify the properties of the menu in the Launcher Properties dialog. For more
information on the elements in the Launcher Properties dialog, see Working With
Panels.

4. Click OK.

To Edit a Menu Item
To edit a menu item, perform the following steps:

1. Right-click on the item that you want to edit.

2. Choose Properties. A Launcher Properties dialog is displayed.

3. Modify the properties of the launcher in the Launcher Properties dialog. For more
information on the elements in the Launcher Properties dialog, see Working With
Panels.
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4. Click OK.

To Delete an Item from a Menu
To delete an item from a menu, use the menu item popup menu. To delete an item
from a menu, perform the following steps:

1. Right-click on the item that you want to delete.
2. Choose Remove this item.
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CHAPTER 6

Working With Windows

The information in this chapter describes how to use windows in the desktop
environment. You can use several types of window manager with the GNOME
Desktop, for example, Metacity and Sawfish. Many of the functions in Metacity are
also available in Sawfish. This chapter describes the functions that are associated with
the Metacity window manager.

� “Windows and Workspaces” on page 85
� “Types of Window” on page 86
� “Menus and Applets for Working With Windows and Workspaces” on page 89
� “Manipulating Windows” on page 94
� “Manipulating Workspaces” on page 97

Windows and Workspaces
You can display many windows at the same time in your desktop environment. Your
windows are displayed in subdivisions of your desktop environment that are called
workspaces. A workspace is a discrete area in which you can work. Every workspace
in your desktop environment contains the same desktop, the same panels, and the
same menus. However, you can run different applications, and open different
windows in each workspace. You can display only one workspace at a time in your
desktop environment but you can have windows open in other workspaces.

The Workspace Switcher applet displays a visual representation of your windows and
workspaces, as show in Figure 6–1.

85



FIGURE 6–1 Workspace Switcher Applet

You can add workspaces at any time. To add workspaces to your desktop
environment, right-click on the Workspace Switcher applet, then choose Preferences.
The Workspace Switcher Preferences dialog is displayed. Use the Number of
workspaces spin box to specify the number of workspaces you require.

Window Manager Behavior
A window manager controls how windows appear and behave. The window manager
manages where your windows are located, and which window has focus. The window
frame contains buttons that enable you to perform standard actions such as moving,
closing, and resizing windows.

You can configure some window manager settings in the Windows preference tool.
This manual describes the functions that are associated with the default configuration
of the Metacity window manager. The default configuration is specified in the
Windows preference tool.

Types of Window
The desktop environment features the following types of windows:

� Application windows

When you start an application, an application window opens. The window
manager applies a frame to the application window. By default, the top edge of the
application window contains a titlebar. The titlebar contains buttons that you can
use to work with the window. The buttons in an application window frame enable
you to perform actions such as open the Window Menu, or close the window. The
Window Menu provides a number of actions that you can perform on the window.

The following figure shows a typical application window.
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� Dialog windows

A dialog window is a popup window in which you enter information or
commands. The dialog appears within a window frame.

You can use the top edge of the frame to work with the window. For example, you
can use the titlebar to move the dialog. The frame also contains buttons that enable
you to do the following:

� Open the Window Menu
� Close the dialog window

Typically, you open a dialog window from an application window. When you open
a dialog window, the window is usually raised and has focus. Some dialog
windows do not allow you to use the application until you close the dialog.

The following figure shows a typical dialog window.
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Window Frames
A window frame is a border around a window. The window frame contains a titlebar.
The titlebar contains buttons that you can use to work with the window.

Themes
You can apply several themes to your window frames. The theme determines how the
frame looks. To choose a theme for all your window frames, choose Applications →
Desktop Preferences → Theme.

Control Elements
You can use the window frame to perform various actions with the window. In
particular, the titlebar contains various buttons. The following figure shows the
titlebar of an application window:

Dialog windows also contain some of the window frame control elements. Table 6–1
describes the active control elements on window frames, from left to right.

TABLE 6–1 Window Frame Control Elements

Control Element Description

Window Menu button Click on the button to open the Window Menu.

Titlebar You can use the titlebar to perform the following
actions:
� To give focus to the window click on the titlebar.
� To move the window grab the titlebar and drag the

window to the new location.
� To shade the window, double-click on the titlebar.

To unshade the window, double-click on the
titlebar again.
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TABLE 6–1 Window Frame Control Elements (Continued)
Control Element Description

Minimize button Click on the Minimize button to minimize the
window.

Maximize button Click on the Maximize button to maximize the
window.

Close Window button Click on the Close Window button to close the
window.

Border The border around the window. Use the border to
perform the following actions:
� To resize the window grab the border and drag the

border to the new size.
� To open the Window Menu, right-click on the

border.

Window contents The area inside the window frame. Use the window
contents to perform the following actions:
� To move a window, press-and-hold Alt, click in the

window contents, then drag the window to the
new location.

� To resize a window, press-and-hold Alt, then
middle-click near the corner you want to resize. To
resize the window, drag from the corner on which
you middle-clicked.

� To open the Window Menu, press-and-hold Alt,
then right-click in the window contents.

Menus and Applets for Working With
Windows and Workspaces
This section describes the menus and applets that you can use to work with windows
and workspaces.

Window Menu
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The Window Menu is a menu of commands that you can use to perform actions on
your windows. To open the Window Menu perform one of the following actions:

� Click on the Window Menu button on the window that you want to work with.
� Press Alt + spacebar.
� Press-and-hold Alt, then right-click on any part of the window that you want to

work with.

Table 6–2 describes the commands and submenus in the Window Menu.

TABLE 6–2 Window Menu Commands and Submenus

Menu Item Function

Minimize Minimizes the window.

Maximize or Unmaximize Maximizes the window. If the window is already maximized,
choose Unmaximize to restore the window to its previous size.

Roll Up or Unroll Reduces a window so that only the titlebar is visible. If the
window is already rolled up, choose Unroll to restore the
window to its previous size.

Move Enables you to use the arrow keys to move the window.

Resize Enables you to use the arrow keys to resize the window.

Close Closes the window.

Put on All Workspaces or
Only on This Workspace

Puts the window on all of your workspaces. If the window is
already on all of your workspaces, choose Only on This
Workspace to put the window on the current workspace only.

Move to workspace-name or
Only on workspace-name

Moves the window to the workspace that you choose. If the
window is on all of your workspaces, choose Only on
workspace-name to put the window on the workspace that you
want.
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Window List Applet
Window List displays a button for each application window that is open. You can use
the Window List to perform the following tasks:

� To minimize a window

Click on the button that represents the window.

� To restore a minimized window

Click on the button that represents the window.

� To give focus to a window

Click on the button that represents the window.

When you open an application window, Window List displays a button that
represents the window. The window list buttons show which application windows are
open. You can view which windows are open even if some windows are minimized,
or other windows overlap a window. Window List can display buttons for the
windows in your current workspace, or in all workspaces. To select this option, you
must change the preferences of Window List.

You can also right-click on a window list button to open the Window Menu for the
window that the button represents. When you open the Window Menu from Window
List, the Window Menu does not contain the workspace commands. For more
information on the Window Menu commands, see “Window Menu” on page 89.

Figure 6–2 shows Window List when the following windows are open:

� gedit
� Dictionary
� GHex
� GNOME Terminal

FIGURE 6–2 Window List Applet

The buttons in the applet show the status of your windows. Table 6–3 explains the
information that the window list buttons provide about the window. The examples in
Table 6–3 refer to Figure 6–2.

TABLE 6–3 Window Status Information on Window List Buttons

State Indicates Example

Button is pressed in. The window has focus. gedit
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TABLE 6–3 Window Status Information on Window List Buttons (Continued)
State Indicates Example

Square brackets around
window title.

The window is minimized. [Dictionary]

Button is not pressed in, no
square brackets around title.

The window is displayed, and
is not minimized.

ghex

Numeral on button, in
parentheses.

The button represents a group
of buttons.

Gnome-terminal (3)

Grouping Buttons
Window List can group the buttons that represent windows in the same class under
one window list button. The Gnome-terminal button in Figure 6–2 is an example of a
button that represents a group of buttons. The following figure shows an example of
Window List with a button group open:

To open a list of the windows in a group, click on the window list button that
represents the group. You can click on the items in the list to give focus to windows,
minimize windows, and restore windows.

To open the Window Menu for a window in a button group, right-click on the window
list button that represents the group. A list of the windows in the group is displayed.
To open the Window Menu for a window in the group, click on the item in the list.
When you open the Window Menu from the Window List, the Window Menu does
not contain the workspace commands. For more information on the Window Menu
commands, see “Window Menu” on page 89.

Workspace Switcher Applet
Workspace Switcher displays a visual representation of your workspaces, as shown in
Figure 6–3. Figure 6–3 shows the applet when the GNOME session contains four
workspaces. Your workspaces appear as buttons on the applet. The background of the
button in the applet that represents the current workspace is highlighted. The current
workspace in Figure 6–3 is the workspace at the left of the applet. To switch to another
workspace, click on the workspace in the applet.
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FIGURE 6–3 Workspace Switcher Applet

Workspace Switcher also displays the application windows and dialogs that are open
in your workspaces.

The applet displays the workspaces in order from left to right across the rows of the
applet. In Figure 6–3, the applet is set up to display the workspaces in one row. You
can specify the number of rows in which your workspaces are displayed in Workspace
Switcher. You can also change the default behavior of the applet to display the names
of your workspaces in the applet.

Using the Top Edge Panel to Work With Windows
From the top edge panel, you can view a list of all windows that are currently open.
You can also choose a window to give focus to. To view the window list, click on the
icon at the extreme right of the top edge panel. The following figure shows an example
of the window list that is displayed from the top edge panel:

When the focus changes, the icon that you click on to display the window list changes.
The icon represents the window that currently has focus. To give focus to a window,
choose that window from the window list.

The window list lists the windows in all workspaces. The windows in all workspaces
other than the current workspace, are listed under a separator line.
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Manipulating Windows
This section describes how to manipulate windows.

To Give Focus to a Window
A window that has focus can receive input from the mouse and the keyboard. Only
one window can have focus at a time. The window that has focus has a different
appearance than other windows.

You can use the following elements to give focus to a window:

Element Action

Mouse Click on the window, if the window is visible.

Shortcut keys Use shortcut keys to switch between the windows that are
open. To give focus to a window, release the keys. The default
shortcut keys to switch between windows are Alt + Tab.

Window List Click on the button that represents the window in Window
List.

Workspace Switcher Click on the window that you want to give focus to in the
Workspace Switcher display. If you click on a window in
another workspace, Workspace Switcher switches to the new
workspace, and gives focus to the window.

Top edge panel Click on the icon at the extreme right of the top edge panel. A
list of your open windows is displayed. Choose the window
from the list.

To Minimize a Window
To minimize a window perform one of the following actions:

� Click on the Minimize button on the window frame.
� Open the Window Menu, then choose Minimize.
� If the window has focus, click on the button that represents the window in

Window List. If the window does not have focus, click twice on the button that
represents the window.

� Right-click on the button that represents the window in Window List, then choose
Minimize from the popup menu.
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To Maximize a Window
When you maximize a window, the window expands as much as possible. To
maximize a window perform one of the following actions:

� To maximize the window, click on the Maximize button on the window frame.
Alternatively, open the Window Menu, then choose Maximize.

� Right-click on the button that represents the window in Window List, then choose
Maximize from the Window Menu.

To Restore a Window
To restore a maximized window perform one of the following actions:

� Click on the Maximize button on the window frame.
� Open the Window Menu. Choose Unmaximize.
� Right-click on the button that represents the window in Window List to open the

Window Menu. Choose Unmaximize.

To restore a minimized window, click on the button that represents the window in
Window List.

To Close a Window
To close a window perform one of the following actions:

� Click on the Close Window button on the window frame.
� Open the Window Menu. Choose Close.
� Right-click on the button that represents the window in Window List, then choose

Close from the Window Menu.

If you have unsaved data in the window, you are prompted to save your data.

To Resize a Window
To resize a window perform one of the following actions:

� Point to a corner of the window. The mouse pointer changes to indicate that you
can resize the window. Grab the corner and drag the window to the new size.

� Right-click on the button that represents the window in Window List. Choose
Resize from the Window Menu. Use the arrow keys to resize the window.

� Press-and-hold Alt, then middle-click near the corner that you want to resize. The
mouse pointer changes to indicate that you can resize from the corner. To resize the
window, drag from the corner on which you middle-clicked.
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� To resize a window horizontally point to one of the vertical edges of the window.
The mouse pointer changes to indicate that you can resize the window. Grab the
edge and drag the window to the new size.

� To resize a window vertically point to the bottom edge of the window. The mouse
pointer changes to indicate that you can resize the window. Grab the edge and
drag the window to the new size.

Note – You cannot resize some dialog windows. Also, some application windows have
a minimum size below which you cannot reduce the window.

To Move a Window
To move a window perform one of the following actions:

� Grab the titlebar of the window and drag the window to the new location.
� Press-and-hold Alt, then drag the window to the new location.
� Open the Window Menu, then choose Move. Use the arrow keys to move the

window to the new location.
� Right-click on the button that represents the window in Window List, then choose

Move from the Window Menu. Use the arrow keys to move the window to the new
location.

To Roll Up a Window
You can roll up and roll down windows, as follows:

Roll up Reduce the window so that only the titlebar is visible.

Roll down Switch a window from a rolled-up state so that the full window is
displayed.

To roll up a window perform one of the following actions:

� Double-click on the titlebar of the window. To roll down the window, double-click
on the titlebar again.

� Open the Window Menu. Choose Roll Up. To roll down the window, choose
Unroll.

� Right-click on the button that represents the window in Window List, then choose
Roll Up from the Window Menu. To roll down the window, choose Unroll.
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To Put a Window on All Workspaces
To put a window in all workspaces, open the Window Menu. Choose Put on All
Workspaces. To set the window to appear only in the current workspace, choose Only
on This Workspace.

To Move a Window to Another Workspace
You can move a window to another workspace in either of the following ways:

� Use Workspace Switcher

In the Workspace Switcher display, drag the window to the workspace you require.

� Use the Window Menu

Open the Window Menu. To move the window to the next workspace choose
Move to workspace-name.

Manipulating Workspaces
This section describes how to manipulate workspaces.

To Switch Between Workspaces
You can switch between workspaces in any of the following ways:

� Use Workspace Switcher

Click on the workspace that you want to switch to in Workspace Switcher.

� Use shortcut keys

The default shortcut keys to switch between the workspaces are as follows:

Default Shortcut Keys Function

Ctrl + Alt + right arrow Selects the workspace to the right.

Ctrl + Alt + left arrow Selects the workspace to the left.
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To Add Workspaces
To add workspaces to your desktop environment, right-click on Workspace Switcher,
then choose Preferences. The Workspace Switcher Preferences dialog is displayed.
Use the Number of workspaces spin box to specify the number of workspaces you
require. Workspace Switcher adds new workspaces at the end of the workspace list.

To Name Workspaces
The default names of your workspaces are Workspace 1, Workspace 2, Workspace
3, and so on. To assign names to your workspaces, right-click on Workspace Switcher,
then choose Preferences. The Workspace Switcher Preferences dialog is displayed.
Use the Workspaces list box to specify the names of your workspaces. Select a
workspace, then type the new name for the workspace.

To Delete Workspaces
When you delete a workspace the windows in the workspace are moved to another
workspace, and the empty workspace is deleted.

To delete workspaces from your desktop environment, right-click on Workspace
Switcher, then choose Preferences. The Workspace Switcher Preferences dialog is
displayed. Use the Number of workspaces spin box to specify the number of
workspaces you require. Workspace Switcher deletes workspaces from the end of the
workspace list.
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CHAPTER 7

Nautilus File Manager

This chapter describes how to use the Nautilus file manager.

� “Introduction to Nautilus File Manager” on page 99
� “File Manager Windows” on page 100
� “Navigating Your Computer” on page 105
� “Managing Your Files and Folders” on page 113
� “Modifying the Appearance of Files and Folders” on page 121
� “Assigning Actions to Files” on page 128
� “Customizing the File Manager” on page 129
� “Using Removable Media” on page 135
� “Writing CDs” on page 138
� “Running Scripts From the File Manager” on page 139

Introduction to Nautilus File Manager
The Nautilus file manager provides an integrated access point to your files and
applications. The file manager enables you to do the following:

� Display your files and folders.
� Manage your files and folders.
� Run scripts.
� Customize your files and folders.
� Open special URI locations.
� Write data to a CD.

Nautilus also manages the desktop. The desktop lies behind all of the other
components on your visible desktop. The desktop is an active component of the user
interface.

File manager windows enable you to display and manage your files and folders. You
can open a file manager window in any of the following ways:

99



� Double-click on the Home object on the desktop.
� Choose Applications → Home Folder.
� Right-click on the desktop to open the Desktop menu. Choose New Window.

The file manager window displays the contents of your home location in the view
pane.

File Manager Windows
File manager windows enable you to display and manage your files and folders.
Figure 7–1 shows a file manager window that displays the contents of a folder.

FIGURE 7–1 Contents of a Folder in a File Manager Window

Table 7–1 describes the components of file manager windows.
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TABLE 7–1 File Manager Window Components

Component Description

Menubar Contains menus that you use to perform tasks in the file manager.

Toolbar Contains buttons that you use to perform tasks in the file
manager.

Location bar Contains the following elements:
� Location field or Go To field: Enables you to specify a file,

folder, or URI that you want to view.
� Zoom buttons: Enable you to change the size of items in the

view pane.
� View as drop-down list: Enables you to choose how to show

items in your view pane.

Side pane Performs the following functions:
� Shows information about the current file or folder.
� Enables you to navigate through your files.

The side pane contains a drop-down list that enables you to
choose what to show in the side pane. You can choose from the
following options:
� Information
� Emblems
� History
� Notes
� Tree

View pane Shows the contents of the following:
� Particular types of files
� Folders
� FTP sites
� Locations that correspond to special URIs

Statusbar Displays status information.

You can also open a popup menu from file manager windows. To open this popup
menu right-click in a file manager window. The items in this menu depend on where
you right-click. For example, when you right-click on a file or folder, you can choose
items related to the file or folder. When you right-click on the background of a view
pane, you can choose items related to the display of items in the view pane.

View Pane
The view pane can display the contents of the following:

� Particular types of files
� Folders
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� FTP sites
� Locations that correspond to special URIs

The file manager contains viewer components that enable you to display particular types
of file in the view pane. For example, you can use a text viewer to display text files in
the view pane. Figure 7–2 shows a text file displayed in the view pane.

FIGURE 7–2 Text File in a File Manager Window

Displaying a file in the view pane provides the following benefits:

� Uses less system resources than when you launch an application.
� Takes less time than when you launch an application.

However, you cannot edit a file in the view pane.

The file manager also includes views that enable you to display the contents of your
folders in different ways. For example, you can display the contents of a folder in the
following types of view:

� Icon view: Shows the items in the folder as icons.
� List view: Shows the items in the folder as a list.
� Audio view: Shows only the audio items in the folder.

Use the View menu to choose how to display a folder. For more information on views,
see “Using Views to Display Your Files and Folders” on page 123.
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Side Pane
To display the side pane, choose View → Side Pane. You can choose what information
you want to view in the side pane. You can choose to display one of the following:

� Information

Displays an icon that represents the current file or current folder. Also displays
information about the current file or current folder. If a file is displayed in the view
pane, buttons appear in the side pane. The buttons enable you to perform actions
on a file, other than the default action.

� Emblems

Contains emblems that you can add to a file or folder. For more information on
emblems, see the next section.

� History

Contains a history list of files, folders, FTP sites, and URIs that you have recently
visited.

� Notes

Enables you to add notes to your files and folders.
� Tree

Displays a hierarchical representation of your file system. You can use the Tree to
navigate through your files.

To close the side pane, click on the X button at the top right of the side pane.

Icons and Emblems
In icon view, the file manager displays your files and folders as icons. You can add
emblems to your file icons and folder icons. An emblem is a small icon that you can
add to an item to visually mark the item. For example, to mark a file as important, you
can add an Important emblem to the file icon to create the following visual effect:

For more information on how to add an emblem to an icon, see “To Add an Emblem
to a File or Folder” on page 121.

The following table describes the structure of the file icon:
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Component Description

Emblem. This emblem is the Important emblem.

Icon that represents the file. This icon mioght contain a
preview of the contents of the file.

Icon caption. You can modify what items of information are
displayed in the icon caption.

The file manager includes default emblems for the following types of item:

� Symbolic links

� Items for which you have the following permissions:

� Read permission only
� No read permission and no write permission

The following table shows the default emblems:

Default Emblem Description

Symbolic link

Read permission only

No read permission and no write permission
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Navigating Your Computer
Each file manager window displays the contents of a single file, folder, FTP site, or
special URI location. This section describes the following:

� How to display items in file manager windows.
� How to open files from file manager windows.
� How to navigate the files and folders in your file system.
� How to navigate to FTP sites.
� How to access special URI locations.

To Display Your Home Location

To display your home location, perform one of the following actions:

� Double-click on the Home object on the desktop.
� On a file manager window, choose Go → Home.
� On a file manager window, click on the Home toolbar button.

The file manager window displays the contents of your home location. To reload the
display, click on the Reload button.

To Display a Folder
You can display the contents of a folder in any of the following ways:

� Double-click on the folder in the view pane.
� In the Location field, type the path of the folder that you want to display, then

press Return. The Location field includes an autocomplete feature. As you type a
path, the file manager reads your file system. When you type enough characters to
uniquely identify a directory, the file manager completes the name of the directory
in the Location field.

� Use the Tree in the side pane. For more information, see “Using the Tree From the
Side Pane” on page 106.

� Use the Back toolbar button and the Forward toolbar button to browse through
your navigation history.
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To change to the folder that is one level above the current folder, choose Go → Up.
Alternatively, click on the Up toolbar button.

To reload the display, click on the Reload button.

If you cannot find the folder that you want to display, you can use Search Tool. To start
Search Tool, choose Actions → Search for Files.

Using the Tree From the Side Pane
The Tree displays a hierarchical representation of your file system. The Tree provides a
convenient way to navigate your file system. To display the Tree in the side pane,
choose Tree from the drop-down list at the top of the side pane.

In the Tree, folders are represented as follows:

Folder State Graphic Representation

Closed folder Right arrow

Open folder Down arrow

Table 7–2 describes the tasks that you can perform with the Tree, and how to perform
the tasks.

TABLE 7–2 Tree Tasks

Task Action

Open the Tree. Choose Tree from the drop-down list at the
top of the side pane.

Close the Tree. Choose another item from the drop-down list
at the top of the side pane.

Open a folder in the Tree. Click on the arrow next to the folder in the
Tree.

Close a folder in the Tree. Click on the arrow next to the folder in the
Tree.

Display the contents of a folder in the view
pane.

Select the folder in the Tree.

Display the contents of a file in the view pane. Select the file in the Tree.

You can set your preferences so that the Tree does not display files. For more
information, see “To Set Views Preferences” on page 130.
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Opening Files
When you open a file, the file manager performs the default action for that file type.
The default action can be one of the following:

� Use a viewer component to display the file in the view pane.
� Launch an application that opens the file.

The file manager checks the contents of a file to determine the type of a file. If the first
lines do not determine the type of the file, then the file manager checks the file
extension.

If you cannot find the file that you want to open, you can use Search Tool. To start
Search Tool, choose Actions → Search for Files.

Viewing Files in the View Pane
The file manager contains viewer components that enable you to display particular
types of file in the view pane. For example, you can display the following types of files
in the view pane:

� Plain text files
� PNG files
� Joint Photographic Experts Group (JPEG) files

To reload the contents of the view pane, choose View → Reload. To stop loading an
item in the view pane, choose View → Stop.

When you display a file in the view pane, the viewer component might add menu
items to the file manager menus. The menu items relate to the file type that is
displayed. For example, when you display a PNG file, the Edit menu contains flip and
rotate menu items.

Also, when you display some types of file in the view pane, you can use the file
manager zoom buttons to change the size of the item.

To Execute the Default Action
To execute the default action for a file, double-click on the file. For example, if the
default action for plain text documents is to display the file in a text viewer. In this
case, you can double-click on the file to display the file in a text viewer.

You can set your file manager preferences so that you click once on a file to execute the
default action. For more information, see “To Set Behavior Preferences” on page 131.
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To Execute Non-Default Actions Using the Open With
Submenu
To execute actions other than the default action for a file, perform the following steps:

1. In the view pane, select the file that you want to perform an action on. Choose File
→ Open With. The Open With submenu opens. The items in this submenu
correspond to the contents of the following parts of the File Types and Programs
preference tool:

� Default action drop-down list in the Edit file type dialog
� Viewer component drop-down list in the Edit file type dialog

2. Choose an action from the Open With submenu.

To Execute Other Actions When Displaying a File
When you display a file in the view pane, the side pane might contain buttons. Figure
7–2 shows the buttons in the side pane when a text file is displayed in the view pane.

The buttons represent any actions that are defined in the File Types and Programs
preference tool. The actions are defined in the Default action drop-down list in the
Edit file type dialog in the File Types and Programs preference tool. Click on a button
to execute an action. For example, if an action defined for plain text documents is to
open the file in gedit. If this action is defined, an Open with gedit button is displayed
in the side pane. To open the file in the gedit application, click on the Open with gedit
button.

Note – A button that represents the action does not appear in the side pane if the
actions are excluded in either of the following dialogs:

� Open with Other Application
� Open with Other Viewer

Using the Start Here Location

The Start Here location enables you to access the following functions:
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� Applications

Double-click on Applications to access your key GNOME applications. You can
also access the Applications menu through the Main Menu and the Menu Bar.

� Desktop Preferences

Double-click on Desktop Preferences to customize your desktop environment. You
can also access the desktop environment preference tools through the Applications
menu.

� Applications that enable you to configure your system as a server, and to choose
other system settings.

You can access the Start Here location in the following ways:

� From a file manager window

Choose Go → Start Here. The contents of the Start Here location are displayed in
the window.

� From the desktop

Double-click on the Start Here object on the desktop. The contents of the Start
Here location are displayed in a file manager window.

To Access FTP Sites
You can use the file manager to access FTP sites. To access an FTP site, enter the URL
for the site in the field on the location bar, then press Return. The contents of the site
are displayed in the view pane. To copy a file from the FTP site, drag the file to the
new location.

To access an FTP site that requires a username and password, you can enter the URL
in the following form:

ftp://username:password@hostname.domain

To reload the FTP site in the view pane, choose View → Reload. To stop loading the
FTP site, choose View → Stop.

To Access Network Servers
If your desktop environment is configured to access servers on a network, you can use
the file manager to access the network servers.

To access network servers, choose Applications → Network Servers. A file manager
window is displayed. The window displays the network servers that you can access.
Double-click on the network server that you want to access.

To access Windows shares, double-click on the Network Neighborhood icon. A list of
the Windows shares available to you is displayed in the file manager window.

Chapter 7 • Nautilus File Manager 109



Location URI

Network servers network:///

NFS servers nfs:///

Shares on Windows servers smb:///

To Add a Network Server
To add a network server, choose Applications → Network Servers. A file manager
window is displayed. Double-click on the New Server object. A New Server dialog is
displayed. Enter the name of the server in the dialog, then click OK.

Accessing Special URI Locations
The GNOME Desktop contains special URI locations that enable you to access
particular functions from the file manager. For example, to access the preference tools,
you can access the preferences:/// URI in a file manager window. The following
table lists the special URI locations that you can use with the file manager:

URI Location Description

applications:/// Displays a list of the applications in your desktop
environment. The applications are the same as the
applications in the Applications menu. To open an
application, double-click on the application.

burn:/// Copy files and folders that you want to write to a CD to this
location. You can write the contents of this location to a CD.

fonts:/// Displays all the fonts that are available in your desktop
environment. To preview a font, double-click on the font. You
can also use this location to add fonts to your desktop
environment.

network:/// Displays network servers, if your desktop environment is
configured to access servers on a network. To access a
network server, double-click on the network server. You can
also use this location to add network servers to your desktop
environment.

nfs:/// Displays NFS network servers, if your desktop environment is
configured to access NFS servers. To access an NFS network
server, double-click on the NFS network server.
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URI Location Description

preferences:/// Displays a list of the preference tools in your desktop
environment. The preference tools are the same as the
preference tools in the Desktop Preferences menu. To open a
preference tool, double-click on the preference tool.

server-settings:/// Displays a list of applications that you can use to configure
your system as a server.

smb:/// Displays Windows servers, if your desktop environment is
configured to access Windows servers. To open a Windows
server, double-click on the Windows server.

start-here:/// Displays a list of applications and preference tools in your
desktop environment. Also displays applications that you can
use to configure your system as a server, and to modify your
system settings.

system-settings:/// Displays a list of applications that you can use to modify your
system settings.

themes:/// Displays all the themes that are available in your desktop
environment. To preview a theme, double-click on the theme.
You can also use this location to add themes to your desktop
environment.

Using Your Navigation History
The file manager maintains a history list of files, folders, and FTP sites. You can use
the history list to navigate to files, folders, and FTP sites that you have recently visited.
Your history list contains the last ten items that you viewed. The following sections
describe how to navigate your history list.

To clear your history list choose Go → Clear History.

To Navigate Your History List Using the Go Menu
To display a list of previously-viewed items, choose the Go menu. Your history list is
displayed in the lower part of the Go menu. To open an item in your history list,
choose the item from the Go menu.

To Navigate Your History List Using the Toolbar
To use the toolbar to navigate your history list, perform one of the following actions:

� To open the previous file, folder, or URL in your history list, click on the Back
toolbar button.
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� To open the next file, folder, or URL in your history list, click on the Forward
toolbar button.

� To display a list of previously-viewed items, click on the down arrow to the right
of the Back toolbar button. To open an item from this list, click on the item.

� To display a list of items that you viewed after you viewed the current item, click
on the down arrow to the right of the Forward toolbar button. To open an item
from this list, click on the item.

To Navigate Your History List Using History in the Side
Pane
To display the History list in the side pane, choose History from the drop-down list at
the top of the side pane. The History list in the side pane displays a list of your
previously-viewed items.

To display an item from your history list in the view pane, click on the item in the
History list.

To Bookmark Your Favorite Locations
To access an item in your bookmarks, choose the item from the Bookmarks menu. You
can add your favorite locations to your Bookmarks menu. You can add bookmarks to
files and folders in your file system, or to FTP sites.

To Add a Bookmark
To add a bookmark, display the item that you want to bookmark in the view pane.
Choose Bookmarks → Add Bookmark.

To Edit a Bookmark
To edit your bookmarks perform the following steps:

1. Choose Bookmarks → Edit Bookmarks. An Edit Bookmarks dialog is displayed.

2. To edit a bookmark, select the bookmark on the left side of the Edit Bookmarks
dialog. Edit the details for the bookmark on the right side of the Edit Bookmarks
dialog, as follows:
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Dialog Element Description

Name Use this text box to specify the name that identifies the bookmark
in the Bookmarks menu.

Location Use this field to specify the location of the bookmark.

3. To delete a bookmark, select the bookmark on the left side of the dialog. Click
Delete.

Managing Your Files and Folders
This section describes how to work with your files and folders.

Drag-and-Drop in the File Manager
You can use drag-and-drop to perform several tasks in the file manager. When you
drag-and-drop, the mouse pointer provides feedback about the task that you perform.
Table 7–3 describes the tasks that you can perform with drag-and-drop. The table also
shows the mouse pointers that appear when you drag-and-drop.

TABLE 7–3 Drag-and-Drop in the File Manager

Task Action Mouse Pointer

Move an item Drag the item to the new location.

Copy an item Grab the item, then press-and-hold Ctrl. Drag the item
to the new location.

Create a symbolic
link to an item

Grab the item, then press-and-hold Ctrl + Shift. Drag
the item to the location where you want the symbolic
link to reside.
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TABLE 7–3 Drag-and-Drop in the File Manager (Continued)
Task Action Mouse Pointer

Ask what to do
with the item you
drag

Grab the item, then press-and-hold Alt. Drag the item
to the location where you want the item to reside.
Release the mouse button. A popup menu appears.
Choose one of the following items from the popup
menu:
� Move here

Moves the item to the location.
� Copy here

Copies the item to the location.
� Link here

Creates a symbolic link to the item at the location.
� Set as Background

If the item is an image, sets the image to be the
desktop background. You can use this command to
set the desktop background and the view pane
background.

� Cancel
Cancels the drag-and-drop operation.

To Select Files and Folders
You can select files and folders in several ways in the file manager. Table 7–4 describes
how to select items in file manager windows and on the desktop.

TABLE 7–4 Selecting Items in the File Manager

Task Action

Select an item Click on the item.

Select a group of contiguous
items

In icon view, drag around the files that you want to select.

In list view, click on the first item in the group.
Press-and-hold Shift, then click on the last item in the
group.

Select multiple items Press-and-hold Ctrl. Click on the items that you want to
select.

Alternatively, press-and-hold Ctrl, then drag around the
files that you want to select.

Select all items in a folder Choose Edit → Select All Files.

To perform the default action on an item, double-click on the item. You can set your
file manager preferences so that you click once on a file to execute the default action.
For more information, see “To Set Behavior Preferences” on page 131.
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To Move a File or Folder
The following sections describe the ways that you can move a file or folder.

Drag to the New Location in a View Pane
To drag a file or folder to a new location in a view pane, perform the following steps:

1. Open a file manager window. Choose File → New Window to open a second file
manager window.

2. In one window, select the folder from which you want to move the file or folder. In
the other window, select the folder to which you want to move the file or folder.

3. Drag the file or folder that you want to move to the new location in the other
window.

To move the file or folder to a folder that is one level below the current location, do
not open a new window. Instead, drag the file or folder to the new location in the
same window.

Cut and Paste to the New Location
You can cut a file or folder and paste the file or folder into another folder, as follows:

1. Select the file or folder that you want to move, then choose Edit → Cut File.

2. Open the folder to which you want to move the file or folder, then choose Edit →
Paste Files.

To Copy a File or Folder
The following sections describe the ways you can copy a file or folder.

Drag to the New Location in a View Pane
To copy a file or folder perform the following steps:

1. Open a file manager window. Choose File → New Window to open a second file
manager window.

2. In one window, select the folder from which you want to copy the file or folder. In
the other window, select the folder to which you want to copy the file or folder.

3. Grab the file or folder, then press-and-hold Ctrl. Drag the file or folder to the new
location in the other window.

To copy the file or folder to a folder that is one level below the current location, do not
open a new window. Instead, grab the file or folder, then press-and-hold Ctrl. Drag the
file or folder to the new location in the same window.
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Copy and Paste to the New Location
You can copy a file or folder and paste the file or folder into another folder, as follows:

1. Select the file or folder that you want to copy, then choose Edit → Copy File.

2. Open the folder to which you want to copy the file or folder, then choose Edit →
Paste Files.

To Duplicate a File or Folder
To create a copy of a file or folder in the current folder perform the following steps:

1. Select the file or folder that you want to duplicate in the view pane.

2. Choose Edit → Duplicate. Alternatively, right-click on the file or folder in the view
pane, then choose Duplicate.

A copy of the file or folder appears in the current folder.

To Create a Folder
To create a folder perform the following steps:

1. Select the folder where you want to create the new folder.

2. Choose File → New Folder. Alternatively, right-click on the background of the view
pane, then choose New Folder.

An untitled folder is added to the view pane. The name of the folder is selected.

3. Type a name for the folder, then press Return.

To Rename a File or Folder
To rename a file or folder perform the following steps:

1. Select the file or folder that you want to rename in the view pane.

2. Choose Edit → Rename. Alternatively, right-click on the file or folder in the view
pane, then choose Rename.

The name of the file or folder is selected.

3. Type a new name for the file or folder, then press Return.

To Move a File or Folder to Trash
To move a file or folder to Trash perform the following steps:

1. Select the file or folder that you want to move to Trash in the view pane.
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2. Choose Edit → Move to Trash. Alternatively, right-click on the file or folder in the
view pane, then choose Move to Trash.

Alternatively, you can drag the file or folder from the view pane to the Trash object on
the desktop.

Note – When you move a file or folder from a removable media to Trash, the file or
folder is stored in a Trash location on the removable media. To remove the file or
folder permanently from the removable media, you must empty Trash.

To Delete a File or Folder
When you delete a file or folder, the file or folder is not moved to Trash, but is deleted
from your file system immediately. The Delete menu item is only available if you
select the Include a Delete command that bypasses Trash option in the File
Management Preferences dialog.

To delete a file or folder perform the following steps:

1. Select the file or folder that you want to delete in the view pane.

2. Choose Edit → Delete. Alternatively, right-click on the file or folder in the view
pane, then choose Delete.

To Create a Symbolic Link to a File or Folder
A symbolic link is a special type of file that points to another file or folder. When you
perform an action on a symbolic link, the action is performed on the file or folder to
which the symbolic link points. However, when you delete a symbolic link, you delete
the link file, not the file to which the symbolic link points.

To create a symbolic link to a file or folder, select the file or folder to which you want
to create a link. Choose Edit → Make Link. A link to the file or folder is added to the
current folder.

Alternatively, grab the item to which you want to create a link, then press-and-hold
Ctrl + Shift. Drag the item to the location where you want to place the link.

By default, the file manager adds an emblem to symbolic links.

Note – The permissions of a symbolic link are determined by the file or folder to which
a symbolic link points.
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To View the Properties of a File or Folder
To view the properties of a file or folder, perform the following steps:

1. Select the file or folder whose properties you want to view.
2. Choose File → Properties. A properties dialog is displayed.
3. Use the properties dialog to view the properties of the desktop object.
4. Click Close to close the properties dialog.

To Change Permissions
Permissions are settings assigned to each file and folder that determine what type of
access users can have to the file or folder. The following table lists the permissions that
you can set for files and folders, and the effect of the permission on files and folders:

Permission File Folder

Read Permission to read the file. Permission to list the contents of the
folder.

Write Permission to make changes to the
file.

Permission to create and delete files in
the folder.

Execute Permission to run the file as a
program. This is only relevant if the
file is a program or script.

Permission to access files in the
directory.

You can set permissions for different types of user. The following table lists the types
of user that you can set for which you can set permissions:

User Category Description

Owner The user that created the file or folder.

Group The group to which the owner belongs.

Others All other users who are not in the group to which the owner
belongs.

To change the permissions on a file or folder perform the following steps:

1. Select the file or folder that you want to change.

2. Choose File → Properties. A properties dialog is displayed.

3. Click on the Permissions tab. In the Permissions tabbed section, use the
drop-down lists and check boxes to change the permissions for the file or folder.
The following table describes the dialog elements on the Permissions tabbed
section:
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Element Description

File owner To change the owner of the file or folder, select the
owner from the drop-down list.

File group To change the group to which a file or folder belongs,
select the group from the drop-down list.

Owner Select the permissions that you want to apply to the
owner of the file or folder.

Group Select the permissions that you want to apply to the
group to which the owner of the file or folder belongs.

Others Select the permissions that you want to apply to all
other users who are not in the group to which the
owner belongs.

Text view Displays the permissions that you select from the Read,
Write, and Execute options, in text format.

Number view Displays the permissions that you select from the Read,
Write, and Execute options, in text format.

Last changed Displays the date and time that the file or folder was
last modified.

4. Click Close to close the properties dialog.

Adding Notes to Files and Folders
You can add notes to files or folders. You can add notes to files or folders in the
following ways:

� From the properties dialog
� From Notes in the side pane

To Add a Note Using the Properties Dialog
To add a note to a file or folder, perform the following steps:

1. Select the file or folder to which you want to add a note.

2. Choose File → Properties. A properties dialog is displayed.

3. Click on the Notes tab. In the Notes tabbed section, type the note.

4. Click Close to close the properties dialog. A note emblem is added to the file or
folder.

To delete a note, delete the note text from the Notes tabbed section.
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To Add a Note Using Notes in the Side Pane
To add a note to a file or folder, perform the following steps:

1. Open the file or folder to which you want to add a note in the view pane.

2. Choose Notes from the drop-down list at the top of the side pane. To display the
side pane, choose View → Side Pane.

3. Type the note in the side pane. A note emblem is added to the file or folder in the
view pane, and a note icon is added to the side pane. You can click on this icon to
display the note.

To delete a note, delete the note text from Notes in the side pane.

Using Trash

You can move the following items to Trash:

� Files
� Folders
� Desktop objects

If you need to retrieve a file from Trash, you can display Trash and move the file out
of Trash. When you empty Trash, you delete the contents of Trash permanently.

To Display Trash
You can display the contents of Trash in the following ways:

� From a file manager window

Choose Go → Trash. The contents of Trash are displayed in the window.
� From the desktop

Double-click on the Trash object on the desktop.

To Empty Trash
You can empty the contents of Trash in the following ways:

� From a file manager window
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Choose File → Empty Trash.
� From the desktop

Right-click on the Trash object, then choose Empty Trash.

Modifying the Appearance of Files and
Folders
The file manager enables you to modify the appearance of your files and folders in
several ways, as described in the following sections.

To Add an Emblem to a File or Folder
To add an emblem to an item perform the following steps:

1. Select the item to which you want to add an emblem.

2. Right-click on the item, then choose Properties. A properties dialog is displayed.

3. Click on the Emblems tab to display the Emblems tabbed section.

4. Select the emblem to add to the item.

5. Click Close to close the properties dialog.

To Add a New Emblem
To add a new emblem, perform the following steps:

1. Choose Edit → Backgrounds and Emblems.

2. Click on the Emblem button, then click on the Add a New Emblem button. A
Create a New Emblem dialog is displayed.

3. Type a name for the emblem in the Keyword text box.

4. Click on the Image button. A dialog is displayed. Choose an emblem from the
dialog. Alternatively, to choose an emblem from another directory, click Browse.
When you choose an emblem, click OK.

5. Click OK on the Create a New Emblem dialog.

To Change the Icon for a File or Folder
To change the icon that represents an individual file or folder, perform the following
steps:
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1. Select the file or folder that you want to change.

2. Choose File → Properties. A properties dialog is displayed.

3. On the Basic tabbed section, click on the Select Custom Icon button. A Select an
icon dialog is displayed.

4. Use the Select an icon dialog to choose the icon to represent the file or folder.

5. Click Close to close the properties dialog.

To restore an icon from a custom icon to the default icon specified in the File Types
and Programs preference tool, right-click on the icon then choose Remove Custom
Icon. Alternatively, click on the Remove Custom Icon button on the Properties dialog.

To change the icon that represents a file type, use the File Types and Programs
preference tool.

To Change the Size of Items in a View
You can change the size of items in a view. You can change the size if the view
displays a file or a folder. You can change the size of items in a view in the following
ways:

� To enlarge the size of items in a view, choose View → Zoom In.
� To reduce the size of items in a view, choose View → Zoom Out.
� To return items in a view to the normal size, choose View → Normal Size.

You can also use the zoom buttons on the location bar to change the size of items in a
view. Table 7–5 describes how to use the zoom buttons.

TABLE 7–5 Zoom Buttons

Button Button Name Description

Zoom Out button Click on this button to reduce the size of
items in a view.

Normal Size button Click on this button to return items in a
view to normal size.
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TABLE 7–5 Zoom Buttons (Continued)
Button Button Name Description

Zoom In button Click on this button to enlarge the size of
items in a view.

The file manager remembers the size of items in a particular folder. The next time that
you display the folder, the items are displayed in the size that you selected. In other
words, when you change the size of items in a folder, you customize the folder to
display the items at that size. To return the size of the items to the default size
specified in your preferences, choose View → Reset View to Defaults.

Using Views to Display Your Files and Folders
The file manager provides several ways to display the contents of your files. The file
manager includes viewer components that enable you to display particular types of
file in the view pane. For example, you can use a web page viewer to display HTML
files in the view pane. You can use a text viewer to view plain text files in the view
pane.

You can also use the file manager to open a file in an appropriate application. For
more information, see “Opening Files” on page 107.

The file manager includes views that enable you to show the contents of your folders
in different ways. For example, you can show the contents of a folder in the following
types of view:

� Icon view

Shows the items in the folder as icons. Figure 7–1 shows a folder in icon view.

� List view

Shows the items in the folder as a list. Figure 7–3 shows a folder in list view.
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FIGURE 7–3 File Manager Window in List View

� Audio view

Shows the audio items in the folder only, and displays controls that enable you to
play the audio files. Figure 7–4 shows a folder in audio view.

FIGURE 7–4 File Manager Window in Audio View
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Use the View menu to choose how to display a file or folder. You can also use the
View as drop-down list to choose how to display a file or folder. When you display a
folder, you can specify how you want to arrange or sort items in the folder. You can
modify the size of the items in the view pane. The following sections describe how to
work with icon view, list view, and views of files.

To Choose a View in Which to Display a File or Folder
Choose the type of view in which to display the contents of a file or folder from the
View menu.

Alternatively, to choose a view, choose View → View as. Select the view that you want
to use from the Open with Other Viewer dialog, then click on the Choose button.

You can also choose the type of view from the View as drop-down list. The View as
drop-down list is located at the right side of the location bar.

You can display different folders in different views. The file manager remembers the
view that you choose for a particular folder. The next time that you display the folder,
the file manager displays the folder in that view. To return the view for the folder to
the default view specified in your preferences, choose View → Reset View to Defaults.

To Arrange Your Files in Icon View
When you display the contents of a folder in icon view, you can specify how to
arrange the items in the folder. To specify how to arrange items in icon view, choose
View → Arrange Items. The Arrange Items submenu contains the following sections:

� The top section contains an option that enables you to arrange your files manually.

� The middle section contains options that enable you to sort your files
automatically.

� The bottom section contains options that enable you to modify how your files are
arranged.

Choose the appropriate options from the submenu, as described in the following table:

Option Description

Manually Select this option to arrange the items manually. To arrange the
items manually, drag the items to the location you require within
the view pane.

By Name Select this option to sort the items alphabetically by name. The
order of the items is not case sensitive. If the file manager is set to
display hidden files, the hidden files are shown last.
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Option Description

By Size Select this option to sort the items by size, with the largest item
first. When you sort items by size, the folders are sorted by the
number of items in the folder. The folders are not sorted by the
total size of the items in the folder.

By Type Select this option to sort the items alphabetically by object type.
The items are sorted alphabetically by the description of their
MIME type in the File Types and Programs preference tool. The
MIME type identifies the format of a file, and enables applications
to read the file. For example, an email application can use the
image/png MIME type to detect that a PNG file is attached to an
email.

By Modification Date Select this option to sort the items by the date the items were last
modified. The most recently modified item is first.

By Emblems Select this option to sort the items by any emblems that are added
to the items. The items are sorted alphabetically by emblem name.
Items that do not have emblems are last.

Compact Layout Select this option to arrange the items so that the items are closer
to each other.

Reversed Order Select this option to reverse the order of the option by which you
sort the items. For example, if you sort the items by name, select
the Reversed Order option to sort the items in reverse alphabetical
order.

The file manager remembers how you arrange the items in a particular folder. The
next time that you display the folder, the items are arranged in the way that you
selected. In other words, when you specify how to arrange the items in a folder, you
customize the folder to display the items in that way. To return the arrangement
settings of the folder to the default arrangement settings specified in your preferences,
choose View → Reset View to Defaults.

To Resize an Icon in Icon View
In icon view, you can change the size of the icon that represents an item that is
displayed. To change the size of an item in icon view, perform the following steps:

1. Right-click on the item that you want to resize, then choose Stretch Icon. A
rectangle appears around the item, with a handle at each corner.

2. Grab one of the handles, then drag the icon to the size that you want.

To return the icon to the original size, right-click on the icon, then choose Restore
Icon’s Original Size.

You can also resize objects on the desktop.
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To Modify the Behavior of a View
You can modify the behavior of a view in the following ways:

� Specify that the view is the default view for a particular file or folder.

� Specify that the view is the default view for a file type or all folders.

� Specify that the view is an item in the View as submenu for a particular file or
folder.

� Specify that the view is an item in the View as submenu for all of a particular file
type or for all folders.

� Specify that the view is not an item in the View as submenu for a particular file or
folder.

To modify the behavior of a view perform the following steps:

1. Choose View → View as. An Open with Other Viewer dialog is displayed.

2. Select the view that you want to modify from the table in the dialog.

3. Click on the Modify button. A Modify dialog is displayed. The following table
describes the options on the Modify dialog:

Option Description

Include in the menu for
item-name items

Select this option to include the view in the View as
submenu for this type of item.

Use as default for item-name
items

Select this option to use the view as the default for this
type of item.

Include in the menu for
item-name only

Select this option to include the view in the View as
submenu for this item only.

Use as default for item-name
only

Select this option to use the view as the default for this
item only.

Don’t include in the menu for
item-name items

Select this option to exclude the view from the View as
submenu for this type of item.

4. Click OK, then click Cancel to close the Open with Other Viewer dialog.

Note – You can also modify the actions that are associated with a file type in the File
Types and Programs preference tool. To open the File Types and Programs preference
tool, click on the Go There button.
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Assigning Actions to Files
When you open a file, the file manager performs the default action for that file type.
The File Types and Programs preference tool contains a table of file types, their
associated file extensions, and their default actions. This table specifies what happens
when you double-click on a file in the file manager.

You can also use the file manager to modify the actions that are associated with a
particular file or file type.

You can use the File Types and Programs preference tool to perform the following
tasks:

� Specify the default action for a file type. You can also change the default action for
a file type in the file manager.

� Associate a file type with one or more applications. The default action might
specify to open the file in an application that is associated with the file type.

� Associate a file type with one or more viewers. The default action might specify to
open the file in a viewer that is associated with the file type.

� Associate a file extension with a MIME type. The MIME type specifies the format
of the file so that Internet browsers and email applications can read the file.

To Modify Actions
You can modify the actions associated with a file or file type. You can do the following:

� Specify that the action is the default action for a particular file.
� Specify that the action is the default action for a particular file type.
� Specify that the action is an item in the Open With submenu for a particular file.
� Specify that the action is an item in the Open With submenu for a particular file

type.
� Specify that the action is not an item in the Open With submenu for a particular file

type.

To modify the actions associated with a file or file type, perform the following steps:

1. In the view pane, select the file for which you want to modify an action. If you
want to modify an action associated with a file type, select a file of that type.

2. Choose File → Open With. Perform either of the following steps:

� Choose Other Application. An Open with Other Application dialog is
displayed.

� Choose Other Viewer. An Open with Other Viewer dialog is displayed.
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3. From the table in the dialog, select the application or viewer for which you want to
modify the behavior.

4. Click on the Modify button. A Modify dialog is displayed. The following table
describes the options on the Modify dialog:

Option Description

Include in the menu for filetype
items

Select this option to include the application or viewer in
the Open With submenu for this file type.

Use as default for filetype items Select this option to use the application or viewer as the
default action for this file type.

Include in the menu for
filename only

Select this option to include the application or viewer in
the Open With submenu for this file, and not for other
files of this type.

Use as default for filename only Select this option to use the application or viewer as the
default action for this file, and not for other files of this
type.

Don’t include in the menu for
filetype items

Select this option to exclude the application or viewer
from the Open With submenu for this file type.

5. Click OK, then click Cancel to close the dialog.

Note – You can also modify the actions that are associated with a file type in the File
Types and Programs preference tool. To open the File Types and Programs preference
tool, click on the Go There button.

Customizing the File Manager
You can customize the file manager to suit your requirements and preferences. This
section describes how to customize the file manager.

Setting Your Preferences
Use the File Management Preferences dialog to set preferences for the file manager.
To display the File Management Preferences dialog, choose Edit → Preferences.

You can set preferences in the following categories:
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� The default settings for views.
� The behavior of files and folders, executable text files, and Trash.
� The information that is displayed in icon captions.
� Preview options to improve the performance of the file manager.

To Set Views Preferences
You can specify a default view, and select sort options and display options. You can
also specify default settings for icon views and list views. To specify your default view
settings, choose Edit → Preferences. Click on the Views tab in the File Management
Preferences dialog to display the Views tabbed section.

Table 7–6 lists the views settings that you can modify.

TABLE 7–6 Views Preferences

Dialog Element Description

View new folders using Select the default view for folders. When you open a folder,
the folder is displayed in the view that you select.

Arrange items Select the characteristic by which you want to sort the items
in folders that are displayed in this view.

Sort folders before files Select this option to list folders before files when you sort a
folder.

Sort in reverse Select this option if you want to reverse the order by which
items are sorted in this view. If you select this option, the
order of the characteristic you select in the Arrange Items
drop-down list is reversed. For example, if you select By
Name, the items are sorted in reverse alphabetical order.

Show hidden and backup files Select this option to display hidden files and backup files in
the view pane. The first character in a hidden filename is a
period (.). The last character in a backup filename is a tilde
(~).

Default zoom level Icon view and list view. Select the default zoom level for
folders that are displayed in this view. The zoom level
specifies the size of items in a view.

Use compact layout Select this option to arrange the items in icon view so that
the items in the folder are closer to each other.

Text beside icons Select this option to place the icon captions for items beside
the icon rather than under the icon.

Use manual layout Select this option if you want to arrange the items in icon
view manually.
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TABLE 7–6 Views Preferences (Continued)
Dialog Element Description

Show only folders Select this option to display only folders in the Tree in the
side pane.

To Set Behavior Preferences
To set your preferences for files and folders, choose Edit → Preferences. Click on the
Files and Folders tab in the File Management Preferences dialog to display the Files
and Folders tabbed section.

Table 7–7 lists the settings that you can modify for files and folders.

TABLE 7–7 Files and Folders Preferences

Option Description

Single click to activate items Select this option to perform the default action for an item
when you click on the item. When this option is selected,
and you point to an item, the title of the item is underlined.

Double click to activate items Select this option to perform the default action for an item
when you double-click on the item.

Open activated item in a new
window

Select this option to open a new window when you open a
file or folder.

Run executable files when they
are clicked

Select this option to run an executable file when you choose
the executable file. An executable file is a text file that can
execute, that is, a shell script.

View executable files when
they are clicked

Select this option to display the contents of an executable
file when you choose the executable file.

Ask each time Select this option to display a dialog when you choose an
executable file. The dialog asks whether you want to execute
the file or display the file.

Ask before emptying the Trash
or deleting files

Select this option to display a confirmation message before
Trash is emptied, or files are deleted.

Include a Delete command that
bypasses Trash

Select this option to add a Delete menu item to the
following menus:
� The Edit menu.
� The popup menu that is displayed when you right-click

on a file, folder, or desktop object.

When you select an item then choose the Delete menu item,
the item is deleted from your file system immediately.
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To Set Icon Captions Preferences
An icon caption displays the name of a file or folder in an icon view. The icon caption
also includes three additional items of information on the file or folder. The additional
information is displayed after the file name. Normally only one item of information is
visible, but when you zoom in on an icon, more of the information is displayed. You
can modify what additional information is displayed in icon captions.

To set your preferences for icon captions, choose Edit → Preferences. Click on the Files
and Folders tab in the File Management Preferences dialog to display the Files and
Folders tabbed section.

Select the items of information that you want to display in the icon caption from the
three drop-down lists. Select the first item from the first drop-down list, select the
second item from the second drop-down list, and so on. The following table describes
the items of information that you can select:

Information Description

Size Choose this option to display the size of the item.

Type Choose this option to display the description of the MIME
type of the item from the File Types and Programs
preference tool.

Date modified Choose this option to display the last modification date of
the item.

Date accessed Choose this option to display the date that the item was last
accessed.

Owner Choose this option to display the owner of the item.

Group Choose this option to display the group to which the item
belongs.

Permissions Choose this option to display the permissions of the item as
three sets of three characters, for example -rwxrw-r--.

Octal permissions Choose this option to display the permissions of the item in
octal notation, for example 764.

MIME type Choose this option to display the MIME type of the item.

None Choose this option to display no information for the item.
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To Set Preview Preferences
The file manager include some file preview features. The preview features can affect
the speed with which the file manager responds to your requests. You can modify the
behavior of some of these features to improve the speed of the file manager. For each
preview preference, you can select one of the options described in the following table:

Option Description

Always Performs the action for both local files, and files on other file
systems.

Local Files Only Performs the action for local files only.

Never Never performs the action.

To set your preview preferences, choose Edit → Preferences. Click on the Preview tab
in the File Management Preferences dialog to display the Preview tabbed section.

Table 7–8 lists the preview settings that you can modify.

TABLE 7–8 Preview Preferences

Dialog Element Description

Show text in icons Select an option to specify when to preview the content of
text files in the icon that represents the file.

Show thumbnails Select an option to specify when to show thumbnails of
image files. The file manager stores the thumbnail files for
each folder in a .thumbnails directory that is one level
below the folder.

Only for files smaller than Specify the maximum file size for files for which the file
manager creates a thumbnail.

Preview sound files Select an option to specify when to preview sound files.

Count number of items Select an option to specify when to show the number of
items in folders.

Changing Backgrounds
The file manager includes backgrounds that you can use to change the look-and-feel of
the following screen components:

� Desktop
� Side pane
� View pane
� Panels
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To change the background of a screen component perform the following steps:

1. Choose Edit → Backgrounds and Emblems. The Backgrounds and Emblems
dialog is displayed.

2. To display a list of patterns that you can use on the background, click on the
Patterns button. To display a list of the colors that you can use on the background,
click on the Colors button.

3. To change the background to a pattern, drag the pattern to the screen component.
To change the background to a color, drag the color to the screen component.

4. Click Close to close the dialog.

To reset the background of the view pane or side pane to the default background,
right-click on the background of the pane, then choose Use Default Background.

When you change the background of the side pane or the view pane of a particular
folder, the file manager remembers the background that you chose. The next time that
you display the folder, the background that you selected is displayed. In other words,
when you change the background of a folder, you customize the folder to display the
background.

To Add a Pattern
To add a pattern to the patterns that you can use on your screen components, choose
Edit → Backgrounds and Emblems. Click on the Patterns button, then click on the Add
a New Pattern button. A dialog is displayed. Use the dialog to find the new pattern.
Click OK to add the new pattern to the Backgrounds and Emblems dialog.

To Add a Color
To add a color to the colors that you can use on your screen components, choose Edit
→ Backgrounds and Emblems. Click on the Colors button, then click on the Add a
New Color button. A color selector dialog is displayed. Use the color wheel or the
sliders to choose the color. Click OK to add the new color to the Backgrounds and
Emblems dialog.

To Show and Hide Window Components
You can show and hide file manager window components as follows:

� To hide the side pane, choose View → Side Pane. To display the side pane again,
choose View → Side Pane again.

� To hide the toolbar, choose View → Toolbar. To display the toolbar again, choose
View → Toolbar again.

� To hide the location bar, choose View → Location Bar. To display the location bar
again, choose View → Location Bar again.
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� To hide the statusbar, choose View → Statusbar. To display the statusbar again,
choose View → Statusbar again.

� To remove a tab from the side pane, right-click in the side pane. Choose the tab that
you want to remove from the popup menu. To add the tab to the side pane again,
choose the tab from the popup menu again.

Using Removable Media
The file manager supports all removable media that have the following characteristics:

� The removable media has an entry in the /etc/fstab file. The /etc/fstab file
describes the file systems that the computer uses.

� The user option is specified in the entry for the removable media in the
/etc/fstab file.

To Mount Media
To mount media is to make the file system of the media available for access. When you
mount media, the file system of the media is attached as a subdirectory to your file
system.

To mount media, insert the media in the appropriate device. An object that represents
the media is added to the desktop. The object is added only if your system is
configured to mount the device automatically when media is detected.

If your system is not configured to mount the device automatically, you must mount
the device manually. Right-click on the desktop, then choose Disks → device-name. For
example, to mount a floppy diskette, choose Disks → Floppy. An object that represents
the media is added to the desktop.

Note – You cannot change the name of a removable media object.

To Display Media Contents
You can display media contents in any of the following ways:

� Double-click on the object that represents the media on the desktop.
� Right-click on the object that represents the media on the desktop, then choose

Open.
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A file manager window displays the contents of the media. To reload the display, click
on the Reload button.

To Display Media Properties
To display the properties of removable media, right-click on the object that represents
the media on the desktop, then choose Properties. A dialog displays the properties of
the media.

To close the properties dialog, click Close.

To Format a Floppy Diskette
To format media is to prepare the media for use with a particular file system. You can
use the file manager to format floppy diskettes.

Caution – When you format media, you overwrite any existing information on the
media.

To format a floppy diskette, perform the following steps:

1. Insert the diskette in the diskette drive. Mount the diskette. For information on
how to mount media, see “To Mount Media” on page 135.

2. Right-click on the object that represents the diskette on the desktop, then choose
Format. A Format a Floppy dialog is displayed.

3. Select your format options in the Format a Floppy dialog. The following table
describes the elements on the dialog:

Dialog Element Description

Floppy device Displays the name of the floppy device.

Floppy density Select the density of the diskette. The density is the
amount of data that the diskette can store.
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Dialog Element Description

File system type Select the type of file system in which you want to format
the diskette. Select one of the following options:
� Linux Native (ext 2): Select this option to format a

diskette for use on Linux systems. Most non-Linux
systems cannot read diskettes with this file system
type.

� DOS (FAT): Select this option to format a diskette for
use on Windows systems. Most UNIX-based systems
can read diskettes with this file system type.

Volume name Type a name for the diskette in this text box.

Quick Select this option to create only the file system on the
diskette. A quick format does not check for bad blocks.

Select this option if the diskette has been formatted before.

Standard Select this option to create the file system on the diskette
and format the diskette. A standard format does not check
for bad blocks.

Select this option if the diskette has not been formatted
before.

Thorough Select this option to create the file system on the diskette,
check for bad blocks, and format the diskette.

Select this option if you want to verify that the diskette has
not been damaged.

4. Click Format to format the diskette.

To Eject Media
To eject media, right-click on the media object on the desktop, then choose Eject. If the
drive for the media is a motorized drive, the media is ejected from the drive. If the
drive for the media is not motorized, wait until the desktop object for the media
disappears, then eject the media manually.

You cannot eject media from a motorized drive when the media is mounted. To eject
media, first unmount the media. To remove a floppy diskette from the drive, perform
the following steps:

1. Close all file manager windows, Terminal windows, and any other windows that
access the diskette.

2. Right-click on the object that represents the diskette on the desktop, then choose
Eject. The desktop object for the diskette disappears.

3. Eject the diskette from the drive.
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Caution – If you eject the diskette from the drive before you unmount the diskette,
you might lose the data on the diskette.

Writing CDs
The file manager provides a special location where you can copy files and folders that
you want to write to a CD. You can write the contents of the location to a CD easily.

To write a CD, perform the following steps:

1. Choose Go → CD Creator. The file manager opens a special location, burn:///, from
which you can write CDs.

2. Copy the files and folders that you want to write to CD into the burn:/// location.

3. Insert a writable CD into the CD writer device on your system.

4. Choose File → Write to CD. A Write files to a CD recorder dialog is displayed.

5. Use the Write files to a CD recorder dialog to specify how you want to write the
CD, as follows:

Dialog Element Description

Target to write to Select the device to which you want to write
the CD from the drop-down list. To create an
CD image file for the files and folders, select
the File image option.

Write speed Select the speed at which you want to write
the CD from the drop-down list.

CD name Type a name for the CD in the text box.

Erase CD Select this option to erase the current
contents of the CD.

Eject CD when done Select this option to eject the CD from the
drive when the CD is written.

Reuse these files for another CD Select this option if you do not want to write
the files and folders to another CD. If you
select this option, the files and folders are
not removed from the burn:/// location after
the CD is written.
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6. Click on the Write files to CD button.

If you selected the File image option from the Target to write to drop-down list, a
Choose a filename for the cdrom image dialog is displayed. Use the dialog to
specify the location where you want to save the CD image file. By default, CD
image files have a .iso file extension.

A Writing CD dialog is displayed. When the CD is written or when the CD image
file is created, a message to indicate that the process is complete is displayed in the
dialog.

If you created a CD image file, you can write this file to a CD. To write a CD image
file to CD, right-click on the CD image file, then choose Write to CD from the
popup menu.

If you did not select the Reuse these files for another CD option, the files and
folders are removed from the burn:/// location.

Running Scripts From the File Manager
The file manager includes a special folder where you can store your scripts. When you
add an executable file to this folder, the file is added to the Scripts submenu. To run a
script choose File → Scripts, then choose the script that you want to run from the
submenu.

To run a script on a particular file, select the file in the view pane. Choose File →
Scripts, then choose the script that you want to run on the file from the submenu. You
can also select multiple files to run your scripts on.

To view the contents of your scripts folder, choose File → Scripts → Open Scripts
Folder.
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CHAPTER 8

Using Your Desktop

The Nautilus file manager manages the desktop. This chapter describes how to use the
Nautilus desktop.

� “Introduction to the Desktop” on page 141
� “Desktop Objects” on page 142
� “Using Trash on the Desktop” on page 148
� “Using the Desktop Menu” on page 149
� “Changing the Pattern or Color of the Desktop” on page 150

Introduction to the Desktop
The desktop lies behind all of the other components on your visible desktop. The
desktop is an active component of the user interface. You can perform the following
tasks from your desktop:

� Start your applications, and open your files and folders.

You can add desktop objects for convenient access to files, folders, and applications
that you use frequently. For example, you can add an application launcher to the
desktop. You can create a symbolic link to a file that you use often, then add this
link to your desktop. You can also store files and folders on the desktop.

� Open the Desktop menu.

Right-click on the desktop to open the Desktop menu. You can use the Desktop
menu to perform actions on the desktop.

� Work with Trash.

You can move objects to Trash and empty your Trash.

� Customize your desktop.

You can customize the pattern or color of the desktop.
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By default, your desktop contains three objects. Table 8–1 describes the functions of
the default objects on the desktop.

TABLE 8–1 Functions of Default Desktop Objects

Object Component Function

Home Opens a file manager window, and
displays your home location in the view
pane.

Start Here Provides an access point to some of the key
features of the GNOME Desktop.

Trash Opens a file manager window, and
displays your Trash in the view pane.

Desktop Objects
A desktop object is an icon on your desktop that you can use to open your files,
folders, and applications. By default, your desktop contains three objects. You can also
add objects to your desktop to provide convenient access to files, folders, applications,
and URIs that you use frequently. For example, you can add a launcher to your
desktop to enable you to open a particular application that you use often.

Table 8–2 describes the types of object that you can add to your desktop.
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TABLE 8–2 Types of Desktop Objects

Object Type Description

Symbolic link A symbolic link is an object that points to another file or folder.
When you choose a symbolic link from the desktop, the file or
folder that the symbolic link points to is opened. You can move
or copy a symbolic link to the desktop.

You can identify symbolic links by the default arrow emblem
that appears on all symbolic links.

Launcher You can add the following types of launcher to the desktop:
� Application: Starts a particular application.
� Link: Links to a particular file, folder, or URI.

File You can add files to your desktop. Files on your desktop reside
in your desktop directory.

Folder You can move folders to your desktop, and you can create
folders on your desktop. Folders on your desktop reside in your
desktop directory.

The following sections describe how to work with objects on the desktop.

To Select Objects on the Desktop
To select an object on the desktop, click on the object. To select multiple objects,
press-and-hold Ctrl, then click on the objects that you want to select.

You can also select an area on the desktop to select all objects within that area.
Click-and-hold on the desktop, then drag over the area that contains the objects that
you want to select. When you click-and-hold then drag, a rectangle appears to mark
the area that you select.

To select multiple areas, press-and-hold Ctrl, then drag over the areas that you want to
select.

To Open an Object from the Desktop
To open an object from the desktop, double-click on the object. Alternatively,
right-click on the object, then choose Open. When you open an object, the default
action for the object executes. For example, if the object is a text file, the text file opens
in a file manager window. The default actions for file types are specified in the File
Types and Programs preference tool.

To execute an action other than the default action for an object, right-click on the
object, then choose Open With. Choose an action from the Open With submenu.
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The items in the Open With submenu correspond to the contents of the following parts
of the File Types and Programs preference tool:

� Default action drop-down list in the Edit file type dialog
� Viewer Component drop-down list in the Edit file type dialog

You can set your preferences in a file manager window so that you click once on a file
to execute the default action.

To Add a Launcher to the Desktop
A desktop launcher can start an application or link to a particular file, folder, FTP site,
or URI.

To add a launcher to your desktop, perform the following steps:

1. Right-click on the desktop, then choose New Launcher. A Create Launcher dialog
is displayed.

2. For information on how to enter the properties of the launcher in the Create
Launcher dialog, see Working With Panels. The command that you enter for the
launcher is the command that is executed when you use the desktop object.

To Add a Symbolic Link to the Desktop
You can create symbolic links on your desktop to perform the following actions:

� Open a particular file in a particular application.
� Open a particular folder in a file manager window.
� Run a binary file or a script.

To create a symbolic link on the desktop, perform the following steps:

1. Display the file or folder for which you want to create a symbolic link in a file
manager window.

2. Create a symbolic link to the file or folder. To create a symbolic link to a file or
folder, select the file or folder to which you want to create a link. Choose Edit →
Make Link. A link to the file or folder is added to the current folder. You can
identify symbolic links by the default arrow emblem that appears on all symbolic
links. The following figure shows a symbolic link to a file:
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3. Drag the symbolic link to the desktop. The icon for the object is moved to the
desktop.

Adding a File or Folder to the Desktop
The following sections describe how you can add file objects and folder objects to the
desktop.

To Move a File or Folder to the Desktop
You can move a file or folder from the file manager to the desktop. To move a file or
folder to the desktop, perform the following steps:

1. Open a file manager window.

2. In the view pane, display the file or folder that you want to move.

3. Drag the file or folder to the desktop. The icon for the file or folder is moved to the
desktop. The file or folder is moved to your desktop directory.

Alternatively, select the file or folder, then choose Edit → Cut Files. Right-click on
any desktop object, then choose Paste Files.

To Copy a File or Folder to the Desktop
You can copy a file or folder from the file manager to the desktop. To copy a file or
folder to the desktop, perform the following steps:

1. Open a file manager window.

2. In the view pane, display the file or folder that you want to move.

3. Press-and-hold Ctrl, then drag the file or folder to the desktop. An icon for the file
or folder is added to the desktop. The file or folder is copied to your desktop
directory.

Alternatively, select the file or folder, then choose Edit → Copy Files. Right-click on
any desktop object, then choose Paste Files.

Chapter 8 • Using Your Desktop 145



To Create a Folder Object on the Desktop
To create a folder object, right-click on the desktop to open the Desktop menu. Choose
New Folder. An untitled folder is added to the desktop. Type the name of the new
folder, then press Return. The folder is displayed with the new name. The new folder
resides in your desktop directory.

To Rename a Desktop Object
To rename a desktop object, right-click on the object, then choose Rename. The name
of the desktop object is highlighted. Type the new name for the object, then press
Return.

To Remove an Object from the Desktop
To remove an object from the desktop, right-click on the object, then choose Move to
Trash. Alternatively, drag the object to Trash.

Note – When you move a file or folder from a removable media to Trash, the file or
folder is stored in a Trash location on the removable media. To remove the file or
folder permanently from the removable media, you must empty Trash.

To Delete an Object from the Desktop
When you delete an object from the desktop, the object is not moved to Trash, but is
immediately deleted from the desktop. The Delete menu item is only available if you
select the Include a Delete command that bypasses Trash option in the Nautilus File
Management Preferences dialog.

To delete an object from the desktop right-click on the object, then choose Delete.

Note – You cannot delete the Home or Trash desktop objects.

To View the Properties of a Desktop Object
To view the properties of a desktop object, perform the following steps:

1. Right-click on the object whose properties you want to view, then choose
Properties. A properties dialog is displayed.
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2. Use the properties dialog to view the properties of the desktop object.

3. Click Close to close the properties dialog.

To Change the Permissions of a Desktop Object
To change the permissions of a desktop object, perform the following steps:

1. Right-click on the object whose permissions you want to change, then choose
Properties. A properties dialog is displayed.

2. Click on the Permissions tab to display the Permissions tabbed section.

3. In the Permissions tabbed section, use the drop-down lists and check boxes to
change the permissions for the file or folder. For more information on the dialog
elements in the Permissions tabbed section, see Nautilus File Manager.

4. Click Close to close the properties dialog.

To Add an Emblem to a Desktop Object
To add an emblem to a desktop object, perform the following steps:

1. Right-click on the object to which you want to add an emblem, then choose
Properties. A properties dialog is displayed.

2. Click on the Emblems tab to display the Emblems tabbed section.

3. Select the emblem to add to the item.

4. Click Close to close the properties dialog.

To Add a Note to a Desktop Object
To add a note to a desktop object, perform the following steps:

1. Select the object to which you want to add a note.

2. Choose File → Properties. A properties dialog is displayed.

3. Click on the Notes tab. In the Notes tabbed section, type the note.

4. Click Close to close the properties dialog. A note emblem is added to the desktop
object.

To delete a note, delete the note text from the Notes tabbed section.

To Change the Icon for a Desktop Object
To change the icon for desktop object, perform the following steps:
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1. Right-click on the object whose permissions you want to change, then choose
Properties. A properties dialog is displayed.

2. On the Basic tabbed section, click on the Select Custom Icon button. A Select an
icon dialog is displayed.

3. Use the Select an icon dialog to choose the icon to represent the file or folder.

4. Click Close to close the properties dialog.

To restore an icon from a custom icon to the default icon specified in the File Types
and Programs preference tool, right-click on the icon then choose Remove Custom
Icon. Alternatively, click on the Remove Custom Icon button on the Properties dialog.

To Resize a Desktop Object Icon
You can change the size of the icon that represents a desktop object. To change the size
of an icon on the desktop, perform the following steps:

1. Right-click on the desktop object whose icon you want to resize, then choose
Stretch Icon. A rectangle appears around the icon, with a handle at each corner.

2. Grab one of the handles, then drag the icon to the size that you want.

To return the icon to the original size, right-click on the icon, then choose Restore
Icon’s Original Size.

Using Trash on the Desktop

You can move the following items to Trash:

� Files
� Folders
� Desktop objects

If you need to retrieve a file from Trash, you can view Trash and move the file out of
Trash. When you empty Trash, you delete the items in Trash permanently.
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To Display Trash
You can display the contents of Trash in the following ways:

� From the desktop

Double-click on the Trash object on the desktop. The contents of Trash are
displayed in a Nautilus window.

� From a file manager window

Choose Go → Trash. The contents of Trash are displayed in the window.

To Empty Trash
You can empty the contents of Trash in the following ways:

� From the desktop

Right-click on the Trash object, then choose Empty Trash.

� From a file manager window

Choose File → Empty Trash.

Using the Desktop Menu

To open the Desktop menu, right-click on a vacant space on the desktop. You can use
the Desktop menu to perform actions on the desktop.

Table 8–3 describes the items in the Desktop menu.
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TABLE 8–3 Items on the Desktop Menu

Menu Item Function

New Window Opens a new file manager window that displays your home
location.

New Folder Creates a new folder object on your desktop. The folder is
created in your desktop directory.

New Terminal Starts a GNOME Terminal.

New Launcher Creates a launcher on your desktop. For more information,
see “To Add a Launcher to the Desktop” on page 144.

Scripts Opens a submenu of scripts that you can run.

Clean Up By Name Arranges the objects on the desktop alphabetically by name.

Keep Aligned Ensures that the left edges of the objects on the desktop are
aligned with one another.

Cut Files Deletes the selected file or files from the folder or desktop,
and places the file or files in buffer.

Copy Files Copies the selected file or files from the folder or desktop,
and places the file or files in buffer.

Paste Files Puts the file or files in the buffer into the selected folder or
the desktop.

Disks Enables you to mount diskettes and other removable media.

Use Default Background Resets the desktop background to the last pattern that you
chose from the Backgrounds and Emblems dialog. You can
access the Backgrounds and Emblems dialog from Nautilus
windows.

Change Desktop Background Starts the Background preference tool to enable you to
change the desktop background.

Changing the Pattern or Color of the
Desktop
You can change the pattern or color of the desktop background to suit your
preferences. The file manager includes background patterns and colors that you can
use to change the look-and-feel of the desktop background.

You can change the pattern or color of the desktop background in any of the following
ways:
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� Drag a pattern or color from another window or dialog to the desktop.

If your desktop background is a color, you can create a gradient effect from a color
into the desktop background color. A gradient effect is a visual effect where one
color blends gradually into another color. To create a gradient effect on your
desktop background, drag a color to one of the edges of the screen. The color
blends from the edge to which you drag the color, to the opposite edge of the
screen.

Before you drag a color to a screen edge, check if there is an edge panel on the
screen edge. If there is an edge panel on the screen edge, you must hide the panel
before you drag the color.

� Use the Background preference tool.

� Choose a pattern or color for the background from the Backgrounds and Emblems
dialog. To change the pattern or color of the desktop background, perform the
following steps:

1. Open a file manager window.

2. Choose Edit → Backgrounds and Emblems. The Backgrounds and Emblems
dialog is displayed.

3. To display a list of patterns that you can use, click on the Patterns button. To
display a list of the colors that you can use, click on the Colors button.

4. To change the desktop background to a pattern, drag the pattern to the desktop
background. To change the desktop background to a color, drag the color to the
desktop background.

5. Click Close to close the dialog.
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PART II

Customizing Your GNOME Desktop

You can customize many of the characteristics of your desktop environment. The
customization of each aspect of the desktop environment is controlled by a dedicated
software tool that is called a desktop environment preference tool. For convenience,
the preference tools are grouped under the following headings:

� Basic
� Accessibility
� Advanced

You can open your preference tools in either of the following ways:

� Choose Applications → Desktop Preferences. Choose the tool that you require from
the submenus.

� Double-click on the Start Here object on the desktop. A Nautilus window opens at
the Start Here location. Double-click on the Preferences object in the Nautilus
window to display your preference tools. Double-click on the tool that you require.

This section describes how to configure the desktop environment in the following
chapters.

� Using the Basic Preference Tools

Read this chapter to find out how to customize your desktop background, and how
to configure your keyboard settings and your mouse settings. This chapter also
describes how to configure shortcut keys, how to set your sound preferences, and
how to configure your network proxy. This chapter also contains information on
how to customize your screensaver, and how to set your screen resolution. This
chapter also describes how to choose a theme and fonts for your desktop
environment, and how to customize your application menubars and toolbars. This
chapter also contains information on how to customize window focus behavior.

� Using the Advanced Preference Tools

This chapter describes how to configure file types, your preferred applications, and
your panels. This chapter also contains information on how to customize your
sessions and startup programs.
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� Using the Accessibility Preference Tools

Read this chapter to find out how to use the accessibility features of the desktop
environment. This chapter describes how to set assistive technology preferences
and how to use the keyboard accessibility features.
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CHAPTER 9

Using the Basic Preference Tools

The basic preference tools enable you to customize your desktop background, and to
configure your keyboard settings and your mouse settings. You can use the basic
preference tools to configure shortcut keys, to set your sound preferences, and to
configure your network proxy. You can also use the basic preference tools to customize
your screensaver, choose a theme and fonts for your desktop environment, and to
customize your application menubars and toolbars. You can also customize window
focus behavior.

This chapter describes how to use the basic preference tools to customize your desktop
environment.

� “Opening a Basic Preference Tool” on page 156
� “Customizing the Desktop Background” on page 156
� “Setting File Management Preferences” on page 157
� “Choosing Default Fonts” on page 158
� “Configuring Keyboard Settings” on page 159
� “Customizing Keyboard Shortcuts” on page 161
� “Customizing Menus and Toolbars in Applications” on page 161
� “Configuring Mouse Settings” on page 162
� “Configuring Network Proxy Settings” on page 164
� “Setting Screensaver Preferences” on page 165
� “Setting Screen Resolution Preferences” on page 168
� “Setting Sound Preferences” on page 168
� “Customizing Themes in the Desktop Environment” on page 170
� “Customizing Windows” on page 173
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Opening a Basic Preference Tool
You can open one of the basic preference tools in either of the following ways:

� From the Desktop Preferences menu

Choose Applications → Desktop Preferences. Choose the preference tool that you
require from the submenu. The dialog for the tool is displayed.

� From the Start Here location

Open a Nautilus file manager window, then choose Go → Start Here. Alternatively,
double-click on the Start Here object on the desktop. The Start Here location is
displayed. Double-click on the Desktop Preferences object in the file manager
window to display your preference tools.

Double-click on the tool that you require. The dialog for the tool is displayed.

Customizing the Desktop Background
The desktop background is the image or color that is applied to your desktop. You can
customize the desktop background in the following ways:

� Select an image for the desktop background. The image is superimposed on the
desktop background color. The desktop background color is visible if you select a
transparent image, or if the image does not cover the entire desktop.

� Select a color for the desktop background. You can select a solid color, or create a
gradient effect with two colors. A gradient effect is a visual effect where one color
blends gradually into another color.

You can also change the appearance of your desktop background from within the
Nautilus file manager.

Table 9–1 lists the background settings that you can configure.

TABLE 9–1 Settings for Desktop Background

Element Function

Select picture Choose an image to display on the desktop. To choose an image,
click on the Select picture button. An image selector dialog is
displayed. Use the dialog to choose an image. When you choose an
image, click OK.
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TABLE 9–1 Settings for Desktop Background (Continued)
Element Function

Picture Options To specify how to display the image, select one of the following
options:
� Wallpaper: Repeats the image to cover the desktop.
� Centered: Displays the image in the middle of the desktop.
� Scaled: Enlarges the image until the image meets the screen

edges, and maintains the relative dimensions of the image.
� Stretched: Enlarges the image to cover the desktop, and does

not maintain the relative dimensions of the image.
� No Picture: Displays no image.

Background Style To specify a color scheme, use the options in the Background Style
drop-down list, and the color selector buttons.

You can specify a color scheme in one of the following ways:
� Choose Solid color from the Background Style drop-down list

to specify a single color for the desktop background.
To choose the color that you require, click on the Color button.
The Pick a Color dialog is displayed. Choose a color, then click
OK.

� Choose Horizontal gradient from the Background Style
drop-down list. This option creates a gradient effect from the
left screen edge to the right screen edge.
Click on the Left Color button to display the Pick a Color
dialog. Choose the color that you want to appear at the left
edge.
Click on the Right Color button. Choose the color that you want
to appear at the right edge.

� Choose Vertical gradient from the Background Style
drop-down list. This creates a gradient effect from the top screen
edge to the bottom screen edge.
Click on the Top Color button to display the Pick a Color
dialog. Choose the color that you want to appear at the top
edge.
Click on the Bottom Color button. Choose the color that you
want to appear at the bottom edge.

Setting File Management Preferences
Use the File Management preference tool to set your Nautilus file manager
preferences. You can also set your file manager preferences in the File Management
preferences dialog, which you can open from the file manager application. For
information on the settings in the File Management preferences dialog and File
Management preference tool, see Nautilus File Manager.
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Choosing Default Fonts
Use the Font preference tool to select the fonts to use in your applications, windows,
terminals, and desktop.

Table 9–2 lists the font settings that you can configure.

TABLE 9–2 Settings for Fonts

Option Function

Application font Click on the font selector button to select a font to use in your
applications.

Desktop font Click on the font selector button to select a font to use on your
desktop only.

Window title font Click on the font selector button to select a font to use in the
titlebars of your windows.

Terminal font Click on the font selector button to select a font to use in the
Terminal application

Font Rendering To specify how to render fonts on your screen, select one of the
following options:
� Monochrome: Renders fonts in black and white only. The

edges of characters might appear jagged in some cases
because the characters are not antialiased. Antialiasing is an
effect that is applied to the edges of characters to make the
characters look smoother.

� Best shapes: Antialiases fonts where possible. Use this option
for standard Cathode Ray Tube (CRT) monitors.

� Best contrast: Adjusts fonts to give the sharpest possible
contrast, and also antialiases fonts, so that characters have
smooth edges. This option might enhance the accessibility of
the desktop environment to users with visual impairments.

� Subpixel smoothing (LCDs): Uses techniques that exploit the
shape of individual Liquid Crystal Display (LCD) pixels to
render fonts smoothly. Use this option for LCD or flat-screen
displays.
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TABLE 9–2 Settings for Fonts (Continued)
Option Function

Details Click on this button to specify further details of how to render
fonts on your screen.
� Resolution (dots per inch): Use the spin box to specify the

resolution to use when your screen renders fonts.
� Smoothing: Select one of the options to specify how to

antialias fonts.
� Hinting: Hinting is a font-rendering technique that improves

the quality of fonts at small sizes and an at low screen
resolutions. Select one of the options to specify how to apply
hinting your fonts.

� Subpixel order: Select one of the options to specify the
subpixel color order for your fonts. Use this option for LCD or
flat-screen displays.

Previewing Fonts
You can use the file manager to preview fonts. To preview fonts, perform the
following steps:

1. Open a file manager window.

2. Enter the URI fonts:/// in the location bar. The fonts are displayed as icons in
the view pane.

3. Double-click on an icon to display a preview of the font.

Configuring Keyboard Settings
Use the Keyboard preference tool to select the autorepeat settings for your keyboard,
and to configure typing break settings.

You can customize the settings for the Keyboard preference tool in the following
functional areas:

� Keyboard
� Typing Break

Keyboard Settings
Use the Keyboard tabbed section to set general keyboard preferences. To start the
Keyboard accessibility preference tool, that is, AccessX, click on the Accessibility
button.
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Table 9–3 lists the keyboard settings that you can configure.

TABLE 9–3 Settings for Keyboard

Option Function

Keyboard repeats when
key is held down

Select this option to enable keyboard repeat. If keyboard repeat is
enabled, when you press-and-hold a key, the action associated
with the key is performed repeatedly. For example, if you
press-and-hold a character key, the character is typed repeatedly.

Delay Select the delay from the time you press a key to the time that the
action repeats.

Speed Select the speed at which the action is repeated.

Blinks in text boxes and
fields

Select this option to enable the cursor to blink in fields and text
boxes.

Speed Use the slider to specify the speed at which the cursor blinks in
fields and text boxes.

Typing Break Settings
Use the Typing Break tabbed section to set typing break preferences. To start the
Keyboard accessibility preference tool, that is, AccessX, click on the Accessibility
button.

Table 9–4 lists the typing break settings that you can configure.

TABLE 9–4 Typing Break Settings

Option Function

Lock screen to enforce typing break Select this option to lock the screen when you
are due a typing break.

Work interval lasts Use the spin box to specify how long you can
work before a typing break occurs.

Break interval lasts Use the spin box to specify the length of your
typing breaks.

Allow postponing of breaks Select this option if you want to be able to
postpone typing breaks.
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Customizing Keyboard Shortcuts
A keyboard shortcut is a key or combination of keys that provides an alternative to
standard ways of performing an action.

Use the Keyboard Shortcuts preference tool to display the default keyboard shortcuts.
You can customize the default keyboard shortcuts to your requirements.

Table 9–5 lists the keyboard shortcut settings that you can customize.

TABLE 9–5 Default Settings for Keyboard Shortcuts

Option Function

Text editing shortcuts Select one of the following settings:
� Default: Use this setting for standard shortcut keys.
� Emacs: Use this setting for Emacs shortcut keys.

Desktop shortcuts This table lists actions and the shortcut keys that are
associated with each action.

To change the shortcut keys for an action, click on the
action to select the action, then click on the shortcut for the
action. Press the keys that you want to associate with the
action.

To disable the shortcut keys for an action, click on the
action to select the action, then click on the shortcut for the
action. Press Back Space.

Customizing Menus and Toolbars in
Applications
You can use the Menus & Toolbars preference tool to customize the appearance of
menus, menubars, and toolbars for GNOME-compliant applications.

Table 9–6 lists the menu and toolbar settings that you can customize for
GNOME-compliant applications.
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TABLE 9–6 Settings for Customizing Applications

Option Function

Show icons in menus Select this option to display an icon beside each item in a menu.
Some menu items do not have an icon.

Detachable toolbars Select this option if you want to move toolbars from application
windows to any location on the screen. If you select this option,
handles are displayed on the left side of the toolbars in your
applications. To move a toolbar, click-and-hold on the handle, then
drag the toolbar to the new location.

Toolbar button labels Choose one of the following options to specify what to display on
the toolbars in your GNOME-compliant applications:
� Text Below Icons: Select this option to display toolbars with text

as well as an icon on each button.
� Text Beside Icons: Select this option to display toolbars with an

icon only on each button, and with text on the most important
buttons.

� Icons Only: Select this option to display toolbars with an icon
only on each button.

� Text Only: Select this option to display toolbars with text only
on each button.

Configuring Mouse Settings
Use the Mouse preference tool to configure your mouse for right-hand use or for
left-hand use. You can also specify the speed and sensitivity of mouse movement.

You can customize the settings for the Mouse preference tool in the following
functional areas:

� Buttons
� Cursors
� Motion

Buttons Settings
Use the Buttons tabbed section to specify whether the mouse buttons are configured
for left-hand use. You can also specify the delay between clicks for a double-click.

Table 9–7 lists the mouse button settings that you can configure.
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TABLE 9–7 Settings for Mouse Buttons

Option Function

Left-handed mouse Select this option to configure your mouse for left-hand use.
When you configure your mouse for left-hand use, the functions
of the left mouse button and the right mouse button are swapped.

Delay Use the slider to specify the amount of time that can pass between
clicks when you double-click. If the interval between the first and
second clicks exceeds the time that is specified here, the action is
not interpreted as a double-click.

Pointer Settings
Use the Cursors tabbed section to set your mouse pointer preferences.

Table 9–8 lists the mouse pointer settings that you can configure:

TABLE 9–8 Settings for Mouse Pointers

Option Function

Cursor Theme Select the mouse pointer theme that you
require from the list box.

Show position of cursor when the Control
key is pressed

Select this option to enable a mouse pointer
animation when you press and release Ctrl.
This feature can assist you to locate the mouse
pointer.

Motion Settings
Use the Motion tabbed section to set your preferences for mouse movement.

Table 9–9 lists the mouse motion settings that you can configure:

TABLE 9–9 Settings for Mouse Motion

Setting Function

Acceleration Use the slider to specify the speed at which your mouse pointer
moves on your screen when you move your mouse.

Sensitivity Use the slider to specify how sensitive your mouse pointer is to
movements of your mouse.
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TABLE 9–9 Settings for Mouse Motion (Continued)
Setting Function

Threshold Use the slider to specify the distance that you must move an item
before the move action is interpreted as a drag-and-drop action.

Configuring Network Proxy Settings
The Network Proxy preference tool enables you to configure how your system
connects to networks. You can configure the desktop environment to connect to a
proxy server, and specify the details of the proxy server. A proxy server is a server that
intercepts requests to another server, and fulfills the request itself, if it can. You can
enter the Domain Name Service (DNS) name or the Internet Protocol (IP) address of
the proxy server. A DNS name is a unique alphabetic identifier for a computer on a
network. An IP address is a unique numeric identifier for a computer on a network.

Table 9–10 lists the network proxy settings that you can configure.

TABLE 9–10 Network Proxy Settings

Option Function

Direct internet connection Select this option if you want to connect directly to the
Internet, without a proxy server.

Manual proxy configuration Select this option if you want to connect to the Internet
through a proxy server, and you want to configure the
proxy server manually.

HTTP proxy Enter the DNS name, or the IP address of the proxy server
to use when you request a HTTP service. Enter the port
number of the HTTP service on the proxy server in the Port
spin box.

Secure HTTP proxy Enter the DNS name, or the IP address of the proxy server
to use when you request a Secure HTTP service. Enter the
port number of the Secure HTTP service on the proxy server
in the Port spin box.

FTP proxy Enter the DNS name, or the IP address of the proxy server
to use when you request a FTP service. Enter the port
number of the FTP service on the proxy server in the Port
spin box.

Socks host Enter the DNS name, or the IP address of the Socks host to
use. Enter the port number for the Socks protocol on the
proxy server in the Port spin box.
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TABLE 9–10 Network Proxy Settings (Continued)
Option Function

Automatic proxy configuration Select this option if you want to connect to the Internet
through a proxy server, and you want to configure the
proxy server automatically.

Autoconfiguration URL Enter the URL that contains the information required to
configure the proxy server automatically.

Setting Screensaver Preferences
A screensaver is an application that you can use to replace the image on your screen
when the screen is not in use. You can use screensavers in the following ways:

� Activate after a specified period of idle time.
� Activate when you lock your screen.
� Manage power used by your monitor when your system is idle.

You can customize the settings for the Mouse preference tool in the following
functional areas:

� Display Modes
� Advanced

Display Modes Settings
Use the Display Modes tabbed section to set display mode preferences.

Table 9–11 lists the display mode settings that you can configure.
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TABLE 9–11 Settings for Screensaver Display Mode

Setting Function

Mode Use the drop-down list to specify the behavior of the
screensaver application. Select from the following options:
� Disable Screen Saver: Select this option if you do not

want to use the screensaver application.
� Blank Screen Only: Select this option if you want your

screen to become blank when your screen locks.
� Only One Screen Saver: Select this option if you want

to display a single screensaver display from the display
list when your screen locks.

� Random Screen Saver: Select this option if you want to
display a random selection of screensaver displays from
the screensaver display list when your screen locks.

Display list Select the screensaver display that you require from the list.

Blank After Specify how long to wait after the last use of the mouse or
keyboard, to activate the screensaver.

Cycle After Specify how long to show a particular screensaver display
before the next display.

Lock Screen After Select this option if you want the screen to lock after the
screensaver is activated. Use the spin box to specify the
delay between the activation of the screensaver and when
the screen locks.

Preview Click on this button to preview the screensaver display that
is selected in the screensaver display list. To stop the
preview, press any key or click a mouse button.

Settings Click on this button to display the options for the
screensaver display that is selected in the screensaver
display list.

Advanced Settings
Use the Advanced tabbed section to set advanced screensaver preferences.

Table 9–12 lists the advanced screensaver settings that you can configure.
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TABLE 9–12 Advanced Screensaver Settings

Setting Function

Grab Desktop Images Some screensavers can take a screenshot of your screen,
then manipulate the screenshot to create your
screensaver display. Select this option to enable
screensavers to take a screenshot of your screen.

Grab Video Frames Some screensavers can capture a frame of video, then
manipulate the captured image to create your
screensaver display. If your system has a video capture
card, select this option to enable screensavers to capture
a frame of video.

Choose Random Image Select this option to enable screensavers to use images
from a directory that you select. Type the path for the
directory in the field. Alternatively, click Browse to
display a dialog from which you can select a directory.

Verbose Dialognostics Select this option if you want to display screensaver
diagnostic information.

Display Subprocess Errors Select this option if you want to display errors related
to screensaver subprocesses on screen.

Display Splash Screen at Startup Select this option to if you want Xscreensaver to
display a splash dialog when Xscreensaver starts.

Power Management Enabled Select this option to enable power management of your
monitor. Power management can reduce energy
consumption by your monitor when you are not using
the monitor.

Standby After Specify how long to wait to put the monitor in standby
mode. When the monitor is in standby mode, the
screen is black.

Suspend After Specify how long to wait to put the monitor in
power-saving mode.

Off After Specify how long to wait to switch off monitor.

Install Colormap Select this option to install a private colormap when the
screensaver is active. Use of a private colormap might
improve the quality of the color in particular
screensaver displays.

Fade to Black When Blanking Select this option if you want your display to fade to
black when the screensaver activates.

Fade from Black When Unblanking Select this option if you want your display to fade from
black to the screen contents when the screensaver stops.
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TABLE 9–12 Advanced Screensaver Settings (Continued)
Setting Function

Fade Duration Specify how long to take to fade to black when the
screensaver activates.

Setting Screen Resolution Preferences
Use the Screen Resolution preference tool to specify the resolution settings for your
screen. Table 9–13 lists the screen resolution settings that you can configure.

TABLE 9–13 Settings for Screen Resolution

Setting Description

Resolution Select the resolution to use for the screen from
the drop-down list.

Refresh rate Select the screen refresh rate to use for the
screen from the drop-down list.

Make default for this computer only Select this option to make the screen
resolution settings the default settings for the
system that you are logged in to only.

Setting Sound Preferences
The Sound preference tool enables you to control when the GNOME sound server
starts. You can also specify which sounds to play when particular events occur.

You can customize the settings for the Sound preference tool in the following
functional areas:

� General
� Sound Events
� System Bell

General Settings
Use the General tabbed section of the Sound preference tool to specify when to launch
the GNOME sound server. You can also enable sound event functions.
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Table 9–14 lists the general sound settings that you can configure.

TABLE 9–14 Settings for Sound

Option Function

Enable sound server
startup

Select this option to start the GNOME sound server when you
start a GNOME session. When the sound server is active, the
desktop environment can play sounds.

Sounds for events Select this option to play sounds when particular events occur in
your desktop environment. You can select this option only if the
Enable sound server startup option is selected.

Sound Event Settings
Use the Sound Events tabbed section of the Sound preference tool to associate
particular sounds with particular events.

Note – You must select the Enable sound server startup option, and the Sounds for
events option before you can access the Sound Events tabbed section.

Table 9–15 lists the sound events settings that you can configure.

TABLE 9–15 Settings for Sound Events

Option Function

Sounds table Use the Sounds table to associate particular sounds with
particular events.

The Event column displays a hierarchical list of events that can
occur. To expand a category of events, click on the right arrow
beside a category of events.

The File to play column lists the sound file that plays when the
event occurs.

Play Click on this button to play the sound file that is associated with
the selected event.
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TABLE 9–15 Settings for Sound Events (Continued)
Option Function

Sound file drop-down
combination box, Browse

To associate a sound with an event, select the event in the Sounds
table. Enter the name of the sound file that you want to associate
with the selected event in the drop-down combination box.
Alternatively, click Browse to display a Select sound file dialog.
Use the dialog to specify the sound file that you want to associate
with the selected event.

Note – You can only associate sound files in .wav format with
events.

System Bell Settings
Use the System Bell tabbed section to set your preferences for the system bell.

Some applications play a bell sound to indicate a keyboard input error. Use the
options in the System Bell tabbed section to configure the bell sound. Table 9–16 lists
the system bell settings that you can configure.

TABLE 9–16 Settings for System Bell

Option Function

Sound an audible bell Select this option to enable the system bell.

Visual feedback Select this option to enable visual feedback to indicate input
errors.

Flash window titlebar Select this option if you want window titlebars to flash to indicate
an input error.

Flash entire screen Select this option if you want the entire screen to flash to indicate
an input error.

Customizing Themes in the Desktop
Environment
A theme is a group of coordinated settings that specifies the visual appearance of a
part of the desktop environment. You can choose themes to change the appearance of
the desktop environment. Use the Theme preference tool to select a theme for your
desktop environment. You can choose from a list of available themes. The list of
available themes includes several themes for users with accessibility requirements.
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A theme contains settings that affect different parts of the GNOME desktop, as
follows:

Controls The controls setting for a theme determines the visual appearance
of windows, panels, and applets. The controls setting also
determines the visual appearance of the GNOME-compliant
interface items that appear on windows, panels, and applets, such
as menus, icons, and buttons. Some of the controls setting options
that are available are designed for special accessibility needs. You
can choose an option for the controls setting from the Controls
tabbed section in the Theme preference tool.

Window frame The window frame setting for a theme determines the appearance
of the frames around windows only. You can choose an option for
the window frame setting from the Window Border tabbed section
in the Theme preference tool.

Icon The icon setting for a theme determines the appearance of the icons
on panels and the desktop background. You can choose an option
for the icon setting from the Icons tabbed section in the Theme
preference tool.

To Create a Custom Theme
The themes that are listed in the Theme preferences tool are different combinations of
controls options, window frame options, and icon options. You can create a custom
theme that uses different combinations of controls options, window frame options,
and icon options.

To create a custom theme, perform the following steps:

1. To open the Theme preference tool, choose Applications → Desktop Preferences →
Theme.

2. Select a theme in the list of themes.

3. Click on the Details button. A Theme Details dialog is displayed.

4. Select the controls option that you want to use in the custom theme from the list in
the Controls tabbed section. The list of available controls options includes several
options for users with accessibility requirements.

5. Click on the Window Border tab to display the Window Border tabbed section.
Select the window frame option that you want to use in the custom theme from the
list of available options. The list of available window frame options includes
several options for users with accessibility requirements.

6. Click on the Icons tab to display the Icons tabbed section. Select the icons option
that you want to use in the custom theme from the list of available options. The list
of available icons options includes several options for users with accessibility
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requirements.

7. Click Close to close the Theme Details dialog.

8. On the Theme preferences tool, click on the Save theme button. A Save theme to
disk dialog is displayed.

9. Type a name and a short description for the custom theme in the dialog, then click
Save. The custom theme now appears in your list of available themes.

To Install a New Theme
You can add a theme to the list of available themes. The new theme must be an archive
file that is tarred and zipped. That is, the new theme must be a .tar.gz file.

To install a new theme, perform the following steps:

1. To open the Theme preference tool, choose Applications → Desktop Preferences →
Theme.

2. Click on the Install theme button. An Install New Theme dialog is displayed.

3. Enter the location of the theme archive file in the drop-down combination box.
Alternatively, to browse for the file, click on the Browse button. When you have
selected the file, click OK.

4. Click on the Install button to install the new theme.

To Install a New Theme Option
You can install new controls options, window frame options, or icons options. You can
find many controls options on the Internet.

To install a new controls option, window frame option, or icons option, perform the
following steps:

1. To open the Theme preference tool, choose Applications → Desktop Preferences →
Theme.

2. Click on the Details button. An Theme Details dialog is displayed.

3. Click on the tab for the type of theme that you want to install. For example, to
install an icons option, click on the Icons tab.

4. Click on the Install new theme button. An Install New Theme dialog is displayed.

5. Enter the location of the option archive file in the drop-down combination box.
Alternatively, to browse for the file, click on the Browse button. When you have
selected the file, click OK.

6. Click on the Install button to install the new option.
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To Delete a Theme Option
You can delete controls options, window frame options, or icons options.

To delete a controls option, window frame option, or icons option, perform the
following steps:

1. To open the Theme preference tool, choose Applications → Desktop Preferences →
Theme.

2. Click on the Details button. A Theme Details dialog is displayed.

3. Click on the tab for the type of option that you want to delete.

4. Click on the Go to theme folder button. A file manager window opens on the
default option folder.

5. Use the file manager window to delete the option.

Previewing Themes
You can use the file manager to preview themes. To preview themes, perform the
following steps:

1. Open a file manager window.

2. Enter the URI themes:/// in the location bar. The themes are displayed as icons
in the view pane.

3. Double-click on a theme to display a preview of the theme.

Customizing Windows
Use the Windows preference tool to customize window behavior for your desktop
environment.

Table 9–17 lists the window behavior settings that you can customize.

TABLE 9–17 Settings for Window Behavior

Option Function

Select windows when
the mouse moves over
them

Select this option to give focus to a window when you point to the
window. The window retains focus until you point to another
window.
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TABLE 9–17 Settings for Window Behavior (Continued)
Option Function

Raise selected windows
after an interval

Select this option to raise windows a short time after the window
receives focus.

Interval before raising Specify the interval to wait before raising a window that has
received focus.

Double-click titlebar to
perform this action

Select the behavior that you want to occur when you double-click
on a window titlebar. Select one of the following options:
� Roll up: Shades the window.
� Maximize: Maximizes the window.

To move a window,
press-and-hold this key
then grab the window

Select the key to press-and-hold when you drag a window to move
the window.
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CHAPTER 10

Using the Advanced Preference Tools

The Advanced preference tools enable you to customize the behavior and appearance
of your applications, panels, and other user interface items. You can use the Advanced
preference tools to configure file types, your default applications, and your panels.
You can also use the Advanced tools to customize your sessions and startup
programs. This chapter describes how to use the Advanced tools to customize your
desktop environment.

� “Opening an Advanced Preference Tool” on page 175
� “Configuring a CD Database” on page 176
� “Configuring File Types and Programs” on page 176
� “Customizing Your Panels” on page 179
� “Choosing Your Preferred Applications” on page 180
� “Configuring Sessions” on page 182

Opening an Advanced Preference Tool
You can open an Advanced preference tool in either of the following ways:

� From the Desktop Preferences menu

Choose Applications → Desktop Preferences → Advanced. Choose the tool that
you require from the submenu. The dialog for the tool is displayed.

� From the Start Here location

Open a Nautilus file manager window, then choose Go → Start Here. Alternatively,
double-click on the Start Here object on the desktop. The Start Here location is
displayed. Double-click on the Desktop Preferences object in the file manager
window, then double-click on the Advanced folder. The Advanced preference tools
are displayed.

Double-click on the tool that you require. The dialog for the tool is displayed.
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Configuring a CD Database
The CD Database preference tool enables you to configure a CD database that your
system can query. A CD database contains information about CDs, such as the name of
the artist, the title, and the track list. When an application plays a CD, the application
can query the CD database about the CD, then display the information.

Table 10–1 describes the elements on the CD Database preference tool.

TABLE 10–1 Settings for CD Database

Element Description

Send no information Select this option if you do not want to send any information to the
CD database server.

Send real information Select this option to send your name and hostname information to
the CD database server.

Send other information Select this option to send another name and hostname to the CD
database server. Enter the name in the Name field. Enter the
hostname in the Hostname field.

FreeDB round robin
server

FreeDB is a CD database. The FreeDB round robin server is a
load-sharing configuration of FreeDB servers. Select this option to
access the FreeDB CD database from this server.

Other FreeDB server Select this option to access the FreeDB CD database from another
server. Select the server that you require from the server table.

Update Server List Click on this button to update the list of available FreeDB servers in
the server table.

Other server Select this option to use another CD database. Enter the name of the
server on which the database resides in the Hostname field. Enter
the port number on which you can access the database in the Port
field.

Configuring File Types and Programs
Use the File Types and Programs preference tool to configure the following:

File types You can specify how files of various types are displayed and edited. For
example, you can specify an icon to represent a particular type of file.
For another example, you can specify that if a file is a plain text file, the
file is launched in a text editor.
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The file manager and other GNOME applications check the contents of a
file to determine the type of a file. If the first lines do not determine the
type of the file, then the application checks the filename.

Services A Uniform Resource Identifier (URI) is a string that identifies a particular
location in a file system or on the Web. For example, the web address of
a web page is a URI. A service is a protocol or task that a URI requests.
For example, the http://www.gnome.org URI requests the http
service.

You can associate an application with a service, so that the application
performs the task required by the service. For example, you can
associate your preferred web browser with the http service.

Table 10–2 describes the elements on the File Types and Programs preference tool.

TABLE 10–2 Elements on File Types and Programs Preference Tool

Element Description

Table To view the contents of a category of file types, click on the right
arrow next to the category name. The category expands, and
displays a description of each file type, and the file extension that is
associated with the file type.

To select a file type that you want to work with, click on the file
type.

Add File Type Click on this button to add a file type. For more information, see
“To Add a File Type” on page 177.

Add Service Click on this button to add a service. For more information, see “To
Add a Service” on page 178.

Edit To edit a file type, a service, or a file type category, select the item
that you want to edit, then click Edit.

Remove To delete a file type or a service, select the item that you want to
delete, then click Remove.

To Add a File Type
To add a file type, perform the following steps:

1. Choose Applications → Desktop Preferences → Advanced → File Types and
Programs to start the File Types and Programs preference tool.

2. Click on the Add file type button. The Add file type dialog is displayed.

3. Enter the properties of the file type in the dialog. The following table describes the
dialog elements on the Add file type dialog:
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Option Function

No Icon Choose an icon to represent the file type. To choose an
icon, click on the No Icon button. An icon selector
dialog is displayed. Choose an icon from the dialog.
Alternatively, to choose an icon from another directory,
click Browse. When you choose an icon, click OK.

Description Type a description of the file type.

MIME type Enter the MIME type for this type of file.

Category Enter the category to which you want the file type to
belong in the File Types and Programs preference tool.
Click on the Choose to choose a category from the
Choose a file category dialog.

Filename extensions Enter the file extensions to associate with the file type.
Enter a file extension in the field on the left side, then
press Return. To delete a file extension, select the file
extension in the field on the right side, then click on the
Remove button.

Viewer Component Information to be supplied in a future release.

Default action Information to be supplied in a future release.

Program to run Specify a program to associate with the file type. Enter
the command to start the program in this field.
Alternatively, to choose a command that you entered
previously, click the down arrow button, then choose
the command to run.

You can also use the Browse button to choose a
command to run.

Run in Terminal Select this option to run the program in a terminal
window. Choose this option for a program that does not
create a window in which to run.

4. Click OK.

To Add a Service
To add a service, perform the following steps:

1. Choose Applications → Desktop Preferences → Advanced → File Types and
Programs to start the File Types and Programs preference tool.

2. Click on the Add service button. The Add service dialog is displayed.

3. Enter the properties of the service in the dialog. The following table describes the
dialog elements on the Add service dialog:
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Option Function

Description Type a description of the service.

Protocol Enter the protocol for the service.

Program to Run Information to be supplied in a future release.

Program Specify the program to associate with the service.
Enter the command to start the program in this
field. Alternatively, to choose a command that you
entered previously, click the down arrow button,
then choose the command to run.

You can also use the Browse button to choose a
command to run.

Run in Terminal Select this option to run the program in a terminal
window. Choose this option for a program that does
not create a window in which to run.

4. Click OK.

Customizing Your Panels
The Panel preference tool enables you to configure the behavior of panels. Any
changes that you make with the Panel preference tool affect all of your panels.

TABLE 10–3 Settings for Panels

Setting Function

Close drawer when launcher is clicked Select this option if you want a drawer on a
panel to close when you choose a launcher in
the drawer.

Drawer and panel animation Select this option if you want your panels and
drawers to show and to hide in an animated
style.

Animation speed Select the speed of the panel animation from
the drop-down list.
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Choosing Your Preferred Applications
Use the Preferred Applications preference tool to specify the applications that you
want the desktop environment to use when the desktop environment starts an
application for you. For example, you can specify Xterm as your preferred terminal
application. When you open the Desktop menu then choose New Terminal, Xterm
starts.

You can customize the settings for the Preferred Applications preference tool in the
following functional areas.

� Web Browser
� Mail Reader
� Text Editor
� Terminal

Web Browser Settings
Use the Web Browser tabbed section to configure your preferred web browser. The
preferred web browser opens when you click on a URL. For example, the preferred
web browser opens when you select a URL in an application, or when you select a
URL launcher on the desktop.

Table 10–4 lists the preferred web browser settings that you can configure.

TABLE 10–4 Settings for Preferred Web Browser

Option Function

Select a Web Browser Select this option if you want to use a standard web browser. Use
the drop-down combination box to select your preferred web
browser.

Custom Web Browser Select this option if you want to use a custom web browser.

Command Enter the command to execute to start the custom web browser. To
enable the browser to display a URL that you click on, include
“%s” after the command.

Start in Terminal Select this option to run the command in a terminal window. Select
this option for a browser that does not create a window in which to
run.
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Email Client Settings
Use the Mail Reader tabbed section to configure your preferred email client.

Table 10–5 lists the preferred email client settings that you can configure.

TABLE 10–5 Settings for Preferred Email Client

Option Function

Select a Mail Reader Select this option if you want to use a standard email client. Use the
drop-down combination box to select your preferred email client.

Custom Mail Reader Select this option if you want to use a custom email client.

Command Enter the command to execute to start the custom email client.

Start in Terminal Select this option to run the command in a terminal window. Select
this option for an email client that does not create a window in
which to run.

Text Editor Settings
Use the Text Editor tabbed section to configure your preferred text editor.

Table 10–6 lists the preferred text editor settings that you can configure.

TABLE 10–6 Settings for Preferred Text Editor

Option Function

Select an Editor Select this option if you want to use a standard text editor. Use the
drop-down combination box to specify your preferred text editor.

Custom Editor Select this option if you want to use a custom text editor. A Custom
Editor Properties dialog is displayed.
� Name: Type the name of the custom text editor.
� Command: Enter the command to execute to start the custom

text editor.
� This application can open multiple files: Select this option if

the default text editor can open multiple files.
� This application needs to be run in a shell: Select this option to

run the command in a terminal window. Select this option for
an editor that does not create a window in which to run.

After you specify a custom text editor, you can click on the
Properties button to display the Custom Editor Properties dialog.
You can use the dialog to modify the properties of the custom text
editor.
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TABLE 10–6 Settings for Preferred Text Editor (Continued)
Option Function

Use this editor to open
text files in the file
manager

Select this option if you want the file manager to start the custom
text editor to display text files.

Terminal Settings
Use the Terminal tabbed section to configure your preferred terminal.

Table 10–7 lists the preferred terminal settings that you can configure.

TABLE 10–7 Settings for Preferred Terminal

Option Function

Select a Terminal Select this option if you want to use a standard terminal. Use the
drop-down combination box to specify your preferred terminal.

Custom Terminal Select this option if you want to use a custom terminal.

Command Enter the command to execute to start the custom terminal.

Exec Flag Enter the exec option to use with the command.

Configuring Sessions
The Sessions preference tool enables you to manage your sessions. You can set session
preferences, and specify which applications to start when you start a session. You can
configure sessions to save the state of applications in your desktop environment, and
to restore the state when you start another session. You can also use this preference
tool to manage multiple GNOME sessions.

You can customize the settings for sessions and startup applications in the following
functional areas:

� Session Options
� Current Session
� Startup Programs

Setting Session Options
Use the Session Options tabbed section to manage multiple sessions, and to set
preferences for the current session.
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Table 10–8 lists the session options settings that you can configure.

TABLE 10–8 Settings for Session Options

Option Function

Show splash screen on
login

Select this option to display a splash screen when you start a
session.

Prompt on logout Select this option to display a confirmation dialog when you end a
session.

Automatically save
changes to session

Select this option if you want the session manager to save the
current state of your session. The session manager saves the
session-managed applications that are open, and the settings
associated with the session-managed applications. The next time
that you start a session, the applications start automatically, with
the saved settings.

If you do not select this option, when you end you session the
Logout Confirmation dialog displays a Save current setup option.

Sessions Use this area of the dialog to manage multiple sessions in the
desktop environment, as follows:
� To create a new session, click on the Add button. The Add a

new session dialog is displayed. Use this dialog to specify a
name for your session.

� To change the name of a session, select the session in the
Choose Current Session table. Click on the Edit button. The
Edit session name dialog is displayed. Type a new name for
your session.

� To delete a session, select the session in the Choose Current
Session table. Click on the Delete button.

When you log in on GDM, you choose a session. When you choose
a session, you can select which of the multiple sessions to use.

Setting Session Properties
Use the Current Session tabbed section to specify startup order values, and to choose
restart styles for the session-managed applications in your current session.

Table 10–9 lists the session properties that you can configure.
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TABLE 10–9 Session Properties

Option Function

Order The Order setting specifies the order in which the session manager
starts session-managed startup applications. The session manager
starts applications with lower order values first. The default value is
50.

To specify the startup order of an application, select the application
in the table. Use the Order spin box to specify the startup order
value.

Style The Style setting determines the restart style of an application. To
select a restart style for an application, select the application in the
table, then choose one of the following styles:
� Normal

Starts automatically when you start a GNOME session. Use the
kill command to terminate applications with this restart style
during a session.

� Restart
Restarts automatically whenever you close or terminate the
application. Choose this style for an application if the
application must run continuously during your session. To
terminate an application with this restart style, select the
application in the table, then click on the Remove button.

� Trash
Does not start when you start a GNOME session.

� Settings
Starts automatically when you start a session. Applications with
this style usually have a low startup order, and store your
configuration settings for GNOME and session-managed
applications.

Remove Click on the Remove button to delete the selected application from
the list. The application is removed from the session manager, and
closed. Application that you delete are not started the next time that
you start a session.

Apply Click on the Apply button to apply changes to the startup order and
the restart style.

Configuring Startup Applications
Use the Startup Programs tabbed section of the Sessions preference tool to specify
non-session-managed startup applications. Startup applications are applications that
start automatically when you start a session. You specify the commands that run the
non-session-managed applications in the Startup Programs tabbed section. The
commands execute automatically when you log in.
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You can also start session-managed applications automatically. For more information,
see “Setting Session Options” on page 182.

Table 10–10 lists the startup applications settings that you can configure.

TABLE 10–10 Settings for Startup Programs

Option Function

Additional startup
programs

Use this table to manage non-session-managed startup applications
as follows:
� To add a startup application, click on the Add button. The Add

Startup Program dialog is displayed. Enter the command to
start the application in the Startup Command field.
If you specify more than one startup application, use the
Priority spin box to specify the startup order of the each
application. The startup order is the order in which you want
the startup applications to start.

� To edit a startup application, select the startup application, then
click on the Edit button. The Edit Startup Program dialog is
displayed. Use the dialog to modify the command and the
startup order for the startup application.

� To delete a startup application, select the startup application,
then click on the Delete button.
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CHAPTER 11

Using the Accessibility Preference
Tools

This chapter describes how to use the Accessibility preference tools to customize your
desktop environment.

� “Opening an Accessibility Tool” on page 187
� “Setting Assistive Technology Preferences” on page 187
� “Configuring Keyboard Accessibility Options” on page 188

Opening an Accessibility Tool
You can open an Accessibility preference tool in the following ways:

� From the Desktop Preferences menu

Choose Applications → Desktop Preferences → Accessibility. Choose the preference
tool that you require from the submenu. The dialog for the tool is displayed.

� From the Start Here location

Open a Nautilus file manager window, then choose Go → Start Here. Alternatively,
double-click on the Start Here object on the desktop. The Start Here location is
displayed. Double-click on the Desktop Preferences object in the file manager
window, then double-click on the Accessibility folder.

Setting Assistive Technology Preferences
Use the Assistive Technology preference tool to enable assistive technologies in your
desktop environment. You can also use the Assistive Technology preference tool to
specify assistive technology applications to start automatically when you log in.
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Table 11–1 lists the font settings that you can configure.

TABLE 11–1 Assistive Technology Settings

Setting Description

Enable assistive technologies Select this option to enable assistive
technologies in your desktop environment.

Screenreader Select this option to start the Screenreader
application automatically when you log in.

Magnifier Select this option to start the Magnifier
application automatically when you log in.

On-screen keyboard Select this option to start the On-screen
keyboard application automatically when you
log in.

Configuring Keyboard Accessibility
Options
Use the Keyboard accessibility preference tool to set the keyboard accessibility
preferences. The Keyboard accessibility preference tool is also known as AccessX.

You can customize the settings for the Keyboard accessibility preference tool in the
following functional areas:

� Basic
� Filters
� Mouse

Basic Settings
Table 11–2 lists the basic keyboard accessibility settings that you can modify.

TABLE 11–2 Keyboard Accessibility Settings

Option Function

Enable keyboard
accessibility features

Select this option to enable keyboard accessibility features. When you
select this option, the other options in the preference tool become
available.
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TABLE 11–2 Keyboard Accessibility Settings (Continued)
Option Function

Disable if unused for Select this option to deactivate keyboard accessibility preferences if
the keyboard is not used for a specified period of time. Use the slider
to specify the number of seconds of keyboard idle time required
before the system disables the keyboard accessibility preferences.
When the specified number of seconds elapses, the following
keyboard accessibility preferences are disabled:
� Bounce keys
� Mouse keys
� Slow keys
� Sticky keys
� Toggle keys

Beep when features
turned on or off from
keyboard

Select this option for an audible indication when a feature such as
sticky keys or slow keys is activated, or deactivated.

Import Feature Settings Click on this button to import an AccessX configuration file.

Enable Sticky Keys Select this option to perform multiple simultaneous keypress
operations by pressing the keys in sequence. You can specify the
following sticky keys settings:
� Beep when modifier is pressed: Select this option for an audible

indication when you press a modifier key.
� Disable if two keys pressed together: Select this option to specify

that when you press two keys simultaneously, you can no longer
press keys in sequence to perform multiple simultaneous
keypresses.

Repeat Keys Select this option to enable the autorepeat settings for your keyboard.
� Delay: Use this setting to specify the interval to wait after the first

keypress before the automatic repeat of a pressed key.
� Speed: Use this setting to specify the number of characters per

second to enter.

Type to test settings The test area is an interactive interface so you can see how the
keyboard settings affect the display as you type. Type text in the test
area to test the effect of your settings.

For more information on configuring keyboard accessibility preferences, see GNOME
2.2 Desktop Accessibility Guide.

Filter Settings
Table 11–3 lists the filter settings that you can modify.
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TABLE 11–3 Filter Settings

Option Function

Enable keyboard
accessibility features

Select this option to enable keyboard accessibility features. When you
select this option, the other options in the preference tool become
available.

Enable Slow Keys Select this option to control the period of time that you must
press-and-hold a key before acceptance. You can specify the following
slow keys settings:
� Only accept keys held for: Use this setting to specify the period

of time that you must press-and-hold a key before acceptance.
� Beep when key is: Select the appropriate option or options for an

audible indication when a key is pressed, accepted, or rejected.

Enable Bounce Keys Select this option to accept a key input and to control the key repeat
characteristics of the keyboard. You can specify the following bounce
keys settings:
� Ignore duplicate keypresses within: Use this setting to specify

the interval to wait after the first keypress before the automatic
repeat of a pressed key.

� Beep if key is rejected: Select this option for an audible indication
of key rejection.

Enable Toggle Keys Select this option for an audible indication of a toggle keypress. You
hear one beep when a toggle key is turned on. You hear two beeps
when a toggle key is turned off.

Type to test settings The test area is an interactive interface so you can see how the
keyboard settings affect the display as you type. Type text in the test
area to test the effect of your settings.

For more information on configuring keyboard accessibility preferences, see GNOME
2.2 Desktop Accessibility Guide.

Mouse Settings
Table 11–4 lists the mouse settings that you can modify.

TABLE 11–4 Mouse Settings

Option Function

Enable keyboard
accessibility features

Select this option to enable keyboard accessibility features. When you
select this option, the other options in the preference tool become
available.
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TABLE 11–4 Mouse Settings (Continued)
Option Function

Enable Mouse Keys Select this option to make the numeric keypad emulate mouse
actions. You can specify the following mouse key settings:
� Maximum pointer speed: Use this setting to specify the

maximum speed that the pointer moves across the screen.
� Time to accelerate to maximum speed: Use this setting to specify

the duration of the acceleration time of the pointer.
� Delay between keypress and pointer movement: Use this setting

to specify the period of time that must pass after a keypress
before the pointer moves.

Mouse Preferences Click on this button to open the Mouse preference tool.

For more information on configuring keyboard accessibility preferences, see GNOME
2.2 Desktop Accessibility Guide.
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Glossary

applet An applet is a small, interactive application that resides within a panel,
for example the CD Player. Each applet has a simple user interface that
you can operate with the mouse or keyboard.

desktop The part of the desktop environment where there are no interface
graphical items, such as panels and windows.

desktop background The image or color that is applied to your desktop.

desktop object An icon on your desktop that you can use to open your files, folders,
and applications. You can use desktop objects to provide convenient
access to files, folders, and applications that you use frequently.

desktop environment A windows-based environment for users. The desktop environment is
the sum of all the parts of your working environment. The desktop
environment includes all of your panels and windows, the desktop,
and all of your workspaces.

DNS name A unique alphabetic identifier for a computer on a network.

drawer A drawer is a sliding extension to a panel that you can open or close
from a drawer icon.

format To format media is to prepare the media for use with a particular file
system. When you format media, you overwrite any existing
information on the media.

GNOME-compliant
application

An application that uses the standard GNOME programming libraries
is called a GNOME-compliant application. For example, Nautilus and
gedit are GNOME-compliant applications.

IP address A unique numeric identifier for a computer on a network.

keyboard shortcut A keyboard shortcut is a key or combination of keys that provides an
alternative to standard ways of performing an action.

launcher A launcher starts a particular application, executes a command, or
opens a file. A launcher can reside in a panel or in a menu.
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menubar A menubar is a bar at the top of an application window that contains
the menus for the application.

MIME type A Multipurpose Internet Mail Extension (MIME) type identifies the
format of a file. The MIME type enables applications to read the file.
For example, an email application can use the image/png MIME type
to detect that a Portable Networks Graphic (PNG) file is attached to an
email.

mount To mount is to make a file system available for access. When you
mount a file system, the file system is attached as a subdirectory to
your file system.

pane A pane is a subdivision of a window. For example, the Nautilus
window contains a side pane and a view pane.

preference tool A dedicated software tool that controls a particular part of the
behavior of the desktop environment.

shortcut keys Shortcut keys are keystrokes that provide a quick way to perform an
action.

stacking order The stacking order is the order in which windows are stacked on top
of each other on your screen.

statusbar A statusbar is a bar at the bottom of a window that provides
information about the current state of what you are viewing in the
window.

symbolic link A special type of file that points to another file or folder. When you
perform an action on a symbolic link, the action is performed on the
file or folder to which the symbolic link points.

toolbar A toolbar is a bar that contains buttons for the most commonly-used
commands in an application. Typically, a toolbar appears under a
menubar.

Uniform Resource
Identifier

A Uniform Resource Identifier (URI) is a string that identifies a
particular location in a file system or on the Web. For example, the
address of a web page is a URI.

Uniform Resource
Locator

A Uniform Resource Locator (URL) is the address of a particular
location on the Web.

view A Nautilus component that enables you to display a folder in a
particular way. For example, Nautilus contains an icon view which
enables you to display the contents of a folder as icons. Nautilus also
contains a list view which enables you to display the contents of a
folder as a list.

viewer component A Nautilus component that enables you to display a particular type of
file in the view pane. A viewer component might add menu items that
are relevant to the file type to the Nautilus menus. A viewer
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component might also enable you to use the Nautilus zoom buttons to
change the size of the item in the view pane.

workspace A workspace is a discrete area in the desktop environment in which
you can work.
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Index

A
access keys, 24
accessibility

bounce keys, 190
configuring keyboard, 188
mouse keys, 191
repeat keys, 189
setting assistive technology preferences, 187
slow keys, 190
sticky keys, 189
toggle keys, 190

AccessX, See preference tools, Keyboard
Accessibility

applets
adding to panel, 59
getting help, 43
introduction, 59
modifying preferences, 60
Notification Area, 68
overview, 31
selecting, 60
Window List, 91
Workspace Switcher, 92

applications
help, 43
overview, 42
terminating, 65

B
backgrounds

adding colors, 134

backgrounds (Continued)
adding patterns, 134
changing desktop background, 150
changing screen component, 133
customizing desktop background, 156

basic skills
keyboard skills, 21
mouse skills, 17
using windows, 25

bottom edge panel
default contents, 52
introduction, 52

burning CDs, See writing CDs
buttons

adding to panel, 64
Force Quit, 65
Lock, 65
Log Out, 66
Run, 66
Screenshot, 67
Search, 67
Show Desktop, 67

C
CDs, writing, 138
closing windows, 95
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D
default applications, See preferred applications
desktop

adding a file or folder to, 145
adding emblems to objects, 147
adding launchers, 144
adding notes to objects, 147
adding symbolic links, 144
background, changing pattern or color, 150
changing icon of a desktop object, 147
changing permissions of object, 147
copying a file or folder to, 145
creating a folder on, 146
customizing background, 156
deleting an object from, 146
desktop objects, 142
introduction, 141
moving a file or folder to, 145
opening objects, 143
overview, 39
removing an object from, 146
renaming object, 146
resizing icons, 148
selecting objects, 143
using Desktop menu, 149
using Trash, 148
viewing properties of object, 146

desktop environment components,
introducing, 27

desktop environment preference tools, See
preference tools

Desktop menu
description, 149
illustration, 149

desktop objects
adding emblems, 147
adding notes to, 147
changing icons, 147
changing permissions, 147
deleting, 146
files and folders, 145
launchers, 144
opening, 143
removing, 146
renaming, 146
resizing icons, 148
selecting, 143
symbolic links, 144

desktop objects (Continued)
viewing properties, 146

drawers
adding objects to, 70
adding to panel, 70
closing, 70
modifying properties, 70
opening, 70

E
email client, preferred application, 181
emblems

adding new, 121
adding to desktop objects, 147
adding to file, 121
adding to folder, 121
introduction, 103

events, associating sounds with, 168

F
file manager

assigning actions to files, 128
audio view

illustration, 124
bookmarks, 112
changing backgrounds, 133
changing permissions, 118
copying files and folders, 115
creating folders, 116
creating symbolic link, 117
customizing, 129
deleting files or folders, 117
displaying folders, 105
drag-and-drop, 113
duplicating files and folders, 116
emblems

See emblems
executing default actions for files, 107
executing non-default actions for files, 108
executing other actions for files, 108
FTP sites

See FTP sites
History, 112
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file manager (Continued)
Home location

See Home location
icon view

arranging files in, 125
illustration, 100

icons
caption preferences, 132
changing, 121
introduction, 103
resizing, 126

introduction, 99
list view

illustration, 124
managing files and folders, 113
modifying actions, 128
modifying appearance of files and

folders, 121
moving files and folders, 115
navigating, 105
navigating history list, 111
network servers

See network servers
notes

adding, 119
deleting, 119

opening files, 107
overview, 37
preferences

behavior, 131
icon captions, 132
introduction, 129
preference tool, 157
preview, 133
views, 130

renaming folders, 116
running scripts, 139
selecting files and folders, 114
side pane

introduction, 103
special URI locations, 110
Start Here location

See Start Here location
Trash

See Trash
Tree, using, 106

file manager (Continued)
view pane

See view pane
viewing files in view pane, 107
viewing properties, 118
views

choosing, 125
introduction, 123
modifying behavior, 127

window components, showing and
hiding, 134

windows, 100
writing CDs, 138
zooming in and out, 122

file types
adding, 177
configuring, 176
editing, 177

focus, giving to a window, 94
fonts

applications, 158
desktop, 158
previewing, 159
rendering, 158
terminal, 158
window title, 158

Force Quit button, 65
FTP sites, accessing, 109

G
GTK+ themes, See themes, controls options

H
help

applets, 43
applications, 43
desktop environment topics, 43
how to find, 43
starting help system, 43

Home location, displaying, 105
hot keys, configuring, 161
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I
icon themes, See themes, icons options

K
keyboard

basic skills, 21
configuring accessibility options, 188
configuring general preferences, 159
configuring sound preferences, 170

keyboard shortcuts, configuring, 161

L
language, logging in in different, 46
launchers

adding to panel, 61, 75
modifying properties, 64

Lock button, 46, 65
locking panel objects, 59
locking screen, 46, 65
Log Out button, 66
logging in

to session, 46
to session in different language, 46

logging out, 49

M
Main Menu

adding to panel, 80
introduction, 79
opening, 79

maximizing windows, 95
Menu Bar

adding to panel, 80
introduction, 80

menu item popup menu
description, 74
illustration, 75

menus
Actions menu, 76
adding, 81
adding launchers to, 81
adding to panel, 68, 75

menus (Continued)
Applications menu, 76
copying launchers to, 82
customizing, 80
deleting menu items, 83
Desktop menu, 149
editing menu items, 82
editing properties, 82
features, 74
in applications, customizing

appearance, 161
introduction, 73
Main Menu

See Main Menu
Menu Bar

See Menu Bar
menu item popup menu, 74
overview, 33
Window Menu, 90

Metacity themes, See themes, window frame
options

minimizing, windows, 94
mouse

action terminology, 19
actions, 18
basic skills, 17
button conventions, 17
configuring, 162
pointers, 19

moving windows, 96

N
Nautilus desktop, See desktop
Nautilus file manager, See file manager
network proxy, setting preferences, 164
network servers, accessing, 109
notes

adding to desktop objects, 147
adding to files and folders, 119
deleting, 119

Notification Area applet, 68

P
panel object popup menu, illustration, 57
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panel objects
adding, 57
applets

See applets
drawers

See drawers
Force Quit button, 65
interacting with, 56
launchers

See launchers
Lock button, 65
locking, 59
Log Out button, 66
menus, 68
modifying properties, 57
moving, 58
Notification Area applet, 68
removing, 59
Run button, 66
Screenshot button, 67
Search button, 67
Show Desktop button, 67

panels
adding new, 53
bottom edge panel

See bottom edge panel
changing background, 56
customizing behavior and appearance, 179
deleting, 56
hiding, 53
interacting with, 53
introduction, 51
managing, 53
modifying properties, 54
moving, 53
overview, 30
panel objects

See panel objects
top edge panel

See top edge panel
panes, resizing, 25
permissions

and emblems, 104
changing file and folder, 118
displaying as characters, 132
displaying in octal notation, 132
introduction, 118

pointers, See mouse pointers
preference tools

Assistive Technology, 187
Background, 156
CD Database, 176
File Management, 157
File Types and Programs, 176
Font, 158
Keyboard, 159
Keyboard Accessibility, 188
Keyboard Shortcuts, 161
Menus & Toolbars, 161
Mouse, 162
Network Proxy, 164
overview, 41
Panel, 179
Preferred Applications, 180
Screen Resolution, 168
Screensaver, 165
Sessions, 47, 182
Sound, 168
Theme, 170
Windows, 173

preferences, file manager, See file manager
preferences

preferred applications
email client, 181
terminal, 182
text editor, 181
web browser, 180

proxy, setting preferences, 164

R
removable media

displaying media contents, 135
displaying media properties, 136
ejecting, 137
formatting floppy diskette, 136
introduction, 135
mounting, 135

resizing windows, 95
restoring, windows, 95
rolling up windows, 96
Run Application dialog, using, 77
Run button, 66
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S
Samba servers, See Windows shares
screensaver, setting preferences, 165
Screenshot button, 67
screenshots, taking, 77
scripts, running from file manager, 139
Search button, 67
services

adding, 178
configuring, 176
editing, 177

sessions
browsing applications, 48
configuring screensaver, 165
different language, logging in, 46
ending, 49
locking screen, 46
logging in, 46
logging out, 49
login behavior, 47
logout behavior, 47
managing, 47
preferences, 182
saving settings, 48
setting options, 182
setting properties, 183
starting, 45
using startup applications, 48

shading windows, See rolling up windows
shortcut keys

application, 23
configuring, 161
desktop environment, 21
panel, 23
window, 22

Show Desktop button, 67
side pane, See file manager
sound

associating events with sounds, 168
configuring system bell preferences, 170
setting preferences, 168

sound server, 168
special URI locations

accessing, 110
and launchers, 61

special URIs, launchers, 64
Start Here location

overview, 40

Start Here location (Continued)
using, 108

startup applications
customizing, 182
non-session-managed, 48, 184
session-managed, 47, 183

startup programs, See startup applications
symbolic link

to desktop object, creating, 144
to file or folder, creating, 117

symbolic links, and emblems, 104
system bell, configuring preferences, 170

T
tables, using, 25
terminal, preferred application, 182
terminating applications, 65
text editor, preferred application, 181
themes

controls options
introduction, 171

icons options
introduction, 171

setting controls themes, 170
setting icons themes, 170
setting window frame themes, 170
window frame options

introduction, 171
toolbars, customizing appearance, 161
top edge panel

default contents, 52
introduction, 52
window list icon, 52, 93

Trash
displaying, 120, 149
emptying, 120, 149
introduction, 120
moving files or folders to, 116
using on desktop, 148

Tree, using, 106
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U
URI, special, See special URI locations

V
view pane

introduction, 101
viewing files in, 107

viewer components, 102, 107, 123

W
web browser, preferred application, 180
Window List applet

grouping buttons, 92
introduction, 91
window status information, 91

window lists
top edge panel, 93
Window List applet, 91

window manager, customizing, 173
windows

applets and menus for working with, 89
closing, 95
frame control elements, 88
frames, 88
giving focus to, 94
introduction, 85
manipulating, 94
maximizing, 95
minimizing, 94
moving, 96
moving to another workspace, 97
overview, 34
putting on all workspaces, 97
resizing, 95
resizing panes, 25
restoring, 95
rolling up, 96
setting frame themes, 170
themes, 88
types of, 86
using tables, 25
Window List applet

See Window List applet
window managers, 86

windows (Continued)
Window Menu, 90

Workspace Switcher applet, 92
workspaces

adding, 98
deleting, 98
introduction, 85
manipulating, 97
moving windows to, 97
naming, 98
overview, 36
specifying number of, 37
switching between, 37, 97
Workspace Switcher applet, 92

writing CDs, 138

X
XScreenSaver, See screensaver
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