summaryrefslogtreecommitdiffstats
path: root/introduction-to-gnome/C/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'introduction-to-gnome/C/Makefile.am')
-rw-r--r--introduction-to-gnome/C/Makefile.am101
1 files changed, 9 insertions, 92 deletions
diff --git a/introduction-to-gnome/C/Makefile.am b/introduction-to-gnome/C/Makefile.am
index 761006f..8f1d3fd 100644
--- a/introduction-to-gnome/C/Makefile.am
+++ b/introduction-to-gnome/C/Makefile.am
@@ -1,93 +1,10 @@
-omffiles=gnome-intro-C.omf
-omf_dir=$(top_srcdir)/omf-install
-
-gnome_user_docs_intro_helpdir = $(datadir)/gnome/help/gnome-intro/C
-
-gnome_user_docs_intro_help_DATA = gnome-intro.sgml
-
-# the "portable" `basename' stand-in should work for the files that we
-# throw at it
-install-data-local: index.html
- $(mkinstalldirs) $(gnome_user_docs_intro_helpdir)
- $(mkinstalldirs) $(gnome_user_docs_intro_helpdir)/figs
- $(mkinstalldirs) $(gnome_user_docs_intro_helpdir)/stylesheet-images
- $(INSTALL_DATA) $(srcdir)/index.html $(gnome_user_docs_intro_helpdir)/
- $(INSTALL_DATA) $(srcdir)/gnome-intro.sgml $(gnome_user_docs_intro_helpdir)/
-
- for file in gnome-intro/*.html; do \
- basefile=`echo $$file | sed -e 's,^.*/,,'`; \
- $(INSTALL_DATA) $(srcdir)/$$file $(gnome_user_docs_intro_helpdir)/$$basefile; \
- done
- for file in gnome-intro/*.css; do \
- basefile=`echo $$file | sed -e 's,^.*/,,'`; \
- $(INSTALL_DATA) $(srcdir)/$$file $(gnome_user_docs_intro_helpdir)/$$basefile; \
- done
- for file in gnome-intro/figs/*.png; do \
- basefile=`echo $$file | sed -e 's,^.*/,,'`; \
- $(INSTALL_DATA) $(srcdir)/$$file $(gnome_user_docs_intro_helpdir)/figs/$$basefile; \
- done
- for file in gnome-intro/stylesheet-images/*.gif; do \
- basefile=`echo $$file | sed -e 's,^.*/,,'`; \
- $(INSTALL_DATA) $(srcdir)/$$file $(gnome_user_docs_intro_helpdir)/stylesheet-images/$$basefile; \
- done
-
-EXTRA_DIST = $(gnome_user_docs_intro_help_DATA)
-
-manual-html: index.html
-manual-ps: gnome-intro.ps
-manual-pdf: gnome-intro.pdf
-manual-rtf: gnome-intro.rtf
-manual-all: manual-html manual-ps manual-pdf manual-rtf
-
-all: index.html omf
-
-omf: $(omffiles)
- -for omffile in $(omffiles); do \
- which scrollkeeper-preinstall >/dev/null 2>&1 && scrollkeeper-preinstall $(gnome_user_docs_intro_helpdir)/gnome-intro.sgml $$omffile $(omf_dir)/$$omffile; \
- done
-
-
-clean:
- rm -rf gnome-intro
- rm -rf gnome-intro.junk
- rm -f figs/*.eps
- rm -f *.log *.aux *.dvi *.tex
- rm -rf DB2*OUTPUT*
- rm -rf DBTO*OUTPUT*
- rm -f index.html
-
-cvsclean: clean
- [ -f Makefile.am ] && rm Makefile.in Makefile
-
-gnome-intro.ps: gnome-intro.sgml
- $(MAKE) -C figs
- db2ps $<
-
-gnome-intro.pdf: gnome-intro.ps
- ps2pdf $<
-
-gnome-intro.rtf: gnome-intro.sgml
- $(MAKE) -C figs
- db2rtf $<
-
-index.html: gnome-intro/index.html
- cd $(srcdir) \
- && cp gnome-intro/index.html index.html
-
-gnome-intro/index.html: gnome-intro.sgml
- -(db2html gnome-intro.sgml \
- && mkdir -p gnome-intro/figs \
- && cp $(srcdir)/figs/*.png gnome-intro/figs || exit 1)
-
-
-dist-hook: all
- mkdir $(distdir)/gnome-intro
- mkdir $(distdir)/gnome-intro/figs
- mkdir $(distdir)/gnome-intro/stylesheet-images
- cp gnome-intro/*.html $(distdir)/gnome-intro
- cp gnome-intro.sgml $(distdir)/gnome-intro
- cp gnome-intro/*.css $(distdir)/gnome-intro
- cp gnome-intro/figs/*.png $(distdir)/gnome-intro/figs
- cp gnome-intro/stylesheet-images/*.gif $(distdir)/gnome-intro/stylesheet-images
- cp $(omffiles) $(distdir)
+figs = \
+ figures/desktop.png \
+ figures/microguiborder.png
+docname = introduction-to-gnome
+lang = C
+omffile = introduction-to-gnome-C.omf
+sgml_ents =
+include $(top_srcdir)/sgmldocs.make
+dist-hook: app-dist-hook