summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDan Mueth <dan@eazel.com>2001-03-12 08:20:35 +0000
committerDan Mueth <dmueth@src.gnome.org>2001-03-12 08:20:35 +0000
commit72d8e0ab83d16e5dedd323354fa37d9f52ca1b1e (patch)
tree3f06403942058c8d16aee5773b84368a7615f3fa /configure.in
parent93d84de72d66cfee121f3ea70f667141a75861bb (diff)
downloadgnome-user-docs-72d8e0ab83d16e5dedd323354fa37d9f52ca1b1e.tar.gz
gnome-user-docs-72d8e0ab83d16e5dedd323354fa37d9f52ca1b1e.tar.xz
gnome-user-docs-72d8e0ab83d16e5dedd323354fa37d9f52ca1b1e.zip
Setting up basics of build system. Still needs some tweaking.
2001-03-12 Dan Mueth <dan@eazel.com> Setting up basics of build system. Still needs some tweaking. * AUTHORS: * COPYING: * COPYING-DOCS: * Makefile.am: * autogen.sh: * configure.in: * gnome-user-docs.spec.in: * sgmldocs.make: * omf-install/Makefile.am: * introduction-to-gnome/Makefile.am: * introduction-to-gnome/C/Makefile.am: Removing these for now, until we can fix up the build to properly do PS docs. * introduction-to-gnome/C/figures/Makefile: * introduction-to-gnome/C/figures/gnome-logo-large.png: * introduction-to-gnome/C/figures/img2eps: Renaming gnome-intro... to introduction-to-gnome... Sasha wrote these docs. * introduction-to-gnome/C/gnome-intro-C.omf: * introduction-to-gnome/C/gnome-intro.sgml: * introduction-to-gnome/C/introduction-to-gnome-C.omf: * introduction-to-gnome/C/introduction-to-gnome.sgml:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 28 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..412a083
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,28 @@
+AC_INIT(introduction-to-gnome)
+
+SCROLLKEEPER_REQUIRED=0.1.4
+AC_SUBST(SCROLLKEEPER_REQUIRED)
+
+AM_INIT_AUTOMAKE(gnome-user-docs, 1.3.0)
+
+AM_MAINTAINER_MODE
+
+dnl ====================================
+dnl = Begin tests for scrollkeeper
+dnl ====================================
+AC_PATH_PROG(SCROLLKEEPER_CONFIG, scrollkeeper-config,no)
+if test x$SCROLLKEEPER_CONFIG = xno; then
+ AC_MSG_ERROR(Couldn't find scrollkeeper-config, please install the scrollkeeper packaga)
+fi
+dnl ====================================
+dnl = End tests for scrollkeeper
+dnl ====================================
+
+
+AC_OUTPUT([
+Makefile
+gnome-user-docs.spec
+introduction-to-gnome/Makefile
+introduction-to-gnome/C/Makefile
+omf-install/Makefile
+])