summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2011-12-02 11:59:20 -0500
committerStephen Gallagher <sgallagh@redhat.com>2011-12-05 11:51:14 -0500
commit7cb5383dc99f74d373184ebcc568d32a5cbc0517 (patch)
treee9e71480da9a2b6bc3bc405ab947d32f8918b882 /configure.ac
parente78c9b966b9717dbfda9588ad4e4a0f67a524f36 (diff)
downloadsssd_unused-7cb5383dc99f74d373184ebcc568d32a5cbc0517.tar.gz
sssd_unused-7cb5383dc99f74d373184ebcc568d32a5cbc0517.tar.xz
sssd_unused-7cb5383dc99f74d373184ebcc568d32a5cbc0517.zip
Allow using Glib for UTF8 support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d86b16a7..caac10fb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -122,7 +122,19 @@ m4_include([src/external/nsupdate.m4])
m4_include([src/external/libkeyutils.m4])
m4_include([src/external/libnl.m4])
m4_include([src/util/signal.m4])
-m4_include([src/external/libunistring.m4])
+
+WITH_UNICODE_LIB
+if test x$unicode_lib = xlibunistring; then
+ m4_include([src/external/libunistring.m4])
+ AC_DEFINE_UNQUOTED(HAVE_LIBUNISTRING, 1, [Using libunistring for unicode])
+ UNICODE_LIBS=-lunistring
+ AC_SUBST(UNICODE_LIBS)
+else
+ m4_include([src/external/glib.m4])
+ AC_DEFINE_UNQUOTED(HAVE_GLIB2, 1, [Using libunistring for unicode])
+ UNICODE_LIBS=$GLIB2_LIBS
+ AC_SUBST(UNICODE_LIBS)
+fi
PKG_CHECK_MODULES([DBUS],[dbus-1])
dnl if test -n "`$PKG_CONFIG --modversion dbus-1 | grep '^0\.'`" ; then