summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2011-06-06 22:26:28 -0400
committerStephen Gallagher <sgallagh@redhat.com>2011-08-04 10:28:14 -0400
commit6d7450e996e7c699aebf12422cc7080a0782b9ae (patch)
treede1c1245e0b888d80493f859c79938ba37d5e1fb /configure.ac
parent47985a7b3a1a4c00b38350692197ce360e5e36ef (diff)
downloadsssd_unused-6d7450e996e7c699aebf12422cc7080a0782b9ae.tar.gz
sssd_unused-6d7450e996e7c699aebf12422cc7080a0782b9ae.tar.xz
sssd_unused-6d7450e996e7c699aebf12422cc7080a0782b9ae.zip
Rewrite HBAC rule evaluator
Add helper function msgs2attrs_array This function converts a list of ldb_messages into a list of sysdb_attrs. Conflicts: src/providers/ldap/ldap_common.c src/providers/ldap/ldap_common.h Add HBAC evaluator and tests Add helper functions for looking up HBAC rule components Remove old HBAC implementation Add new HBAC lookup and evaluation routines Conflicts: Makefile.am Add ipa_hbac_refresh option This option describes the time between refreshes of the HBAC rules on the IPA server. Add ipa_hbac_treat_deny_as option By default, we will treat the presence of any DENY rule as denying all users. This option will allow the admin to explicitly ignore DENY rules during a transitional period. Treat NULL or empty rhost as unknown Previously, we were assuming this meant it was coming from the localhost, but this is not a safe assumption. We will now treat it as unknown and it will fail to match any rule that requires a specified srchost or group of srchosts. libipa_hbac: Support case-insensitive comparisons with UTF8 UTF8 HBAC test Fix memory leak in ipa_hbac_evaluate_rules https://fedorahosted.org/sssd/ticket/933 Fix incorrect NULL check in ipa_hbac_common.c https://fedorahosted.org/sssd/ticket/936 Require matched version and release for libipa_hbac Add rule validator to libipa_hbac https://fedorahosted.org/sssd/ticket/943
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 84b83eb1..f11dfb87 100644
--- a/configure.ac
+++ b/configure.ac
@@ -121,6 +121,7 @@ m4_include([src/external/nsupdate.m4])
m4_include([src/external/libkeyutils.m4])
m4_include([src/external/libnl.m4])
m4_include([src/util/signal.m4])
+m4_include([src/external/libunistring.m4])
PKG_CHECK_MODULES([DBUS],[dbus-1])
dnl if test -n "`$PKG_CONFIG --modversion dbus-1 | grep '^0\.'`" ; then
@@ -187,6 +188,7 @@ AC_DEFINE_UNQUOTED([ABS_BUILD_DIR], ["$abs_build_dir"], [Absolute path to the bu
AC_SUBST([abs_builddir], $abs_build_dir)
AC_CONFIG_FILES([Makefile contrib/sssd.spec src/examples/rwtab src/doxy.config
- src/sysv/systemd/sssd.service po/Makefile.in src/man/Makefile])
+ src/sysv/systemd/sssd.service po/Makefile.in src/man/Makefile
+ src/providers/ipa/ipa_hbac.pc])
AC_OUTPUT