summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@inai.de>2012-05-11 14:23:51 -0400
committerStephen Gallagher <sgallagh@redhat.com>2012-05-11 14:30:56 -0400
commitd248b68f90e60a1dd1cca1f694cc51bc3007c8b1 (patch)
treeb3c67fdff7a9ca0c5e5f9ad4a7c31d3a024b3233 /Makefile.am
parent79a93ba6dc35ebe525e2d7587bc7e293e8cf3b81 (diff)
downloadsssd_unused-d248b68f90e60a1dd1cca1f694cc51bc3007c8b1.tar.gz
sssd_unused-d248b68f90e60a1dd1cca1f694cc51bc3007c8b1.tar.xz
sssd_unused-d248b68f90e60a1dd1cca1f694cc51bc3007c8b1.zip
build: resolve link failure
libtool: link: gcc -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual -Wcast-align -Wwrite-strings -Werror-implicit-function-declaration -fno-strict-aliasing -fmessage-length=0 -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -g -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -Wl,--version-script -Wl,./src/providers/sssd_be.exports -o sssd_be src/providers/data_provider_be.o src/providers/data_provider_fo.o src/providers/data_provider_opts.o src/providers/data_provider_callbacks.o src/providers/fail_over.o src/resolv/async_resolv.o -Wl,--export-dynamic -lpam -lcares ./.libs/libsss_util.a -ltevent -ltalloc -lpopt -lldb -ldbus-1 -lpcre -lini_config -lcollection -ldhash -llber -lldap -ltdb -lunistring -lcrypto /usr/lib64/gcc/x86_64-suse-linux/4.7/../../../../x86_64-suse-linux/bin/ld: src/providers/data_provider_be.o: undefined reference to symbol 'dlsym@@GLIBC_2.2.5' /usr/lib64/gcc/x86_64-suse-linux/4.7/../../../../x86_64-suse-linux/bin/ld: note: 'dlsym@@GLIBC_2.2.5' is defined in DSO /lib64/libdl.so.2 so try adding it to the linker command line /lib64/libdl.so.2: could not read symbols: Invalid operation collect2: error: ld returned 1 exit status make[2]: *** [sssd_be] Error 1 Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b36464bb..5089b8e5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -587,6 +587,7 @@ sssd_be_SOURCES = \
src/providers/data_provider_callbacks.c \
$(SSSD_FAILOVER_OBJ)
sssd_be_LDADD = \
+ -ldl \
$(SSSD_LIBS) \
$(CARES_LIBS) \
libsss_util.la