summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2012-01-27 12:00:17 +0100
committerStephen Gallagher <sgallagh@redhat.com>2012-03-26 20:17:21 -0400
commita6098862048d4bb469130b9ff21be3020d6f2c54 (patch)
treeae1233d430251936fed1ac376b59df8879755c01 /Makefile.am
parentd7e3a3704d22e69f01214873a7207b4fc760d3f3 (diff)
downloadsssd_unused-a6098862048d4bb469130b9ff21be3020d6f2c54.tar.gz
sssd_unused-a6098862048d4bb469130b9ff21be3020d6f2c54.tar.xz
sssd_unused-a6098862048d4bb469130b9ff21be3020d6f2c54.zip
Add idmap library
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 24 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index bdbfd481..1e93305c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -114,7 +114,8 @@ if HAVE_CHECK
crypto-tests \
util-tests \
debug-tests \
- ipa_hbac-tests
+ ipa_hbac-tests \
+ sss_idmap-tests
endif
check_PROGRAMS = \
@@ -461,7 +462,7 @@ libsss_util_la_SOURCES += \
src/util/sss_ssh.c
endif
-lib_LTLIBRARIES = libipa_hbac.la
+lib_LTLIBRARIES = libipa_hbac.la libsss_idmap.la
dist_pkgconfig_DATA += src/providers/ipa/ipa_hbac.pc
libipa_hbac_la_SOURCES = \
src/providers/ipa/hbac_evaluator.c \
@@ -470,8 +471,16 @@ libipa_hbac_la_LDFLAGS = \
-version 1:0:1 \
$(UNICODE_LIBS)
+dist_pkgconfig_DATA += src/lib/idmap/sss_idmap.pc
+libsss_idmap_la_SOURCES = \
+ src/lib/idmap/sss_idmap.c
+libsss_idmap_la_LDFLAGS = \
+ -version 1:0:1
+
+
include_HEADERS = \
- src/providers/ipa/ipa_hbac.h
+ src/providers/ipa/ipa_hbac.h \
+ src/lib/idmap/sss_idmap.h
####################
# Program Binaries #
@@ -914,6 +923,17 @@ ipa_hbac_tests_LDADD = \
libsss_test_common.la \
libipa_hbac.la
+sss_idmap_tests_SOURCES = \
+ src/tests/sss_idmap-tests.c
+sss_idmap_tests_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(CHECK_CFLAGS)
+sss_idmap_tests_LDADD = \
+ $(CHECK_LIBS) \
+ $(TALLOC_LIBS) \
+ libsss_test_common.la \
+ libsss_idmap.la
+
endif
stress_tests_SOURCES = \
@@ -1383,6 +1403,7 @@ if HAVE_DOXYGEN
docs:
$(DOXYGEN) src/doxy.config
$(DOXYGEN) src/providers/ipa/ipa_hbac.doxy
+ $(DOXYGEN) src/lib/idmap/sss_idmap.doxy
if BUILD_SUDO
$(DOXYGEN) src/sss_client/sudo/sss_sudo.doxy
endif BUILD_SUDO