summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2011-10-13 15:56:46 -0400
committerStephen Gallagher <sgallagh@redhat.com>2011-10-14 08:57:32 -0400
commit8b15480dfacd883077729a3332a8cdcfd97e9488 (patch)
tree0249010e0165323b64a95a1ef7430918b9d98d99 /Makefile.am
parent66f9d4a3419bd8d41bd1ba50e69b00acd22e3123 (diff)
downloadsssd_unused-8b15480dfacd883077729a3332a8cdcfd97e9488.tar.gz
sssd_unused-8b15480dfacd883077729a3332a8cdcfd97e9488.tar.xz
sssd_unused-8b15480dfacd883077729a3332a8cdcfd97e9488.zip
BUILDSYS: Fix --without-manpages
We weren't honoring the --without-manpages option, and this was causing builds to break. Note: 'make dist[check]' will not work if you have configured with --without-manpages because it will not be able to pre-generate the translation files necessary for tarball release.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d30d07b2..916881e1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,10 @@
DISTCHECK_CONFIGURE_FLAGS = --with-ldb-lib-dir="$$dc_install_base"/lib/ldb
-SUBDIRS = po src/man
+SUBDIRS = po
+
+if HAVE_MANPAGES
+SUBDIRS += src/man
+endif
# Some old versions of automake don't define builddir
builddir ?= .
@@ -1039,7 +1043,9 @@ endif
# TRANSLATIONS #
################
update-po:
+if HAVE_MANPAGES
$(MAKE) -C src/man update-po
+endif
$(MAKE) -C po update-po
#######################