summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2017-09-06 16:42:20 +0200
committerJakub Hrozek <jhrozek@redhat.com>2017-09-14 16:57:09 +0200
commitf2e70ec742cd7aab82b74d7e4b424ba3258da7aa (patch)
treeacf40a7bf82695de7566097168204ac2c9696047 /Makefile.am
parentf5a8cd60c6f377af1954b58f007d16cf3f6dc846 (diff)
downloadsssd-f2e70ec742cd7aab82b74d7e4b424ba3258da7aa.tar.gz
sssd-f2e70ec742cd7aab82b74d7e4b424ba3258da7aa.tar.xz
sssd-f2e70ec742cd7aab82b74d7e4b424ba3258da7aa.zip
IPA: fix handling of certmap_ctx
This patch fixes a use-after-free in the AD provider part and initializes the certmap_ctx with data from the cache at startup. Related to https://pagure.io/SSSD/sssd/issue/3508 Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com> Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f99649e92..f1f467100 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -258,6 +258,7 @@ if HAVE_CMOCKA
test_search_bases \
test_ldap_auth \
test_sdap_access \
+ test_sdap_certmap \
sdap-tests \
test_sysdb_ts_cache \
test_sysdb_views \
@@ -2683,6 +2684,24 @@ test_sdap_access_LDADD = \
libdlopen_test_providers.la \
$(NULL)
+test_sdap_certmap_SOURCES = \
+ src/tests/cmocka/test_sdap_certmap.c \
+ src/providers/ldap/sdap_certmap.c \
+ $(NULL)
+test_sdap_certmap_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(TALLOC_CFLAGS) \
+ $(POPT_CFLAGS) \
+ $(NULL)
+test_sdap_certmap_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(TALLOC_LIBS) \
+ $(POPT_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la \
+ libsss_certmap.la \
+ $(NULL)
+
ad_access_filter_tests_SOURCES = \
src/tests/cmocka/test_ad_access_filter.c
ad_access_filter_tests_LDADD = \
@@ -3742,6 +3761,7 @@ libsss_ldap_common_la_SOURCES = \
src/providers/ldap/sdap_child_helpers.c \
src/providers/ldap/sdap_fd_events.c \
src/providers/ldap/sdap_id_op.c \
+ src/providers/ldap/sdap_certmap.c \
src/providers/ldap/sdap_idmap.c \
src/providers/ldap/sdap_idmap.h \
src/providers/ldap/sdap_range.c \