summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPetr Cech <pcech@redhat.com>2016-06-27 11:53:19 +0200
committerJakub Hrozek <jhrozek@redhat.com>2016-08-17 16:09:05 +0200
commite4d18b748fd8298b5cc6b6687ca05ffffa20c574 (patch)
tree9b7cc6131b7c966da75de99a9fc39b9b9552be63 /Makefile.am
parentba26252f43409a2e4c3d2396e4e7a21584bd725a (diff)
downloadsssd-e4d18b748fd8298b5cc6b6687ca05ffffa20c574.tar.gz
sssd-e4d18b748fd8298b5cc6b6687ca05ffffa20c574.tar.xz
sssd-e4d18b748fd8298b5cc6b6687ca05ffffa20c574.zip
TESTS: Adding tests for ad_enabled_domains option
There is special logic around ad_enabled_domains option: * option is disabled by default * master domain is always added to enabled domains Resolves: https://fedorahosted.org/sssd/ticket/2828 Reviewed-by: Jakub Hrozek <jhrozek@redhat.com> Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c74869722..85ed2d948 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -257,6 +257,7 @@ if HAVE_CMOCKA
test_sbus_opath \
test_fo_srv \
pam-srv-tests \
+ test_ad_subdom \
test_ipa_subdom_util \
test_tools_colondb \
test_krb5_wait_queue \
@@ -2802,6 +2803,25 @@ test_fo_srv_LDADD = \
libsss_test_common.la \
$(NULL)
+test_ad_subdom_SOURCES = \
+ src/tests/cmocka/test_ad_subdomains.c \
+ $(NULL)
+test_ad_subdom_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(NDR_NBT_CFLAGS) \
+ $(NULL)
+test_ad_subdom_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(POPT_LIBS) \
+ $(TALLOC_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_ldap_common.la \
+ libsss_ad_tests.la \
+ libsss_idmap.la \
+ libsss_test_common.la \
+ libdlopen_test_providers.la \
+ $(NULL)
+
test_ipa_subdom_util_SOURCES = \
src/tests/cmocka/test_ipa_subdomains_utils.c \
src/providers/ipa/ipa_subdomains_utils.c \