summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHoward Guo <hguo@suse.com>2016-10-11 10:35:13 +0200
committerLukas Slebodnik <lslebodn@redhat.com>2016-11-24 12:12:46 +0100
commitd2f93542650c2f9613043acfa8e2f368972a70cd (patch)
treee2d409d0f6a88400e1d15c2f88bfcce02deaa4b8 /Makefile.am
parent7171a7584dda534dde5409f3e7f4657e845ece15 (diff)
downloadsssd-d2f93542650c2f9613043acfa8e2f368972a70cd.tar.gz
sssd-d2f93542650c2f9613043acfa8e2f368972a70cd.tar.xz
sssd-d2f93542650c2f9613043acfa8e2f368972a70cd.zip
sss_client: Defer thread cancellation until completion of nss/pam operations
The client code is not cancellation-safe, an application which has cancelled an NSS operation will experience subtle bugs, hence thread cancellation is deferred until completion of client operations. Resolves: https://fedorahosted.org/sssd/ticket/3156 Reviewed-by: Sumit Bose <sbose@redhat.com> Reviewed-by: Florian Weimer <fweimer@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index e037930ff..9f1da4d1e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -792,10 +792,6 @@ endif
CLIENT_LIBS = $(LTLIBINTL)
-if HAVE_PTHREAD
-CLIENT_LIBS += -lpthread
-endif
-
if WITH_JOURNALD
SYSLOG_LIBS = $(JOURNALD_LIBS)
endif