summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Březina <pbrezina@redhat.com>2016-11-10 13:11:41 +0100
committerLukas Slebodnik <lslebodn@redhat.com>2016-12-19 23:28:46 +0100
commita5a3bbb0bbaeb8946c228c2fb7f0cf450595dd3e (patch)
treecde9d4432f98a348309755ac2611984ff56430c2 /Makefile.am
parent7162dc780fe9458018c577f6f1638522d74f63b0 (diff)
downloadsssd-a5a3bbb0bbaeb8946c228c2fb7f0cf450595dd3e.tar.gz
sssd-a5a3bbb0bbaeb8946c228c2fb7f0cf450595dd3e.tar.xz
sssd-a5a3bbb0bbaeb8946c228c2fb7f0cf450595dd3e.zip
utils: add sss_ptr_hash module
We often work with <string, pointer> type of hash table throughout sssd. This module creates and maintains such hash table and makes sure that hash entry is destroyed when original value is freed. Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 08cc5ef95..588884911 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -597,6 +597,7 @@ dist_noinst_HEADERS = \
src/util/safe-format-string.h \
src/util/strtonum.h \
src/util/sss_cli_cmd.h \
+ src/util/sss_ptr_hash.h \
src/util/sss_endian.h \
src/util/sss_nss.h \
src/util/sss_ldap.h \
@@ -973,6 +974,7 @@ libsss_util_la_SOURCES = \
src/util/string_utils.c \
src/util/become_user.c \
src/util/util_watchdog.c \
+ src/util/sss_ptr_hash.c \
$(NULL)
libsss_util_la_CFLAGS = \
$(AM_CFLAGS) \