summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2017-04-21 10:31:25 +0200
committerJakub Hrozek <jhrozek@redhat.com>2017-07-25 10:50:24 +0200
commit614545382c4ac75d85fb8c80917cc675bc0ec580 (patch)
tree9340dc1e489c4aeeb361b9214fc4d59f2b0ad3f8 /Makefile.am
parenta406b52a0d20e0ec502f52d63dee293636d1443a (diff)
downloadsssd-614545382c4ac75d85fb8c80917cc675bc0ec580.tar.gz
sssd-614545382c4ac75d85fb8c80917cc675bc0ec580.tar.xz
sssd-614545382c4ac75d85fb8c80917cc675bc0ec580.zip
KCM: Modify krb5 snippet file kcm_default_ccache
The file kcm_default_ccache must enable KCM ccache by default without any modification of the file. /etc/krb5.conf.d/ is fedora/el7 specific and it is not allowed to enable or start systemd services in scriptlets. It would result in broken krb5 configuration. Therefore krb5 configuration snippet was moved from /etc/krb5.conf.d/ -> /usr/share/sssd-kcm. And each downstream distribution should enable systemd services + change krb5 configuration in it's own way. Reviewed-by: Stephen Gallagher <sgallagh@redhat.com> Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 9000866b2..7f6c47c5b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -87,7 +87,7 @@ sudolibdir = @sudolibpath@
polkitdir = @polkitdir@
pamconfdir = $(sysconfdir)/pam.d
systemtap_tapdir = @tapset_dir@
-krb5sysincludedir = $(sysconfdir)/krb5.conf.d
+sssdkcmdatadir = $(datadir)/sssd-kcm
if HAVE_SYSTEMD_UNIT
ifp_exec_cmd = $(sssdlibexecdir)/sssd_ifp --uid 0 --gid 0 --debug-to-files --dbus-activated
@@ -189,7 +189,7 @@ sssdlibexec_PROGRAMS += sssd_secrets
endif
if BUILD_KCM
sssdlibexec_PROGRAMS += sssd_kcm
-dist_krb5sysinclude_DATA = contrib/kcm_default_ccache
+dist_sssdkcmdata_DATA = contrib/kcm_default_ccache
endif
@@ -4760,7 +4760,7 @@ if BUILD_SAMBA
mv $(DESTDIR)/$(winbindplugindir)/winbind_idmap_sss.so $(DESTDIR)/$(winbindplugindir)/sss.so
endif
if BUILD_KCM
- $(MKDIR_P) $(DESTDIR)/$(krb5sysincludedir)
+ $(MKDIR_P) $(DESTDIR)/$(sssdkcmdatadir)
endif
uninstall-hook: