summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSorah Fukumori <her@sorah.jp>2016-10-23 01:43:05 +0900
committerLukas Slebodnik <lslebodn@redhat.com>2016-10-22 22:54:10 +0200
commit13adcd07000ba3ca1422c6ee863df17d70e2b14c (patch)
treed34cd0880511575a99cb1a3eff5ce70f6bec1d8b /Makefile.am
parent96d239e83e671b82525cec760cf0bcaa5ee1c249 (diff)
downloadsssd-13adcd07000ba3ca1422c6ee863df17d70e2b14c.tar.gz
sssd-13adcd07000ba3ca1422c6ee863df17d70e2b14c.tar.xz
sssd-13adcd07000ba3ca1422c6ee863df17d70e2b14c.zip
BUILD: Fix installation without samba
winbindplugindir is defined only when BUILD_SAMBA is on. Also the file doesn't exist when BUILD_SAMBA is off, so installation will fail. Reviewed-by: Fabiano Fidêncio <fidencio@redhat.com> Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7fc4e2bd7..64328766e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4151,7 +4151,9 @@ install-data-hook:
if [ ! $(krb5rcachedir) = "__LIBKRB5_DEFAULTS__" ]; then \
$(MKDIR_P) $(DESTDIR)/$(krb5rcachedir) ; \
fi
+if BUILD_SAMBA
mv $(DESTDIR)/$(winbindplugindir)/winbind_idmap_sss.so $(DESTDIR)/$(winbindplugindir)/sss.so
+endif
uninstall-hook:
if [ -f $(abs_builddir)/src/config/.files2 ]; then \
@@ -4173,7 +4175,9 @@ if BUILD_PYTHON3_BINDINGS
cd $(DESTDIR)$(py3execdir) && \
rm -f pysss.so pyhbac.so pysss_murmur.so pysss_nss_idmap.so
endif
+if BUILD_SAMBA
rm $(DESTDIR)/$(winbindplugindir)/sss.so
+endif
clean-local:
if BUILD_PYTHON2_BINDINGS