summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJustin Stephenson <jstephen@redhat.com>2017-05-12 22:42:40 -0400
committerLukas Slebodnik <lslebodn@redhat.com>2017-09-25 21:50:32 +0200
commitda19eaea902744ec3cb41f87fa93fadb767f90e7 (patch)
tree7ddcb30ef6207b27626d63f6d2206ac0579d98c1 /Makefile.am
parentd2c614143870e6efd4b3ab20c3a55cf714595256 (diff)
downloadsssd-da19eaea902744ec3cb41f87fa93fadb767f90e7.tar.gz
sssd-da19eaea902744ec3cb41f87fa93fadb767f90e7.tar.xz
sssd-da19eaea902744ec3cb41f87fa93fadb767f90e7.zip
SSSCTL: Replace sss_debuglevel with shell wrapper
The sss_debuglevel binary is replaced by a shell wrapper calling sssctl debug-level as part of merging sss_debuglevel into sssctl. The wrapper will redirect sss_debuglevel to the sssctl debug-level command performing the same task. The sss_debuglevel(8) man page is updated to indicate that sss_debuglevel is deprecated and functionality exists now in sssctl. Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com> Reviewed-by: Jakub Hrozek <jhrozek@redhat.com> Reviewed-by: Michal Židek <mzidek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 352401ce5..cb2075b93 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -432,6 +432,10 @@ py3exec_LTLIBRARIES = \
$(NULL)
endif
+sbin_SCRIPTS = \
+ src/tools/wrappers/sss_debuglevel \
+ $(NULL)
+
dist_noinst_SCRIPTS = \
$(EXTRA_SCRIPTS) \
src/config/setup.py \
@@ -4668,6 +4672,14 @@ src/sysv/systemd/sssd-kcm.service: src/sysv/systemd/sssd-kcm.service.in Makefile
$(replace_script)
endif
+EXTRA_DIST += \
+ src/tools/wrappers/sss_debuglevel.in \
+ $(NULL)
+
+src/tools/wrappers/sss_debuglevel: src/tools/wrappers/sss_debuglevel.in Makefile
+ @$(MKDIR_P) src/tools/wrappers/
+ $(replace_script)
+
SSSD_USER_DIRS = \
$(DESTDIR)$(dbpath) \
$(DESTDIR)$(keytabdir) \
@@ -4912,6 +4924,7 @@ endif
rm -f $(builddir)/src/sysv/systemd/sssd-kcm.socket
rm -f $(builddir)/src/sysv/systemd/sssd-kcm.service
rm -f $(builddir)/src/sysv/systemd/journal.conf
+ rm -f $(builddir)/src/tools/wrappers/sss_debuglevel
CLEANFILES += *.X */*.X */*/*.X