summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJustin Stephenson <jstephen@redhat.com>2017-05-03 16:36:57 -0400
committerLukas Slebodnik <lslebodn@redhat.com>2017-09-08 16:09:30 +0200
commitd46d59e78600aa72176df7217c94743b7e71881a (patch)
treefbd189ce8ff3bc675069e0205c4f43c70465be39 /Makefile.am
parentf00591a4615720640cf01b1c408315b57dd397dc (diff)
downloadsssd-d46d59e78600aa72176df7217c94743b7e71881a.tar.gz
sssd-d46d59e78600aa72176df7217c94743b7e71881a.tar.xz
sssd-d46d59e78600aa72176df7217c94743b7e71881a.zip
DP: Add Generic DP Request Probes
Add the ability to analyze performance and monitor Data Provider requests at a high-level, probes fire when a request is sent and when a request is completed. Request name, domain, target, method, and return code information is passed as target variables to the systemtap probe tapsets which can be used in systemtap scripts. Resolves: https://pagure.io/SSSD/sssd/issue/3061 Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 42d7e4a17..f61560135 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1587,6 +1587,9 @@ sssd_be_LDADD = \
sssd_be_LDFLAGS = \
-Wl,--version-script,$(srcdir)/src/providers/sssd_be.exports \
-export-dynamic
+if BUILD_SYSTEMTAP
+sssd_be_LDADD += stap_generated_probes.lo
+endif
if BUILD_PYTHON_BINDINGS
sss_obfuscate_pythondir = $(sbindir)
@@ -1893,6 +1896,9 @@ libdlopen_test_providers_la_LIBADD = \
$(SSSD_LIBS) \
$(CARES_LIBS) \
$(SSSD_INTERNAL_LTLIBS)
+if BUILD_SYSTEMTAP
+libdlopen_test_providers_la_LIBADD += stap_generated_probes.lo
+endif
libdlopen_test_providers_la_LDFLAGS = \
-shared \
-avoid-version \
@@ -3317,6 +3323,9 @@ test_dp_request_LDADD = \
$(LIBADD_DL) \
libsss_test_common.la \
$(NULL)
+if BUILD_SYSTEMTAP
+test_dp_request_LDADD += stap_generated_probes.lo
+endif
test_dp_builtin_SOURCES = \
src/providers/data_provider/dp_modules.c \