summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2017-08-23 17:11:03 +0200
committerJakub Hrozek <jhrozek@redhat.com>2017-08-28 21:50:42 +0200
commitb4e45531b3e98efce868d8a01ebd2dbe54348217 (patch)
tree6ec86dc870c1a046547cc0831182615666c47b56 /Makefile.am
parent3f94a979eebd1c9496b49b4e07b7823550dec97e (diff)
downloadsssd-b4e45531b3e98efce868d8a01ebd2dbe54348217.tar.gz
sssd-b4e45531b3e98efce868d8a01ebd2dbe54348217.tar.xz
sssd-b4e45531b3e98efce868d8a01ebd2dbe54348217.zip
tests: add unit tests for krb5 localauth plugin
Reviewed-by: Jakub Hrozek <jhrozek@redhat.com> Reviewed-by: Fabiano FidĂȘncio <fidencio@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6cda729d3..9fc3dfcd1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -324,6 +324,10 @@ non_interactive_cmocka_based_tests += \
$(NULL)
endif
+if BUILD_KRB5_LOCALAUTH_PLUGIN
+non_interactive_cmocka_based_tests += test_sssd_krb5_localauth_plugin
+endif # BUILD_KRB5_LOCALAUTH_PLUGIN
+
endif # HAVE_CMOCKA
check_PROGRAMS = \
@@ -3521,6 +3525,20 @@ tcurl_test_tool_LDADD = \
$(NULL)
endif
+if BUILD_KRB5_LOCALAUTH_PLUGIN
+test_sssd_krb5_localauth_plugin_SOURCES = \
+ src/tests/cmocka/test_sssd_krb5_localauth_plugin.c \
+ src/krb5_plugin/sssd_krb5_localauth_plugin.c \
+ $(NULL)
+test_sssd_krb5_localauth_plugin_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(NULL)
+test_sssd_krb5_localauth_plugin_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(KRB5_LIBS) \
+ $(NULL)
+endif
+
#####################
# Integration tests #
#####################