summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAmitKumar <amitkuma@redhat.com>2017-07-23 05:19:27 +0530
committerJakub Hrozek <jhrozek@redhat.com>2017-08-03 11:08:15 +0200
commit3996e391054a1c02ab62e1541ae21a8204bd5d0a (patch)
tree2ea95da3956964681692514d711a80b3ec92b5b5 /Makefile.am
parent1b3425d8cbc5697f7321ba364e38ef4c5ed9f2b4 (diff)
downloadsssd-3996e391054a1c02ab62e1541ae21a8204bd5d0a.tar.gz
sssd-3996e391054a1c02ab62e1541ae21a8204bd5d0a.tar.xz
sssd-3996e391054a1c02ab62e1541ae21a8204bd5d0a.zip
Moving headers used by both server and client to special folder
These are the header files which are used by both client and server: src/util/io.h src/util/murmurhash3.h src/util/util_safealign.h This patch is about moving these header files to special folder (src/shared). It will be easier to identify these headers when looking for them in the src tree. util_safalign.h is renamed as safalign.h because util_ namespace is appropriate when this file belonged to the util's folder which is no longer the case. Resolves: https://pagure.io/SSSD/sssd/issue/1898 Reviewed-by: Fabiano FidĂȘncio <fidencio@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 62e0baf76..faa2fbaba 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -652,7 +652,6 @@ dist_noinst_HEADERS = \
src/util/dlinklist.h \
src/util/debug.h \
src/util/util.h \
- src/util/io.h \
src/util/util_errors.h \
src/util/safe-format-string.h \
src/util/session_recording.h \
@@ -673,13 +672,11 @@ dist_noinst_HEADERS = \
src/util/refcount.h \
src/util/find_uid.h \
src/util/user_info_msg.h \
- src/util/murmurhash3.h \
src/util/mmap_cache.h \
src/util/atomic_io.h \
src/util/auth_utils.h \
src/util/authtok.h \
src/util/authtok-utils.h \
- src/util/util_safealign.h \
src/util/util_sss_idmap.h \
src/util/util_creds.h \
src/util/inotify.h \
@@ -849,6 +846,9 @@ dist_noinst_HEADERS = \
src/tools/common/sss_colondb.h \
src/tools/sssctl/sssctl.h \
src/util/probes.h \
+ src/shared/io.h \
+ src/shared/murmurhash3.h \
+ src/shared/safealign.h \
$(NULL)