summaryrefslogtreecommitdiffstats
path: root/src/realmd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/realmd/CMakeLists.txt')
-rw-r--r--src/realmd/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/realmd/CMakeLists.txt b/src/realmd/CMakeLists.txt
index 545933c..4552382 100644
--- a/src/realmd/CMakeLists.txt
+++ b/src/realmd/CMakeLists.txt
@@ -45,4 +45,8 @@ target_link_libraries(${LIBRARY_NAME}
# Create registration file
cim_registration(${PROVIDER_NAME} ${LIBRARY_NAME} ${MOF} share/openlmi-providers)
+set(TARGET_MOF "${CMAKE_BINARY_DIR}/mof/90_LMI_Realmd_Profile.mof")
+profile_mof_generate("90_LMI_Realmd_Profile.mof.skel" "${TARGET_MOF}" "${CIM_CLASSES}")
+
install(TARGETS ${LIBRARY_NAME} DESTINATION lib${LIB_SUFFIX}/cmpi/)
+install(FILES ${TARGET_MOF} DESTINATION share/openlmi-providers/)