summaryrefslogtreecommitdiffstats
path: root/src/power/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/power/CMakeLists.txt')
-rw-r--r--src/power/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/src/power/CMakeLists.txt b/src/power/CMakeLists.txt
index 4c06beb..606c1f3 100644
--- a/src/power/CMakeLists.txt
+++ b/src/power/CMakeLists.txt
@@ -5,8 +5,6 @@ set(MOF Linux_PowerManagement.mof)
set(provider_SRCS
power.c
- trace.c
- globals.c
)
konkretcmpi_generate(${MOF}
@@ -22,7 +20,7 @@ add_library(${LIBRARY_NAME} SHARED
include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMPI_INCLUDE_DIR} ${GLIB_INCLUDE_DIRS})
-target_link_libraries(${LIBRARY_NAME} ${KONKRETCMPI_LIBRARIES} ${GLIB_LIBRARIES})
+target_link_libraries(${LIBRARY_NAME} curacommon ${KONKRETCMPI_LIBRARIES} ${GLIB_LIBRARIES})
# Check if we have upower and link it
pkg_check_modules(UPOWER upower-glib)