summaryrefslogtreecommitdiffstats
path: root/src/power/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/power/CMakeLists.txt')
-rw-r--r--src/power/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/power/CMakeLists.txt b/src/power/CMakeLists.txt
index 7b1ddc0..73725d3 100644
--- a/src/power/CMakeLists.txt
+++ b/src/power/CMakeLists.txt
@@ -1,6 +1,6 @@
set(PROVIDER_NAME PowerManagement)
-set(LIBRARY_NAME cmpiCura_${PROVIDER_NAME})
+set(LIBRARY_NAME cmpiLMI_${PROVIDER_NAME})
set(MOF LMI_PowerManagement.mof)
set(provider_SRCS
@@ -23,7 +23,7 @@ pkg_check_modules(GLIB REQUIRED glib-2.0)
include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMPI_INCLUDE_DIR} ${GLIB_INCLUDE_DIRS})
-target_link_libraries(${LIBRARY_NAME} curacommon ${KONKRETCMPI_LIBRARIES} ${GLIB_LIBRARIES})
+target_link_libraries(${LIBRARY_NAME} openlmicommon ${KONKRETCMPI_LIBRARIES} ${GLIB_LIBRARIES})
# Check if we have upower and link it
pkg_check_modules(UPOWER upower-glib)
@@ -40,7 +40,7 @@ if (${SYSTEMCTL_FOUND})
endif (${SYSTEMCTL_FOUND})
# Create registration file
-cim_registration(${PROVIDER_NAME} ${LIBRARY_NAME} ${MOF} share/cura-providers)
+cim_registration(${PROVIDER_NAME} ${LIBRARY_NAME} ${MOF} share/openlmi-providers)
install(TARGETS ${LIBRARY_NAME} DESTINATION lib${LIB_SUFFIX}/cmpi/)