summaryrefslogtreecommitdiffstats
path: root/src/logicalfile/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/logicalfile/CMakeLists.txt')
-rw-r--r--src/logicalfile/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/logicalfile/CMakeLists.txt b/src/logicalfile/CMakeLists.txt
index d770080..3a09a4a 100644
--- a/src/logicalfile/CMakeLists.txt
+++ b/src/logicalfile/CMakeLists.txt
@@ -35,5 +35,9 @@ target_link_libraries(${LIBRARY_NAME} openlmicommon
# Create registration file
cim_registration(${PROVIDER_NAME} ${LIBRARY_NAME} ${MOF} share/openlmi-providers)
+set(TARGET_MOF "${CMAKE_BINARY_DIR}/mof/90_LMI_LogicalFile_Profile.mof")
+profile_mof_generate("90_LMI_LogicalFile_Profile.mof.skel" "${TARGET_MOF}" "${CIM_CLASSES}")
+
install(TARGETS ${LIBRARY_NAME} DESTINATION lib${LIB_SUFFIX}/cmpi)
install(PROGRAMS ${CIMPROVAGT_SCRIPT} DESTINATION libexec/pegasus)
+install(FILES ${TARGET_MOF} DESTINATION share/openlmi-providers/)